gnu: Add Openbox.
[jackhill/guix/guix.git] / gnu / packages / openbox.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages openbox)
20 #:use-module ((guix licenses) #:select (gpl2+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages gnome)
25 #:use-module (gnu packages gtk)
26 #:use-module (gnu packages image)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages xml)
29 #:use-module (gnu packages xorg))
30
31 (define-public openbox
32 (package
33 (name "openbox")
34 (version "3.5.2")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append
38 "http://www.icculus.org/openbox/releases/" name "-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "0cxgb334zj6aszwiki9g10i56sm18i7w1kw52vdnwgzq27pv93qj"))))
43 (build-system gnu-build-system)
44 (native-inputs `(("pkg-config" ,pkg-config)))
45 (inputs `(("imlib2" ,imlib2)
46 ("libxml2" ,libxml2)
47 ("librsvg" ,librsvg)
48 ("libsm" ,libsm)
49 ("libxcursor" ,libxcursor)
50 ("libxinerama" ,libxinerama)
51 ("libxml2" ,libxml2)
52 ("libxrandr" ,libxrandr)
53 ("libxft" ,libxft)
54 ("pango" ,pango)))
55 (synopsis "Box style window manager")
56 (description
57 "Openbox is a highly configurable, next generation window manager with
58 extensive standars support. The *box visual style is well known for its
59 minimalistic appearance. Openbox uses the *box visual style, while providing
60 a greater number of options for theme developers than previous *box
61 implementations.")
62 (home-page "http://openbox.org/wiki/Main_Page")
63 (license gpl2+)))
64
65 ;;; openbox.scm ends here