gnu: brlaser: Update to 6.
[jackhill/guix/guix.git] / gnu / packages / tls.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
5 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
6 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
7 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
8 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
9 ;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
10 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
11 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
12 ;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
13 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
14 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
15 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages tls)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix packages)
35 #:use-module (guix download)
36 #:use-module (guix git-download)
37 #:use-module (guix utils)
38 #:use-module (guix build-system gnu)
39 #:use-module (guix build-system go)
40 #:use-module (guix build-system perl)
41 #:use-module (guix build-system python)
42 #:use-module (guix build-system cmake)
43 #:use-module (guix build-system trivial)
44 #:use-module (gnu packages compression)
45 #:use-module (gnu packages)
46 #:use-module (gnu packages bash)
47 #:use-module (gnu packages check)
48 #:use-module (gnu packages curl)
49 #:use-module (gnu packages dns)
50 #:use-module (gnu packages gawk)
51 #:use-module (gnu packages guile)
52 #:use-module (gnu packages libbsd)
53 #:use-module (gnu packages libffi)
54 #:use-module (gnu packages libidn)
55 #:use-module (gnu packages linux)
56 #:use-module (gnu packages ncurses)
57 #:use-module (gnu packages nettle)
58 #:use-module (gnu packages perl)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages python)
61 #:use-module (gnu packages python-crypto)
62 #:use-module (gnu packages python-web)
63 #:use-module (gnu packages python-xyz)
64 #:use-module (gnu packages sphinx)
65 #:use-module (gnu packages texinfo)
66 #:use-module (gnu packages time)
67 #:use-module (gnu packages base)
68 #:use-module (srfi srfi-1))
69
70 (define-public libtasn1
71 (package
72 (name "libtasn1")
73 (version "4.14")
74 (source
75 (origin
76 (method url-fetch)
77 (uri (string-append "mirror://gnu/libtasn1/libtasn1-"
78 version ".tar.gz"))
79 (sha256
80 (base32
81 "025sqnlzji78ss2fi78dajc0v0h5fi02wp39hws41sn8qnjlnq4y"))))
82 (build-system gnu-build-system)
83 (arguments
84 `(#:configure-flags '("--disable-static")))
85 (native-inputs `(("perl" ,perl)))
86 (home-page "https://www.gnu.org/software/libtasn1/")
87 (synopsis "ASN.1 library")
88 (description
89 "GNU libtasn1 is a library implementing the ASN.1 notation. It is used
90 for transmitting machine-neutral encodings of data objects in computer
91 networking, allowing for formal validation of data according to some
92 specifications.")
93 (license license:lgpl2.0+)))
94
95 (define-public asn1c
96 (package
97 (name "asn1c")
98 (version "0.9.28")
99 (source (origin
100 (method url-fetch)
101 (uri (string-append "https://lionet.info/soft/asn1c-"
102 version ".tar.gz"))
103 (sha256
104 (base32
105 "1fc64g45ykmv73kdndr4zdm4wxhimhrir4rxnygxvwkych5l81w0"))))
106 (build-system gnu-build-system)
107 (native-inputs
108 `(("perl" ,perl)))
109 (home-page "https://lionet.info/asn1c")
110 (synopsis "ASN.1 to C compiler")
111 (description "The ASN.1 to C compiler takes ASN.1 module
112 files and generates C++ compatible C source code. That code can be
113 used to serialize the native C structures into compact and unambiguous
114 BER/XER/PER-based data files, and deserialize the files back.
115
116 Various ASN.1 based formats are widely used in the industry, such as to encode
117 the X.509 certificates employed in the HTTPS handshake, to exchange control
118 data between mobile phones and cellular networks, to car-to-car communication
119 in intelligent transportation networks.")
120 (license license:bsd-2)))
121
122 (define-public p11-kit
123 (package
124 (name "p11-kit")
125 (version "0.23.18.1")
126 (source
127 (origin
128 (method url-fetch)
129 (uri (string-append "https://github.com/p11-glue/p11-kit/releases/"
130 "download/" version "/p11-kit-" version ".tar.gz"))
131 (sha256
132 (base32
133 "0vrwab1082f7l5sbzpb28nrs3q4d2q7wzbi8c977rpah026bvhrl"))))
134 (build-system gnu-build-system)
135 (native-inputs
136 `(("pkg-config" ,pkg-config)))
137 (inputs
138 `(("libffi" ,libffi)
139 ("libtasn1" ,libtasn1)))
140 (arguments
141 `(#:configure-flags '("--without-trust-paths")
142 #:phases (modify-phases %standard-phases
143 (add-before 'check 'prepare-tests
144 (lambda _
145 ;; "test-runtime" expects XDG_RUNTIME_DIR to be set up
146 ;; and looks for .cache and other directories (only).
147 ;; For simplicity just drop it since it is irrelevant
148 ;; in the build container.
149 (substitute* "Makefile"
150 (("test-runtime\\$\\(EXEEXT\\)") ""))
151 #t)))))
152 (home-page "https://p11-glue.freedesktop.org/p11-kit.html")
153 (synopsis "PKCS#11 library")
154 (description
155 "p11-kit provides a way to load and enumerate PKCS#11 modules. It
156 provides a standard configuration setup for installing PKCS#11 modules
157 in such a way that they are discoverable. It also solves problems with
158 coordinating the use of PKCS#11 by different components or libraries
159 living in the same process.")
160 (license license:bsd-3)))
161
162 (define-public gnutls
163 (package
164 (name "gnutls")
165 (version "3.6.9")
166 (source (origin
167 (method url-fetch)
168 (uri
169 ;; Note: Releases are no longer on ftp.gnu.org since the
170 ;; schism (after version 3.1.5).
171 (string-append "mirror://gnupg/gnutls/v"
172 (version-major+minor version)
173 "/gnutls-" version ".tar.xz"))
174 (patches (search-patches "gnutls-skip-trust-store-test.patch"))
175 (sha256
176 (base32
177 "1jqz5s3lv8sa53348cfi9nr5pw5l55n8m40b8msdvv0pb2jzqca3"))))
178 (build-system gnu-build-system)
179 (arguments
180 `(; Ensure we don't keep a reference to this buggy software.
181 #:disallowed-references (,net-tools)
182 #:configure-flags
183 (list
184 ;; GnuTLS doesn't consult any environment variables to specify
185 ;; the location of the system-wide trust store. Instead it has a
186 ;; configure-time option. Unless specified, its configure script
187 ;; attempts to auto-detect the location by looking for common
188 ;; places in the file system, none of which are present in our
189 ;; chroot build environment. If not found, then no default trust
190 ;; store is used, so each program has to provide its own
191 ;; fallback, and users have to configure each program
192 ;; independently. This seems suboptimal.
193 "--with-default-trust-store-dir=/etc/ssl/certs"
194
195 ;; Tell the build system that we want Guile bindings installed to
196 ;; the output instead of Guiles own module directory.
197 (string-append "--with-guile-site-dir="
198 "$(datarootdir)/guile/site/$(GUILE_EFFECTIVE_VERSION)")
199 (string-append "--with-guile-site-ccache-dir="
200 "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache")
201 (string-append "--with-guile-extension-dir="
202 "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions")
203
204 ;; FIXME: Temporarily disable p11-kit support since it is not
205 ;; working on mips64el.
206 "--without-p11-kit")
207
208 #:phases (modify-phases %standard-phases
209 (add-after
210 'install 'move-doc
211 (lambda* (#:key outputs #:allow-other-keys)
212 ;; Copy the 4.1 MiB of section 3 man pages to "doc".
213 (let* ((out (assoc-ref outputs "out"))
214 (doc (assoc-ref outputs "doc"))
215 (mandir (string-append doc "/share/man/man3"))
216 (oldman (string-append out "/share/man/man3")))
217 (mkdir-p mandir)
218 (copy-recursively oldman mandir)
219 (delete-file-recursively oldman)
220 #t))))))
221 (outputs '("out" ;4.4 MiB
222 "debug"
223 "doc")) ;4.1 MiB of man pages
224 (native-inputs
225 `(("net-tools" ,net-tools)
226 ("pkg-config" ,pkg-config)
227 ("which" ,which)))
228 (inputs
229 `(("guile" ,guile-2.2)))
230 (propagated-inputs
231 ;; These are all in the 'Requires.private' field of gnutls.pc.
232 `(("libtasn1" ,libtasn1)
233 ("libidn2" ,libidn2)
234 ("nettle" ,nettle)
235 ("zlib" ,zlib)))
236 (home-page "https://www.gnu.org/software/gnutls/")
237 (synopsis "Transport layer security library")
238 (description
239 "GnuTLS is a secure communications library implementing the SSL, TLS
240 and DTLS protocols. It is provided in the form of a C library to support the
241 protocols, as well as to parse and write X.5009, PKCS 12, OpenPGP and other
242 required structures.")
243 (license license:lgpl2.1+)
244 (properties '((ftp-server . "ftp.gnutls.org")
245 (ftp-directory . "/gcrypt/gnutls")))))
246
247 (define-public gnutls/guile-2.0
248 ;; GnuTLS for Guile 2.0.
249 (package
250 (inherit gnutls)
251 (name "guile2.0-gnutls")
252 (inputs `(("guile" ,guile-2.0)
253 ,@(alist-delete "guile" (package-inputs gnutls))))))
254
255 (define-public gnutls/dane
256 ;; GnuTLS with build libgnutls-dane, implementing DNS-based
257 ;; Authentication of Named Entities. This is required for GNS functionality
258 ;; by GNUnet and gnURL. This is done in an extra package definition
259 ;; to have the choice between GnuTLS with Dane and without Dane.
260 (package
261 (inherit gnutls)
262 (name "gnutls-dane")
263 (inputs `(("unbound" ,unbound)
264 ,@(package-inputs gnutls)))))
265
266 (define-public openssl
267 (package
268 (name "openssl")
269 (version "1.1.1c")
270 (replacement openssl-1.1.1d)
271 (source (origin
272 (method url-fetch)
273 (uri (list (string-append "https://www.openssl.org/source/openssl-"
274 version ".tar.gz")
275 (string-append "ftp://ftp.openssl.org/source/"
276 "openssl-" version ".tar.gz")
277 (string-append "ftp://ftp.openssl.org/source/old/"
278 (string-trim-right version char-set:letter)
279 "/openssl-" version ".tar.gz")))
280 (sha256
281 (base32
282 "142c7zdlz06hjrrvinb9f276czc78bnkyhd9xma621qmmmwk1yzn"))
283 (patches (search-patches "openssl-1.1-c-rehash-in.patch"))))
284 (build-system gnu-build-system)
285 (outputs '("out"
286 "doc" ;6.8 MiB of man3 pages and full HTML documentation
287 "static")) ;6.4 MiB of .a files
288 (native-inputs `(("perl" ,perl)))
289 (arguments
290 `(#:disallowed-references (,perl)
291 #:parallel-build? #f
292 #:parallel-tests? #f
293 #:test-target "test"
294
295 ;; Changes to OpenSSL sometimes cause Perl to "sneak in" to the closure,
296 ;; so we explicitly disallow it here.
297 #:disallowed-references ,(list (canonical-package perl))
298 #:phases
299 (modify-phases %standard-phases
300 (replace 'configure
301 (lambda* (#:key outputs #:allow-other-keys)
302 (let* ((out (assoc-ref outputs "out"))
303 (lib (string-append out "/lib")))
304 ;; It's not a shebang so patch-source-shebangs misses it.
305 (substitute* "config"
306 (("/usr/bin/env")
307 (string-append (assoc-ref %build-inputs "coreutils")
308 "/bin/env")))
309 (invoke "./config"
310 "shared" ;build shared libraries
311 "--libdir=lib"
312
313 ;; The default for this catch-all directory is
314 ;; PREFIX/ssl. Change that to something more
315 ;; conventional.
316 (string-append "--openssldir=" out
317 "/share/openssl-" ,version)
318
319 (string-append "--prefix=" out)
320 (string-append "-Wl,-rpath," lib)))))
321 (add-after 'install 'move-static-libraries
322 (lambda* (#:key outputs #:allow-other-keys)
323 ;; Move static libraries to the "static" output.
324 (let* ((out (assoc-ref outputs "out"))
325 (lib (string-append out "/lib"))
326 (static (assoc-ref outputs "static"))
327 (slib (string-append static "/lib")))
328 (for-each (lambda (file)
329 (install-file file slib)
330 (delete-file file))
331 (find-files lib "\\.a$"))
332 #t)))
333 (add-after 'install 'move-extra-documentation
334 (lambda* (#:key outputs #:allow-other-keys)
335 ;; Move man3 pages and full HTML documentation to "doc".
336 (let* ((out (assoc-ref outputs "out"))
337 (man3 (string-append out "/share/man/man3"))
338 (html (string-append out "/share/doc/openssl"))
339 (doc (assoc-ref outputs "doc"))
340 (man-target (string-append doc "/share/man/man3"))
341 (html-target (string-append doc "/share/doc/openssl")))
342 (copy-recursively man3 man-target)
343 (delete-file-recursively man3)
344 (copy-recursively html html-target)
345 (delete-file-recursively html)
346 #t)))
347 (add-after
348 'install 'remove-miscellany
349 (lambda* (#:key outputs #:allow-other-keys)
350 ;; The 'misc' directory contains random undocumented shell and Perl
351 ;; scripts. Remove them to avoid retaining a reference on Perl.
352 (let ((out (assoc-ref outputs "out")))
353 (delete-file-recursively (string-append out "/share/openssl-"
354 ,version "/misc"))
355 #t))))))
356 (native-search-paths
357 (list (search-path-specification
358 (variable "SSL_CERT_DIR")
359 (separator #f) ;single entry
360 (files '("etc/ssl/certs")))
361 (search-path-specification
362 (variable "SSL_CERT_FILE")
363 (file-type 'regular)
364 (separator #f) ;single entry
365 (files '("etc/ssl/certs/ca-certificates.crt")))))
366 (synopsis "SSL/TLS implementation")
367 (description
368 "OpenSSL is an implementation of SSL/TLS.")
369 (license license:openssl)
370 (home-page "https://www.openssl.org/")))
371
372 (define openssl-1.1.1d
373 (package/inherit
374 openssl
375 (version "1.1.1d")
376 (source (origin
377 (method url-fetch)
378 (uri (list (string-append "https://www.openssl.org/source/openssl-"
379 version ".tar.gz")
380 (string-append "ftp://ftp.openssl.org/source/"
381 "openssl-" version ".tar.gz")
382 (string-append "ftp://ftp.openssl.org/source/old/"
383 (string-trim-right version char-set:letter)
384 "/openssl-" version ".tar.gz")))
385 (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
386 (sha256
387 (base32
388 "1whinyw402z3b9xlb3qaxv4b9sk4w1bgh9k0y8df1z4x3yy92fhy"))))))
389
390 (define-public openssl-1.0
391 (package
392 (inherit openssl)
393 (name "openssl")
394 (version "1.0.2s")
395 (replacement openssl-1.0.2t)
396 (source (origin
397 (method url-fetch)
398 (uri (list (string-append "https://www.openssl.org/source/openssl-"
399 version ".tar.gz")
400 (string-append "ftp://ftp.openssl.org/source/"
401 "openssl-" version ".tar.gz")
402 (string-append "ftp://ftp.openssl.org/source/old/"
403 (string-trim-right version char-set:letter)
404 "/openssl-" version ".tar.gz")))
405 (sha256
406 (base32
407 "15mbmg8hf7s12vr3v2bdc0pi9y4pdbnsxhzk4fyyap42jaa5rgfa"))
408 (patches (search-patches "openssl-runpath.patch"
409 "openssl-c-rehash-in.patch"))))
410 (outputs '("out"
411 "doc" ;1.5MiB of man3 pages
412 "static")) ;6MiB of .a files
413 (arguments
414 (substitute-keyword-arguments (package-arguments openssl)
415 ((#:phases phases)
416 `(modify-phases ,phases
417 (add-before 'patch-source-shebangs 'patch-tests
418 (lambda* (#:key inputs native-inputs #:allow-other-keys)
419 (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
420 (substitute* (find-files "test" ".*")
421 (("/bin/sh")
422 (string-append bash "/bin/sh"))
423 (("/bin/rm")
424 "rm"))
425 #t)))
426 (add-before 'configure 'patch-Makefile.org
427 (lambda* (#:key outputs #:allow-other-keys)
428 ;; The default MANDIR is some unusual place. Fix that.
429 (let ((out (assoc-ref outputs "out")))
430 (patch-makefile-SHELL "Makefile.org")
431 (substitute* "Makefile.org"
432 (("^MANDIR[[:blank:]]*=.*$")
433 (string-append "MANDIR = " out "/share/man\n")))
434 #t)))
435 (replace 'configure
436 ;; Override this phase because OpenSSL 1.0 does not understand -rpath.
437 (lambda* (#:key outputs #:allow-other-keys)
438 (let ((out (assoc-ref outputs "out")))
439 (invoke "./config"
440 "shared" ;build shared libraries
441 "--libdir=lib"
442
443 ;; The default for this catch-all directory is
444 ;; PREFIX/ssl. Change that to something more
445 ;; conventional.
446 (string-append "--openssldir=" out
447 "/share/openssl-" ,version)
448
449 (string-append "--prefix=" out)))))
450 (delete 'move-extra-documentation)
451 (add-after 'install 'move-man3-pages
452 (lambda* (#:key outputs #:allow-other-keys)
453 ;; Move section 3 man pages to "doc".
454 (let* ((out (assoc-ref outputs "out"))
455 (man3 (string-append out "/share/man/man3"))
456 (doc (assoc-ref outputs "doc"))
457 (target (string-append doc "/share/man/man3")))
458 (mkdir-p target)
459 (for-each (lambda (file)
460 (rename-file file
461 (string-append target "/"
462 (basename file))))
463 (find-files man3))
464 (delete-file-recursively man3)
465 #t)))
466 ;; XXX: Duplicate this phase to make sure 'version' evaluates
467 ;; in the current scope and not the inherited one.
468 (replace 'remove-miscellany
469 (lambda* (#:key outputs #:allow-other-keys)
470 ;; The 'misc' directory contains random undocumented shell and Perl
471 ;; scripts. Remove them to avoid retaining a reference on Perl.
472 (let ((out (assoc-ref outputs "out")))
473 (delete-file-recursively (string-append out "/share/openssl-"
474 ,version "/misc"))
475 #t)))))))))
476
477 (define openssl-1.0.2t
478 (package
479 (inherit openssl)
480 (version "1.0.2t")
481 (source (origin
482 (inherit (package-source openssl-1.0))
483 (uri (list (string-append "https://www.openssl.org/source/openssl-"
484 version ".tar.gz")
485 (string-append "ftp://ftp.openssl.org/source/"
486 "openssl-" version ".tar.gz")
487 (string-append "ftp://ftp.openssl.org/source/old/"
488 (string-trim-right version char-set:letter)
489 "/openssl-" version ".tar.gz")))
490 (sha256
491 (base32
492 "1g67ra0ph7gpz6fgvv1i96d792jmd6ymci5kk53vbikszr74djql"))))
493 (arguments
494 (substitute-keyword-arguments (package-arguments openssl-1.0)
495 ;; Parallel build is not supported in 1.0.x.
496 ((#:parallel-build? _ #f) #f)))))
497
498 (define-public libressl
499 (package
500 (name "libressl")
501 (version "2.7.4")
502 (source (origin
503 (method url-fetch)
504 (uri (string-append "mirror://openbsd/LibreSSL/"
505 "libressl-" version ".tar.gz"))
506 (sha256
507 (base32
508 "19kxa5i97q7p6rrps9qm0nd8zqhdjvzx02j72400c73cl2nryfhy"))))
509 (build-system gnu-build-system)
510 (arguments
511 ;; Do as if 'getentropy' was missing since older Linux kernels lack it
512 ;; and libc would return ENOSYS, which is not properly handled.
513 ;; See <https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00235.html>.
514 '(#:configure-flags '("ac_cv_func_getentropy=no"
515 ;; Provide a TLS-enabled netcat.
516 "--enable-nc")))
517 (native-search-paths
518 (list (search-path-specification
519 (variable "SSL_CERT_DIR")
520 (separator #f) ;single entry
521 (files '("etc/ssl/certs")))
522 (search-path-specification
523 (variable "SSL_CERT_FILE")
524 (separator #f) ;single entry
525 (files '("etc/ssl/certs/ca-certificates.crt")))))
526 (home-page "https://www.libressl.org/")
527 (synopsis "SSL/TLS implementation")
528 (description "LibreSSL is a version of the TLS/crypto stack, forked from
529 OpenSSL in 2014 with the goals of modernizing the codebase, improving security,
530 and applying best practice development processes. This package also includes a
531 netcat implementation that supports TLS.")
532 ;; Files taken from OpenSSL keep their license, others are under various
533 ;; non-copyleft licenses.
534 (license (list license:openssl
535 (license:non-copyleft
536 "file://COPYING"
537 "See COPYING in the distribution.")))))
538
539 (define-public python-acme
540 (package
541 (name "python-acme")
542 ;; Remember to update the hash of certbot when updating python-acme.
543 (version "0.40.1")
544 (source (origin
545 (method url-fetch)
546 (uri (pypi-uri "acme" version))
547 (sha256
548 (base32
549 "1z2zibs9lyxi5gxw9bny1127bjliwsp476kai1wnnnwd8238dgrk"))))
550 (build-system python-build-system)
551 (arguments
552 `(#:phases
553 (modify-phases %standard-phases
554 (add-after 'build 'build-documentation
555 (lambda _
556 (invoke "make" "-C" "docs" "man" "info")))
557 (add-after 'install 'install-documentation
558 (lambda* (#:key outputs #:allow-other-keys)
559 (let* ((out (assoc-ref outputs "out"))
560 (man (string-append out "/share/man/man1"))
561 (info (string-append out "/info")))
562 (install-file "docs/_build/texinfo/acme-python.info" info)
563 (install-file "docs/_build/man/acme-python.1" man)
564 #t))))))
565 ;; TODO: Add optional inputs for testing.
566 (native-inputs
567 `(("python-mock" ,python-mock)
568 ("python-pytest" ,python-pytest)
569 ;; For documentation
570 ("python-sphinx" ,python-sphinx)
571 ("python-sphinxcontrib-programoutput" ,python-sphinxcontrib-programoutput)
572 ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
573 ("texinfo" ,texinfo)))
574 (propagated-inputs
575 `(("python-josepy" ,python-josepy)
576 ("python-six" ,python-six)
577 ("python-requests" ,python-requests)
578 ("python-requests-toolbelt" ,python-requests-toolbelt)
579 ("python-pytz" ,python-pytz)
580 ("python-pyrfc3339" ,python-pyrfc3339)
581 ("python-pyasn1" ,python-pyasn1)
582 ("python-cryptography" ,python-cryptography)
583 ("python-pyopenssl" ,python-pyopenssl)))
584 (home-page "https://github.com/certbot/certbot")
585 (synopsis "ACME protocol implementation in Python")
586 (description "ACME protocol implementation in Python")
587 (license license:asl2.0)))
588
589 (define-public certbot
590 (package
591 (name "certbot")
592 ;; Certbot and python-acme are developed in the same repository, and their
593 ;; versions should remain synchronized.
594 (version (package-version python-acme))
595 (source (origin
596 (method url-fetch)
597 (uri (pypi-uri "certbot" version))
598 (sha256
599 (base32
600 "1l8h7ggq75h59246mmzigmjr5jvzi29hihrnz9aiqh6g8hq1pj4d"))))
601 (build-system python-build-system)
602 (arguments
603 `(,@(substitute-keyword-arguments (package-arguments python-acme)
604 ((#:phases phases)
605 `(modify-phases ,phases
606 (replace 'install-documentation
607 (lambda* (#:key outputs #:allow-other-keys)
608 (let* ((out (assoc-ref outputs "out"))
609 (man1 (string-append out "/share/man/man1"))
610 (man7 (string-append out "/share/man/man7"))
611 (info (string-append out "/info")))
612 (install-file "docs/_build/texinfo/Certbot.info" info)
613 (install-file "docs/_build/man/certbot.1" man1)
614 (install-file "docs/_build/man/certbot.7" man7)
615 #t))))))))
616 ;; TODO: Add optional inputs for testing.
617 (native-inputs
618 `(("python-mock" ,python-mock)
619 ("python-pytest" ,python-pytest)
620 ;; For documentation
621 ("python-sphinx" ,python-sphinx)
622 ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
623 ("python-sphinx-repoze-autointerface" ,python-sphinx-repoze-autointerface)
624 ("python-sphinxcontrib-programoutput" ,python-sphinxcontrib-programoutput)
625 ("texinfo" ,texinfo)))
626 (propagated-inputs
627 `(("python-acme" ,python-acme)
628 ("python-cryptography" ,python-cryptography)
629 ("python-zope-interface" ,python-zope-interface)
630 ("python-pyrfc3339" ,python-pyrfc3339)
631 ("python-pyopenssl" ,python-pyopenssl)
632 ("python-configobj" ,python-configobj)
633 ("python-configargparse" ,python-configargparse)
634 ("python-distro" ,python-distro)
635 ("python-zope-component" ,python-zope-component)
636 ("python-parsedatetime" ,python-parsedatetime)
637 ("python-six" ,python-six)
638 ("python-psutil" ,python-psutil)
639 ("python-requests" ,python-requests)
640 ("python-pytz" ,python-pytz)))
641 (synopsis "Let's Encrypt client by the Electronic Frontier Foundation")
642 (description "Certbot automatically receives and installs X.509 certificates
643 to enable Transport Layer Security (TLS) on servers. It interoperates with the
644 Let’s Encrypt certificate authority (CA), which issues browser-trusted
645 certificates for free.")
646 (home-page "https://certbot.eff.org/")
647 (license license:asl2.0)))
648
649 (define-public letsencrypt
650 (package (inherit certbot)
651 (name "letsencrypt")
652 (properties `((superseded . ,certbot)))))
653
654 (define-public perl-net-ssleay
655 (package
656 (name "perl-net-ssleay")
657 (version "1.88")
658 (source (origin
659 (method url-fetch)
660 (uri (string-append "mirror://cpan/authors/id/C/CH/CHRISN/"
661 "Net-SSLeay-" version ".tar.gz"))
662 (sha256
663 (base32
664 "1pfgh4h3szcpvqlcimc60pjbk9zwls99x5863sva0wc47i4dl010"))))
665 (build-system perl-build-system)
666 (inputs `(("openssl" ,openssl)))
667 (arguments
668 `(#:phases
669 (modify-phases %standard-phases
670 (add-before
671 'configure 'set-ssl-prefix
672 (lambda* (#:key inputs #:allow-other-keys)
673 (setenv "OPENSSL_PREFIX" (assoc-ref inputs "openssl"))
674 #t)))))
675 (synopsis "Perl extension for using OpenSSL")
676 (description
677 "This module offers some high level convenience functions for accessing
678 web pages on SSL servers (for symmetry, the same API is offered for accessing
679 http servers, too), an sslcat() function for writing your own clients, and
680 finally access to the SSL api of the SSLeay/OpenSSL package so you can write
681 servers or clients for more complicated applications.")
682 (license license:perl-license)
683 (home-page "https://metacpan.org/release/Net-SSLeay")))
684
685 (define-public perl-crypt-openssl-rsa
686 (package
687 (name "perl-crypt-openssl-rsa")
688 (version "0.31")
689 (source
690 (origin
691 (method url-fetch)
692 (uri (string-append
693 "mirror://cpan/authors/id/T/TO/TODDR/Crypt-OpenSSL-RSA-"
694 version
695 ".tar.gz"))
696 (sha256
697 (base32
698 "0djl5i6kibl7862b6ih29q8dhg5zpwzq77q9j8hp6xngshx40ws1"))))
699 (build-system perl-build-system)
700 (native-inputs
701 `(("perl-crypt-openssl-guess" ,perl-crypt-openssl-guess)))
702 (inputs
703 `(("perl-crypt-openssl-bignum" ,perl-crypt-openssl-bignum)
704 ("perl-crypt-openssl-random" ,perl-crypt-openssl-random)
705 ("openssl" ,openssl)))
706 (arguments perl-crypt-arguments)
707 (home-page
708 "https://metacpan.org/release/Crypt-OpenSSL-RSA")
709 (synopsis
710 "RSA encoding and decoding, using the openSSL libraries")
711 (description "Crypt::OpenSSL::RSA does RSA encoding and decoding (using the
712 OpenSSL libraries).")
713 (license license:perl-license)))
714
715 (define perl-crypt-arguments
716 `(#:phases (modify-phases %standard-phases
717 (add-before 'configure 'patch-Makefile.PL
718 (lambda* (#:key inputs #:allow-other-keys)
719 (substitute* "Makefile.PL"
720 (("'LIBS'.*=>.*") (string-append "'LIBS' => ['-L"
721 (assoc-ref inputs "openssl")
722 "/lib -lcrypto'],")))
723 #t)))))
724
725 (define-public perl-crypt-openssl-bignum
726 (package
727 (name "perl-crypt-openssl-bignum")
728 (version "0.09")
729 (source
730 (origin
731 (method url-fetch)
732 (uri (string-append
733 "mirror://cpan/authors/id/K/KM/KMX/Crypt-OpenSSL-Bignum-"
734 version
735 ".tar.gz"))
736 (sha256
737 (base32
738 "1p22znbajq91lbk2k3yg12ig7hy5b4vy8igxwqkmbm4nhgxp4ki3"))))
739 (build-system perl-build-system)
740 (inputs `(("openssl" ,openssl)))
741 (arguments perl-crypt-arguments)
742 (home-page
743 "https://metacpan.org/release/Crypt-OpenSSL-Bignum")
744 (synopsis
745 "OpenSSL's multiprecision integer arithmetic in Perl")
746 (description "Crypt::OpenSSL::Bignum provides multiprecision integer
747 arithmetic in Perl.")
748 ;; At your option either gpl1+ or the Artistic License
749 (license license:perl-license)))
750
751 (define-public perl-crypt-openssl-guess
752 (package
753 (name "perl-crypt-openssl-guess")
754 (version "0.11")
755 (source
756 (origin
757 (method url-fetch)
758 (uri (string-append
759 "mirror://cpan/authors/id/A/AK/AKIYM/Crypt-OpenSSL-Guess-"
760 version ".tar.gz"))
761 (sha256
762 (base32
763 "0rvi9l4ljcbhwwvspq019nfq2h2v746dk355h2nwnlmqikiihsxa"))))
764 (build-system perl-build-system)
765 (home-page "https://metacpan.org/release/Crypt-OpenSSL-Guess")
766 (synopsis "Guess the OpenSSL include path")
767 (description
768 "The Crypt::OpenSSL::Guess Perl module provides helpers to guess the
769 correct OpenSSL include path. It is intended for use in your
770 @file{Makefile.PL}.")
771 (license license:perl-license)))
772
773 (define-public perl-crypt-openssl-random
774 (package
775 (name "perl-crypt-openssl-random")
776 (version "0.15")
777 (source
778 (origin
779 (method url-fetch)
780 (uri (string-append
781 "mirror://cpan/authors/id/R/RU/RURBAN/Crypt-OpenSSL-Random-"
782 version
783 ".tar.gz"))
784 (sha256
785 (base32 "1x6ffps8q7mnawmcfq740llzy7i10g3319vap0wiw4d33fm6z1zh"))))
786 (build-system perl-build-system)
787 (native-inputs
788 `(("perl-crypt-openssl-guess" ,perl-crypt-openssl-guess)))
789 (inputs
790 `(("openssl" ,openssl)))
791 (arguments perl-crypt-arguments)
792 (home-page
793 "https://metacpan.org/release/Crypt-OpenSSL-Random")
794 (synopsis
795 "OpenSSL/LibreSSL pseudo-random number generator access")
796 (description "Crypt::OpenSSL::Random is a OpenSSL/LibreSSL pseudo-random
797 number generator")
798 (license license:perl-license)))
799
800 (define-public acme-client
801 (package
802 (name "acme-client")
803 (version "0.1.16")
804 (source (origin
805 (method url-fetch)
806 (uri (string-append "https://kristaps.bsd.lv/" name "/"
807 "snapshots/" name "-portable-"
808 version ".tgz"))
809 (sha256
810 (base32
811 "00q05b3b1dfnfp7sr1nbd212n0mqrycl3cr9lbs51m7ncaihbrz9"))))
812 (build-system gnu-build-system)
813 (arguments
814 '(#:tests? #f ; no test suite
815 #:make-flags
816 (list "CC=gcc"
817 (string-append "PREFIX=" (assoc-ref %outputs "out")))
818 #:phases
819 (modify-phases %standard-phases
820 (add-after 'unpack 'patch-paths
821 (lambda* (#:key inputs #:allow-other-keys)
822 (let ((pem (string-append (assoc-ref inputs "libressl")
823 "/etc/ssl/cert.pem")))
824 (substitute* "http.c"
825 (("/etc/ssl/cert.pem") pem))
826 #t)))
827 (delete 'configure)))) ; no './configure' script
828 (native-inputs
829 `(("pkg-config" ,pkg-config)))
830 (inputs
831 `(("libbsd" ,libbsd)
832 ("libressl" ,libressl)))
833 (synopsis "Let's Encrypt client by the OpenBSD project")
834 (description "acme-client is a Let's Encrypt client implemented in C. It
835 uses a modular design, and attempts to secure itself by dropping privileges and
836 operating in a chroot where possible. acme-client is developed on OpenBSD and
837 then ported to the GNU / Linux environment.")
838 (home-page "https://kristaps.bsd.lv/acme-client/")
839 ;; acme-client is distributed under the ISC license, but the files 'jsmn.h'
840 ;; and 'jsmn.c' are distributed under the Expat license.
841 (license (list license:isc license:expat))))
842
843 ;; The "-apache" variant is the upstreamed prefered variant. A "-gpl"
844 ;; variant exists in addition to the "-apache" one.
845 (define-public mbedtls-apache
846 (package
847 (name "mbedtls-apache")
848 (version "2.16.3")
849 (source
850 (origin
851 (method url-fetch)
852 ;; XXX: The download links on the website are script redirection links
853 ;; which effectively lead to the format listed in the uri here.
854 (uri (string-append "https://tls.mbed.org/download/mbedtls-"
855 version "-apache.tgz"))
856 (sha256
857 (base32
858 "0qd65lnr63vmx2gxla6lcmm5gawlnaj4wy4h4vmdc3h9h9nyw6zc"))))
859 (build-system cmake-build-system)
860 (arguments
861 `(#:configure-flags
862 (list "-DUSE_SHARED_MBEDTLS_LIBRARY=ON")))
863 (native-inputs
864 `(("perl" ,perl)
865 ("python" ,python)))
866 (synopsis "Small TLS library")
867 (description
868 "@code{mbed TLS}, formerly known as PolarSSL, makes it trivially easy
869 for developers to include cryptographic and SSL/TLS capabilities in their
870 (embedded) products, facilitating this functionality with a minimal
871 coding footprint.")
872 (home-page "https://tls.mbed.org")
873 (license license:asl2.0)))
874
875 ;; The Hiawatha Web server requires some specific features to be enabled.
876 (define-public mbedtls-for-hiawatha
877 (hidden-package
878 (package
879 (inherit mbedtls-apache)
880 (arguments
881 (substitute-keyword-arguments
882 `(#:phases
883 (modify-phases %standard-phases
884 (add-after 'configure 'configure-extra-features
885 (lambda _
886 (for-each (lambda (feature)
887 (invoke "scripts/config.pl" "set" feature))
888 (list "MBEDTLS_THREADING_C"
889 "MBEDTLS_THREADING_PTHREAD"))
890 #t)))
891 ,@(package-arguments mbedtls-apache)))))))
892
893 (define-public dehydrated
894 (package
895 (name "dehydrated")
896 (version "0.6.5")
897 (source (origin
898 (method url-fetch)
899 (uri (string-append
900 "https://github.com/lukas2511/dehydrated/releases/download/"
901 "v" version "/dehydrated-" version ".tar.gz"))
902 (sha256
903 (base32
904 "0dgskgbdd95p13jx6s13p77y15wngb5cm6p4305cf2s54w0bvahh"))))
905 (build-system trivial-build-system)
906 (arguments
907 `(#:modules ((guix build utils))
908 #:builder
909 (begin
910 (use-modules (guix build utils))
911 (let* ((source (assoc-ref %build-inputs "source"))
912 (tar (assoc-ref %build-inputs "tar"))
913 (gz (assoc-ref %build-inputs "gzip"))
914 (out (assoc-ref %outputs "out"))
915 (bin (string-append out "/bin"))
916 (doc (string-append out "/share/doc/"))
917 (bash (in-vicinity (assoc-ref %build-inputs "bash") "bin")))
918
919 (setenv "PATH" (string-append gz "/bin"))
920 (invoke (string-append tar "/bin/tar") "xvf" source)
921 (chdir (string-append ,name "-" ,version))
922
923 (install-file "dehydrated" bin)
924 (install-file "LICENSE" (string-append doc ,name "-" ,version))
925 (with-directory-excursion bin
926 (patch-shebang "dehydrated" (list bash))
927
928 ;; Do not try to write in the store.
929 (substitute* "dehydrated"
930 (("SCRIPTDIR=\"\\$.*\"") "SCRIPTDIR=~/.dehydrated"))
931
932 (setenv "PATH" bash)
933 (wrap-program "dehydrated"
934 `("PATH" ":" prefix
935 ,(map (lambda (dir)
936 (string-append dir "/bin"))
937 (map (lambda (input)
938 (assoc-ref %build-inputs input))
939 '("coreutils"
940 "curl"
941 "diffutils"
942 "gawk"
943 "grep"
944 "openssl"
945 "sed"))))))
946 #t))))
947 (inputs
948 `(("bash" ,bash)
949 ("coreutils" ,coreutils)
950 ("curl" ,curl)
951 ("diffutils" ,diffutils)
952 ("gawk" ,gawk)
953 ("grep" ,grep)
954 ("openssl" ,openssl)
955 ("sed" ,sed)))
956 (native-inputs
957 `(("gzip" ,gzip)
958 ("tar" ,tar)))
959 (home-page "https://dehydrated.io/")
960 (synopsis "Let's Encrypt/ACME client implemented as a shell script")
961 (description "Dehydrated is a client for signing certificates with an
962 ACME-server (currently only provided by Let's Encrypt) implemented as a
963 relatively simple Bash script.")
964 (license license:expat)))
965
966 (define-public go-github-com-certifi-gocertifi
967 (let ((commit "d2eda712971317d7dd278bc2a52acda7e945f97e")
968 (revision "0"))
969 (package
970 (name "go-github-com-certifi-gocertifi")
971 (version (git-version "2018.01.18" revision commit))
972 (source (origin
973 (method git-fetch)
974 (uri (git-reference
975 (url "https://github.com/certifi/gocertifi")
976 (commit commit)))
977 (file-name (git-file-name name version))
978 (sha256
979 (base32
980 "0f3v26xps7gadw4qfmh1kxbpgp0cgqdd61a257xnnvnd7ll6k8dh"))))
981 (build-system go-build-system)
982 (arguments
983 '(#:import-path "github.com/certifi/gocertifi"))
984 (synopsis "X.509 TLS root certificate bundle for Go")
985 (description "This package is a Go language X.509 TLS root certificate bundle,
986 derived from Mozilla's collection.")
987 (home-page "https://certifi.io")
988 (license license:mpl2.0))))