Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / lxde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
5 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
6 ;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
7 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Ison111 <ison111@protonmail.com>
9 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages lxde)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages autotools)
29 #:use-module (gnu packages bash)
30 #:use-module (gnu packages docbook)
31 #:use-module (gnu packages freedesktop)
32 #:use-module (gnu packages gettext)
33 #:use-module (gnu packages glib)
34 #:use-module (gnu packages gnome)
35 #:use-module (gnu packages gtk)
36 #:use-module (gnu packages image-viewers)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages lsof)
39 #:use-module (gnu packages openbox)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages polkit)
42 #:use-module (gnu packages text-editors)
43 #:use-module (gnu packages video)
44 #:use-module (gnu packages wm)
45 #:use-module (gnu packages xml)
46 #:use-module (gnu packages xorg)
47 #:use-module (guix build-system gnu)
48 #:use-module (guix build-system trivial)
49 #:use-module (guix download)
50 #:use-module ((guix licenses) #:prefix license:)
51 #:use-module (guix packages)
52 #:use-module (guix utils))
53
54 (define-public libfm
55 (package
56 (name "libfm")
57 (version "1.3.0.2")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "mirror://sourceforge/pcmanfm/"
61 "PCManFM%20%2B%20Libfm%20%28tarball%20release"
62 "%29/LibFM/" name "-" version ".tar.xz"))
63 (sha256
64 (base32
65 "0wkwbi1nyvqza3r1dhrq846axiiq0fy0dqgngnagh76fjrwnzl0q"))))
66 (build-system gnu-build-system)
67 (inputs `(("glib" ,glib)
68 ("gtk+" ,gtk+-2)))
69 (native-inputs `(("intltool" ,intltool)
70 ("glib" ,glib "bin") ; for gtester
71 ("libtool" ,libtool)
72 ("menu-cache" ,menu-cache)
73 ("pkg-config" ,pkg-config)
74 ("vala" ,vala)))
75 (synopsis "File management support (core library)")
76 (description "LibFM provides file management functions built on top of
77 Glib/GIO giving a higher-level API.")
78 (home-page "https://lxde.org")
79 (license license:gpl2+)))
80
81 (define-public libfm-extra
82 (package (inherit libfm)
83 (name "libfm-extra")
84 (arguments '(#:configure-flags '("--with-extra-only")))
85 (inputs `(("glib" ,glib)))
86 (native-inputs `(("intltool" ,intltool)
87 ("libtool" ,libtool)
88 ("pkg-config" ,pkg-config)))
89 (synopsis "File management support (extra library)")
90 (description "This package contains standalone library which extends the
91 libFM file management library.")))
92
93 (define-public lxappearance
94 (package
95 (name "lxappearance")
96 (version "0.6.2")
97 (source (origin
98 (method url-fetch)
99 (uri (string-append "mirror://sourceforge/lxde/"
100 "LXAppearance/" name "-" version ".tar.xz"))
101 (sha256
102 (base32
103 "07r0xbi6504zjnbpan7zrn7gi4j0kbsqqfpj8v2x94gr05p16qj4"))))
104 (build-system gnu-build-system)
105 (inputs `(("gtk+" ,gtk+-2)))
106 (native-inputs `(("intltool" ,intltool)
107 ("pkg-config" ,pkg-config)))
108 (synopsis "LXDE GTK+ theme switcher")
109 (description "LXAppearance is a desktop-independent GTK+ theme switcher
110 able to change themes, icons, and fonts used by GTK+ applications.")
111 (home-page "https://lxde.org")
112 (license license:gpl2+)))
113
114 (define-public lxrandr
115 (package
116 (name "lxrandr")
117 (version "0.3.1")
118 (source (origin
119 (method url-fetch)
120 (uri (string-append "mirror://sourceforge/lxde/LXRandR"
121 "%20%28monitor%20config%20tool%29/LXRandR%20"
122 (version-major+minor version) ".x/"
123 name "-" version ".tar.xz"))
124 (sha256
125 (base32
126 "0khqi42paqg82jllb2kza4arf3fafzgq90fhyr3rw3d9hn23763d"))))
127 (build-system gnu-build-system)
128 (inputs `(("gtk+" ,gtk+-2)))
129 (native-inputs `(("intltool" ,intltool)
130 ("pkg-config" ,pkg-config)))
131 (synopsis "LXDE monitor configuration tool")
132 (description "LXRandR is a very basic monitor configuration tool. It
133 relies on the X11 resize-and-rotate (RandR) extension but doesn't aim to be a
134 full frontend of it. LXRandR only gives you some easy and quick options which
135 are intuitive. It's suitable for laptop users who frequently uses projectors
136 or external monitor.")
137 (home-page "https://lxde.org")
138 (license license:gpl2+)))
139
140 (define-public lxtask
141 (package
142 (name "lxtask")
143 (version "0.1.7")
144 (source (origin
145 (method url-fetch)
146 (uri (string-append "mirror://sourceforge/lxde/LXTask"
147 "%20%28task%20manager%29/LXTask%20"
148 (version-major+minor version) ".x/"
149 name "-" version ".tar.xz"))
150 (sha256
151 (base32
152 "1zihhvzsg9bl6k0gv7jwx6cgsi3rmcagvnmshc1h0mjq2immmdph"))))
153 (build-system gnu-build-system)
154 (inputs `(("gtk+" ,gtk+-2)))
155 (native-inputs `(("intltool" ,intltool)
156 ("pkg-config" ,pkg-config)))
157 (synopsis "LXDE task manager")
158 (description "LXTask is a lightweight task manager derived from Xfce task
159 manager with all dependencies on Xfce removed. LXTask is based on the GTK+
160 toolkit. It allows users to monitor and control of running processes.")
161 (home-page "https://lxde.org")
162 (license license:gpl2+)))
163
164 (define-public lxterminal
165 (package
166 (name "lxterminal")
167 (version "0.3.1")
168 (source (origin
169 (method url-fetch)
170 (uri (string-append "mirror://sourceforge/lxde/LXTerminal"
171 "%20%28terminal%20emulator%29/LXTerminal%20"
172 version "/" name "-" version ".tar.xz"))
173 (sha256
174 (base32
175 "0jrc3m0hbxcmcgahwjlm46s2350gh80ggb6a90xy0h6xqa3z73fd"))))
176 (build-system gnu-build-system)
177 (inputs `(("gtk+" ,gtk+-2)
178 ("vte" ,vte/gtk+-2)))
179 (native-inputs `(("intltool" ,intltool)
180 ("pkg-config" ,pkg-config)))
181 (synopsis "LXDE terminal emulator")
182 (description "LXTerminal is a VTE-based terminal emulator. It supports
183 multiple tabs and has only minimal dependencies thus being completely
184 desktop-independent. In order to reduce memory usage and increase the
185 performance, all instances of the terminal are sharing a single process.")
186 (home-page "https://lxde.org")
187 (license license:gpl2+)))
188
189 (define-public menu-cache
190 (package
191 (name "menu-cache")
192 (version "1.0.2")
193 (source (origin
194 (method url-fetch)
195 (uri (string-append "mirror://sourceforge/lxde/" name "/"
196 (version-major+minor version) "/"
197 name "-" version ".tar.xz"))
198 (sha256
199 (base32
200 "1m8j40npykfcfqs43kc0fmksal2jfmfi8lnb3mq3xy1lvvrfv0vg"))))
201 (build-system gnu-build-system)
202 (inputs `(("glib" ,glib)
203 ("libfm" ,libfm-extra)))
204 (native-inputs `(("pkg-config" ,pkg-config)))
205 (synopsis "LXDE implementation of the freedesktop menu's cache")
206 (description "Menu-cache is a library creating and utilizing caches to
207 speed up the access to freedesktop.org defined application menus.")
208 (home-page "https://lxde.org")
209 (license license:lgpl2.1+)))
210
211 (define-public pcmanfm
212 (package
213 (name "pcmanfm")
214 (version "1.3.0")
215 (source (origin
216 (method url-fetch)
217 (uri (string-append "mirror://sourceforge/" name "/"
218 "PCManFM%20%2B%20Libfm%20%28tarball%20release"
219 "%29/PCManFM/" name "-" version ".tar.xz"))
220 (sha256
221 (base32
222 "1ywgfyklms5hqkapsbjps4kyx20ac0d1qk16ww74yagkyfdkwsas"))))
223 (build-system gnu-build-system)
224 (inputs `(("gtk+" ,gtk+-2)
225 ("gvfs" ,gvfs) ; for trash and mount support
226 ("libfm" ,libfm)
227 ("libx11" ,libx11)))
228 (native-inputs `(("intltool" ,intltool)
229 ("libtool" ,libtool)
230 ("pkg-config" ,pkg-config)))
231 (propagated-inputs
232 `(("lxmenu-data" ,lxmenu-data))) ; for "Open With..." application list
233 (synopsis "LXDE file manager")
234 (description "PCMan is a lightweight GTK+ based file manager, compliant
235 with freedesktop.org standard.")
236 (home-page "https://lxde.org")
237 (license license:gpl2+)))
238
239 (define-public spacefm
240 ;; SpaceFM is based on PCManFM.
241 (package
242 (name "spacefm")
243 (version "1.0.6")
244 (source (origin
245 (method url-fetch)
246 (uri (string-append
247 "https://github.com/IgnorantGuru/spacefm/archive/"
248 version ".tar.gz"))
249 (sha256
250 (base32
251 "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
252 (file-name (string-append name "-" version ".tar.gz"))))
253 (build-system gnu-build-system)
254 (native-inputs `(("pkg-config" ,pkg-config)
255 ("intltool" ,intltool)))
256 (inputs `(("bash" ,bash)
257 ("gtk+" ,gtk+)
258 ("eudev" ,eudev)
259 ("desktop-file-utils" ,desktop-file-utils)
260 ("shared-mime-info" ,shared-mime-info)
261 ("ffmpegthumbnailer" ,ffmpegthumbnailer)
262 ("jmtpfs" ,jmtpfs)
263 ("lsof" ,lsof)
264 ("udisks" ,udisks)))
265 (arguments
266 `(#:configure-flags (list (string-append "--with-bash-path="
267 (assoc-ref %build-inputs "bash")
268 "/bin/bash")
269 (string-append "--sysconfdir="
270 (assoc-ref %outputs "out")
271 "/etc"))))
272 (home-page "http://ignorantguru.github.io/spacefm/")
273 (synopsis "Multi-panel tabbed file manager")
274 (description "SpaceFM is a graphical, multi-panel, tabbed file manager
275 based on PCManFM with built-in virtual file system, udev-based device manager,
276 customizable menu system, and Bash integration.")
277
278 ;; The combination is GPLv3+ but src/exo is under LGPLv3+.
279 (license license:gpl3+)))
280
281 (define-public lxmenu-data
282 (package
283 (name "lxmenu-data")
284 (version "0.1.5")
285 (source
286 (origin
287 (method url-fetch)
288 (uri (string-append "https://downloads.sourceforge.net/lxde/"
289 name "-" version ".tar.xz"))
290 (sha256
291 (base32
292 "1f5sh2dvb3pdnjlcsyzq9543ck2jsqizkx3204cr22zm5s6j3qwz"))))
293 (build-system gnu-build-system)
294 (native-inputs
295 `(("pkg-config" ,pkg-config)
296 ("intltool" ,intltool)))
297 (synopsis "Freedesktop.org desktop menus for LXDE")
298 (description
299 "Lxmenu-data provides files required to build freedesktop.org
300 menu spec-compliant desktop menus for LXDE.")
301 (home-page "https://lxde.org")
302 (license license:lgpl2.1+)))
303
304 (define-public lxde-icon-theme
305 (package
306 (name "lxde-icon-theme")
307 (version "0.5.1")
308 (source
309 (origin
310 (method url-fetch)
311 (uri (string-append "https://downloads.sourceforge.net/lxde/"
312 name "-" version ".tar.xz"))
313 (sha256
314 (base32
315 "0v4i6x86fr2hbx4fb2si7y2qzmj7h6hcjwaifnin18r8kwwvgl73"))))
316 (build-system gnu-build-system)
317 (native-inputs
318 `(("pkg-config" ,pkg-config)))
319 (synopsis "LXDE default icon theme based on nuoveXT2")
320 (description
321 "Lxde-icon-theme provides an default icon theme for LXDE.")
322 (home-page "https://lxde.org")
323 (license license:lgpl3)))
324
325 (define-public lxde-common
326 (package
327 (name "lxde-common")
328 (version "0.99.2")
329 (source
330 (origin
331 (method url-fetch)
332 (uri (string-append "https://downloads.sourceforge.net/lxde/"
333 name "-" version ".tar.xz"))
334 (sha256
335 (base32
336 "0mj84fa3f4ak1jjslrwc2q3ci9zxrxpciggviza9bjb0168brn8w"))))
337 (build-system gnu-build-system)
338 (arguments
339 '(#:phases (modify-phases %standard-phases
340 (add-before 'configure 'set-lxsession
341 (lambda* (#:key inputs #:allow-other-keys)
342 ;; Set the right file name for 'lxsession'.
343 (let ((lxsession (assoc-ref inputs "lxsession")))
344 (substitute* "startlxde.in"
345 (("^exec .*/bin/lxsession")
346 (string-append "exec " lxsession
347 "/bin/lxsession")))
348 #t))))))
349 (native-inputs
350 `(("pkg-config" ,pkg-config)
351 ("intltool" ,intltool)
352 ("lxmenu-data" ,lxmenu-data)
353 ("lxde-icon-theme" ,lxde-icon-theme)))
354 (inputs
355 `(("lxsession" ,lxsession)
356 ;; ("lxlock" ,lxlock) ;for 'lxde-screenlock.desktop'
357 ))
358 (synopsis "Common files of the LXDE Desktop")
359 (description
360 "Lxde-common provides common files of the LXDE Desktop.")
361 (home-page "https://lxde.org")
362 (license license:gpl2+)))
363
364 (define-public lxinput
365 (package
366 (name "lxinput")
367 (version "0.3.5")
368 (source
369 (origin
370 (method url-fetch)
371 (uri (string-append "https://downloads.sourceforge.net/lxde/"
372 name "-" version ".tar.xz"))
373 (sha256
374 (base32
375 "123f3yn4rp1w5b3n5aj3ad9snkxab29qkrs7bcvf5bx4cn57g3sf"))))
376 (build-system gnu-build-system)
377 (inputs
378 `(("gtk+-2" ,gtk+-2)))
379 (native-inputs
380 `(("pkg-config" ,pkg-config)
381 ("intltool" ,intltool)))
382 (synopsis "Tool for mouse and keyboard configuration in LXDE")
383 (description
384 "Lxinput provides a small program to configure keyboard and mouse
385 in LXDE.")
386 (home-page "https://lxde.org")
387 (license license:gpl2+)))
388
389 (define-public lxsession
390 (package
391 (name "lxsession")
392 (version "0.5.3")
393 (source
394 (origin
395 (method url-fetch)
396 (uri (string-append "https://downloads.sourceforge.net/lxde/"
397 name "-" version ".tar.xz"))
398 (patches (search-patches "lxsession-use-gapplication.patch"))
399 (sha256
400 (base32
401 "1a0zmyywwzdh59nc0l94cir18vhp633z4q2xfhn5zx11ajj45gwh"))
402 (modules '((guix build utils)))
403 (snippet
404 ;; Remove C files generated by Vala so we can build from source.
405 '(let* ((c->vala
406 (lambda (file)
407 (string-append (string-drop-right file 2)
408 ".vala")))
409 (generated-c-file?
410 (lambda (file stat)
411 (and (string-suffix? ".c" file)
412 (file-exists? (c->vala file))))))
413 (for-each delete-file
414 (find-files "." generated-c-file?))
415 #t))))
416 (build-system gnu-build-system)
417 (arguments
418 `(#:phases
419 (modify-phases %standard-phases
420 (add-after 'unpack 'rm-stamp
421 (lambda _
422 (for-each delete-file (find-files "." "\\.stamp$"))))
423 (add-after 'rm-stamp 'autoreconf
424 (lambda _
425 (zero? (system* "autoreconf" "-vfi")))))))
426 (inputs
427 `(("gtk+-2" ,gtk+-2)
428 ("polkit" ,polkit)))
429 (native-inputs
430 `(("pkg-config" ,pkg-config)
431 ("intltool" ,intltool)
432 ("docbook-xsl" ,docbook-xsl)
433 ("vala" ,vala)
434 ("autoconf" ,autoconf)
435 ("automake" ,automake)))
436 (synopsis "Lightweight X11 session manager")
437 (description
438 "Lxsession provides an lightweight X11 session manager.")
439 (home-page "https://lxde.org")
440 (license license:gpl2+)))
441
442 (define-public lxpanel
443 (package
444 (name "lxpanel")
445 (version "0.9.3")
446 (source
447 (origin
448 (method url-fetch)
449 (uri (string-append "https://downloads.sourceforge.net/lxde/"
450 name "-" version ".tar.xz"))
451 (sha256
452 (base32
453 "1ccgv7jgl3y865cpb6w7baaz7468fxncm83bqxlwyni5bwhglb1l"))))
454 (build-system gnu-build-system)
455 (arguments
456 `(#:phases
457 (modify-phases %standard-phases
458 (add-after 'install 'wrap
459 (lambda* (#:key inputs outputs #:allow-other-keys)
460 (let ((out (assoc-ref outputs "out"))
461 (menu (assoc-ref inputs "lxmenu-data")))
462 (wrap-program (string-append out "/bin/lxpanel")
463 `("XDG_DATA_DIRS" ":" prefix
464 (,(string-append menu "/share"))))
465 #t))))))
466 (inputs
467 ;; TODO: libindicator-0.3.0
468 `(("gtk+-2" ,gtk+-2)
469 ("alsa-lib" ,alsa-lib)
470 ("libwnck-2" ,libwnck-2)
471 ("keybinder" ,keybinder)
472 ("libxmu" ,libxmu)
473 ("libxpm" ,libxpm)
474 ("libxml2" ,libxml2)
475 ("cairo" ,cairo)
476 ("libx11" ,libx11)
477 ("wireless-tools" ,wireless-tools)))
478 (native-inputs
479 `(("pkg-config" ,pkg-config)
480 ("intltool" ,intltool)
481 ("docbook-xml" ,docbook-xml)
482 ("gettext-minimal" ,gettext-minimal)))
483 (propagated-inputs
484 `(("lxmenu-data" ,lxmenu-data)
485 ("libfm" ,libfm)
486 ("menu-cache" ,menu-cache)))
487 (synopsis "X11 Desktop panel for LXDE")
488 (description
489 "Lxpanel provides an X11 desktop panel for LXDE.")
490 (home-page "https://lxde.org")
491 (license license:gpl2+)))
492
493 (define-public lxde
494 (package
495 (name "lxde")
496 (version (package-version lxde-common))
497 (source #f)
498 (build-system trivial-build-system)
499 (arguments '(#:builder (begin (mkdir %output) #t)))
500 (propagated-inputs
501 ;; TODO:
502 ;; lxshortcut, lxsession-edit
503 ;; lxappearance-obconf
504 `(("menu-cache" ,menu-cache)
505 ("gpicview" ,gpicview)
506 ("leafpad" ,leafpad)
507 ("lxappearance" ,lxappearance)
508 ("lxde-icon-theme" ,lxde-icon-theme)
509 ("lxde-common" ,lxde-common)
510 ("lxmenu-data" ,lxmenu-data)
511 ("lxpanel" ,lxpanel)
512 ("lxrandr" ,lxrandr)
513 ("lxsession" ,lxsession)
514 ("libfm" ,libfm)
515 ("libfm-extra" ,libfm-extra)
516 ("lxtask" ,lxtask)
517 ("lxterminal" ,lxterminal)
518 ("pcmanfm" ,pcmanfm)
519 ("openbox" ,openbox)
520 ("obconf" ,obconf)))
521 (synopsis "Lightweight X11 Desktop Environment")
522 (description
523 "LXDE, which stands for Lightweight X11 Desktop Environment, is a
524 desktop environment which is lightweight and fast. It is designed to be
525 user friendly and slim, while keeping the resource usage low. LXDE uses
526 less RAM and less CPU while being a feature rich desktop environment. Unlike
527 other tightly integrated desktops LXDE strives to be modular, so each
528 component can be used independently with few dependencies.")
529 (home-page "https://lxde.org")
530 (license license:gpl2+))) ; And others.
531
532 ;;; lxde.scm ends here