tests: hackage: Fix mock urls.
[jackhill/guix/guix.git] / gnu / packages / slim.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Joshua Grant <tadni@riseup.net>
3 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages slim)
22 #:use-module ((guix licenses) #:prefix l:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system cmake)
26 #:use-module (guix packages)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages gl)
29 #:use-module (gnu packages xorg)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages fontutils)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages linux))
34
35 (define-public slim
36 (package
37 (name "slim")
38 (version "1.3.6")
39 (source (origin
40 (method url-fetch)
41 ;; Used to be available from download.berlios.de.
42 (uri (string-append
43 "mirror://sourceforge/slim.berlios/slim-"
44 version ".tar.gz"))
45 (sha256
46 (base32 "1pqhk22jb4aja4hkrm7rjgbgzjyh7i4zswdgf5nw862l2znzxpi1"))
47 (patches (search-patches "slim-config.patch"
48 "slim-session.patch"
49 "slim-sigusr1.patch"))))
50 (build-system cmake-build-system)
51 (inputs `(("linux-pam" ,linux-pam)
52 ("libpng" ,libpng)
53 ("libjpeg" ,libjpeg)
54 ("freeglut" ,freeglut)
55 ("libxrandr" ,libxrandr)
56 ("libxrender" ,libxrender)
57 ("freetype" ,freetype)
58 ("fontconfig" ,fontconfig)
59 ("libx11" ,libx11)
60 ("libxft" ,libxft)
61 ("libxmu" ,libxmu)
62 ("xauth" ,xauth)))
63 (native-inputs
64 `(("pkg-config" ,pkg-config)))
65 (arguments
66 '(#:phases (alist-cons-before
67 'configure 'set-new-etc-location
68 (lambda _
69 (substitute* "CMakeLists.txt"
70 (("/etc")
71 (string-append (assoc-ref %outputs "out") "/etc"))
72 (("install.*systemd.*")
73 ;; The build system's logic here is: if "Linux", then
74 ;; "systemd". Strip that.
75 "")))
76 %standard-phases)
77 #:configure-flags '("-DUSE_PAM=yes"
78 "-DUSE_CONSOLEKIT=no")
79 #:tests? #f))
80
81 ;; This used to be at <http://slim.berlios.de/>.
82 (home-page "http://sourceforge.net/projects/slim.berlios/")
83 (synopsis "Desktop-independent graphical login manager for X11")
84 (description
85 "SLiM is a Desktop-independent graphical login manager for X11, derived
86 from Login.app. It aims to be light and simple, although completely
87 configurable through themes and an option file; is suitable for machines on
88 which remote login functionalities are not needed.
89
90 Features included: PNG and XFT support for alpha transparency and antialiased
91 fonts, External themes support, Configurable runtime options: X server --
92 login / shutdown / reboot commands, Single (GDM-like) or double (XDM-like)
93 input control, Can load predefined user at startup, Configurable welcome /
94 shutdown messages, Random theme selection.")
95 (license l:gpl2)))