gnu: Python: use /nix/.../sh instead of /bin/sh in the subprocess module
[jackhill/guix/guix.git] / gnu / packages / plotutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages plotutils)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages libpng)
26 #:use-module (gnu packages))
27
28 (define-public plotutils
29 (package
30 (name "plotutils")
31 (version "2.6")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/plotutils/plotutils-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1arkyizn5wbgvbh53aziv3s6lmd3wm9lqzkhxb3hijlp1y124hjg"))
39 (patches (list (search-patch "plotutils-libpng-jmpbuf.patch")))))
40 (build-system gnu-build-system)
41 (inputs `(("libpng" ,libpng)
42 ("libx11" ,libx11)
43 ("libxt" ,libxt)
44 ("libxaw" ,libxaw)))
45 (home-page
46 "http://www.gnu.org/software/plotutils/")
47 (synopsis "Plotting utilities and library")
48 (description
49 "GNU Plotutils is a package for plotting and working with 2D graphics.
50 It includes a library, \"libplot\", for C and C++ for exporting 2D vector
51 graphics in many file formats. It also has support for 2D vector graphics
52 animations. The package also contains command-line programs for plotting
53 scientific data.")
54 (license gpl2+)))