gnu: Use HTTPS for almost all gnu.org HOME-PAGEs.
[jackhill/guix/guix.git] / gnu / packages / gnu-doc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gnu-doc)
21 #:use-module (gnu packages base)
22 #:use-module (gnu packages compression)
23 #:use-module (gnu packages texinfo)
24
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system trivial)
27 #:use-module (guix cvs-download)
28 #:use-module (guix download)
29 #:use-module (guix licenses)
30 #:use-module (guix packages))
31
32 (define-public miscfiles
33 (package
34 (name "miscfiles")
35 (version "1.5")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/" name "/" name "-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "005588vfrwx8ghsdv9p7zczj9lbc9a3r4m5aphcaqv8gif4siaka"))))
44 (build-system gnu-build-system)
45 (home-page "https://www.gnu.org/software/miscfiles/")
46 (synopsis
47 "Data files for airport codes, zip codes, a dictionary, and more")
48 (description
49 "GNU Miscfiles is a collection of common data files. They include, for
50 example, country abbreviations, names and capital cities; currency
51 abbreviations and names; a Best Current Practices index; a map of the ASCII
52 character set; a list of three-letter airport codes; and an English word
53 list.")
54 (license gpl2+)))
55
56 (define-public gnu-standards
57 (package
58 (name "gnu-standards")
59 (version "2016-03-25")
60 (source
61 (origin
62 (method cvs-fetch)
63 (uri (cvs-reference
64 (root-directory
65 ":pserver:anonymous@cvs.savannah.gnu.org:/sources/gnustandards")
66 (module "gnustandards")
67 (revision "2016-03-25")))
68 (sha256
69 (base32
70 "0qn7mzdjqwc6h9prin22x6kj9iqipxpbzldzhmis7q4x4hpi61vj"))))
71 (build-system trivial-build-system)
72 (native-inputs `(("gzip" ,gzip)
73 ("source" ,source)
74 ("texinfo" ,texinfo)))
75 (arguments
76 `(#:modules ((guix build utils))
77 #:builder
78 (begin
79 (use-modules (guix build utils))
80 (let ((gzip (assoc-ref %build-inputs "gzip"))
81 (source (assoc-ref %build-inputs "source"))
82 (texinfo (assoc-ref %build-inputs "texinfo"))
83 (info-dir (string-append %output "/share/info")))
84 (setenv "PATH" (string-append gzip "/bin"
85 ":" texinfo "/bin"))
86 (mkdir-p info-dir)
87 (system* "makeinfo" "--output" info-dir
88 (string-append source "/maintain.texi"))
89 (system* "makeinfo" "--output" info-dir
90 (string-append source "/standards.texi"))
91 (system* "gzip" (string-append info-dir "/maintain.info"))
92 (system* "gzip" (string-append info-dir "/standards.info"))))))
93 (home-page "https://www.gnu.org/prep/standards/")
94 (synopsis "GNU coding standards and maintainer information")
95 (description "The GNU Coding Standards were written by Richard Stallman
96 and other GNU Project volunteers. Their purpose is to make the GNU system
97 clean, consistent, and easy to install.
98
99 The information for maintainers of GNU software has guidelines and advice for
100 someone who is the maintainer of a GNU program on behalf of the GNU Project.")
101 (license fdl1.3+)))