gnu: Use HTTPS for almost all gnu.org HOME-PAGEs.
[jackhill/guix/guix.git] / gnu / packages / dico.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages dico)
21 #:use-module (guix packages)
22 #:use-module ((guix licenses) #:select (gpl3+))
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages readline)
27 #:use-module (gnu packages m4)
28 #:use-module (gnu packages groff)
29 #:use-module (gnu packages guile)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages pcre)
32 #:use-module (gnu packages gsasl)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages wordnet))
36
37 (define-public dico
38 (package
39 (name "dico")
40 (version "2.4")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "mirror://gnu/dico/dico-"
44 version ".tar.xz"))
45 (sha256
46 (base32
47 "13m7vahfbdj7hb38bjgd4cmfswavvxrcpppj9n4m4rar3wyzg52g"))))
48 (build-system gnu-build-system)
49 (arguments
50 '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
51 "/share/guile/site/2.0"))
52 #:make-flags '("V=1")
53 #:phases (modify-phases %standard-phases
54 (add-before 'check 'silence-guile
55 (lambda _
56 ;; Guile is too talkative, which disturbs the test
57 ;; infrastructure. Gag it.
58 (setenv "GUILE_AUTO_COMPILE" "0")
59 (setenv "GUILE_WARN_DEPRECATED" "no")
60 #t)))))
61 (inputs
62 `(("m4" ,m4) ;used at run time
63 ("pcre" ,pcre)
64 ("python" ,python-2)
65 ("guile" ,guile-2.0)
66 ("gsasl" ,gsasl)
67 ("groff" ,groff)
68 ("readline" ,readline)
69 ("zlib" ,zlib)
70 ;; ("wordnet" ,wordnet) ;FIXME: link failure
71 ("libltdl" ,libltdl)))
72 (home-page "https://www.gnu.org/software/dico/")
73 (synopsis "Implementation of DICT server (RFC 2229)")
74 (description
75 "GNU Dico implements a flexible dictionary server and client according to
76 RFC 2229 (DICT Server). It is able to access any database available,
77 regardless of format, thanks to its modular structure. New modules may be
78 written in C, Guile or Python. Dico also includes a command-line client,
79 which may be used to query remote dictionary databases.")
80 (license gpl3+)))