gnu: Use HTTPS for almost all gnu.org HOME-PAGEs.
[jackhill/guix/guix.git] / gnu / packages / bison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages bison)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages m4)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages flex)
27 #:use-module (srfi srfi-1))
28
29 (define-public bison
30 (package
31 (name "bison")
32 (version "3.0.4")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/bison/bison-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "1qbgf6q1n2z17k8g33444m0q68kf3fbiq65q7jlrzpvvj73jh957"))))
41 (build-system gnu-build-system)
42 (native-inputs `(("perl" ,perl)
43 ;; m4 is not present in PATH when cross-building
44 ("m4" ,m4)))
45 (inputs `(("flex" ,flex)))
46 (propagated-inputs `(("m4" ,m4)))
47 (home-page "https://www.gnu.org/software/bison/")
48 (synopsis "Parser generator")
49 (description
50 "GNU Bison is a general-purpose parser generator. It can build a
51 deterministic or generalized LR parser from an annotated, context-free
52 grammar. It is versatile enough to have many applications, from parsers for
53 simple tools through complex programming languages.")
54 (license gpl3+)))
55
56 (define-public bison-2.7
57 (package (inherit bison)
58 (version "2.7")
59 (source
60 (origin
61 (method url-fetch)
62 (uri (string-append "mirror://gnu/bison/bison-"
63 version ".tar.xz"))
64 (sha256
65 (base32
66 "1zd77ilmpv5mi3kr55jrj6ncqlcnyhpianhrwzak2q28cv2cbn23"))))))