gnu: sdl-mixer: Enable fluidsynth MIDI backend.
[jackhill/guix/guix.git] / gnu / packages / sdl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015, 2017 David Thompson <dthompson2@worcester.edu>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015, 2017 Sou Bunnbu <iyzsong@member.fsf.org>
5 ;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
6 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
8 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
11 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
12 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
13 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
14 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages sdl)
32 #:use-module (ice-9 match)
33 #:use-module (srfi srfi-1)
34 #:use-module (srfi srfi-26)
35 #:use-module (gnu packages)
36 #:use-module ((guix licenses) #:hide (freetype))
37 #:use-module (guix packages)
38 #:use-module (guix download)
39 #:use-module (guix git-download)
40 #:use-module (guix utils)
41 #:use-module (guix build-system gnu)
42 #:use-module (guix build-system trivial)
43 #:use-module (gnu packages audio)
44 #:use-module (gnu packages fcitx)
45 #:use-module (gnu packages fontutils)
46 #:use-module (gnu packages freedesktop)
47 #:use-module (gnu packages glib)
48 #:use-module (gnu packages guile)
49 #:use-module (gnu packages ibus)
50 #:use-module (gnu packages image)
51 #:use-module (gnu packages linux)
52 #:use-module (gnu packages mono)
53 #:use-module (gnu packages mp3)
54 #:use-module (gnu packages pkg-config)
55 #:use-module (gnu packages pulseaudio)
56 #:use-module (gnu packages gl)
57 #:use-module (gnu packages xdisorg)
58 #:use-module (gnu packages xiph)
59 #:use-module (gnu packages xorg)
60 #:export (sdl-union))
61
62 (define-public sdl
63 (package
64 (name "sdl")
65 (version "1.2.15")
66 (source (origin
67 (method url-fetch)
68 (uri
69 (string-append "https://libsdl.org/release/SDL-"
70 version ".tar.gz"))
71 (sha256
72 (base32
73 "005d993xcac8236fpvd1iawkz4wqjybkpn8dbwaliqz5jfkidlyn"))
74 (patches (search-patches "sdl-libx11-1.6.patch"))))
75 (build-system gnu-build-system)
76 (arguments
77 '(;; Explicitly link against shared libraries instead of dlopening them.
78 ;; For X11, ALSA, and PulseAudio.
79 ;; OpenGL library is still dlopened at runtime.
80 #:configure-flags '("--disable-alsa-shared"
81 "--disable-pulseaudio-shared"
82 "--disable-x11-shared"
83 ;; Explicitly link with mesa.
84 ;; This add mesa to libsdl's RUNPATH, to make dlopen
85 ;; finding the libGL from mesa at runtime.
86 "LDFLAGS=-lGL")
87
88 #:make-flags '("V=1") ;build verbosely
89
90 #:tests? #f)) ; no check target
91 (propagated-inputs
92 ;; SDL headers include X11 headers.
93 `(("libx11" ,libx11)
94 ("libcap" ,libcap) ; 'libSDL.la' contain `-lcap'.
95 ;; TODO: Since building Mesa with Meson it is now necessary that Mesa is
96 ;; a propogated input. We still need to figure out why, possibly due to a
97 ;; change in pkg-config.
98 ("mesa" ,mesa)))
99 (native-inputs `(("pkg-config" ,pkg-config)))
100 (inputs `(("libxrandr" ,libxrandr)
101 ("glu" ,glu)
102 ("alsa-lib" ,alsa-lib)
103 ("pulseaudio" ,pulseaudio)))
104 (outputs '("out" "debug"))
105 (synopsis "Cross platform game development library")
106 (description "Simple DirectMedia Layer is a cross-platform development
107 library designed to provide low level access to audio, keyboard, mouse,
108 joystick, and graphics hardware.")
109 (home-page "https://libsdl.org/")
110 (license lgpl2.1)))
111
112 (define-public sdl2
113 (package (inherit sdl)
114 (name "sdl2")
115 (version "2.0.10")
116 (source (origin
117 (method url-fetch)
118 (uri
119 (string-append "https://libsdl.org/release/SDL2-"
120 version ".tar.gz"))
121 (patches (search-patches "sdl2-mesa-compat.patch"))
122 (sha256
123 (base32
124 "0mqxp6w5jhbq6y1j690g9r3gpzwjxh4czaglw8x05l7hl49nqrdl"))))
125 (arguments
126 (substitute-keyword-arguments (package-arguments sdl)
127 ((#:configure-flags flags)
128 `(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
129 "--disable-kmsdrm-shared")
130 ,flags))
131 ((#:make-flags flags ''())
132 ;; Add the Fcitx header files to GCCs "system header" search path
133 ;; in order to suppress compiler warnings induced by those:
134 ;; .../include/fcitx-utils/utarray.h:178:9: error: ISO C90 forbids
135 ;; mixed declarations and code [-Werror=declaration-after-statement]
136 `(append (list (string-append "C_INCLUDE_PATH="
137 (assoc-ref %build-inputs "fcitx")
138 "/include"))
139 ,flags))))
140 (inputs
141 ;; SDL2 needs to be built with ibus support otherwise some systems
142 ;; experience a bug where input events are doubled.
143 ;;
144 ;; For more information, see: https://dev.solus-project.com/T1721
145 (append `(("dbus" ,dbus)
146 ("fcitx" ,fcitx) ; helps with CJK input
147 ("glib" ,glib)
148 ("ibus" ,ibus)
149 ("libxkbcommon" ,libxkbcommon)
150 ("libxcursor" ,libxcursor) ; enables X11 cursor support
151 ("wayland" ,wayland)
152 ("wayland-protocols" ,wayland-protocols))
153 (package-inputs sdl)))
154 (license bsd-3)))
155
156 (define-public libmikmod
157 (package
158 (name "libmikmod")
159 (version "3.3.11.1")
160 (source (origin
161 (method url-fetch)
162 (uri (list
163 (string-append "mirror://sourceforge/mikmod/libmikmod/"
164 version "/libmikmod-" version ".tar.gz")
165 ;; Older versions are sometimes moved to:
166 (string-append "mirror://sourceforge/mikmod/"
167 "outdated_versions/libmikmod/"
168 version "/libmikmod-" version ".tar.gz")))
169 (sha256
170 (base32
171 "06bdnhb0l81srdzg6gn2v2ydhhaazza7rshrcj3q8dpqr3gn97dd"))))
172 (build-system gnu-build-system)
173 (arguments
174 ;; By default, libmikmod tries to dlopen libasound etc., which won't work
175 ;; unless the right libalsa happens to be in $LD_LIBRARY_PATH. Pass
176 ;; '--disable-dl' to avoid that.
177 '(#:configure-flags '("--disable-dl")))
178 (synopsis "Library for module sound formats")
179 (description
180 "MikMod is able to play a wide range of module formats, as well as
181 digital sound files. It can take advantage of particular features of your
182 system, such as sound redirection over the network.")
183 (license lgpl2.1)
184 (home-page "http://mikmod.sourceforge.net/")))
185
186 (define-public sdl-gfx
187 (package
188 (name "sdl-gfx")
189 (version "2.0.26")
190 (source (origin
191 (method url-fetch)
192 (uri
193 (string-append "http://www.ferzkopp.net/Software/SDL_gfx-2.0/SDL_gfx-"
194 version ".tar.gz"))
195 (sha256
196 (base32
197 "0ijljhs0v99dj6y27hc10z6qchyp8gdp4199y6jzngy6dzxlzsvw"))))
198 (build-system gnu-build-system)
199 (outputs '("out" "debug"))
200 (arguments
201 `(,@(if (any (cute string-prefix? <> (or (%current-system)
202 (%current-target-system)))
203 '("x86_64" "i686"))
204 ;; mmx is supported only on Intel processors.
205 '()
206 '(#:configure-flags '("--disable-mmx")))))
207 (propagated-inputs `(("sdl" ,sdl)))
208 (synopsis "SDL graphics primitives library")
209 (description "SDL_gfx provides graphics drawing primitives, rotozoom and
210 other supporting functions for SDL.")
211 (home-page "http://www.ferzkopp.net/joomla/software-mainmenu-14/4-ferzkopps-linux-software/19-sdlgfx")
212 (license zlib)))
213
214 (define-public sdl-image
215 (package
216 (name "sdl-image")
217 (version "1.2.12")
218 (source (origin
219 (method url-fetch)
220 (uri
221 (string-append "https://www.libsdl.org/projects/SDL_image/release/SDL_image-"
222 version ".tar.gz"))
223 (sha256
224 (base32
225 "16an9slbb8ci7d89wakkmyfvp7c0cval8xw4hkg0842nhhlp540b"))))
226 (build-system gnu-build-system)
227 (outputs '("out" "debug"))
228 (arguments
229 ;; Explicitly link against shared libraries instead of dlopening them.
230 '(#:configure-flags '("--disable-jpg-shared"
231 "--disable-png-shared"
232 "--disable-tif-shared"
233 "--disable-webp-shared")))
234 (native-inputs `(("pkg-config" ,pkg-config)))
235 ;; libjpeg, libpng, and libtiff are propagated inputs because the
236 ;; SDL_image headers include the headers of these libraries. SDL is a
237 ;; propagated input because the pkg-config file refers to SDL's pkg-config
238 ;; file.
239 (propagated-inputs `(("sdl" ,sdl)
240 ("libjpeg" ,libjpeg)
241 ("libpng" ,libpng)
242 ("libtiff" ,libtiff)
243 ("libwebp" ,libwebp)))
244 (synopsis "SDL image loading library")
245 (description "SDL_image is an image file loading library for SDL that
246 supports the following formats: BMP, GIF, JPEG, LBM, PCX, PNG, PNM, TGA, TIFF,
247 WEBP, XCF, XPM, and XV.")
248 (home-page "https://www.libsdl.org/projects/SDL_image/")
249 (license zlib)))
250
251 (define-public sdl-mixer
252 (package
253 (name "sdl-mixer")
254 (version "1.2.12")
255 (source (origin
256 (method url-fetch)
257 (uri
258 (string-append "https://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-"
259 version ".tar.gz"))
260 (sha256
261 (base32
262 "0alrhqgm40p4c92s26mimg9cm1y7rzr6m0p49687jxd9g6130i0n"))))
263 (build-system gnu-build-system)
264 (outputs '("out" "debug"))
265 (arguments
266 `(#:tests? #f ; No check target.
267 #:configure-flags
268 '("--enable-music-mp3-mad-gpl" ; Use libmad instead of smpeg.
269 ;; Explicitly link against shared libraries instead of dlopening them.
270 "--disable-music-flac-shared"
271 "--disable-music-fluidsynth-shared"
272 "--disable-music-mod-shared"
273 "--disable-music-ogg-shared")))
274 (inputs
275 `(("fluidsynth" ,fluidsynth)
276 ("libflac" ,flac)
277 ("libmad" ,libmad)
278 ("libmikmod" ,libmikmod)
279 ("libvorbis" ,libvorbis)))
280 (propagated-inputs `(("sdl" ,sdl)))
281 (synopsis "SDL multi-channel audio mixer library")
282 (description "SDL_mixer is a multi-channel audio mixer library for SDL.
283 It supports any number of simultaneously playing channels of 16 bit stereo
284 audio, plus a single channel of music. Supported format include FLAC, MOD,
285 MIDI, Ogg Vorbis, and MP3.")
286 (home-page "https://www.libsdl.org/projects/SDL_mixer/")
287 (license zlib)))
288
289 (define-public sdl-net
290 (package
291 (name "sdl-net")
292 (version "1.2.8")
293 (source (origin
294 (method url-fetch)
295 (uri
296 (string-append "https://www.libsdl.org/projects/SDL_net/release/SDL_net-"
297 version ".tar.gz"))
298 (sha256
299 (base32
300 "1d5c9xqlf4s1c01gzv6cxmg0r621pq9kfgxcg3197xw4p25pljjz"))))
301 (build-system gnu-build-system)
302 (propagated-inputs `(("sdl" ,sdl)))
303 (native-inputs `(("pkg-config" ,pkg-config)))
304 (outputs '("out" "debug"))
305 (synopsis "SDL networking library")
306 (description "SDL_net is a small, cross-platform networking library for
307 SDL.")
308 (home-page "https://www.libsdl.org/projects/SDL_net/")
309 (license zlib)))
310
311 (define-public sdl-ttf
312 (package
313 (name "sdl-ttf")
314 (version "2.0.11")
315 (source (origin
316 (method url-fetch)
317 (uri
318 (string-append "https://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-"
319 version ".tar.gz"))
320 (sha256
321 (base32
322 "1dydxd4f5kb1288i5n5568kdk2q7f8mqjr7i7sd33nplxjaxhk3j"))))
323 (build-system gnu-build-system)
324 (propagated-inputs `(("sdl" ,sdl)))
325 (inputs `(("freetype" ,freetype)
326 ("mesa" ,mesa)))
327 (native-inputs `(("pkg-config" ,pkg-config)))
328 (outputs '("out" "debug"))
329 (synopsis "SDL TrueType font library")
330 (description "SDL_ttf is a TrueType font rendering library for SDL.")
331 (home-page "https://www.libsdl.org/projects/SDL_ttf/")
332 (license zlib)))
333
334 (define* (sdl-union #:optional (packages (list sdl sdl-gfx sdl-net sdl-ttf
335 sdl-image sdl-mixer)))
336 "Return 'sdl-union' package which is a union of PACKAGES.
337 If PACKAGES are not specified, all SDL packages are used."
338 (package
339 (name "sdl-union")
340 (version (package-version sdl))
341 (source #f)
342 (build-system trivial-build-system)
343 (arguments
344 '(#:modules ((guix build union))
345 #:builder (begin
346 (use-modules (ice-9 match)
347 (guix build union))
348 (match %build-inputs
349 (((names . directories) ...)
350 (union-build (assoc-ref %outputs "out")
351 directories)
352 #t)))))
353 (inputs (map (lambda (package)
354 (list (package-name package) package))
355 packages))
356 (synopsis "Union of SDL libraries")
357 (description
358 "A union of SDL and its extension libraries. A union is required because
359 sdl-config assumes that all of the headers and libraries are in the same
360 directory.")
361 (home-page (package-home-page sdl))
362 (license (package-license sdl))))
363
364 (define (propagated-inputs-with-sdl2 package)
365 "Replace the \"sdl\" propagated input of PACKAGE with SDL2."
366 (map (match-lambda
367 (("sdl" _)
368 `("sdl2" ,sdl2))
369 (other other))
370 (package-propagated-inputs package)))
371
372 (define-public sdl2-gfx
373 (package (inherit sdl-gfx)
374 (name "sdl2-gfx")
375 (version "1.0.4")
376 (source (origin
377 (method url-fetch)
378 (uri
379 (string-append "https://www.ferzkopp.net/Software/SDL2_gfx/SDL2_gfx-"
380 version ".tar.gz"))
381 (sha256
382 (base32
383 "0qk2ax7f7grlxb13ba0ll3zlm8780s7j8fmrhlpxzjgdvldf1q33"))))
384 (propagated-inputs
385 (propagated-inputs-with-sdl2 sdl-gfx))))
386
387 (define-public sdl2-image
388 (package (inherit sdl-image)
389 (name "sdl2-image")
390 (version "2.0.4")
391 (source
392 (origin
393 (method url-fetch)
394 (uri
395 (string-append "https://www.libsdl.org/projects/SDL_image/release/"
396 "SDL2_image-" version ".tar.gz"))
397 (sha256
398 (base32 "1b6f7002bm007y3zpyxb5r6ag0lml51jyvx1pwpj9sq24jfc8kp7"))))
399 (propagated-inputs
400 (propagated-inputs-with-sdl2 sdl-image))))
401
402 (define-public sdl2-mixer
403 (package (inherit sdl-mixer)
404 (name "sdl2-mixer")
405 (version "2.0.4")
406 (source
407 (origin
408 (method url-fetch)
409 (uri
410 (string-append "http://www.libsdl.org/projects/SDL_mixer/release/"
411 "SDL2_mixer-" version ".tar.gz"))
412 (modules '((guix build utils)))
413 (snippet '(begin
414 ;; Remove bundled libraries.
415 (delete-file-recursively "external")
416 #t))
417 (sha256
418 (base32 "0694vsz5bjkcdgfdra6x9fq8vpzrl8m6q96gh58df7065hw5mkxl"))))
419 (arguments
420 (substitute-keyword-arguments (package-arguments sdl-mixer)
421 ((#:configure-flags flags)
422 `(cons*
423 ;; These options were renamed in SDL2 mixer. Keeping the inherited
424 ;; variants produces a harmless warning.
425 "--disable-music-mod-modplug-shared"
426 "--disable-music-midi-fluidsynth-shared"
427 ,flags))))
428 (inputs
429 ;; The default MOD library changed in SDL2 mixer.
430 `(("libmodplug" ,libmodplug)
431 ,@(alist-delete "libmikmod" (package-inputs sdl-mixer))))
432 (propagated-inputs
433 (propagated-inputs-with-sdl2 sdl-mixer))))
434
435 (define-public sdl2-net
436 (package (inherit sdl-net)
437 (name "sdl2-net")
438 (version "2.0.1")
439 (source
440 (origin
441 (method url-fetch)
442 (uri
443 (string-append "http://www.libsdl.org/projects/SDL_net/release/"
444 "SDL2_net-" version ".tar.gz"))
445 (sha256
446 (base32
447 "08cxc1bicmyk89kiks7izw1rlx5ng5n6xpy8fy0zxni3b9z8mkhm"))))
448 (propagated-inputs
449 (propagated-inputs-with-sdl2 sdl-net))))
450
451 (define-public sdl2-ttf
452 (package (inherit sdl-ttf)
453 (name "sdl2-ttf")
454 (version "2.0.15")
455 (source (origin
456 (method url-fetch)
457 (uri
458 (string-append "https://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-"
459 version ".tar.gz"))
460 (modules '((guix build utils)))
461 (snippet (begin
462 ;; Remove bundled libraries.
463 '(delete-file-recursively "external")
464 #t))
465 (sha256
466 (base32
467 "0cyd48dipc0m399qy8s03lci8b0bpiy8xlkvrm2ia7wcv0dfpv59"))))
468 (propagated-inputs
469 (propagated-inputs-with-sdl2 sdl-ttf))))
470
471 (define-public guile-sdl
472 (package
473 (name "guile-sdl")
474 (version "0.5.2")
475 (source (origin
476 (method url-fetch)
477 (uri
478 (string-append "mirror://gnu/guile-sdl/guile-sdl-"
479 version ".tar.xz"))
480 (sha256
481 (base32
482 "0cjgs012a9922hn6xqwj66w6qmfs3nycnm56hyykx5n3g5p7ag01"))))
483 (build-system gnu-build-system)
484 (native-inputs
485 `(("pkg-config" ,pkg-config)
486 ;; Required by test suite.
487 ("xorg-server" ,xorg-server)
488 ("libjpeg" ,libjpeg)))
489 (inputs
490 `(("guile" ,guile-2.2)
491 ("sdl-union" ,(sdl-union))))
492 (arguments
493 '(#:configure-flags
494 (list (string-append "--with-sdl-prefix="
495 (assoc-ref %build-inputs "sdl-union")))
496 #:modules ((ice-9 popen)
497 (guix build utils)
498 (guix build gnu-build-system))
499
500 #:parallel-build? #f ; parallel build fails
501
502 #:phases
503 (modify-phases %standard-phases
504 (add-before 'configure 'fix-env-and-patch
505 (lambda* (#:key inputs #:allow-other-keys)
506 (setenv "GUILE_AUTO_COMPILE" "0")
507 ;; SDL_image needs to dlopen libjpeg in the test suite.
508 (setenv "LD_LIBRARY_PATH"
509 (string-append (assoc-ref inputs "libjpeg") "/lib"))
510
511 ;; Change the site directory /site/X.Y like Guile expects.
512 (substitute* "build-aux/guile-baux/re-prefixed-site-dirs"
513 (("\"/site\"")
514 (let ((effective
515 (read
516 (open-pipe* OPEN_READ
517 "guile" "-c"
518 "(write (effective-version))"))))
519 (string-append "\"/site/" effective "\""))))
520
521 ;; Skip tests that rely on sound support, which is unavailable in
522 ;; the build environment.
523 (substitute* "test/Makefile.in"
524 (("HAVE_MIXER = .*$")
525 "HAVE_MIXER = 0\n"))
526 #t))
527 (add-before 'check 'start-xorg-server
528 (lambda* (#:key inputs #:allow-other-keys)
529 ;; The test suite requires a running X server.
530 (system (format #f "~a/bin/Xvfb :1 &"
531 (assoc-ref inputs "xorg-server")))
532 (setenv "DISPLAY" ":1")
533 #t))
534 (add-before 'check 'skip-cursor-test
535 (lambda _
536 ;; XXX: This test sometimes enters an endless loop, and sometimes
537 ;; crashes with:
538 ;; guile: xcb_io.c:147: append_pending_request: Assertion `!xcb_xlib_unknown_seq_number' failed.
539 ;; Skip it.
540 (substitute* "test/cursor.scm"
541 (("\\(SDL:init .*" all)
542 (string-append "(exit 77) ;" all "\n")))
543 #t)))))
544 (synopsis "Guile interface for SDL (Simple DirectMedia Layer)")
545 (description "Guile-SDL is a set of bindings to the Simple DirectMedia
546 Layer (SDL). With them, Guile programmers can have easy access to graphics,
547 sound and device input (keyboards, joysticks, mice, etc.).")
548 (home-page "https://www.gnu.org/software/guile-sdl/")
549 (license gpl3+)))
550
551 (define-public guile-sdl2
552 (package
553 (name "guile-sdl2")
554 (version "0.4.0")
555 (source (origin
556 (method url-fetch)
557 (uri (string-append "https://files.dthompson.us/guile-sdl2/"
558 "guile-sdl2-" version ".tar.gz"))
559 (sha256
560 (base32
561 "0zcxwgyadwpbhq6h5mv2569c3kalgra26zc186y9fqiyyzmh1v9s"))))
562 (build-system gnu-build-system)
563 (arguments
564 '(#:make-flags '("GUILE_AUTO_COMPILE=0")
565 #:configure-flags
566 (list (string-append "--with-libsdl2-prefix="
567 (assoc-ref %build-inputs "sdl2"))
568 (string-append "--with-libsdl2-image-prefix="
569 (assoc-ref %build-inputs "sdl2-image"))
570 (string-append "--with-libsdl2-ttf-prefix="
571 (assoc-ref %build-inputs "sdl2-ttf"))
572 (string-append "--with-libsdl2-mixer-prefix="
573 (assoc-ref %build-inputs "sdl2-mixer")))))
574 (native-inputs
575 `(("guile" ,guile-2.2)
576 ("pkg-config" ,pkg-config)))
577 (inputs
578 `(("sdl2" ,sdl2)
579 ("sdl2-image" ,sdl2-image)
580 ("sdl2-mixer" ,sdl2-mixer)
581 ("sdl2-ttf" ,sdl2-ttf)))
582 (synopsis "Guile bindings for SDL2")
583 (home-page "https://dthompson.us/projects/guile-sdl2.html")
584 (description
585 "Guile-SDL2 provides Guile Scheme bindings for the SDL2 C shared library.
586 The bindings are written in pure Scheme using Guile's foreign function
587 interface.")
588 (license lgpl3+)))
589
590 (define-public sdl2-cs
591 (let ((commit "1a3556441e1394eb0b5d46aeb514b8d1090b93f8"))
592 (package
593 (name "sdl2-cs")
594 (version (git-version "B1" "1" commit))
595 (source (origin
596 (method git-fetch)
597 (uri (git-reference
598 (url "https://github.com/flibitijibibo/SDL2-CS")
599 (commit commit)))
600 (file-name (git-file-name name version))
601 (sha256
602 (base32
603 "007mzkqr9nmvfrvvhs2r6cm36lzgsww24kwshsz9c4fd97f9qk58"))))
604 (build-system gnu-build-system)
605 (arguments
606 '(#:tests? #f ; No tests.
607 #:phases
608 (modify-phases %standard-phases
609 (delete 'configure)
610 (replace 'build
611 (lambda _
612 (invoke "make" "release")))
613 (replace 'install
614 (lambda* (#:key outputs #:allow-other-keys)
615 (let ((out (assoc-ref outputs "out")))
616 (install-file "bin/Release/SDL2-CS.dll" (string-append out "/lib"))
617 #t))))))
618 (native-inputs
619 `(("mono" ,mono)))
620 (inputs
621 `(("sdl2" ,sdl2)
622 ("sdl2-image" ,sdl2-image)
623 ("sdl2-mixer" ,sdl2-mixer)
624 ("sdl2-ttf" ,sdl2-ttf)))
625 (home-page "https://dthompson.us/projects/guile-sdl2.html")
626 (synopsis "C# wrapper for SDL2")
627 (description
628 "SDL2-CS provides C# bindings for the SDL2 C shared library.
629 The C# wrapper was written to be used for FNA's platform support. However, this
630 is written in a way that can be used for any general C# application.")
631 (license zlib))))