gnu: swig: Disable input python.
[jackhill/guix/guix.git] / gnu / packages / swig.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages swig)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pcre)
25 #:use-module (gnu packages guile)
26 #:use-module (gnu packages boost)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages perl)
29 #:export (swig))
30
31 (define swig
32 (package
33 (name "swig")
34 (version "3.0.2")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://sourceforge/swig/swig-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "04vqrij3k6pcq41y7rzl5rmhnghqg905f11wyrqw7vdwr9brcrm2"))))
42 (build-system gnu-build-system)
43 (native-inputs `(("boost" ,boost)))
44 (inputs `(("pcre" ,pcre)
45
46 ;; Provide these to run the corresponding tests.
47 ("guile" ,guile-2.0)
48 ("perl" ,perl)))
49 ;; FIXME: reactivate input python as soon as the test failures
50 ;; fatal error: Python.h: No such file or directory
51 ;; # include <Python.h>
52 ;; are fixed.
53 ;; The python part probably never worked and does not seem to
54 ;; be needed for currently dependent packages.
55 ;; ("python" ,python-wrapper)))
56 (home-page "http://swig.org/")
57 (synopsis
58 "Interface compiler that connects C/C++ code to higher-level languages")
59 (description
60 "SWIG is an interface compiler that connects programs written in C and
61 C++ with languages such as Perl, Python, Ruby, Scheme, and Tcl. It works by
62 taking the declarations found in C/C++ header files and using them to generate
63 the wrapper code that scripting languages need to access the underlying C/C++
64 code. In addition, SWIG provides a variety of customization features that let
65 you tailor the wrapping process to suit your application.")
66
67 ;; See http://www.swig.org/Release/LICENSE for details.
68 (license gpl3+)))