gnu: Add external-program.
[jackhill/guix/guix.git] / gnu / packages / mastodon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages mastodon)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system python)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages check)
26 #:use-module (gnu packages python-web)
27 #:use-module (gnu packages python-xyz))
28
29 (define-public toot
30 (package
31 (name "toot")
32 (version "0.24.0")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (pypi-uri "toot" version))
37 (sha256
38 (base32 "0w83b6ydaggrand9285wfrjrm1qry8fjl4as0iihma630ky6y2w3"))))
39 (build-system python-build-system)
40 (arguments
41 '(#:phases
42 (modify-phases %standard-phases
43 (delete 'check)
44 (add-after 'install 'check
45 (lambda* (#:key inputs outputs #:allow-other-keys)
46 (add-installed-pythonpath inputs outputs)
47 (invoke "py.test"))))))
48 (native-inputs
49 `(("python-pytest" ,python-pytest)))
50 (inputs
51 `(("python-beautifulsoup4" ,python-beautifulsoup4)
52 ("python-requests" ,python-requests)
53 ("python-urwid" ,python-urwid)
54 ("python-wcwidth" ,python-wcwidth)))
55 (home-page "https://github.com/ihabunek/toot/")
56 (synopsis "Mastodon CLI client")
57 (description "Interact with Mastodon social network from the command line.
58 Features include:
59 @itemize
60 @item Posting, replying, deleting statuses
61 @item Support for media uploads, spoiler text, sensitive content
62 @item Search by account or hash tag
63 @item Following, muting and blocking accounts
64 @item Simple switching between authenticated in Mastodon accounts
65 @end itemize")
66 (license license:gpl3)))