gnu: Add external-program.
[jackhill/guix/guix.git] / gnu / packages / cinnamon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 ng0 <ng0@n0.is>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages cinnamon)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix utils)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages freedesktop)
31 #:use-module (gnu packages gettext)
32 #:use-module (gnu packages glib)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages gnome)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages pulseaudio)
37 #:use-module (gnu packages python)
38 #:use-module (gnu packages xorg))
39
40 (define-public cinnamon-desktop
41 (package
42 (name "cinnamon-desktop")
43 (version "3.4.2")
44 (source (origin
45 (method git-fetch)
46 (uri (git-reference
47 (url "https://github.com/linuxmint/cinnamon-desktop")
48 (commit version)))
49 (file-name (git-file-name name version))
50 (sha256
51 (base32
52 "18mjy80ly9361npjhxpm3n0pkmrwviaqr2kixjb7hyxa6kzzh5xw"))))
53 (build-system gnu-build-system)
54 (arguments
55 `(#:phases
56 (modify-phases %standard-phases
57 (add-before 'bootstrap 'skip-premature-configure
58 (lambda _
59 (setenv "NOCONFIGURE" "set")
60 #t)))))
61 ;; TODO: package 'libgsystem'.
62 (inputs
63 `(("accountsservice" ,accountsservice)
64 ("gtk+" ,gtk+)
65 ("glib" ,glib)
66 ("gobject-introspection" ,gobject-introspection)
67 ("gnome-common" ,gnome-common)
68 ("libxkbfile" ,libxkbfile)
69 ("libxrandr" ,libxrandr)
70 ("python-2" ,python-2)
71 ("pulseaudio" ,pulseaudio)
72 ("xkeyboard-config" ,xkeyboard-config)))
73 (native-inputs
74 `(("autoconf" ,autoconf)
75 ("automake" ,automake)
76 ("gettext" ,gettext-minimal)
77 ("glib" ,glib "bin") ; glib-gettextize
78 ("intltool" ,intltool)
79 ("libtool" ,libtool)
80 ("pkg-config" ,pkg-config)))
81 (home-page "https://github.com/linuxmint/cinnamon-desktop/")
82 (synopsis "Library for the Cinnamon Desktop")
83 (description
84 "The cinnamon-desktop package contains the libcinnamon-desktop library,
85 as well as some desktop-wide documents.")
86 (license (list license:gpl2+ license:lgpl2.0+
87 license:expat)))) ;display-name.c , edid-parse.c