gnu: sbcl-trivial-clipboard: Update to 20200904.
[jackhill/guix/guix.git] / gnu / packages / patches / telepathy-glib-channel-memory-leak.patch
1 Prevent a memory leak in call-channel, which otherwise would cause a
2 test failure in file-transfer-channel.c.
3
4 Taken from upstream:
5 https://gitlab.freedesktop.org/telepathy/telepathy-glib/commit/2e8b2cc0db09b781d99e3755bb6d01548037fe7b
6
7 diff --git a/telepathy-glib/call-channel.c b/telepathy-glib/call-channel.c
8 index 8ed76323be32f83c5f4d6045a50bc1698d8093fd..2a1fa203d4be9f0c8b99344225f4ba9900666ffc 100644
9 --- a/telepathy-glib/call-channel.c
10 +++ b/telepathy-glib/call-channel.c
11 @@ -525,6 +525,8 @@ update_call_members (TpCallChannel *self,
12
13 _tp_channel_contacts_queue_prepare_async ((TpChannel *) self,
14 contacts, update_call_members_prepared_cb, data);
15 +
16 + g_ptr_array_unref (contacts);
17 }
18
19 static void