gnu: bind: Update to 9.16.1.
[jackhill/guix/guix.git] / gnu / packages / dns.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
3 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
7 ;;; Copyright © 2016 ng0 <ng0@n0.is>
8 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
10 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
11 ;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
12 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
13 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
14 ;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
15 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages dns)
33 #:use-module (gnu packages admin)
34 #:use-module (gnu packages autotools)
35 #:use-module (gnu packages base)
36 #:use-module (gnu packages bash)
37 #:use-module (gnu packages check)
38 #:use-module (gnu packages databases)
39 #:use-module (gnu packages documentation)
40 #:use-module (gnu packages compression)
41 #:use-module (gnu packages crypto)
42 #:use-module (gnu packages datastructures)
43 #:use-module (gnu packages flex)
44 #:use-module (gnu packages glib)
45 #:use-module (gnu packages groff)
46 #:use-module (gnu packages groff)
47 #:use-module (gnu packages libedit)
48 #:use-module (gnu packages libevent)
49 #:use-module (gnu packages libidn)
50 #:use-module (gnu packages linux)
51 #:use-module (gnu packages lua)
52 #:use-module (gnu packages ncurses)
53 #:use-module (gnu packages nettle)
54 #:use-module (gnu packages networking)
55 #:use-module (gnu packages perl)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages protobuf)
58 #:use-module (gnu packages python)
59 #:use-module (gnu packages python-xyz)
60 #:use-module (gnu packages sphinx)
61 #:use-module (gnu packages swig)
62 #:use-module (gnu packages tls)
63 #:use-module (gnu packages web)
64 #:use-module (gnu packages xml)
65 #:use-module (gnu packages)
66 #:use-module ((guix licenses) #:prefix license:)
67 #:use-module (guix packages)
68 #:use-module (guix download)
69 #:use-module (guix git-download)
70 #:use-module (guix utils)
71 #:use-module (guix build-system gnu)
72 #:use-module (guix build-system meson)
73 #:use-module (guix build-system trivial))
74
75 (define-public dnsmasq
76 (package
77 (name "dnsmasq")
78 (version "2.80")
79 (source (origin
80 (method url-fetch)
81 (uri (string-append
82 "http://www.thekelleys.org.uk/dnsmasq/dnsmasq-"
83 version ".tar.xz"))
84 (sha256
85 (base32
86 "1fv3g8vikj3sn37x1j6qsywn09w1jipvlv34j3q5qrljbrwa5ayd"))))
87 (build-system gnu-build-system)
88 (native-inputs
89 `(("pkg-config" ,pkg-config)))
90 (inputs
91 `(("dbus" ,dbus)))
92 (arguments
93 `(#:phases
94 (modify-phases %standard-phases (delete 'configure))
95 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
96 "CC=gcc"
97 "COPTS=\"-DHAVE_DBUS\"")
98 #:tests? #f)) ; no ‘check’ target
99 (home-page "http://www.thekelleys.org.uk/dnsmasq/doc.html")
100 (synopsis "Small caching DNS proxy and DHCP/TFTP server")
101 (description
102 "Dnsmasq is a light-weight DNS forwarder and DHCP server. It is designed
103 to provide DNS and, optionally, DHCP to a small network. It can serve the
104 names of local machines which are not in the global DNS. The DHCP server
105 integrates with the DNS server and allows machines with DHCP-allocated
106 addresses to appear in the DNS with names configured either on each host or in
107 a central configuration file. Dnsmasq supports static and dynamic DHCP leases
108 and BOOTP/TFTP for network booting of diskless machines.")
109 ;; Source files only say GPL2 and GPL3 are allowed.
110 (license (list license:gpl2 license:gpl3))))
111
112 ;; 'bind' is the name of a built-in Guile procedure, which is why we choose a
113 ;; different name here.
114 (define-public isc-bind
115 (package
116 (name "bind")
117 (version "9.16.1")
118 (source (origin
119 (method url-fetch)
120 (uri (string-append
121 "https://ftp.isc.org/isc/bind9/" version
122 "/bind-" version ".tar.xz"))
123 (sha256
124 (base32
125 "14ayswxnyaqwb935iqdi1w9ih3zs0a0va59j4cyi5f9mh7kxf4x9"))))
126 (build-system gnu-build-system)
127 (outputs `("out" "utils"))
128 (inputs
129 ;; It would be nice to add GeoIP and gssapi once there are packages.
130 `(("libcap" ,libcap)
131 ("libuv" ,libuv)
132 ("libxml2" ,libxml2)
133 ("openssl" ,openssl)
134 ("p11-kit" ,p11-kit)
135 ("python" ,python)
136 ("python-ply" ,python-ply)))
137 (native-inputs
138 `(("perl" ,perl)
139 ("pkg-config" ,pkg-config)))
140 (arguments
141 `(#:configure-flags
142 (list (string-append "--with-pkcs11="
143 (assoc-ref %build-inputs "p11-kit")))
144 #:phases
145 (modify-phases %standard-phases
146 (add-after 'strip 'move-to-utils
147 (lambda _
148 (for-each
149 (lambda (file)
150 (let ((target (string-append (assoc-ref %outputs "utils") file))
151 (src (string-append (assoc-ref %outputs "out") file)))
152 (mkdir-p (dirname target))
153 (link src target)
154 (delete-file src)))
155 '("/bin/dig" "/bin/delv" "/bin/nslookup" "/bin/host" "/bin/nsupdate"
156 "/share/man/man1/dig.1"
157 "/share/man/man1/host.1"
158 "/share/man/man1/nslookup.1"
159 "/share/man/man1/nsupdate.1"))
160 #t))
161 ;; When and if guix provides user namespaces for the build process,
162 ;; then the following can be uncommented and the subsequent "force-test"
163 ;; will not be necessary.
164 ;;
165 ;; (add-before 'check 'set-up-loopback
166 ;; (lambda _
167 ;; (system "bin/tests/system/ifconfig.sh up")))
168 (replace 'check
169 (lambda _
170 ;; XXX Even ‘make force-test’ tries to create network interfaces
171 ;; and fails. The only working target is the (trivial) fuzz test.
172 (with-directory-excursion "fuzz"
173 (invoke "make" "check"))
174 #t)))))
175 (synopsis "An implementation of the Domain Name System")
176 (description "BIND is an implementation of the @dfn{Domain Name System}
177 (DNS) protocols for the Internet. It is a reference implementation of those
178 protocols, but it is also production-grade software, suitable for use in
179 high-volume and high-reliability applications. The name BIND stands for
180 \"Berkeley Internet Name Domain\", because the software originated in the early
181 1980s at the University of California at Berkeley.")
182 (home-page "https://www.isc.org/downloads/bind")
183 (license (list license:mpl2.0))))
184
185 (define-public dnscrypt-proxy
186 (package
187 (name "dnscrypt-proxy")
188 (version "1.9.5")
189 (source (origin
190 (method url-fetch)
191 (uri (string-append
192 "https://download.dnscrypt.org/dnscrypt-proxy/"
193 "dnscrypt-proxy-" version ".tar.bz2"))
194 (sha256
195 (base32
196 "1dhvklr4dg2vlw108n11xbamacaryyg3dbrg629b76lp7685p7z8"))
197 (modules '((guix build utils)))
198 (snippet
199 ;; Delete bundled libltdl. XXX: This package also bundles
200 ;; a modified libevent that cannot currently be removed.
201 '(begin
202 (delete-file-recursively "libltdl")
203 #t))))
204 (build-system gnu-build-system)
205 (arguments
206 `(#:phases
207 (modify-phases %standard-phases
208 (add-after 'unpack 'autoreconf
209 (lambda _
210 ;; Re-generate build files due to unbundling ltdl.
211 ;; TODO: Prevent generating new libltdl and building it.
212 ;; The system version is still favored and referenced.
213 (invoke "autoreconf" "-vif"))))))
214 (native-inputs
215 `(("pkg-config" ,pkg-config)
216 ("automake" ,automake)
217 ("autoconf" ,autoconf)
218 ("libtool" ,libtool)))
219 (inputs
220 `(("libltdl" ,libltdl)
221 ("libsodium" ,libsodium)))
222 (home-page "https://www.dnscrypt.org/")
223 (synopsis "Securely send DNS requests to a remote server")
224 (description
225 "@command{dnscrypt-proxy} is a tool for securing communications
226 between a client and a DNS resolver. It verifies that responses you get
227 from a DNS provider was actually sent by that provider, and haven't been
228 tampered with. For optimal performance it is recommended to use this as
229 a forwarder for a caching DNS resolver such as @command{dnsmasq}, but it
230 can also be used as a normal DNS \"server\". A list of public dnscrypt
231 servers is included, and an up-to-date version is available at
232 @url{https://download.dnscrypt.org/dnscrypt-proxy/dnscrypt-resolvers.csv}.")
233 (license (list license:isc
234 ;; Libevent and src/ext/queue.h is 3-clause BSD.
235 license:bsd-3))))
236
237 (define-public dnscrypt-wrapper
238 (package
239 (name "dnscrypt-wrapper")
240 (version "0.2.2")
241 (source (origin
242 (method url-fetch)
243 (uri (string-append
244 "https://github.com/cofyc/dnscrypt-wrapper/releases"
245 "/download/v" version "/" name "-v" version ".tar.bz2"))
246 (sha256
247 (base32
248 "1vhg4g0r687f51wcdn7z9w1hxapazx6vyh5rsr8wa48sljzd583g"))))
249 (build-system gnu-build-system)
250 (arguments
251 `(#:make-flags '("CC=gcc")
252 ;; TODO: Tests require ruby-cucumber and ruby-aruba.
253 #:tests? #f
254 #:phases
255 (modify-phases %standard-phases
256 (add-after 'unpack 'create-configure
257 (lambda _
258 (invoke "make" "configure"))))))
259 (native-inputs
260 `(("autoconf" ,autoconf)))
261 (inputs
262 `(("libevent" ,libevent)
263 ("libsodium" ,libsodium)))
264 (home-page "https://github.com/Cofyc/dnscrypt-wrapper")
265 (synopsis "Server-side dnscrypt proxy")
266 (description
267 "@command{dnscrypt-wrapper} is a tool to expose a name server over
268 the @code{dnscrypt} protocol. It can be used as an endpoint for the
269 @command{dnscrypt-proxy} client to securely tunnel DNS requests between
270 the two.")
271 (license (list license:isc
272 ;; Bundled argparse is MIT. TODO: package and unbundle.
273 license:expat
274 ;; dns-protocol.h and rfc1035.{c,h} is gpl2 or gpl3 (either).
275 license:gpl2
276 license:gpl3))))
277
278 (define-public libasr
279 (package
280 (name "libasr")
281 (version "1.0.4")
282 (source
283 (origin
284 (method url-fetch)
285 (uri (string-append "https://www.opensmtpd.org/archives/"
286 "libasr-" version ".tar.gz"))
287 (sha256
288 (base32 "1d6s8njqhvayx2gp47409sp1fn8m608ws26hr1srfp6i23nnpyqr"))))
289 (build-system gnu-build-system)
290 (arguments
291 `(#:phases
292 (modify-phases %standard-phases
293 (add-after 'install 'install-documentation
294 (lambda* (#:key outputs #:allow-other-keys)
295 (let ((out (assoc-ref outputs "out")))
296 (install-file "src/asr_run.3"
297 (string-append out "/share/man/man3"))
298 #t))))))
299 (native-inputs
300 `(("autoconf" ,autoconf)
301 ("automake" ,automake)
302 ("libtool" ,libtool)
303 ("pkg-config" ,pkg-config)))
304 (home-page "https://www.opensmtpd.org")
305 (synopsis "Asynchronous resolver library by the OpenBSD project")
306 (description
307 "libasr is a free, simple and portable asynchronous resolver library.
308 It allows to run DNS queries and perform hostname resolutions in a fully
309 asynchronous fashion.")
310 (license (list license:isc
311 license:bsd-2 ; last part of getrrsetbyname_async.c
312 license:bsd-3
313 (license:non-copyleft "file://LICENSE") ; includes.h
314 license:openssl))))
315
316 (define-public nsd
317 (package
318 (name "nsd")
319 (version "4.2.4")
320 (source
321 (origin
322 (method url-fetch)
323 (uri (string-append "https://www.nlnetlabs.nl/downloads/nsd/nsd-"
324 version ".tar.gz"))
325 (sha256
326 (base32 "0z7j3vwqqj0hh8n5irb2yqwzl45k4sn2wczbq1b1lqv5cxv6vgcy"))))
327 (build-system gnu-build-system)
328 (arguments
329 `(#:configure-flags
330 (list "--enable-pie" ; fully benefit from ASLR
331 "--enable-ratelimit"
332 "--enable-recvmmsg"
333 "--enable-relro-now" ; protect GOT and .dtor areas
334 "--disable-radix-tree"
335 (string-append "--with-libevent="
336 (assoc-ref %build-inputs "libevent"))
337 (string-append "--with-ssl="
338 (assoc-ref %build-inputs "openssl"))
339 "--with-configdir=/etc"
340 "--with-nsd_conf_file=/etc/nsd/nsd.conf"
341 "--with-logfile=/var/log/nsd.log"
342 "--with-pidfile=/var/db/nsd/nsd.pid"
343 "--with-dbfile=/var/db/nsd/nsd.db"
344 "--with-zonesdir=/etc/nsd"
345 "--with-xfrdfile=/var/db/nsd/xfrd.state"
346 "--with-zonelistfile=/var/db/nsd/zone.list")
347 #:phases
348 (modify-phases %standard-phases
349 (add-before 'configure 'patch-installation-paths
350 (lambda* (#:key outputs #:allow-other-keys)
351 (let* ((out (assoc-ref outputs "out"))
352 (doc (string-append out "/share/doc/" ,name "-" ,version)))
353 ;; The ‘make install’ target tries to create the parent
354 ;; directories of run-time things like ‘pidfile’ above, and
355 ;; useless empty directories like 'configdir'. Remove such
356 ;; '$(INSTALL)' lines and install the example configuration file
357 ;; in an appropriate location.
358 (substitute* "Makefile.in"
359 ((".*INSTALL.*\\$\\((config|pid|xfr|db)dir" command)
360 (string-append "#" command))
361 (("\\$\\(nsdconfigfile\\)\\.sample" file-name)
362 (string-append doc "/examples/" file-name)))
363 #t))))
364 #:tests? #f)) ; no tests
365 (inputs
366 `(("libevent" ,libevent)
367 ("openssl" ,openssl)))
368 (home-page "https://www.nlnetlabs.nl/projects/nsd/about/")
369 (synopsis "Authoritative DNS name server")
370 (description "@dfn{NSD}, short for Name Server Daemon, is an authoritative
371 name server for the Domain Name System (@dfn{DNS}). It aims to be a fast and
372 RFC-compliant nameserver.
373
374 NSD uses zone information compiled via @command{zonec} into a binary database
375 file (@file{nsd.db}). This allows fast startup of the name service daemon and
376 allows syntax-structural errors in zone files to be flagged at compile time,
377 before being made available to NSD service itself. However, most traditional
378 BIND-style zone files can be directly imported into NSD without modification.
379
380 The collection of programs and processes that make up NSD are designed so that
381 the daemon itself runs as a non-privileged user and can be easily configured to
382 run in a @code{chroot} jail, thus making any security flaws in NSD less likely
383 to result in system-wide compromise.")
384 (license (list license:bsd-3))))
385
386 (define-public unbound
387 (package
388 (name "unbound")
389 (version "1.10.0")
390 (source
391 (origin
392 (method url-fetch)
393 (uri (string-append "https://www.unbound.net/downloads/unbound-"
394 version ".tar.gz"))
395 (sha256
396 (base32 "0mg9divpysr42sp0m693a70693dp8025v6c9dv1yabr4g1jlhbqm"))))
397 (build-system gnu-build-system)
398 (outputs '("out" "python"))
399 (native-inputs
400 `(("flex" ,flex)
401 ("swig" ,swig)))
402 (inputs
403 `(("expat" ,expat)
404 ("libevent" ,libevent)
405 ("protobuf" ,protobuf)
406 ("python-wrapper" ,python-wrapper)
407 ("openssl" ,openssl)))
408 (arguments
409 `(#:configure-flags
410 (list "--disable-static" ; save space and non-determinism in libunbound.a
411 (string-append
412 "--with-ssl=" (assoc-ref %build-inputs "openssl"))
413 (string-append
414 "--with-libevent=" (assoc-ref %build-inputs "libevent"))
415 (string-append
416 "--with-libexpat=" (assoc-ref %build-inputs "expat"))
417 "--with-pythonmodule" "--with-pyunbound")
418 #:phases
419 (modify-phases %standard-phases
420 (add-after 'configure 'fix-python-site-package-path
421 ;; Move python modules into their own output.
422 (lambda* (#:key outputs #:allow-other-keys)
423 (let ((pyout (assoc-ref outputs "python"))
424 (ver ,(version-major+minor (package-version python))))
425 (substitute* "Makefile"
426 (("^PYTHON_SITE_PKG=.*$")
427 (string-append
428 "PYTHON_SITE_PKG="
429 pyout "/lib/python-" ver "/site-packages\n"))))
430 #t))
431 (add-before 'check 'fix-missing-nss-for-tests
432 ;; Unfortunately, the package's unittests involve some checks
433 ;; looking up protocols and services which are not provided
434 ;; by the minimalistic build environment, in particular,
435 ;; /etc/protocols and /etc/services are missing.
436 ;; Also, after plain substitution of protocol and service names
437 ;; in the test data, the tests still fail because the
438 ;; corresponding Resource Records have been signed by
439 ;; RRSIG records.
440 ;; The following LD_PRELOAD library overwrites the glibc
441 ;; functions ‘get{proto,serv}byname’, ‘getprotobynumber’ and
442 ;; ‘getservbyport’ providing the few records required for the
443 ;; unit tests to pass.
444 (lambda* (#:key inputs outputs #:allow-other-keys)
445 (let* ((source (assoc-ref %build-inputs "source"))
446 (gcc (assoc-ref %build-inputs "gcc")))
447 (call-with-output-file "/tmp/nss_preload.c"
448 (lambda (port)
449 (display "#include <stdlib.h>
450 #include <string.h>
451 #include <strings.h>
452
453 #include <netdb.h>
454
455 struct protoent *getprotobyname(const char *name) {
456 struct protoent *p = malloc(sizeof(struct protoent));
457 p->p_aliases = malloc(sizeof(char*));
458 if (strcasecmp(name, \"tcp\") == 0) {
459 p->p_name = \"tcp\";
460 p->p_proto = 6;
461 p->p_aliases[0] = \"TCP\";
462 } else if (strcasecmp(name, \"udp\") == 0) {
463 p->p_name = \"udp\";
464 p->p_proto = 17;
465 p->p_aliases[0] = \"UDP\";
466 } else
467 p = NULL;
468 return p;
469 }
470
471 struct protoent *getprotobynumber(int proto) {
472 struct protoent *p = malloc(sizeof(struct protoent));
473 p->p_aliases = malloc(sizeof(char*));
474 switch(proto) {
475 case 6:
476 p->p_name = \"tcp\";
477 p->p_proto = 6;
478 p->p_aliases[0] = \"TCP\";
479 break;
480 case 17:
481 p->p_name = \"udp\";
482 p->p_proto = 17;
483 p->p_aliases[0] = \"UDP\";
484 break;
485 default:
486 p = NULL;
487 break;
488 }
489 return p;
490 }
491
492 struct servent *getservbyname(const char *name, const char *proto) {
493 struct servent *s = malloc(sizeof(struct servent));
494 char* buf = malloc((strlen(proto)+1)*sizeof(char));
495 strcpy(buf, proto);
496 s->s_aliases = malloc(sizeof(char*));
497 s->s_aliases[0] = NULL;
498 if (strcasecmp(name, \"domain\") == 0) {
499 s->s_name = \"domain\";
500 s->s_port = htons(53);
501 s->s_proto = buf;
502 } else
503 s = NULL;
504 return s;
505 }
506
507 struct servent *getservbyport(int port, const char *proto) {
508 char buf[32];
509 struct servent *s = malloc(sizeof(struct servent));
510 strcpy(buf, proto);
511 s->s_aliases = malloc(sizeof(char*));
512 s->s_aliases[0] = NULL;
513 switch(port) {
514 case 53:
515 s->s_name = \"domain\";
516 s->s_port = 53;
517 s->s_proto = \"udp\";
518 break;
519 default:
520 s = NULL;
521 break;
522 }
523 return s;
524 }" port)))
525 (invoke (string-append gcc "/bin/gcc")
526 "-shared" "-fPIC" "-o" "/tmp/nss_preload.so"
527 "/tmp/nss_preload.c")
528 ;; The preload library only affects the unittests.
529 (substitute* "Makefile"
530 (("./unittest")
531 "LD_PRELOAD=/tmp/nss_preload.so ./unittest")))
532 #t)))))
533 (home-page "https://www.unbound.net")
534 (synopsis "Validating, recursive, and caching DNS resolver")
535 (description
536 "Unbound is a recursive-only caching DNS server which can perform DNSSEC
537 validation of results. It implements only a minimal amount of authoritative
538 service to prevent leakage to the root nameservers: forward lookups for
539 localhost, reverse for @code{127.0.0.1} and @code{::1}, and NXDOMAIN for zones
540 served by AS112. Stub and forward zones are supported.")
541 (license license:bsd-4)))
542
543 (define-public yadifa
544 (package
545 (name "yadifa")
546 (version "2.3.9")
547 (source
548 (let ((build "8497"))
549 (origin
550 (method url-fetch)
551 (uri
552 (string-append "http://cdn.yadifa.eu/sites/default/files/releases/"
553 "yadifa-" version "-" build ".tar.gz"))
554 (sha256
555 (base32 "0xvyr91sfgzkpw6g3h893ldbwnki3w2472n56rr18w67qghs1sa5")))))
556 (build-system gnu-build-system)
557 (native-inputs
558 `(("which" ,which)))
559 (inputs
560 `(("openssl" ,openssl)))
561 (arguments
562 `(#:phases
563 (modify-phases %standard-phases
564 (add-before 'configure 'omit-example-configurations
565 (lambda _
566 (substitute* "Makefile.in"
567 ((" (etc|var)") ""))
568 #t)))
569 #:configure-flags
570 (list "--sysconfdir=/etc"
571 "--localstatedir=/var"
572 "--disable-build-timestamp" ; build reproducibly
573 "--enable-shared"
574 "--disable-static"
575 "--enable-acl"
576 "--enable-caching"
577 "--enable-ctrl" ; enable remote control
578 "--enable-nsec"
579 "--enable-nsec3"
580 "--enable-tsig")))
581 (home-page "https://www.yadifa.eu/")
582 (synopsis "Authoritative DNS name server")
583 (description "YADIFA is an authoritative name server for the @dfn{Domain
584 Name System} (DNS). It aims for both higher performance and a smaller memory
585 footprint than other implementations, while remaining fully RFC-compliant.
586 YADIFA supports dynamic record updates and the @dfn{Domain Name System Security
587 Extensions} (DNSSEC).")
588 (license license:bsd-3)))
589
590 (define-public knot
591 (package
592 (name "knot")
593 (version "2.9.3")
594 (source
595 (origin
596 (method url-fetch)
597 (uri (string-append "https://secure.nic.cz/files/knot-dns/"
598 "knot-" version ".tar.xz"))
599 (sha256
600 (base32 "0zm0642hkb16sqkqpa84f89f3s0bw44m837r1nia8m89swvz3bgj"))
601 (modules '((guix build utils)))
602 (snippet
603 '(begin
604 ;; Delete bundled libraries.
605 (with-directory-excursion "src/contrib"
606 (delete-file-recursively "lmdb"))
607 #t))))
608 (build-system gnu-build-system)
609 (native-inputs
610 `(("pkg-config" ,pkg-config)))
611 (inputs
612 `(("fstrm" ,fstrm)
613 ("gnutls" ,gnutls)
614 ("jansson" ,jansson)
615 ("libcap-ng" ,libcap-ng)
616 ("libedit" ,libedit)
617 ("libidn" ,libidn)
618 ("liburcu" ,liburcu)
619 ("lmdb" ,lmdb)
620 ("ncurses" ,ncurses)
621 ("protobuf-c" ,protobuf-c)))
622 (arguments
623 `(#:phases
624 (modify-phases %standard-phases
625 (add-before 'configure 'disable-directory-pre-creation
626 (lambda _
627 ;; Don't install empty directories like ‘/etc’ outside the store.
628 ;; This is needed even when using ‘make config_dir=... install’.
629 (substitute* "src/Makefile.in" (("\\$\\(INSTALL\\) -d") "true"))
630 #t))
631 (replace 'install
632 (lambda* (#:key outputs #:allow-other-keys)
633 (let* ((out (assoc-ref outputs "out"))
634 (doc (string-append out "/share/doc/" ,name "-" ,version))
635 (etc (string-append doc "/examples/etc")))
636 (invoke "make"
637 (string-append "config_dir=" etc)
638 "install")))))
639 #:configure-flags
640 (list "--sysconfdir=/etc"
641 "--localstatedir=/var"
642 "--enable-dnstap" ; let tools read/write capture files
643 "--with-module-dnstap=yes" ; detailed query capturing & logging
644 (string-append "--with-bash-completions="
645 (assoc-ref %outputs "out")
646 "/etc/bash_completion.d"))))
647 (home-page "https://www.knot-dns.cz/")
648 (synopsis "Authoritative DNS name server")
649 (description "Knot DNS is an authoritative name server for the @dfn{Domain
650 Name System} (DNS), designed to meet the needs of root and @dfn{top-level
651 domain} (TLD) name servers. It is implemented as a threaded daemon and uses a
652 number of programming techniques to improve speed. For example, the responder
653 is completely lock-free, resulting in a very high response rate. Other features
654 include automatic @dfn{DNS Security Extensions} (DNSSEC) signing, dynamic record
655 synthesis, and on-the-fly re-configuration.")
656 (license
657 (list
658 ;; src/contrib/{hat-trie,murmurhash3,openbsd},
659 ;; src/dnssec/contrib/vpool.[ch], and parts of libtap/ are ‘MIT’ (expat).
660 license:expat
661 license:lgpl2.0+ ; parts of scr/contrib/ucw
662 license:public-domain ; src/contrib/fnv and possibly murmurhash3
663 license:gpl3+)))) ; everything else
664
665 (define-public knot-resolver
666 (package
667 (name "knot-resolver")
668 (version "4.3.0")
669 (source (origin
670 (method url-fetch)
671 (uri (string-append "https://secure.nic.cz/files/knot-resolver/"
672 "knot-resolver-" version ".tar.xz"))
673 (sha256
674 (base32
675 "09ffmqx79lv5psr433x4n946njgsn071b9b7161pcb9bmrqz380c"))))
676 (build-system meson-build-system)
677 (arguments
678 '(#:configure-flags '("-Ddoc=enabled")
679 #:phases
680 (modify-phases %standard-phases
681 (add-before 'configure 'disable-default-ta
682 (lambda _
683 ;; Disable the default managed root TA, since we don't have
684 ;; write access to the keyfile and its directory in store.
685 (substitute* "daemon/lua/sandbox.lua.in"
686 (("^trust_anchors\\.add_file.*") ""))
687 #t))
688 (add-after 'build 'build-doc
689 (lambda _
690 (invoke "ninja" "doc")))
691 (add-after 'install 'wrap-binary
692 (lambda* (#:key inputs outputs #:allow-other-keys)
693 (let* ((out (assoc-ref outputs "out"))
694 (lua-* (map cdr (filter
695 (lambda (input)
696 (string-prefix? "lua-" (car input)))
697 inputs)))
698 (lua-path (lambda (p)
699 (string-append p "/share/lua/5.1/?.lua")))
700 (lua-cpath (lambda (p)
701 (string-append p "/lib/lua/5.1/?.so"))))
702 (wrap-program (string-append out "/sbin/kresd")
703 `("LUA_PATH" ";" prefix ,(map lua-path lua-*))
704 `("LUA_CPATH" ";" prefix ,(map lua-cpath lua-*)))
705 #t))))))
706 (native-inputs
707 `(("cmocka" ,cmocka) ; for unit tests
708 ("doxygen" ,doxygen)
709 ("protobuf-c" ,protobuf-c)
710 ("pkg-config" ,pkg-config)
711 ("python-breathe" ,python-breathe)
712 ("python-sphinx" ,python-sphinx)
713 ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
714 (inputs
715 `(("fstrm" ,fstrm)
716 ("gnutls" ,gnutls)
717 ("knot" ,knot)
718 ("libuv" ,libuv)
719 ("lmdb" ,lmdb)
720 ("luajit" ,luajit)
721 ;; TODO: Add optional lua modules: basexx, cqueues and psl.
722 ("lua-bitop" ,lua5.1-bitop)
723 ("lua-filesystem" ,lua5.1-filesystem)
724 ("lua-sec" ,lua5.1-sec)
725 ("lua-socket" ,lua5.1-socket)))
726 (home-page "https://www.knot-resolver.cz/")
727 (synopsis "Caching validating DNS resolver")
728 (description
729 "Knot Resolver is a caching full resolver implementation written in C and
730 LuaJIT, both a resolver library and a daemon.")
731 (license (list license:gpl3+
732 ;; Some 'contrib' files are under MIT, CC0 and LGPL2.
733 license:expat
734 license:cc0
735 license:lgpl2.0))))
736
737 (define-public ddclient
738 (package
739 (name "ddclient")
740 (version "3.9.1")
741 (source
742 (origin
743 (method git-fetch)
744 (uri (git-reference
745 (url "https://github.com/ddclient/ddclient.git")
746 (commit (string-append "v" version))))
747 (file-name (git-file-name name version))
748 (sha256
749 (base32 "0hf377g4j9r9sac75xp17nk2h58mazswz4vkg4g2gl2yyhvzq91w"))))
750 (build-system trivial-build-system) ; no Makefile.PL
751 (native-inputs
752 `(("bash" ,bash)
753 ("perl" ,perl)))
754 (inputs
755 `(("inetutils" ,inetutils) ; logger
756 ("net-tools" ,net-tools)
757 ("perl-data-validate-ip" ,perl-data-validate-ip)
758 ("perl-digest-sha1" ,perl-digest-sha1)
759 ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
760 (arguments
761 `(#:modules ((guix build utils)
762 (ice-9 match)
763 (srfi srfi-26))
764 #:builder
765 (begin
766 (use-modules (guix build utils)
767 (ice-9 match)
768 (srfi srfi-26))
769 (setenv "PATH" (string-append
770 (assoc-ref %build-inputs "bash") "/bin" ":"
771 (assoc-ref %build-inputs "perl") "/bin"))
772
773 ;; Copy the (read-only) source into the (writable) build directory.
774 (copy-recursively (assoc-ref %build-inputs "source") ".")
775
776 ;; Install.
777 (let* ((out (assoc-ref %outputs "out"))
778 (bin (string-append out "/bin")))
779 (let ((file "ddclient"))
780 (substitute* file
781 (("/usr/bin/perl") (which "perl"))
782 ;; Strictly use ‘/etc/ddclient/ddclient.conf’.
783 (("\\$\\{program\\}\\.conf") "/etc/ddclient/ddclient.conf")
784 (("\\$etc\\$program.conf") "/etc/ddclient/ddclient.conf")
785 ;; Strictly use ‘/var/cache/ddclient/ddclient.cache’
786 (("\\$cachedir\\$program\\.cache")
787 "/var/cache/ddclient/ddclient.cache"))
788 (install-file file bin)
789 (wrap-program (string-append bin "/" file)
790 `("PATH" ":" =
791 ("$PATH"
792 ,@(map (lambda (input)
793 (match input
794 ((name . store)
795 (string-append store "/bin"))))
796 %build-inputs)))
797 `("PERL5LIB" ":" =
798 ,(delete
799 ""
800 (map (match-lambda
801 (((? (cut string-prefix? "perl-" <>) name) . dir)
802 (string-append dir "/lib/perl5/site_perl"))
803 (_ ""))
804 %build-inputs)))))
805 (for-each (cut install-file <> (string-append out
806 "/share/ddclient"))
807 (find-files "." "sample.*$"))))))
808 (home-page "https://ddclient.net/")
809 (synopsis "Address updating utility for dynamic DNS services")
810 (description "This package provides a client to update dynamic IP
811 addresses with several dynamic DNS service providers, such as
812 @uref{https://www.dyndns.com/account/login.html,DynDNS.com}.
813
814 This makes it possible to use a fixed hostname (such as myhost.dyndns.org) to
815 access a machine with a dynamic IP address.
816
817 The client supports both dynamic and (near) static services, as well as MX
818 record and alternative name management. It caches the address, and only
819 attempts the update when it has changed.")
820 (license license:gpl2+)))
821
822 (define-public hnsd
823 ;; There have been no releases yet, hence this commit.
824 (let ((revision "0")
825 (commit "895d89c25d316d18df9d374fe78aae3902bc89fb"))
826 (package
827 (name "hnsd")
828 (version (git-version "0.0" revision commit))
829 (source (origin
830 (method git-fetch)
831 (uri (git-reference
832 (url "https://github.com/handshake-org/hnsd")
833 (commit commit)))
834 (sha256
835 (base32
836 "0704y73sddn24jga9csw4gxyfb3pnrfnk0vdcph84n1h38490l16"))
837 (file-name (git-file-name name version))
838 (modules '((guix build utils)))
839 (snippet
840 '(begin
841 ;; Delete the bundled copy of libuv.
842 (delete-file-recursively "uv")
843 (substitute* "configure.ac"
844 (("AC_CONFIG_SUBDIRS\\(\\[uv\\]\\)") ""))
845 (substitute* "Makefile.am"
846 (("SUBDIRS = uv") "\n")
847 (("\\$\\(top_builddir\\)/uv/libuv.la") "-luv")
848
849 ;; Make sure the 'hnsd' binary is installed and
850 ;; dynamically-linked.
851 (("noinst_PROGRAMS") "bin_PROGRAMS")
852 (("hnsd_LDFLAGS = -static") ""))
853
854 ;; This script tries to chdir to "uv" and doesn't do more
855 ;; than "autoreconf" so remove it.
856 (delete-file "autogen.sh")
857 #t))))
858 (build-system gnu-build-system)
859 (arguments
860 '(#:configure-flags '("--disable-static"))) ;no need for libhsk.a
861 (native-inputs
862 `(("autoconf" ,autoconf)
863 ("automake" ,automake)
864 ("libtool" ,libtool)))
865 (inputs
866 `(("unbound" ,unbound)
867 ("libuv" ,libuv)))
868 (home-page "https://www.handshake.org/")
869 (synopsis "Resolver daemon for the Handshake naming protocol")
870 (description
871 "@command{hnsd} is a @dfn{host name resolver} for the Handshake Naming
872 System (HNS) peer-to-peer network.")
873 (license license:expat))))
874
875 (define-public libmicrodns
876 (package
877 (name "libmicrodns")
878 (version "0.0.10")
879 (source (origin
880 (method git-fetch)
881 (uri (git-reference
882 (url "https://github.com/videolabs/libmicrodns")
883 (commit version)))
884 (file-name (git-file-name name version))
885 (sha256
886 (base32
887 "1xvl9k49ng35wbsqmnjnyqvkyjf8dcq2ywsq3jp3wh0rgmxhq2fh"))))
888 (build-system gnu-build-system)
889 (native-inputs
890 `(("pkg-config" ,pkg-config)
891 ("autoconf" ,autoconf)
892 ("automake" ,automake)
893 ("libtool" ,libtool)))
894 (home-page "https://github.com/videolabs/libmicrodns")
895 (synopsis "Minimal mDNS resolver library")
896 (description "@code{libmicrodns} provides a minimal implementation of a
897 mDNS resolver as well as an announcer. mDNS (Multicast Domain Name System) is
898 a zero-config service that allows one to resolve host names to IP addresses in
899 local networks.")
900 (license license:lgpl2.1)))
901
902 (define-public public-suffix-list
903 ;; Mozilla releases the official list here:
904 ;;
905 ;; https://publicsuffix.org/list/public_suffix_list.dat
906 ;;
907 ;; However, Mozilla syncs that file from the GitHub repository periodically,
908 ;; so its contents will change over time. If you update this commit, please
909 ;; make sure that the new commit refers to a list which is identical to the
910 ;; officially published list available from the URL above.
911 (let ((commit "9375b697baddb0827a5995c81bd3c75877a0b35d"))
912 (package
913 (name "public-suffix-list")
914 (version (git-version "0" "1" commit))
915 (source (origin
916 (method git-fetch)
917 (uri (git-reference
918 (url "https://github.com/publicsuffix/list.git")
919 (commit commit)))
920 (file-name (git-file-name name version))
921 (sha256
922 (base32
923 "1sm7pni01rnl4ldzi8z8nc4cbgq8nxda9gwc68v0s3ij7jd1jmik"))))
924 (build-system trivial-build-system)
925 (arguments
926 `(#:modules ((guix build utils))
927 #:builder
928 (begin
929 (use-modules (guix build utils))
930 (let* ((out (assoc-ref %outputs "out"))
931 ;; Install to /share because that is where "read-only
932 ;; architecture-independent data files" should go (see:
933 ;; (standards) Directory Variables). Include the version in
934 ;; the directory name so that if multiple versions are ever
935 ;; installed in the same profile, they will not conflict.
936 (destination (string-append
937 out "/share/public-suffix-list-" ,version))
938 (source (assoc-ref %build-inputs "source")))
939 (with-directory-excursion source
940 (install-file "public_suffix_list.dat" destination)
941 (install-file "LICENSE" destination))
942 #t))))
943 (home-page "https://publicsuffix.org/")
944 (synopsis "Database of current and historical DNS suffixes")
945 (description "This is the Public Suffix List maintained by Mozilla. A
946 \"public suffix\" is one under which Internet users can (or historically
947 could) directly register names in the Domain Name System (DNS). Some examples
948 of public suffixes are .com, .co.uk and pvt.k12.ma.us. This is a list of all
949 known public suffixes.")
950 (license license:mpl2.0))))