gnu: Add bullet.
[jackhill/guix/guix.git] / gnu / packages / game-development.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Tomáš Čech <sleep_walker@suse.cz>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages game-development)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system cmake)
24 #:use-module (gnu packages))
25
26 (define-public bullet
27 (package
28 (name "bullet")
29 (version "2.82-r2704")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "https://bullet.googlecode.com/files/bullet-"
33 version ".tgz"))
34 (sha256
35 (base32
36 "1lnfksxa9b1slyfcxys313ymsllvbsnxh9np06azkbgpfvmwkr37"))))
37 (build-system cmake-build-system)
38 (arguments '(#:tests? #f ; no 'test' target
39 #:configure-flags (list
40 (string-append
41 "-DCMAKE_CXX_FLAGS=-fPIC "
42 (or (getenv "CXXFLAGS") "")))))
43 (home-page "http://bulletphysics.org/")
44 (synopsis "3D physics engine library")
45 (description
46 "Bullet is a physics engine library usable for collision detection. It
47 is used in some video games and movies.")
48 (license zlib)))