gnu: git-annex: Update to 7.20191017.
[jackhill/guix/guix.git] / gnu / packages / haskell-apps.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
3 ;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
5 ;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
6 ;;; Copyright © 2017, 2018 Alex Vong <alexvong1995@gmail.com>
7 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
9 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
10 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
11 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
12 ;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
13 ;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
14 ;;;
15 ;;; This file is part of GNU Guix.
16 ;;;
17 ;;; GNU Guix is free software; you can redistribute it and/or modify it
18 ;;; under the terms of the GNU General Public License as published by
19 ;;; the Free Software Foundation; either version 3 of the License, or (at
20 ;;; your option) any later version.
21 ;;;
22 ;;; GNU Guix is distributed in the hope that it will be useful, but
23 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
24 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
25 ;;; GNU General Public License for more details.
26 ;;;
27 ;;; You should have received a copy of the GNU General Public License
28 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
29
30 (define-module (gnu packages haskell-apps)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module (guix packages)
34 #:use-module ((guix licenses) #:prefix license:)
35 #:use-module (guix build-system haskell)
36 #:use-module (gnu packages base)
37 #:use-module (gnu packages curl)
38 #:use-module (gnu packages gl)
39 #:use-module (gnu packages haskell)
40 #:use-module (gnu packages haskell-check)
41 #:use-module (gnu packages haskell-crypto)
42 #:use-module (gnu packages haskell-web)
43 #:use-module (gnu packages haskell-xyz)
44 #:use-module (gnu packages ncurses)
45 #:use-module (gnu packages perl)
46 #:use-module (gnu packages pkg-config)
47 #:use-module (gnu packages rsync)
48 #:use-module (gnu packages version-control))
49
50 (define-public cabal-install
51 (package
52 (name "cabal-install")
53 (version "2.2.0.0")
54 (source
55 (origin
56 (method url-fetch)
57 (uri (string-append
58 "https://hackage.haskell.org/package/cabal-install/cabal-install-"
59 version
60 ".tar.gz"))
61 (sha256
62 (base32 "1nd3ch7qr4dpfxhgkcq2lnhvszx2kjgnn1kwb44vk9y5jgfs4mn8"))))
63 (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
64 (build-system haskell-build-system)
65 (inputs
66 `(("ghc-async" ,ghc-async)
67 ("ghc-base16-bytestring" ,ghc-base16-bytestring)
68 ("ghc-cryptohash-sha256" ,ghc-cryptohash-sha256)
69 ("ghc-echo" ,ghc-echo)
70 ("ghc-edit-distance" ,ghc-edit-distance)
71 ("ghc-hackage-security" ,ghc-hackage-security)
72 ("ghc-hashable" ,ghc-hashable)
73 ("ghc-http" ,ghc-http)
74 ("ghc-network-uri" ,ghc-network-uri)
75 ("ghc-network" ,ghc-network)
76 ("ghc-random" ,ghc-random)
77 ("ghc-resolv" ,ghc-resolv)
78 ("ghc-tar" ,ghc-tar)
79 ("ghc-zlib" ,ghc-zlib)))
80 (home-page "https://www.haskell.org/cabal/")
81 (synopsis "Command-line interface for Cabal and Hackage")
82 (description
83 "The cabal command-line program simplifies the process of managing
84 Haskell software by automating the fetching, configuration, compilation and
85 installation of Haskell libraries and programs.")
86 (license license:bsd-3)))
87
88 (define-public corrode
89 (let ((commit "b6699fb2fa552a07c6091276285a44133e5c9789"))
90 (package
91 (name "corrode")
92 (version (string-append "0.0.1-" (string-take commit 7)))
93 (source
94 (origin
95 (method git-fetch)
96 (uri (git-reference
97 (url "https://github.com/jameysharp/corrode.git")
98 (commit "b6699fb2fa552a07c6091276285a44133e5c9789")))
99 (file-name
100 (string-append name "-" version "-checkout"))
101 (sha256
102 (base32 "02v0yyj6sk4gpg2222wzsdqjxn8w66scbnf6b20x0kbmc69qcz4r"))))
103 (build-system haskell-build-system)
104 (inputs
105 `(("ghc-language-c" ,ghc-language-c)
106 ("ghc-markdown-unlit" ,ghc-markdown-unlit)))
107 (home-page "https://github.com/jameysharp/corrode")
108 (synopsis "Automatic semantics-preserving translation from C to Rust")
109 (description
110 "This program reads a C source file and prints an equivalent module in
111 Rust syntax. It is intended to be useful for two different purposes:
112
113 @enumerate
114 @item Partial automation for migrating legacy code that was implemented in C.
115 @item A new, complementary approach to static analysis for C programs.
116 @end enumerate\n")
117 (license license:gpl2+))))
118
119 (define-public cpphs
120 (package
121 (name "cpphs")
122 (version "1.20.8")
123 (source
124 (origin
125 (method url-fetch)
126 (uri (string-append
127 "https://hackage.haskell.org/package/" name "/"
128 name "-" version ".tar.gz"))
129 (sha256
130 (base32
131 "1bh524asqhk9v1s0wvipl0hgn7l63iy3js867yv0z3h5v2kn8vg5"))))
132 (build-system haskell-build-system)
133 (inputs
134 `(("ghc-polyparse" ,ghc-polyparse)
135 ("ghc-old-locale" ,ghc-old-locale)
136 ("ghc-old-time" ,ghc-old-time)))
137 (home-page "http://projects.haskell.org/cpphs/")
138 (synopsis "Liberalised re-implementation of cpp, the C pre-processor")
139 (description "Cpphs is a re-implementation of the C pre-processor that is
140 both more compatible with Haskell, and itself written in Haskell so that it
141 can be distributed with compilers. This version of the C pre-processor is
142 pretty-much feature-complete and compatible with traditional (K&R)
143 pre-processors. Additional features include: a plain-text mode; an option to
144 unlit literate code files; and an option to turn off macro-expansion.")
145 (license (list license:lgpl2.1+ license:gpl3+))))
146
147 ;; Darcs has no https support: http://irclog.perlgeek.de/darcs/2016-09-17
148 ;; http://darcs.net/manual/Configuring_darcs.html#SECTION00440070000000000000
149 ;; and results of search engines will show that if the protocol is http, https
150 ;; is never mentioned.
151 (define-public darcs
152 (package
153 (name "darcs")
154 (version "2.14.2")
155 (source
156 (origin
157 (method url-fetch)
158 (uri (string-append "https://hackage.haskell.org/package/darcs/"
159 "darcs-" version ".tar.gz"))
160 (sha256
161 (base32
162 "0zm2486gyhiga1amclbg92cd09bvki6vgh0ll75hv5kl72j61lb5"))
163 (modules '((guix build utils)))
164 ;; Remove time-dependent code for reproducibility.
165 (snippet
166 '(begin
167 (substitute* "darcs/darcs.hs"
168 (("__DATE__") "\"1970-01-01\"")
169 (("__TIME__") "\"00:00:00\""))
170 #t))))
171 (build-system haskell-build-system)
172 (arguments
173 `(#:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"
174 "-fnetwork-uri" "-fhttp" "--flag=executable"
175 "--flag=library")
176 #:phases
177 (modify-phases %standard-phases
178 (add-after 'patch-source-shebangs 'patch-sh
179 (lambda _
180 (substitute* "tests/issue538.sh"
181 (("/bin/sh") (which "sh")))
182 #t)))))
183 (inputs
184 `(("ghc-cmdargs" ,ghc-cmdargs)
185 ("ghc-split" ,ghc-split)
186 ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
187 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
188 ("ghc-test-framework" ,ghc-test-framework)
189 ("ghc-quickcheck" ,ghc-quickcheck)
190 ("ghc-findbin" ,ghc-findbin)
191 ("ghc-hunit" ,ghc-hunit)
192 ("ghc-async" ,ghc-async)
193 ("ghc-attoparsec" ,ghc-attoparsec)
194 ("ghc-base16-bytestring" ,ghc-base16-bytestring)
195 ("ghc-bytestring-builder" ,ghc-bytestring-builder)
196 ("ghc-cryptohash" ,ghc-cryptohash)
197 ("ghc-data-ordlist" ,ghc-data-ordlist)
198 ("ghc-fgl" ,ghc-fgl)
199 ("ghc-system-filepath" ,ghc-system-filepath)
200 ("ghc-graphviz" ,ghc-graphviz)
201 ("ghc-hashable" ,ghc-hashable)
202 ("ghc-html" ,ghc-html)
203 ("ghc-mmap" ,ghc-mmap)
204 ("ghc-old-time" ,ghc-old-time)
205 ("ghc-random" ,ghc-random)
206 ("ghc-regex-applicative" ,ghc-regex-applicative)
207 ("ghc-regex-compat-tdfa" ,ghc-regex-compat-tdfa)
208 ("ghc-sandi" ,ghc-sandi)
209 ("ghc-shelly" ,ghc-shelly)
210 ("ghc-tar" ,ghc-tar)
211 ("ghc-transformers-compat" ,ghc-transformers-compat)
212 ("ghc-unix-compat" ,ghc-unix-compat)
213 ("ghc-utf8-string" ,ghc-utf8-string)
214 ("ghc-vector" ,ghc-vector)
215 ("ghc-zip-archive" ,ghc-zip-archive)
216 ("ghc-zlib" ,ghc-zlib)
217 ("ghc-http" ,ghc-http)
218 ("curl" ,curl)
219 ("ghc" ,ghc)
220 ("ncurses" ,ncurses)
221 ("perl" ,perl)
222 ("libiconv" ,libiconv)
223 ("ghc-network" ,ghc-network)
224 ("ghc-network-uri" ,ghc-network-uri)))
225 (native-inputs
226 `(("pkg-config" ,pkg-config)))
227 (home-page "http://darcs.net")
228 (synopsis "Distributed Revision Control System")
229 (description
230 "Darcs is a revision control system. It is:
231
232 @enumerate
233 @item Distributed: Every user has access to the full command set, removing boundaries
234 between server and client or committer and non-committers.
235 @item Interactive: Darcs is easy to learn and efficient to use because it asks you
236 questions in response to simple commands, giving you choices in your work flow.
237 You can choose to record one change in a file, while ignoring another. As you update
238 from upstream, you can review each patch name, even the full diff for interesting
239 patches.
240 @item Smart: Originally developed by physicist David Roundy, darcs is based on a
241 unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
242 @end enumerate")
243 (license license:gpl2)))
244
245 (define-public git-annex
246 (package
247 (name "git-annex")
248 (version "7.20191017")
249 (source
250 (origin
251 (method url-fetch)
252 (uri (string-append "https://hackage.haskell.org/package/"
253 "git-annex/git-annex-" version ".tar.gz"))
254 (sha256
255 (base32 "1ydccqqn8v9jns25r6cyz6nd9w80x9wgw85x1v0z6mhv00l2ifp0"))))
256 (build-system haskell-build-system)
257 (arguments
258 `(#:configure-flags
259 '("--flags=-Android -Assistant -Pairing -S3 -Webapp -WebDAV")
260 #:phases
261 (modify-phases %standard-phases
262 (add-before 'configure 'patch-shell-for-tests
263 (lambda _
264 ;; Shell.hs defines "/bin/sh" that is used in Git hooks. We
265 ;; shouldn't patch hooks with Guix's current bash because the
266 ;; hooks can exist after that bash is garbage collected, but
267 ;; let's temporarily patch it so that we can run the tests.
268 (copy-file "Utility/Shell.hs" "/tmp/Shell.hs")
269 (substitute* "Utility/Shell.hs"
270 (("/bin/sh") (which "sh")))
271 #t))
272 (add-before 'configure 'factor-setup
273 (lambda _
274 ;; Factor out necessary build logic from the provided
275 ;; `Setup.hs' script. The script as-is does not work because
276 ;; it cannot find its dependencies, and there is no obvious way
277 ;; to tell it where to look. Note that we do not preserve the
278 ;; code that installs man pages here.
279 (call-with-output-file "PreConf.hs"
280 (lambda (out)
281 (format out "import qualified Build.Configure as Configure~%")
282 (format out "main = Configure.run Configure.tests~%")))
283 (call-with-output-file "Setup.hs"
284 (lambda (out)
285 (format out "import Distribution.Simple~%")
286 (format out "main = defaultMain~%")))
287 #t))
288 (add-before 'configure 'pre-configure
289 (lambda _
290 (invoke "runhaskell" "PreConf.hs")
291 #t))
292 (replace 'check
293 (lambda _
294 ;; We need to set the path so that Git recognizes
295 ;; `git annex' as a custom command.
296 (setenv "PATH" (string-append (getenv "PATH") ":"
297 (getcwd) "/dist/build/git-annex"))
298 (with-directory-excursion "dist/build/git-annex"
299 (symlink "git-annex" "git-annex-shell"))
300 (invoke "git-annex" "test")
301 #t))
302 (add-after 'check 'unpatch-shell-and-rebuild
303 (lambda args
304 ;; Undo `patch-shell-for-tests'.
305 (copy-file "/tmp/Shell.hs" "Utility/Shell.hs")
306 (apply (assoc-ref %standard-phases 'build) args)))
307 (add-after 'install 'install-symlinks
308 (lambda* (#:key outputs #:allow-other-keys)
309 (let* ((out (assoc-ref outputs "out"))
310 (bin (string-append out "/bin")))
311 (symlink (string-append bin "/git-annex")
312 (string-append bin "/git-annex-shell"))
313 (symlink (string-append bin "/git-annex")
314 (string-append bin "/git-remote-tor-annex"))
315 #t))))))
316 (inputs
317 `(("curl" ,curl)
318 ("ghc-aeson" ,ghc-aeson)
319 ("ghc-async" ,ghc-async)
320 ("ghc-bloomfilter" ,ghc-bloomfilter)
321 ("ghc-byteable" ,ghc-byteable)
322 ("ghc-case-insensitive" ,ghc-case-insensitive)
323 ("ghc-concurrent-output" ,ghc-concurrent-output)
324 ("ghc-crypto-api" ,ghc-crypto-api)
325 ("ghc-cryptonite" ,ghc-cryptonite)
326 ("ghc-data-default" ,ghc-data-default)
327 ("ghc-disk-free-space" ,ghc-disk-free-space)
328 ("ghc-dlist" ,ghc-dlist)
329 ("ghc-edit-distance" ,ghc-edit-distance)
330 ("ghc-esqueleto" ,ghc-esqueleto)
331 ("ghc-exceptions" ,ghc-exceptions)
332 ("ghc-feed" ,ghc-feed)
333 ("ghc-free" ,ghc-free)
334 ("ghc-hslogger" ,ghc-hslogger)
335 ("ghc-http-client" ,ghc-http-client)
336 ("ghc-http-conduit" ,ghc-http-conduit)
337 ("ghc-http-types" ,ghc-http-types)
338 ("ghc-ifelse" ,ghc-ifelse)
339 ("ghc-magic" ,ghc-magic)
340 ("ghc-memory" ,ghc-memory)
341 ("ghc-monad-control" ,ghc-monad-control)
342 ("ghc-monad-logger" ,ghc-monad-logger)
343 ("ghc-network" ,ghc-network)
344 ("ghc-old-locale" ,ghc-old-locale)
345 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
346 ("ghc-persistent" ,ghc-persistent)
347 ("ghc-persistent-sqlite" ,ghc-persistent-sqlite)
348 ("ghc-persistent-template" ,ghc-persistent-template)
349 ("ghc-quickcheck" ,ghc-quickcheck)
350 ("ghc-random" ,ghc-random)
351 ("ghc-regex-tdfa" ,ghc-regex-tdfa)
352 ("ghc-resourcet" ,ghc-resourcet)
353 ("ghc-safesemaphore" ,ghc-safesemaphore)
354 ("ghc-sandi" ,ghc-sandi)
355 ("ghc-securemem" ,ghc-securemem)
356 ("ghc-socks" ,ghc-socks)
357 ("ghc-split" ,ghc-split)
358 ("ghc-stm-chans" ,ghc-stm-chans)
359 ("ghc-tagsoup" ,ghc-tagsoup)
360 ("ghc-unix-compat" ,ghc-unix-compat)
361 ("ghc-unordered-containers" ,ghc-unordered-containers)
362 ("ghc-utf8-string" ,ghc-utf8-string)
363 ("ghc-uuid" ,ghc-uuid)
364 ("git" ,git)
365 ("rsync" ,rsync)))
366 (native-inputs
367 `(("ghc-tasty" ,ghc-tasty)
368 ("ghc-tasty-hunit" ,ghc-tasty-hunit)
369 ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
370 ("ghc-tasty-rerun" ,ghc-tasty-rerun)))
371 (home-page "https://git-annex.branchable.com/")
372 (synopsis "Manage files with Git, without checking in their contents")
373 (description "This package allows managing files with Git, without
374 checking the file contents into Git. It can store files in many places,
375 such as local hard drives and cloud storage services. It can also be
376 used to keep a folder in sync between computers.")
377 ;; The main author has released all his changes under AGPLv3+ as of March
378 ;; 2019 (7.20190219-187-g40ecf58d4). These are also licensed under the
379 ;; original GPLv3+ license, but going forward new changes will be under
380 ;; only AGPLv3+. The other licenses below cover code written by others.
381 ;; See git-annex's COPYRIGHT file for details on each file.
382 (license (list license:agpl3+
383 license:gpl3+
384 license:bsd-2
385 license:expat
386 license:gpl2))))
387
388 (define-public hlint
389 (package
390 (name "hlint")
391 (version "2.1.10")
392 (source
393 (origin
394 (method url-fetch)
395 (uri (string-append
396 "https://hackage.haskell.org/package/" name
397 "/" name "-" version ".tar.gz"))
398 (sha256
399 (base32
400 "19as2m9g75cr6n1agzvsij0cvqhb0wbjlk31w4y5d5mns87dki0w"))))
401 (build-system haskell-build-system)
402 (inputs
403 `(("cpphs" ,cpphs)
404 ("ghc-unordered-containers" ,ghc-unordered-containers)
405 ("ghc-yaml" ,ghc-yaml)
406 ("ghc-vector" ,ghc-vector)
407 ("ghc-data-default" ,ghc-data-default)
408 ("ghc-cmdargs" ,ghc-cmdargs)
409 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
410 ("ghc-haskell-src-exts-util" ,ghc-haskell-src-exts-util)
411 ("ghc-uniplate" ,ghc-uniplate)
412 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
413 ("ghc-extra" ,ghc-extra)
414 ("ghc-refact" ,ghc-refact)
415 ("ghc-aeson" ,ghc-aeson)
416 ("hscolour" ,hscolour)))
417 (home-page "http://community.haskell.org/~ndm/hlint/")
418 (synopsis "Suggest improvements for Haskell source code")
419 (description "HLint reads Haskell programs and suggests changes that
420 hopefully make them easier to read. HLint also makes it easy to disable
421 unwanted suggestions, and to add your own custom suggestions.")
422 (license license:bsd-3)))
423
424 (define-public hoogle
425 (package
426 (name "hoogle")
427 (version "5.0.17.3")
428 (source
429 (origin
430 (method url-fetch)
431 (uri
432 (string-append
433 "https://hackage.haskell.org/package/hoogle/hoogle-"
434 version ".tar.gz"))
435 (sha256
436 (base32
437 "174gp41v0krzj37m75pnr3aawyhkbk2wq4q6zk2z3zh0avvvmgk6"))))
438 (build-system haskell-build-system)
439 (inputs
440 `(("ghc-network-uri" ,ghc-network-uri)
441 ("ghc-network" ,ghc-network)
442 ("ghc-quickcheck" ,ghc-quickcheck)
443 ("ghc-aeson" ,ghc-aeson)
444 ("ghc-cmdargs" ,ghc-cmdargs)
445 ("ghc-conduit" ,ghc-conduit)
446 ("ghc-conduit-extra" ,ghc-conduit-extra)
447 ("ghc-connection" ,ghc-connection)
448 ("ghc-extra" ,ghc-extra)
449 ("ghc-old-locale" ,ghc-old-locale)
450 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
451 ("ghc-http-conduit" ,ghc-http-conduit)
452 ("ghc-http-types" ,ghc-http-types)
453 ("ghc-js-flot" ,ghc-js-flot)
454 ("ghc-js-jquery" ,ghc-js-jquery)
455 ("ghc-mmap" ,ghc-mmap)
456 ("ghc-process-extras" ,ghc-process-extras)
457 ("ghc-resourcet" ,ghc-resourcet)
458 ("ghc-storable-tuple" ,ghc-storable-tuple)
459 ("ghc-tar" ,ghc-tar)
460 ("ghc-uniplate" ,ghc-uniplate)
461 ("ghc-utf8-string" ,ghc-utf8-string)
462 ("ghc-vector" ,ghc-vector)
463 ("ghc-wai" ,ghc-wai)
464 ("ghc-wai-logger" ,ghc-wai-logger)
465 ("ghc-warp" ,ghc-warp)
466 ("ghc-warp-tls" ,ghc-warp-tls)
467 ("ghc-zlib" ,ghc-zlib)))
468 (home-page "https://hoogle.haskell.org/")
469 (synopsis "Haskell API Search")
470 (description "Hoogle is a Haskell API search engine, which allows
471 you to search many standard Haskell libraries by either function name,
472 or by approximate type signature.")
473 (license license:bsd-3)))
474
475 (define-public hscolour
476 (package
477 (name "hscolour")
478 (version "1.24.4")
479 (source
480 (origin
481 (method url-fetch)
482 (uri (string-append
483 "https://hackage.haskell.org/package/hscolour/hscolour-"
484 version
485 ".tar.gz"))
486 (sha256
487 (base32
488 "079jwph4bwllfp03yfr26s5zc6m6kw3nhb1cggrifh99haq34cr4"))))
489 (build-system haskell-build-system)
490 (home-page "https://hackage.haskell.org/package/hscolour")
491 (synopsis "Script to colourise Haskell code")
492 (description "HSColour is a small Haskell script to colourise Haskell
493 code. It currently has six output formats: ANSI terminal codes (optionally
494 XTerm-256colour codes), HTML 3.2 with font tags, HTML 4.01 with CSS, HTML 4.01
495 with CSS and mouseover annotations, XHTML 1.0 with inline CSS styling, LaTeX,
496 and mIRC chat codes.")
497 (license license:bsd-3)))
498
499 (define-public raincat
500 (package
501 (name "raincat")
502 (version "1.2.1")
503 (source
504 (origin
505 (method url-fetch)
506 (uri (string-append "http://hackage.haskell.org/package/Raincat/"
507 "Raincat-" version ".tar.gz"))
508 (sha256
509 (base32
510 "10y9zi22m6hf13c9h8zd9vg7mljpwbw0r3djb6r80bna701fdf6c"))))
511 (build-system haskell-build-system)
512 (arguments
513 `(#:phases
514 (modify-phases %standard-phases
515 (add-after 'install 'wrap-executable
516 (lambda* (#:key inputs outputs #:allow-other-keys)
517 (let ((out (assoc-ref outputs "out")))
518 (wrap-program (string-append out "/bin/raincat")
519 `("LD_LIBRARY_PATH" ":" =
520 (,(string-append (assoc-ref inputs "freeglut")
521 "/lib"))))
522 #t))))))
523 (inputs
524 `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
525 ("ghc-random" ,ghc-random)
526 ("ghc-glut" ,ghc-glut)
527 ("freeglut" ,freeglut)
528 ("ghc-opengl" ,ghc-opengl)
529 ("ghc-sdl2" ,ghc-sdl2)
530 ("ghc-sdl2-image" ,ghc-sdl2-image)
531 ("ghc-sdl2-mixer" ,ghc-sdl2-mixer)))
532 (home-page "http://www.bysusanlin.com/raincat/")
533 (synopsis "Puzzle game with a cat in lead role")
534 (description "Project Raincat is a game developed by Carnegie Mellon
535 students through GCS during the Fall 2008 semester. Raincat features game
536 play inspired from classics Lemmings and The Incredible Machine. The project
537 proved to be an excellent learning experience for the programmers. Everything
538 is programmed in Haskell.")
539 (license license:bsd-3)))
540
541 (define-public shellcheck
542 (package
543 (name "shellcheck")
544 (version "0.7.0")
545 (source
546 (origin
547 (method url-fetch)
548 (uri (string-append
549 "https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
550 version ".tar.gz"))
551 (sha256
552 (base32 "1vx895cp5k5h0680xfwj74lk97m9y627n965x6srds0gfnbkzy9s"))
553 (file-name (string-append name "-" version ".tar.gz"))))
554 (build-system haskell-build-system)
555 (inputs
556 `(("ghc-aeson" ,ghc-aeson)
557 ("ghc-diff" ,ghc-diff)
558 ("ghc-quickcheck" ,ghc-quickcheck)
559 ("ghc-regex-tdfa" ,ghc-regex-tdfa)))
560 (home-page "https://github.com/koalaman/shellcheck")
561 (synopsis "Static analysis for shell scripts")
562 (description "@code{shellcheck} provides static analysis for
563 @command{bash} and @command{sh} shell scripts.
564 It gives warnings and suggestions in order to:
565
566 @enumerate
567 @item Point out and clarify typical beginner's syntax issues that cause
568 a shell to give cryptic error messages.
569 @item Point out and clarify typical intermediate level semantic problems
570 that cause a shell to behave strangely and counter-intuitively.
571 @item Point out subtle caveats, corner cases and pitfalls that may cause an
572 advanced user's otherwise working script to fail under future circumstances.
573 @end enumerate")
574 (license license:gpl3+)))
575
576 (define-public stylish-haskell
577 (package
578 (name "stylish-haskell")
579 (version "0.9.2.2")
580 (source
581 (origin
582 (method url-fetch)
583 (uri
584 (string-append
585 "mirror://hackage/package/stylish-haskell/"
586 "stylish-haskell-" version ".tar.gz"))
587 (sha256
588 (base32
589 "1zs624xqp6j8vrl6pfv18dm8vz8hvz25grri65ximxhcizgwhnax"))))
590 (build-system haskell-build-system)
591 (inputs
592 `(("ghc-aeson" ,ghc-aeson)
593 ("ghc-file-embed" ,ghc-file-embed)
594 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
595 ("ghc-semigroups" ,ghc-semigroups)
596 ("ghc-syb" ,ghc-syb)
597 ("ghc-yaml" ,ghc-yaml)
598 ("ghc-strict" ,ghc-strict)
599 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
600 ("ghc-hunit" ,ghc-hunit)
601 ("ghc-test-framework" ,ghc-test-framework)
602 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
603 (home-page "https://github.com/jaspervdj/stylish-haskell")
604 (synopsis "Haskell code prettifier")
605 (description
606 "A simple Haskell code prettifier. The goal is not to format all of the
607 code in a file, just clean up import statements and a few other tedious
608 items. This tool tries to help where necessary without getting in the way.")
609 (license license:bsd-3)))