Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / wget.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages wget)
22 #:use-module (guix licenses)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages libidn)
25 #:use-module (gnu packages python)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages web)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages tls)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public wget
35 (package
36 (name "wget")
37 (version "1.19.1")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "mirror://gnu/wget/wget-"
42 version ".tar.xz"))
43 (patches (search-patches "wget-CVE-2017-6508.patch"
44 "wget-fix-504-test-timeout.patch"
45 "wget-perl-5.26.patch"))
46 (sha256
47 (base32
48 "1ljcfhbkdsd0zjfm520rbl1ai62fc34i7c45sfj244l8f6b0p58c"))))
49 (build-system gnu-build-system)
50 (arguments
51 '(#:phases (modify-phases %standard-phases
52 (add-before 'check 'disable-https-tests
53 (lambda _
54 ;; XXX: Skip TLS tests, which fail with "The
55 ;; certificate's owner does not match hostname" as
56 ;; reported at:
57 ;; <https://lists.gnu.org/archive/html/bug-wget/2017-07/msg00012.html>.
58 ;; The problem appears to be due to a change in GnuTLS
59 ;; 3.5.12, whereby 'gnutls_x509_crt_check_hostname2' no
60 ;; longer matches IP address against the 'CN' or
61 ;; 'DNSname' fields of certificates.
62 (substitute* "testenv/Makefile"
63 (("SSL_TESTS=1") ""))
64 #t)))))
65 (inputs
66 `(("gnutls" ,gnutls)
67 ("libidn2" ,libidn2)
68 ("libpsl" ,libpsl)))
69 (native-inputs
70 `(("pkg-config" ,pkg-config)
71 ("perl" ,perl)
72 ("python" ,python) ;for testenv suite
73 ("perl-http-daemon" ,perl-http-daemon)
74 ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
75 (home-page "https://www.gnu.org/software/wget/")
76 (synopsis "Non-interactive command-line utility for downloading files")
77 (description
78 "GNU Wget is a non-interactive tool for fetching files using the HTTP,
79 HTTPS and FTP protocols. It can resume interrupted downloads, use file name
80 wild cards, supports proxies and cookies, and it can convert absolute links
81 in downloaded documents to relative links.")
82 (license gpl3+))) ; some files are under GPLv2+
83
84 (define-public wgetpaste
85 (package
86 (name "wgetpaste")
87 (version "2.28")
88 (source
89 (origin
90 (method url-fetch)
91 (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
92 version ".tar.bz2"))
93 (sha256
94 (base32
95 "1hh9svyypqcvdg5mjxyyfzpdzhylhf7s7xq5dzglnm4injx3i3ak"))))
96 (build-system gnu-build-system)
97 (arguments
98 '(#:phases
99 (modify-phases %standard-phases
100 (delete 'configure)
101 (delete 'build)
102 (replace 'install
103 (lambda* (#:key outputs #:allow-other-keys)
104 (let* ((out (assoc-ref outputs "out"))
105 (bin (string-append out "/bin"))
106 (zsh (string-append out "/share/zsh/site-functions")))
107 (install-file "wgetpaste" bin)
108 (install-file "_wgetpaste" zsh)))))
109 #:tests? #f)) ; no test target
110 (home-page "http://wgetpaste.zlin.dk/")
111 (synopsis "Script that automates pasting to a number of pastebin services")
112 (description
113 "@code{wgetpaste} is an extremely simple command-line interface to various
114 online pastebin services.")
115 (license public-domain)))