Merge branch 'xorg' into core-updates
[jackhill/guix/guix.git] / gnu / packages / lesstif.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lesstif)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages xorg))
26
27
28 (define-public lesstif
29 (package
30 (name "lesstif")
31 (version "0.95.2")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append
36 "mirror://sourceforge/lesstif/lesstif/" version
37 "/lesstif-" version ".tar.bz2"))
38 (sha256
39 (base32
40 "1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb"))))
41 (build-system gnu-build-system)
42 (propagated-inputs
43 `(("printproto" ,printproto)))
44 (inputs
45 `(("libxext" ,libxext)
46 ("libxt" ,libxt)))
47 (home-page "http://lesstif.sourceforge.net/")
48 (synopsis "Clone of the Motif toolkit for the X window system")
49 (description "Clone of the Motif toolkit for the X window system")
50 (license license:gpl2+))) ; some files are lgpl2.1+ or x11