gnu: emacs-sly: Update to 20200228.
[jackhill/guix/guix.git] / gnu / packages / onc-rpc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
4 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages onc-rpc)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix git-download)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages gettext)
31 #:use-module (gnu packages kerberos)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (guix build-system gnu))
34
35 (define-public libtirpc
36 (package
37 (name "libtirpc")
38 (version "1.1.4")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
42 version "/libtirpc-"
43 version ".tar.bz2"))
44 (sha256
45 (base32
46 "07anqypf7c719x9y683qz65cxllmzlgmlab2hlahrqcj4bq2k99c"))))
47 (build-system gnu-build-system)
48 (arguments
49 `(#:configure-flags '("--disable-static")
50 #:phases
51 (modify-phases %standard-phases
52 (add-after 'unpack 'remote-dangling-symlink
53 (lambda _
54 (substitute* '("man/netconfig.5"
55 "man/getnetconfig.3t"
56 "man/getnetpath.3t"
57 "man/rpc.3t"
58 "src/getnetconfig.c"
59 "tirpc/netconfig.h")
60 (("/etc/netconfig") (string-append %output "/etc/netconfig")))
61
62 ;; Remove the dangling symlinks since it breaks the
63 ;; 'patch-source-shebangs' file tree traversal.
64 (delete-file "INSTALL")
65 #t)))))
66 (inputs `(("mit-krb5" ,mit-krb5)))
67 (home-page "https://sourceforge.net/projects/libtirpc/")
68 (synopsis "Transport-independent Sun/ONC RPC implementation")
69 (description
70 "This package provides a library that implements the Sun/ONC RPC (remote
71 procedure calls) protocol in a transport-independent manner. It supports both
72 IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
73 (license bsd-3)))
74
75 (define-public rpcbind
76 (package
77 (name "rpcbind")
78 (version "0.2.4")
79 (source
80 (origin
81 (method url-fetch)
82 (uri (string-append "mirror://sourceforge/" name "/" name "/"
83 version "/"
84 name "-" version ".tar.bz2"))
85 (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
86 (sha256
87 (base32
88 "0rjc867mdacag4yqvs827wqhkh27135rp9asj06ixhf71m9rljh7"))))
89 (build-system gnu-build-system)
90 (arguments
91 `(#:configure-flags
92 `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
93 (inputs
94 `(("libnsl" ,libnsl)
95 ("libtirpc" ,libtirpc)))
96 (native-inputs
97 `(("pkg-config" ,pkg-config)))
98 (home-page "http://rpcbind.sourceforge.net/")
99 (synopsis "Server to convert RPC program numbers into universal addresses")
100 (description
101 "@command{Rpcbind} is a server that converts RPC program numbers into
102 universal addresses.")
103 (license bsd-3)))
104
105 (define-public rpcsvc-proto
106 (package
107 (name "rpcsvc-proto")
108 (version "1.4")
109 (home-page "https://github.com/thkukuk/rpcsvc-proto")
110 (source (origin
111 (method url-fetch)
112 (uri (string-append home-page "/releases/download/v" version
113 "/rpcsvc-proto-" version ".tar.xz"))
114 (sha256
115 (base32
116 "0i93wbpw5dk2gf5v4a5hq6frh814wzgjydh7saj28wlgbpqdaja1"))))
117 (build-system gnu-build-system)
118 (synopsis "RPCSVC protocol definitions")
119 (description
120 "This package provides @code{rpcsvc} @file{protocol.x} files and headers
121 that are not included with the @code{libtirpc} package. Additionally it
122 contains @command{rpcgen}, which is used to produce header files and sources
123 from the protocol files.")
124 (license bsd-3)))
125
126 (define-public libnsl
127 (package
128 (name "libnsl")
129 (version "1.2.0")
130 (source (origin
131 (method git-fetch)
132 (uri (git-reference
133 (url "https://github.com/thkukuk/libnsl.git")
134 (commit (string-append "v" version))))
135 (file-name (git-file-name name version))
136 (sha256
137 (base32
138 "1chzqhcgh0yia9js8mh92cmhyka7rh32ql6b3mgdk26n94dqzs8b"))))
139 (build-system gnu-build-system)
140 (arguments
141 `(#:configure-flags '("--disable-static")
142 #:phases (modify-phases %standard-phases
143 (add-before 'bootstrap 'gettextize
144 (lambda _
145 ;; Regenerate the bundled Makefile.in.in to avoid a
146 ;; "gettext infrastructure mismatch" because the
147 ;; existing version was generated by an older gettext.
148 (invoke "gettextize" "-f"))))))
149 (native-inputs
150 `(("autoconf" ,autoconf)
151 ("automake" ,automake)
152 ("gettext" ,gettext-minimal)
153 ("libtool" ,libtool)
154 ("pkg-config" ,pkg-config)))
155 (inputs
156 `(("libtirpc" ,libtirpc)))
157 (synopsis "Public client interface for NIS(YP) and NIS+")
158 (description "Libnsl is the public client interface for the Network
159 Information Service / Yellow Pages (NIS/YP) and NIS+. It includes IPv6 support.
160 This library was part of glibc < 2.26, but is now distributed separately.")
161 (home-page "https://github.com/thkukuk/libnsl")
162 ;; The package is distributed under the LGPL 2.1. Some files in
163 ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
164 (license lgpl2.1)))