gnu: emacs-sly: Update to 20200228.
[jackhill/guix/guix.git] / gnu / packages / guile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
4 ;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
5 ;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
7 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
8 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
9 ;;; Copyright © 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
11 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
12 ;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
13 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
14 ;;; Copyright © 2017, 2018 Amirouche <amirouche@hypermove.net>
15 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
16 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
17 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages guile)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages autotools)
38 #:use-module (gnu packages base)
39 #:use-module (gnu packages bash)
40 #:use-module (gnu packages bdw-gc)
41 #:use-module (gnu packages compression)
42 #:use-module (gnu packages dbm)
43 #:use-module (gnu packages flex)
44 #:use-module (gnu packages gawk)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages hurd)
47 #:use-module (gnu packages libffi)
48 #:use-module (gnu packages libunistring)
49 #:use-module (gnu packages linux)
50 #:use-module (gnu packages m4)
51 #:use-module (gnu packages multiprecision)
52 #:use-module (gnu packages pkg-config)
53 #:use-module (gnu packages readline)
54 #:use-module (gnu packages sqlite)
55 #:use-module (gnu packages texinfo)
56 #:use-module (gnu packages version-control)
57 #:use-module (guix packages)
58 #:use-module (guix download)
59 #:use-module (guix git-download)
60 #:use-module (guix build-system gnu)
61 #:use-module (guix build-system guile)
62 #:use-module (guix deprecation)
63 #:use-module (guix utils)
64 #:use-module (ice-9 match)
65 #:use-module ((srfi srfi-1) #:prefix srfi-1:))
66
67 ;;; Commentary:
68 ;;;
69 ;;; GNU Guile, and modules and extensions.
70 ;;;
71 ;;; Code:
72
73 (define-public guile-1.8
74 (package
75 (name "guile")
76 (version "1.8.8")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "mirror://gnu/guile/guile-" version
80 ".tar.gz"))
81 (sha256
82 (base32
83 "0l200a0v7h8bh0cwz6v7hc13ds39cgqsmfrks55b1rbj5vniyiy3"))
84 (patches (search-patches "guile-1.8-cpp-4.5.patch"))))
85 (build-system gnu-build-system)
86 (arguments '(#:configure-flags '("--disable-error-on-warning")
87
88 ;; Insert a phase before `configure' to patch things up.
89 #:phases
90 (modify-phases %standard-phases
91 (add-before 'configure 'patch-stuff
92 (lambda* (#:key outputs #:allow-other-keys)
93 ;; Add a call to `lt_dladdsearchdir' so that
94 ;; `libguile-readline.so' & co. are in the
95 ;; loader's search path.
96 (substitute* "libguile/dynl.c"
97 (("lt_dlinit.*$" match)
98 (format #f
99 " ~a~% lt_dladdsearchdir(\"~a/lib\");~%"
100 match
101 (assoc-ref outputs "out"))))
102
103 ;; The usual /bin/sh...
104 (substitute* "ice-9/popen.scm"
105 (("/bin/sh") (which "sh")))
106 #t)))))
107
108 ;; When cross-compiling, a native version of Guile itself is needed.
109 (native-inputs (if (%current-target-system)
110 `(("self" ,this-package))
111 '()))
112
113 (inputs `(("gawk" ,gawk)
114 ("readline" ,readline)))
115
116 ;; Since `guile-1.8.pc' has "Libs: ... -lgmp -lltdl", these must be
117 ;; propagated.
118 (propagated-inputs `(("gmp" ,gmp)
119 ("libltdl" ,libltdl)))
120
121 (native-search-paths
122 (list (search-path-specification
123 (variable "GUILE_LOAD_PATH")
124 (files '("share/guile/site")))))
125
126 (synopsis "Scheme implementation intended especially for extensions")
127 (description
128 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
129 official extension language of the GNU system. It is an implementation of
130 the Scheme language which can be easily embedded in other applications to
131 provide a convenient means of extending the functionality of the application
132 without requiring the source code to be rewritten.")
133 (home-page "https://www.gnu.org/software/guile/")
134 (license license:lgpl2.0+)))
135
136 (define-public guile-2.0
137 (package
138 (name "guile")
139 (version "2.0.14")
140 (source (origin
141 (method url-fetch)
142 (uri (string-append "mirror://gnu/guile/guile-" version
143 ".tar.xz"))
144 (sha256
145 (base32
146 "10lxc6l5alf3lzbs3ihnbfy6dfcrsyf8667wa57f26vf4mk2ai78"))))
147 (build-system gnu-build-system)
148
149 ;; When cross-compiling, a native version of Guile itself is needed.
150 (native-inputs `(,@(if (%current-target-system)
151 `(("self" ,this-package))
152 '())
153 ("pkgconfig" ,pkg-config)))
154 (inputs `(("libffi" ,libffi)
155 ,@(libiconv-if-needed)
156
157 ;; We need Bash when cross-compiling because some of the scripts
158 ;; in bin/ refer to it. Use 'bash-minimal' because we don't need
159 ;; an interactive Bash with Readline and all.
160 ,@(if (target-mingw?) '() `(("bash" ,bash-minimal)))))
161 (propagated-inputs
162 `( ;; These ones aren't normally needed here, but since `libguile-2.0.la'
163 ;; reads `-lltdl -lunistring', adding them here will add the needed
164 ;; `-L' flags. As for why the `.la' file lacks the `-L' flags, see
165 ;; <http://thread.gmane.org/gmane.comp.lib.gnulib.bugs/18903>.
166 ("libunistring" ,libunistring)
167
168 ;; Depend on LIBLTDL, not LIBTOOL. That way, we avoid some the extra
169 ;; dependencies that LIBTOOL has, which is helpful during bootstrap.
170 ("libltdl" ,libltdl)
171
172 ;; The headers and/or `guile-2.0.pc' refer to these packages, so they
173 ;; must be propagated.
174 ("bdw-gc" ,libgc)
175 ("gmp" ,gmp)))
176
177 (outputs '("out" "debug"))
178
179 (arguments
180 `(#:configure-flags '("--disable-static") ; saves 3 MiB
181 #:phases
182 (modify-phases %standard-phases
183 (add-before 'configure 'pre-configure
184 (lambda* (#:key inputs #:allow-other-keys)
185 ;; Tell (ice-9 popen) the file name of Bash.
186 (let ((bash (assoc-ref inputs "bash")))
187 (substitute* "module/ice-9/popen.scm"
188 ;; If bash is #f allow fallback for user to provide
189 ;; "bash" in PATH. This happens when cross-building to
190 ;; MinGW for which we do not have Bash yet.
191 (("/bin/sh")
192 ,@(if (target-mingw?)
193 '((if bash
194 (string-append bash "/bin/bash")
195 "bash"))
196 '((string-append bash "/bin/bash")))))
197 #t))))))
198
199 (native-search-paths
200 (list (search-path-specification
201 (variable "GUILE_LOAD_PATH")
202 (files '("share/guile/site/2.0")))
203 (search-path-specification
204 (variable "GUILE_LOAD_COMPILED_PATH")
205 (files '("lib/guile/2.0/site-ccache")))))
206
207 (synopsis "Scheme implementation intended especially for extensions")
208 (description
209 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
210 official extension language of the GNU system. It is an implementation of
211 the Scheme language which can be easily embedded in other applications to
212 provide a convenient means of extending the functionality of the application
213 without requiring the source code to be rewritten.")
214 (home-page "https://www.gnu.org/software/guile/")
215 (license license:lgpl3+)))
216
217 (define-public guile-2.2
218 (package (inherit guile-2.0)
219 (name "guile")
220 (version "2.2.6")
221 (source (origin
222 (method url-fetch)
223
224 ;; Note: we are limited to one of the compression formats
225 ;; supported by the bootstrap binaries, so no lzip here.
226 (uri (string-append "mirror://gnu/guile/guile-" version
227 ".tar.xz"))
228 (sha256
229 (base32
230 "1269ymxm56j1z1lvq1y42rm961f2n7rinm3k6l00p9k52hrpcddk"))
231 (modules '((guix build utils)))
232 (patches (search-patches
233 "guile-2.2-skip-oom-test.patch"))
234
235 ;; Remove the pre-built object files. Instead, build everything
236 ;; from source, at the expense of significantly longer build
237 ;; times (almost 3 hours on a 4-core Intel i5).
238 (snippet '(begin
239 (for-each delete-file
240 (find-files "prebuilt" "\\.go$"))
241 #t))))
242 (properties '((timeout . 72000) ;20 hours
243 (max-silent-time . 36000))) ;10 hours (needed on ARM
244 ; when heavily loaded)
245 (native-search-paths
246 (list (search-path-specification
247 (variable "GUILE_LOAD_PATH")
248 (files '("share/guile/site/2.2")))
249 (search-path-specification
250 (variable "GUILE_LOAD_COMPILED_PATH")
251 (files '("lib/guile/2.2/site-ccache")))))))
252
253 (define-public guile-2.2.7
254 ;; This version contains a bug fix for a relatively rare crash that could
255 ;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
256 (package
257 (inherit guile-2.2)
258 (version "2.2.7")
259 (source (origin
260 (inherit (package-source guile-2.2))
261 (uri (string-append "mirror://gnu/guile/guile-" version
262 ".tar.xz"))
263 (sha256
264 (base32
265 "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))))))
266
267 (define-deprecated guile-2.2/bug-fix guile-2.2.7)
268
269 (define-public guile-2.2/fixed
270 ;; A package of Guile 2.2 that's rarely changed. It is the one used
271 ;; in the `base' module, and thus changing it entails a full rebuild.
272 (package
273 (inherit guile-2.2)
274 (properties '((hidden? . #t) ;people should install 'guile-2.2'
275 (timeout . 72000) ;20 hours
276 (max-silent-time . 36000))))) ;10 hours (needed on ARM
277 ; when heavily loaded)
278 (define-public guile-2.2.4
279 (package/inherit
280 guile-2.2
281 (version "2.2.4")
282 (source (origin
283 (inherit (package-source guile-2.2))
284 (uri (string-append "mirror://gnu/guile/guile-" version
285 ".tar.xz"))
286 (sha256
287 (base32
288 "07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))))))
289
290 (define-public guile-3.0
291 ;; This is the latest Guile stable version.
292 (package
293 (inherit guile-2.2)
294 (name "guile-next") ;to be renamed to "guile"
295 (version "3.0.0")
296 (source (origin
297 (inherit (package-source guile-2.2))
298 (uri (string-append "mirror://gnu/guile/guile-"
299 version ".tar.xz"))
300 (sha256
301 (base32
302 "0x8ca6q1qdmk29lh12gj6ngvgn7kp79w42rxfgwrpxm9jmjqs4y9"))))
303 (arguments
304 (substitute-keyword-arguments (package-arguments guile-2.2)
305 ;; XXX: On ARMv7, work around <https://bugs.gnu.org/39208> by disabling
306 ;; JIT.
307 ((#:configure-flags flags '())
308 (if (target-arm32?)
309 `(cons "--disable-jit" ,flags)
310 flags))))
311 (native-search-paths
312 (list (search-path-specification
313 (variable "GUILE_LOAD_PATH")
314 (files '("share/guile/site/3.0")))
315 (search-path-specification
316 (variable "GUILE_LOAD_COMPILED_PATH")
317 (files '("lib/guile/3.0/site-ccache"
318 "share/guile/site/3.0")))))))
319
320 (define-public guile-next guile-3.0)
321
322 (define* (make-guile-readline guile #:optional (name "guile-readline"))
323 (package
324 (name name)
325 (version (package-version guile))
326 (source (package-source guile))
327 (build-system gnu-build-system)
328 (arguments
329 '(#:configure-flags '("--disable-silent-rules")
330 #:phases (modify-phases %standard-phases
331 (add-before 'build 'chdir
332 (lambda* (#:key outputs #:allow-other-keys)
333 (invoke "make" "-C" "libguile" "scmconfig.h")
334 (invoke "make" "-C" "lib")
335 (chdir "guile-readline")
336
337 (substitute* "Makefile"
338 (("../libguile/libguile-[[:graph:]]+\\.la")
339 ;; Remove dependency on libguile-X.Y.la.
340 "")
341 (("^READLINE_LIBS = (.*)$" _ libs)
342 ;; Link against the provided libguile.
343 (string-append "READLINE_LIBS = "
344 "-lguile-$(GUILE_EFFECTIVE_VERSION) "
345 libs "\n"))
346 (("\\$\\(top_builddir\\)/meta/build-env")
347 ;; Use the provided Guile, not the one from
348 ;; $(builddir).
349 "")
350
351 ;; Install modules to the 'site' directories.
352 (("^moddir = .*$")
353 "moddir = $(pkgdatadir)/site/$(GUILE_EFFECTIVE_VERSION)\n")
354 (("^ccachedir = .*$")
355 "ccachedir = $(pkglibdir)/$(GUILE_EFFECTIVE_VERSION)/site-ccache\n"))
356
357 ;; Load 'guile-readline.so' from the right place.
358 (substitute* "ice-9/readline.scm"
359 (("load-extension \"guile-readline\"")
360 (format #f "load-extension \
361 (string-append ~s \"/lib/guile/\" (effective-version) \"/extensions/guile-readline\")"
362 (assoc-ref outputs "out"))))
363 #t)))))
364 (home-page (package-home-page guile))
365 (native-inputs (package-native-inputs guile))
366 (inputs
367 `(,@(package-inputs guile) ;to placate 'configure'
368 ,@(package-propagated-inputs guile)
369 ("guile" ,guile)
370 ("readline" ,readline)))
371 (synopsis "Line editing support for GNU Guile")
372 (description
373 "This module provides line editing support via the Readline library for
374 GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
375 @code{activate-readline} procedure to enable it.")
376 (license license:gpl3+)))
377
378 (define-public guile-readline
379 (make-guile-readline guile-2.2))
380
381 (define-public guile3.0-readline
382 (make-guile-readline guile-next "guile3.0-readline"))
383
384 (define (guile-variant-package-name prefix)
385 (lambda (name)
386 "Return NAME with PREFIX instead of \"guile-\", when applicable."
387 (if (string-prefix? "guile-" name)
388 (string-append prefix "-"
389 (string-drop name
390 (string-length "guile-")))
391 name)))
392
393 (define package-for-guile-2.0
394 ;; A procedure that rewrites the dependency tree of the given package to use
395 ;; GUILE-2.0 instead of GUILE-2.2.
396 (package-input-rewriting `((,guile-2.2 . ,guile-2.0))
397 (guile-variant-package-name "guile2.0")))
398
399 (define package-for-guile-3.0
400 (package-input-rewriting `((,guile-2.2 . ,guile-next))
401 (guile-variant-package-name "guile3.0")))
402
403 (define-public guile-for-guile-emacs
404 (package (inherit guile-2.2)
405 (name "guile-for-guile-emacs")
406 (version "20150510.d8d9a8d")
407 (source (origin
408 (method git-fetch)
409 (uri (git-reference
410 (url "git://git.hcoop.net/git/bpt/guile.git")
411 (commit "d8d9a8da05ec876acba81a559798eb5eeceb5a17")))
412 (file-name (string-append name "-" version "-checkout"))
413 (sha256
414 (base32
415 "00sprsshy16y8pxjy126hr2adqcvvzzz96hjyjwgg8swva1qh6b0"))))
416 (arguments
417 `(;; Tests aren't passing for now.
418 ;; Obviously we should re-enable this!
419 #:tests? #f
420 ,@(package-arguments guile-2.2)))
421 (native-inputs
422 `(("autoconf" ,autoconf)
423 ("automake" ,automake)
424 ("libtool" ,libtool)
425 ("flex" ,flex)
426 ("texinfo" ,texinfo)
427 ("gettext" ,gettext-minimal)
428 ,@(package-native-inputs guile-2.2)))
429 ;; Same as in guile-2.0
430 (native-search-paths
431 (list (search-path-specification
432 (variable "GUILE_LOAD_PATH")
433 (files '("share/guile/site/2.0")))
434 (search-path-specification
435 (variable "GUILE_LOAD_COMPILED_PATH")
436 (files '("lib/guile/2.0/site-ccache"
437 "share/guile/site/2.0")))))))
438
439 \f
440 ;;;
441 ;;; Extensions.
442 ;;;
443
444 (define-public guile-json-1
445 (package
446 (name "guile-json")
447 (version "1.2.0")
448 (home-page "https://github.com/aconchillo/guile-json")
449 (source (origin
450 (method url-fetch)
451 (uri (string-append "mirror://savannah/guile-json/guile-json-"
452 version ".tar.gz"))
453 (sha256
454 (base32
455 "15gnb84d7hpazqhskkf3g9z4r6knw54wfj4ch5270kakz1lp70c9"))))
456 (build-system gnu-build-system)
457 (native-inputs `(("pkg-config" ,pkg-config)
458 ("guile" ,guile-2.2)))
459 (inputs `(("guile" ,guile-2.2)))
460 (synopsis "JSON module for Guile")
461 (description
462 "Guile-JSON supports parsing and building JSON documents according to the
463 specification. These are the main features:
464
465 @itemize
466 @item Strictly complies to @uref{http://json.org, specification}.
467 @item Build JSON documents programmatically via macros.
468 @item Unicode support for strings.
469 @item Allows JSON pretty printing.
470 @end itemize\n")
471
472 ;; Version 1.2.0 switched to GPLv3+ (from LGPLv3+).
473 (license license:gpl3+)))
474
475 ;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
476 ;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
477 ;; 'guile-json-3'.
478 (define-deprecated guile-json guile-json-1)
479 (export guile-json)
480
481 (define-public guile2.0-json
482 (package-for-guile-2.0 guile-json-1))
483
484 (define-public guile-json-3
485 ;; This version is incompatible with 1.x; see the 'NEWS' file.
486 (package
487 (inherit guile-json-1)
488 (name "guile-json")
489 (version "3.2.0")
490 (source (origin
491 (method url-fetch)
492 (uri (string-append "mirror://savannah/guile-json/guile-json-"
493 version ".tar.gz"))
494 (sha256
495 (base32
496 "14m6b6g2maw0mkvfm4x63rqb54vgbpn1gcqs715ijw4bikfzlqfz"))))))
497
498 (define-public guile3.0-json
499 (package-for-guile-3.0 guile-json-3))
500
501 ;; There are two guile-gdbm packages, one using the FFI and one with
502 ;; direct C bindings, hence the verbose name.
503
504 (define-public guile-gdbm-ffi
505 (package
506 (name "guile-gdbm-ffi")
507 (version "20120209.fa1d5b6")
508 (source (origin
509 (method git-fetch)
510 (uri (git-reference
511 (url "https://github.com/ijp/guile-gdbm.git")
512 (commit "fa1d5b6231d0e4d096687b378c025f2148c5f246")))
513 (file-name (string-append name "-" version "-checkout"))
514 (patches (search-patches
515 "guile-gdbm-ffi-support-gdbm-1.14.patch"))
516 (sha256
517 (base32
518 "1j8wrsw7v9w6qkl47xz0rdikg50v16nn6kbs3lgzcymjzpa7babj"))))
519 (build-system guile-build-system)
520 (arguments
521 '(#:phases (modify-phases %standard-phases
522 (add-after 'unpack 'move-examples
523 (lambda* (#:key outputs #:allow-other-keys)
524 ;; Move examples where they belong.
525 (let* ((out (assoc-ref outputs "out"))
526 (doc (string-append out "/share/doc/"
527 (strip-store-file-name out)
528 "/examples")))
529 (copy-recursively "examples" doc)
530 (delete-file-recursively "examples")
531 #t)))
532 (add-after 'unpack 'set-libgdbm-file-name
533 (lambda* (#:key inputs #:allow-other-keys)
534 (substitute* "gdbm.scm"
535 (("\\(dynamic-link \"libgdbm\"\\)")
536 (format #f "(dynamic-link \"~a/lib/libgdbm.so\")"
537 (assoc-ref inputs "gdbm"))))
538 #t)))))
539 (native-inputs
540 `(("guile" ,guile-2.2)))
541 (inputs
542 `(("gdbm" ,gdbm)))
543 (home-page "https://github.com/ijp/guile-gdbm")
544 (synopsis "Guile bindings to the GDBM library via Guile's FFI")
545 (description
546 "Guile bindings to the GDBM key-value storage system, using
547 Guile's foreign function interface.")
548 (license license:gpl3+)))
549
550 (define-public guile2.0-gdbm-ffi
551 (package-for-guile-2.0 guile-gdbm-ffi))
552
553 (define-public guile3.0-gdbm-ffi
554 (package-for-guile-3.0 guile-gdbm-ffi))
555
556 (define-public guile-sqlite3
557 (package
558 (name "guile-sqlite3")
559 (version "0.1.0")
560 (home-page "https://notabug.org/guile-sqlite3/guile-sqlite3.git")
561 (source (origin
562 (method git-fetch)
563 (uri (git-reference
564 (url home-page)
565 (commit (string-append "v" version))))
566 (sha256
567 (base32
568 "1nv8j7wk6b5n4p22szyi8lv8fs31rrzxhzz16gyj8r38c1fyp9qp"))
569 (file-name (string-append name "-" version "-checkout"))
570 (modules '((guix build utils)))
571 (snippet
572 '(begin
573 ;; Allow builds with Guile 3.0.
574 (substitute* "configure.ac"
575 (("^GUILE_PKG.*")
576 "GUILE_PKG([3.0 2.2 2.0])\n"))
577 #t))))
578 (build-system gnu-build-system)
579 (native-inputs
580 `(("autoconf" ,autoconf)
581 ("automake" ,automake)
582 ("pkg-config" ,pkg-config)))
583 (inputs
584 `(("guile" ,guile-2.2)
585 ("sqlite" ,sqlite)))
586 (synopsis "Access SQLite databases from Guile")
587 (description
588 "This package provides Guile bindings to the SQLite database system.")
589 (license license:gpl3+)))
590
591 (define-public guile2.0-sqlite3
592 (package-for-guile-2.0 guile-sqlite3))
593
594 (define-public guile3.0-sqlite3
595 (package-for-guile-3.0 guile-sqlite3))
596
597 (define-public guile-bytestructures
598 (package
599 (name "guile-bytestructures")
600 (version "1.0.7")
601 (home-page "https://github.com/TaylanUB/scheme-bytestructures")
602 (source (origin
603 (method git-fetch)
604 (uri (git-reference
605 (url home-page)
606 (commit (string-append "v" version))))
607 (file-name (git-file-name name version))
608 (sha256
609 (base32
610 "0q0habjiy3h9cigb7q1br9kz6z212dn2ab31f6dgd3rrmsfn5rvb"))))
611 (build-system gnu-build-system)
612 (arguments
613 `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
614
615 #:phases (modify-phases %standard-phases
616 (add-after 'install 'install-doc
617 (lambda* (#:key outputs #:allow-other-keys)
618 (let* ((out (assoc-ref outputs "out"))
619 (package ,(package-full-name this-package "-"))
620 (doc (string-append out "/share/doc/" package)))
621 (install-file "README.md" doc)
622 #t))))))
623 (native-inputs
624 `(("autoconf" ,autoconf)
625 ("automake" ,automake)
626 ("pkg-config" ,pkg-config)
627 ("guile" ,guile-2.2)))
628 (inputs
629 `(("guile" ,guile-2.2)))
630 (synopsis "Structured access to bytevector contents for Guile")
631 (description
632 "Guile bytestructures offers a system imitating the type system
633 of the C programming language, to be used on bytevectors. C's type
634 system works on raw memory, and Guile works on bytevectors which are
635 an abstraction over raw memory. It's also more powerful than the C
636 type system, elevating types to first-class status.")
637 (license license:gpl3+)
638 (properties '((upstream-name . "bytestructures")))))
639
640 (define-public guile2.0-bytestructures
641 (package-for-guile-2.0 guile-bytestructures))
642
643 (define-public guile3.0-bytestructures
644 (package-for-guile-3.0 guile-bytestructures))
645
646 (define-public guile-git
647 (package
648 (name "guile-git")
649 (version "0.3.0")
650 (home-page "https://gitlab.com/guile-git/guile-git.git")
651 (source (origin
652 (method url-fetch)
653 (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
654 "4c563d8e7e1ff84396abe8ca7011bcaf/guile-git-"
655 version ".tar.gz"))
656 (sha256
657 (base32
658 "0c5i3d16hp7gp9rd78vk9zc45js8bphf92m4lbb5gyi4l1yl7kkm"))))
659 (build-system gnu-build-system)
660 (native-inputs
661 `(("pkg-config" ,pkg-config)
662 ("guile" ,guile-2.2)
663 ("guile-bytestructures" ,guile-bytestructures)))
664 (inputs
665 `(("guile" ,guile-2.2)
666 ("libgit2" ,libgit2)))
667 (propagated-inputs
668 `(("guile-bytestructures" ,guile-bytestructures)))
669 (synopsis "Guile bindings for libgit2")
670 (description
671 "This package provides Guile bindings to libgit2, a library to
672 manipulate repositories of the Git version control system.")
673 (license license:gpl3+)))
674
675 (define-public guile3.0-git
676 (package-for-guile-3.0 guile-git))
677
678 (define-public guile2.0-git
679 (let ((base (package-for-guile-2.0 guile-git)))
680 (package
681 (inherit base)
682 ;; Libgit2's Guile test driver requires (ice-9 textual-ports), which is
683 ;; not in Guile 2.0. Thus, keep LIBGIT2 as-is here (i.e., built against
684 ;; Guile 2.2).
685 (inputs `(("libgit2" ,libgit2)
686 ,@(srfi-1:alist-delete "libgit2"
687 (package-inputs base)))))))
688
689 ;;; guile.scm ends here
690