gnu: emacs-sly: Update to 20200228.
[jackhill/guix/guix.git] / gnu / packages / gl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Joshua Grant <tadni@riseup.net>
4 ;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
5 ;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2016 ng0 <ng0@n0.is>
7 ;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
8 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
9 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
10 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
11 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
12 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
13 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
14 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages gl)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages bison)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages documentation)
37 #:use-module (gnu packages elf)
38 #:use-module (gnu packages flex)
39 #:use-module (gnu packages fontutils)
40 #:use-module (gnu packages freedesktop)
41 #:use-module (gnu packages gettext)
42 #:use-module (gnu packages guile)
43 #:use-module (gnu packages image)
44 #:use-module (gnu packages linux)
45 #:use-module (gnu packages llvm)
46 #:use-module (gnu packages mono)
47 #:use-module (gnu packages pkg-config)
48 #:use-module (gnu packages python)
49 #:use-module (gnu packages python-xyz)
50 #:use-module (gnu packages tls)
51 #:use-module (gnu packages video)
52 #:use-module (gnu packages vulkan)
53 #:use-module (gnu packages xdisorg)
54 #:use-module (gnu packages xml)
55 #:use-module (gnu packages xorg)
56 #:use-module (guix download)
57 #:use-module (guix git-download)
58 #:use-module (guix hg-download)
59 #:use-module (guix build-system gnu)
60 #:use-module (guix build-system cmake)
61 #:use-module (guix build-system meson)
62 #:use-module ((guix licenses) #:prefix license:)
63 #:use-module (guix packages)
64 #:use-module (guix utils)
65 #:use-module (ice-9 match)
66 #:use-module ((srfi srfi-1) #:hide (zip)))
67
68 (define-public glu
69 (package
70 (name "glu")
71 (version "9.0.1")
72 (source (origin
73 (method url-fetch)
74 (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/glu/glu-"
75 version ".tar.gz"))
76 (sha256
77 (base32
78 "1xqhk9bn10nbvffw3r4p4rjslwz1l7gaycc0x2pqkr2irp7q9x7n"))))
79 (build-system gnu-build-system)
80 (propagated-inputs
81 `(("mesa" ,mesa))) ; according to glu.pc
82 (home-page "http://www.opengl.org/archives/resources/faq/technical/glu.htm")
83 (synopsis "Mesa OpenGL Utility library")
84 (description
85 "GLU, or OpenGL Utility Library provides some higher-level functionality
86 not provided by just OpenGL itself. Some of GLU's Features
87 include: Scaling of 2D images and creation of mipmap pyramids,
88 Transformation of object coordinates into device coordinates and
89 vice versa, Support for NURBS surfaces, Support for tessellation
90 of concave or bow tie polygonal primitives, Specialty transformation
91 matrices for creating perspective and orthographic projections,
92 positioning a camera, and selection/picking, Rendering of disk,
93 cylinder, and sphere primitives, Interpreting OpenGL error values
94 as ASCII text.")
95 (license (license:x11-style "http://directory.fsf.org/wiki/License:SGIFreeBv2"))))
96
97 (define-public freeglut
98 (package
99 (name "freeglut")
100 (version "3.2.1")
101 (source (origin
102 (method url-fetch)
103 (uri (string-append
104 "mirror://sourceforge/freeglut/freeglut/"
105 version "/freeglut-" version ".tar.gz"))
106 (sha256
107 (base32
108 "0s6sk49q8ijgbsrrryb7dzqx2fa744jhx1wck5cz5jia2010w06l"))))
109 (build-system cmake-build-system)
110 (arguments
111 '(#:tests? #f ;no test target
112 #:configure-flags '("-DFREEGLUT_BUILD_STATIC_LIBS=OFF")))
113 (inputs `(("libx11" ,libx11)
114 ("libxi" ,libxi)
115 ("libxrandr" ,libxrandr)
116 ("libxxf86vm" ,libxxf86vm)))
117 (propagated-inputs
118 ;; Headers from Mesa and GLU are needed.
119 `(("glu" ,glu)
120 ("mesa" ,mesa)))
121 (home-page "http://freeglut.sourceforge.net/")
122 (synopsis "Alternative to the OpenGL Utility Toolkit (GLUT)")
123 (description
124 "Freeglut is a completely Free/OpenSourced alternative to
125 the OpenGL Utility Toolkit (GLUT) library. GLUT was originally
126 written by Mark Kilgard to support the sample programs in the
127 second edition OpenGL @code{RedBook}. Since then, GLUT has been used
128 in a wide variety of practical applications because it is simple,
129 widely available and highly portable.
130
131 GLUT (and hence freeglut) allows the user to create and manage windows
132 containing OpenGL contexts on a wide range of platforms and also read
133 the mouse, keyboard and joystick functions. Freeglut is released under
134 the X-Consortium license.")
135 (license license:x11)))
136
137 ;; Needed for "kiki".
138 (define-public freeglut-2.8
139 (package (inherit freeglut)
140 (name "freeglut")
141 (version "2.8.1")
142 (source (origin
143 (method url-fetch)
144 (uri (string-append
145 "mirror://sourceforge/freeglut/freeglut/"
146 version "/freeglut-" version ".tar.gz"))
147 (sha256
148 (base32
149 "16lrxxxd9ps9l69y3zsw6iy0drwjsp6m26d1937xj71alqk6dr6x"))))
150 (build-system gnu-build-system)
151 (arguments
152 '(#:configure-flags '("--disable-static")))))
153
154 (define-public ftgl
155 (package
156 (name "ftgl")
157 (version "2.4.0")
158 (home-page "https://github.com/frankheckenbach/ftgl")
159 (source (origin
160 (method git-fetch)
161 (uri (git-reference (url home-page)
162 (commit (string-append "v" version))))
163 (file-name (git-file-name name version))
164 (sha256
165 (base32
166 "0zjs1h9w30gajq9lndzvjsa26rsmr1081lb1fbpbj10yhcdcsc79"))))
167 (build-system gnu-build-system)
168 (arguments
169 `(#:configure-flags '("--disable-static")))
170 ;; The pkg-config file lists "freetype2" as Requires.private.
171 (propagated-inputs `(("freetype" ,freetype)))
172 (inputs `(("libx11" ,libx11)
173 ("mesa" ,mesa)
174 ("glu" ,glu)))
175 (native-inputs
176 `(("pkg-config" ,pkg-config)
177 ("autoconf" ,autoconf)
178 ("automake" ,automake)
179 ("libtool" ,libtool)))
180 (synopsis "Font rendering library for OpenGL applications")
181 (description
182 "FTGL is a font rendering library for OpenGL applications. Supported
183 rendering modes are: Bitmaps, Anti-aliased pixmaps, Texture maps, Outlines,
184 Polygon meshes, and Extruded polygon meshes.")
185 (license license:x11)))
186
187 (define-public s2tc
188 (package
189 (name "s2tc")
190 (version "1.0")
191 (source
192 (origin
193 (method git-fetch)
194 (uri (git-reference
195 (url "https://github.com/divVerent/s2tc.git")
196 (commit (string-append "v" version))))
197 (file-name (git-file-name name version))
198 (sha256
199 (base32 "1fg323fk7wlv2xh6lw66wswgcv6qi8aaadk7c28h2f2lj1s7njnf"))))
200 (build-system gnu-build-system)
201 (native-inputs
202 `(("autoconf" ,autoconf)
203 ("automake" ,automake)
204 ("libtool" ,libtool)))
205 (inputs
206 `(("mesa-headers" ,mesa-headers)))
207 (home-page "https://github.com/divVerent/s2tc")
208 (synopsis "S3 Texture Compression implementation")
209 (description
210 "S2TC is a patent-free implementation of S3 Texture Compression (S3TC,
211 also known as DXTn or DXTC) for Mesa.")
212 (license license:expat)))
213
214 ;;; Mesa needs LibVA headers to build its Gallium-based VA API implementation;
215 ;;; LibVA itself depends on Mesa. We use the following to solve the circular
216 ;;; dependency.
217 (define libva-without-mesa
218 ;; Delay to work around circular import problem.
219 (delay
220 (package
221 (inherit libva)
222 (name "libva-without-mesa")
223 (inputs `(,@(fold alist-delete (package-inputs libva)
224 '("mesa" "wayland"))))
225 (arguments
226 (strip-keyword-arguments
227 '(#:make-flags)
228 (substitute-keyword-arguments (package-arguments libva)
229 ((#:configure-flags flags)
230 '(list "--disable-glx" "--disable-egl"))))))))
231
232 (define-public mesa
233 (package
234 (name "mesa")
235 (version "19.3.2")
236 (source
237 (origin
238 (method url-fetch)
239 (uri (list (string-append "https://mesa.freedesktop.org/archive/"
240 "mesa-" version ".tar.xz")
241 (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
242 "mesa-" version ".tar.xz")
243 (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
244 version "/mesa-" version ".tar.xz")))
245 (sha256
246 (base32
247 "1hg1gvcwvayksrdh9z8rfz66h3z1ffspmm2qgyy2nd8n8qrfwfjf"))
248 (patches
249 (search-patches "mesa-skip-disk-cache-test.patch"))))
250 (build-system meson-build-system)
251 (propagated-inputs
252 `(;; The following are in the Requires.private field of gl.pc.
253 ("libdrm" ,libdrm)
254 ("libvdpau" ,libvdpau)
255 ("libx11" ,libx11)
256 ("libxdamage" ,libxdamage)
257 ("libxfixes" ,libxfixes)
258 ("libxshmfence" ,libxshmfence)
259 ("libxxf86vm" ,libxxf86vm)
260 ("xorgproto" ,xorgproto)))
261 (inputs
262 `(("expat" ,expat)
263 ("libelf" ,elfutils) ;required for r600 when using llvm
264 ("libva" ,(force libva-without-mesa))
265 ("libxml2" ,libxml2)
266 ;; TODO: Add 'libxml2-python' for OpenGL ES 1.1 and 2.0 support
267 ("libxrandr" ,libxrandr)
268 ("libxvmc" ,libxvmc)
269 ,@(match (%current-system)
270 ((or "x86_64-linux" "i686-linux")
271 `(("llvm" ,llvm-8)))
272 (_
273 `()))
274 ("makedepend" ,makedepend)
275 ("wayland" ,wayland)
276 ("wayland-protocols" ,wayland-protocols)))
277 (native-inputs
278 `(("bison" ,bison)
279 ("flex" ,flex)
280 ("gettext" ,gettext-minimal)
281 ,@(match (%current-system)
282 ((or "x86_64-linux" "i686-linux")
283 `(("glslang" ,glslang)))
284 (_
285 `()))
286 ("pkg-config" ,pkg-config)
287 ("python" ,python-wrapper)
288 ("python-mako" ,python-mako)
289 ("which" ,(@ (gnu packages base) which))))
290 (arguments
291 `(#:configure-flags
292 '(,@(match (%current-system)
293 ((or "armhf-linux" "aarch64-linux")
294 ;; TODO: Fix svga driver for aarch64 and armhf.
295 '("-Dgallium-drivers=etnaviv,freedreno,nouveau,r300,r600,swrast,tegra,v3d,vc4,virgl"))
296 (_
297 '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
298 ;; Enable various optional features. TODO: opencl requires libclc,
299 ;; omx requires libomxil-bellagio
300 "-Dplatforms=x11,drm,surfaceless,wayland"
301 "-Dglx=dri" ;Thread Local Storage, improves performance
302 ;; "-Dopencl=true"
303 ;; "-Domx=true"
304 "-Dosmesa=gallium"
305 "-Dgallium-xa=true"
306
307 ;; features required by wayland
308 "-Dgles2=true"
309 "-Dgbm=true"
310 "-Dshared-glapi=true"
311
312 ;; Enable Vulkan on i686-linux and x86-64-linux.
313 ,@(match (%current-system)
314 ((or "i686-linux" "x86_64-linux")
315 '("-Dvulkan-drivers=intel,amd"))
316 (_
317 '("-Dvulkan-drivers=auto")))
318
319 ;; Enable the Vulkan overlay layer on i686-linux and x86-64-linux.
320 ,@(match (%current-system)
321 ((or "x86_64-linux" "i686-linux")
322 '("-Dvulkan-overlay-layer=true"))
323 (_
324 '()))
325
326 ;; Also enable the tests.
327 "-Dbuild-tests=true"
328
329 ;; on non-intel systems, drop i915 and i965
330 ;; from the default dri drivers
331 ,@(match (%current-system)
332 ((or "x86_64-linux" "i686-linux")
333 '("-Ddri-drivers=i915,i965,nouveau,r200,r100"
334 "-Dllvm=true")) ; default is x86/x86_64 only
335 (_
336 '("-Ddri-drivers=nouveau,r200,r100"))))
337
338 ;; XXX: 'debugoptimized' causes LTO link failures on some drivers. The
339 ;; documentation recommends using 'release' for performance anyway.
340 #:build-type "release"
341
342 #:modules ((ice-9 match)
343 (srfi srfi-1)
344 (guix build utils)
345 (guix build meson-build-system))
346 #:phases
347 (modify-phases %standard-phases
348 (add-after
349 'unpack 'patch-create_test_cases
350 (lambda _
351 (substitute* "src/intel/genxml/gen_pack_header.py"
352 (("/usr/bin/env python2") (which "python")))
353 #t))
354 ,@(if (string-prefix? "i686" (or (%current-target-system)
355 (%current-system)))
356 ;; Disable new test from Mesa 19 that fails on i686. Upstream
357 ;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.
358 `((add-after 'unpack 'disable-failing-test
359 (lambda _
360 (substitute* "src/gallium/tests/unit/meson.build"
361 (("'u_format_test',") ""))
362 #t)))
363 '())
364 (add-before
365 'configure 'fix-dlopen-libnames
366 (lambda* (#:key inputs outputs #:allow-other-keys)
367 (let ((out (assoc-ref outputs "out")))
368 ;; Remain agnostic to .so.X.Y.Z versions while doing
369 ;; the substitutions so we're future-safe.
370 (substitute* "src/glx/dri_common.c"
371 (("dlopen\\(\"libGL\\.so")
372 (string-append "dlopen(\"" out "/lib/libGL.so")))
373 (substitute* "src/egl/drivers/dri2/egl_dri2.c"
374 (("\"libglapi\\.so")
375 (string-append "\"" out "/lib/libglapi.so")))
376 (substitute* "src/gbm/main/backend.c"
377 ;; No need to patch the gbm_gallium_drm.so reference;
378 ;; it's never installed since Mesa removed its
379 ;; egl_gallium support.
380 (("\"gbm_dri\\.so")
381 (string-append "\"" out "/lib/dri/gbm_dri.so")))
382 #t)))
383 (add-after 'install 'symlinks-instead-of-hard-links
384 (lambda* (#:key outputs #:allow-other-keys)
385 ;; All the drivers and gallium targets create hard links upon
386 ;; installation (search for "hardlink each megadriver instance"
387 ;; in the makefiles). This is no good for us since we'd produce
388 ;; nars that contain several copies of these files. Thus, turn
389 ;; them into symlinks, which saves ~124 MiB.
390 (let* ((out (assoc-ref outputs "out"))
391 (lib (string-append out "/lib"))
392 (files (find-files lib
393 (lambda (file stat)
394 (and (string-contains file ".so")
395 (eq? 'regular
396 (stat:type stat))))))
397 (inodes (map (compose stat:ino stat) files)))
398 (for-each (lambda (inode)
399 (match (filter-map (match-lambda
400 ((file ino)
401 (and (= ino inode) file)))
402 (zip files inodes))
403 ((_)
404 #f)
405 ((reference others ..1)
406 (format #t "creating ~a symlinks to '~a'~%"
407 (length others) reference)
408 (for-each delete-file others)
409 (for-each (lambda (file)
410 (if (string=? (dirname file)
411 (dirname reference))
412 (symlink (basename reference)
413 file)
414 (symlink reference file)))
415 others))))
416 (delete-duplicates inodes))
417 #t))))))
418 (home-page "https://mesa3d.org/")
419 (synopsis "OpenGL and Vulkan implementations")
420 (description "Mesa is a free implementation of the OpenGL and Vulkan
421 specifications - systems for rendering interactive 3D graphics. A variety of
422 device drivers allows Mesa to be used in many different environments ranging
423 from software emulation to complete hardware acceleration for modern GPUs.")
424 (license license:x11)))
425
426 ;; Mesa 19.3.2 causes a test failure in some packages, so add this newer
427 ;; version separately until the next rebuild cycle.
428 (define-public mesa-19.3.3
429 (package/inherit
430 mesa
431 (version "19.3.3")
432 (source (origin
433 (inherit (package-source mesa))
434 (uri (list (string-append "https://mesa.freedesktop.org/archive/"
435 "mesa-" version ".tar.xz")
436 (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
437 "mesa-" version ".tar.xz")
438 (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
439 version "/mesa-" version ".tar.xz")))
440 (sha256
441 (base32
442 "02czqdqf64i3az5p1allnxycyjad3x35cj0hz0017mi5pc84ikl1"))))))
443
444 (define-public mesa-opencl
445 (package
446 (inherit mesa)
447 (name "mesa-opencl")
448 (arguments
449 (substitute-keyword-arguments (package-arguments mesa)
450 ((#:configure-flags flags)
451 `(cons "-Dgallium-opencl=standalone" ,flags))))
452 (inputs
453 `(("libclc" ,libclc)
454 ,@(package-inputs mesa)))
455 (native-inputs
456 `(("clang" ,clang-8)
457 ,@(package-native-inputs mesa)))))
458
459 (define-public mesa-opencl-icd
460 (package
461 (inherit mesa-opencl)
462 (name "mesa-opencl-icd")
463 (arguments
464 (substitute-keyword-arguments (package-arguments mesa)
465 ((#:configure-flags flags)
466 `(cons "-Dgallium-opencl=icd"
467 ,(delete "-Dgallium-opencl=standalone" flags)))))))
468
469 (define-public mesa-headers
470 (package
471 (inherit mesa)
472 (name "mesa-headers")
473 (propagated-inputs '())
474 (inputs '())
475 (native-inputs '())
476 (arguments
477 '(#:phases
478 (modify-phases %standard-phases
479 (delete 'configure)
480 (delete 'build)
481 (delete 'check)
482 (replace 'install
483 (lambda* (#:key outputs #:allow-other-keys)
484 (copy-recursively "include" (string-append
485 (assoc-ref outputs "out")
486 "/include"))
487 #t)))))))
488
489 ;;; The mesa-demos distribution contains non-free files, many files with no
490 ;;; clear license information, and many demos that aren't useful for most
491 ;;; people, so we just use this for the mesa-utils package below, and possibly
492 ;;; other packages in the future. This is modeled after Debian's solution.
493 (define (mesa-demos-source version)
494 (origin
495 (method url-fetch)
496 (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/demos"
497 "/mesa-demos-" version ".tar.bz2"))
498 (sha256 (base32 "0zgzbz55a14hz83gbmm0n9gpjnf5zadzi2kjjvkn6khql2a9rs81"))))
499
500 (define-public mesa-utils
501 (package
502 (name "mesa-utils")
503 (version "8.4.0")
504 (source (mesa-demos-source version))
505 (build-system gnu-build-system)
506 (inputs
507 `(("mesa" ,mesa)
508 ("glut" ,freeglut)
509 ("glew" ,glew)))
510 (native-inputs
511 `(("pkg-config" ,pkg-config)))
512 (arguments
513 '(#:phases
514 (modify-phases %standard-phases
515 (replace
516 'install
517 (lambda* (#:key outputs #:allow-other-keys)
518 (let ((out (assoc-ref outputs "out")))
519 (mkdir-p (string-append out "/bin"))
520 (for-each
521 (lambda (file)
522 (copy-file file (string-append out "/bin/" (basename file))))
523 '("src/xdemos/glxdemo" "src/xdemos/glxgears"
524 "src/xdemos/glxinfo" "src/xdemos/glxheads"))
525 #t))))))
526 (home-page "https://mesa3d.org/")
527 (synopsis "Utility tools for Mesa")
528 (description
529 "The mesa-utils package contains several utility tools for Mesa: glxdemo,
530 glxgears, glxheads, and glxinfo.")
531 ;; glxdemo is public domain; others expat.
532 (license (list license:expat license:public-domain))))
533
534 (define-public glew
535 (package
536 (name "glew")
537 (version "2.1.0")
538 (source (origin
539 (method url-fetch)
540 (uri (string-append "mirror://sourceforge/glew/glew/" version
541 "/glew-" version ".tgz"))
542 (sha256
543 (base32
544 "159wk5dc0ykjbxvag5i1m2mhp23zkk6ra04l26y3jc3nwvkr3ph4"))
545 (modules '((guix build utils)))
546 (snippet
547 '(begin
548 (substitute* "config/Makefile.linux"
549 (("= cc") "= gcc")
550 (("/lib64") "/lib"))
551 #t))))
552 (build-system gnu-build-system)
553 (arguments
554 '(#:phases (modify-phases %standard-phases (delete 'configure))
555 #:make-flags (list (string-append "GLEW_PREFIX="
556 (assoc-ref %outputs "out"))
557 (string-append "GLEW_DEST="
558 (assoc-ref %outputs "out")))
559 #:tests? #f)) ;no 'check' target
560 (inputs
561 `(("libxi" ,libxi)
562 ("libxmu" ,libxmu)
563 ("libx11" ,libx11)
564 ("mesa" ,mesa)))
565
566 ;; <GL/glew.h> includes <GL/glu.h>.
567 (propagated-inputs `(("glu" ,glu)))
568
569 (home-page "http://glew.sourceforge.net/")
570 (synopsis "OpenGL extension loading library for C and C++")
571 (description
572 "The OpenGL Extension Wrangler Library (GLEW) is a C/C++ extension
573 loading library. GLEW provides efficient run-time mechanisms for determining
574 which OpenGL extensions are supported on the target platform. OpenGL core and
575 extension functionality is exposed in a single header file.")
576 (license license:bsd-3)))
577
578 (define-public guile-opengl
579 (package
580 (name "guile-opengl")
581 (version "0.1.0")
582 (source (origin
583 (method url-fetch)
584 (uri (string-append "mirror://gnu/guile-opengl/guile-opengl-"
585 version ".tar.gz"))
586 (sha256
587 (base32
588 "13qfx4xh8baryxqrv986l848ygd0piqwm6s2s90pxk9c0m9vklim"))))
589 (build-system gnu-build-system)
590 (native-inputs `(("pkg-config" ,pkg-config)))
591 (inputs `(("guile" ,guile-2.2)
592 ("mesa" ,mesa)
593 ("glu" ,glu)
594 ("freeglut" ,freeglut)))
595 (arguments
596 '(#:phases (modify-phases %standard-phases
597 (add-after 'configure 'patch-makefile
598 (lambda _
599 ;; Install compiled Guile files in the expected place.
600 (substitute* '("Makefile")
601 (("^godir = .*$")
602 "godir = $(moddir)\n"))))
603 (add-before 'build 'patch-dynamic-link
604 (lambda* (#:key inputs outputs #:allow-other-keys)
605 (define (dynamic-link-substitute file lib input)
606 (substitute* file
607 (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
608 (string-append "dynamic-link \""
609 (assoc-ref inputs input)
610 "/lib/lib" lib "\""))))
611 ;; Replace dynamic-link calls for libGL, libGLU, and
612 ;; libglut with absolute paths to the store.
613 (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
614 (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
615 (dynamic-link-substitute "glut/runtime.scm" "glut"
616 "freeglut"))))))
617 (home-page "https://gnu.org/s/guile-opengl")
618 (synopsis "Guile binding for the OpenGL graphics API")
619 (description
620 "Guile-OpenGL is a library for Guile that provides bindings to the
621 OpenGL graphics API.")
622 (license license:lgpl3+)))
623
624 (define-public libepoxy
625 (package
626 (name "libepoxy")
627 (version "1.5.4")
628 (source (origin
629 (method url-fetch)
630 (uri (string-append
631 "https://github.com/anholt/libepoxy/releases/download/"
632 version "/libepoxy-" version ".tar.xz"))
633 (sha256
634 (base32
635 "1ll9fach4v30dsyd47s5ial4gaiwihzr2afb77vxxzzy3mlcrlhb"))))
636 (arguments
637 `(#:phases
638 (modify-phases %standard-phases
639 (delete 'bootstrap)
640 (add-before
641 'configure 'patch-paths
642 (lambda* (#:key inputs #:allow-other-keys)
643 (let ((python (assoc-ref inputs "python"))
644 (mesa (assoc-ref inputs "mesa")))
645 (substitute* "src/gen_dispatch.py"
646 (("/usr/bin/env python") python))
647 (substitute* (find-files "." "\\.[ch]$")
648 (("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
649 (("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
650 #t))))))
651 (build-system meson-build-system)
652 (native-inputs
653 `(("pkg-config" ,pkg-config)
654 ("python" ,python)))
655 (inputs
656 `(("mesa" ,mesa)))
657 (home-page "https://github.com/anholt/libepoxy/")
658 (synopsis "A library for handling OpenGL function pointer management")
659 (description
660 "A library for handling OpenGL function pointer management.")
661 (license license:x11)))
662
663 (define-public soil
664 (package
665 (name "soil")
666 (version "1.0.7")
667 (source (origin
668 (method url-fetch)
669 ;; No versioned archive available.
670 (uri "http://www.lonesock.net/files/soil.zip")
671 (sha256
672 (base32
673 "00gpwp9dldzhsdhksjvmbhsd2ialraqbv6v6dpikdmpncj6mnc52"))))
674 (build-system gnu-build-system)
675 (arguments
676 '(#:tests? #f ; no tests
677 #:phases (modify-phases %standard-phases
678 (delete 'configure)
679 (add-before 'build 'init-build
680 (lambda* (#:key outputs #:allow-other-keys)
681 (let ((out (assoc-ref outputs "out")))
682 (setenv "CFLAGS" "-fPIC") ; needed for shared library
683 ;; Use alternate Makefile
684 (copy-file "projects/makefile/alternate Makefile.txt"
685 "src/Makefile")
686 (chdir "src")
687 (substitute* '("Makefile")
688 (("INCLUDEDIR = /usr/include/SOIL")
689 (string-append "INCLUDEDIR = " out "/include/SOIL"))
690 (("LIBDIR = /usr/lib")
691 (string-append "LIBDIR = " out "/lib"))
692 ;; Remove these flags from 'install' commands.
693 (("-o root -g root") ""))))))))
694 (native-inputs
695 `(("unzip" ,unzip)))
696 (inputs
697 `(("mesa" ,mesa)))
698 (home-page "https://www.lonesock.net/soil.html")
699 (synopsis "OpenGL texture loading library")
700 (description
701 "SOIL is a tiny C library used primarily for uploading textures into
702 OpenGL.")
703 (license license:public-domain)))
704
705 (define-public glfw
706 (package
707 (name "glfw")
708 (version "3.2.1")
709 (source (origin
710 (method url-fetch)
711 (uri (string-append "https://github.com/glfw/glfw"
712 "/releases/download/" version
713 "/glfw-" version ".zip"))
714 (sha256
715 (base32
716 "09kk5yc1zhss9add8ryqrngrr16hdmc94rszgng135bhw09mxmdp"))))
717 (build-system cmake-build-system)
718 (arguments
719 '(#:tests? #f ; no test target
720 #:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
721 (native-inputs
722 `(("doxygen" ,doxygen)
723 ("unzip" ,unzip)))
724 (propagated-inputs
725 `(("mesa" ,mesa) ;included in public headers
726
727 ;; These are in 'Requires.private' of 'glfw3.pc'.
728 ("libx11" ,libx11)
729 ("libxrandr" ,libxrandr)
730 ("libxinerama" ,libxinerama)
731 ("libxcursor" ,libxcursor)
732 ("libxxf86vm" ,libxxf86vm)))
733 (home-page "http://www.glfw.org")
734 (synopsis "OpenGL application development library")
735 (description
736 "GLFW is a library for OpenGL, OpenGL ES and Vulkan development for
737 desktop computers. It provides a simple API for creating windows, contexts
738 and surfaces, receiving input and events.")
739 (license license:zlib)))
740
741 (define-public nanovg-for-extempore
742 (package
743 (name "nanovg-for-extempore")
744 (version "0.7.1")
745 (source (origin
746 (method url-fetch)
747 (uri (string-append "https://github.com/extemporelang/nanovg/"
748 "archive/" version ".tar.gz"))
749 (file-name (string-append name "-" version ".tar.gz"))
750 (sha256
751 (base32
752 "0ivs1sagq19xiw8jxd9f8w2b39svi0n9hrbmdvckwvqg95r8701g"))))
753 (build-system cmake-build-system)
754 (arguments `(#:tests? #f)) ; no tests included
755 (inputs
756 `(("mesa" ,mesa)))
757 ;; Extempore refuses to build on architectures other than x86_64
758 (supported-systems '("x86_64-linux"))
759 (home-page "https://github.com/extemporelang/nanovg")
760 (synopsis "2D vector drawing library on top of OpenGL")
761 (description "NanoVG is small antialiased vector graphics rendering
762 library for OpenGL. It has lean API modeled after HTML5 canvas API. It is
763 aimed to be a practical and fun toolset for building scalable user interfaces
764 and visualizations.")
765 (license license:zlib)))
766
767 (define-public gl2ps
768 (package
769 (name "gl2ps")
770 (version "1.4.0")
771 (source
772 (origin
773 (method url-fetch)
774 (uri (string-append
775 "http://geuz.org/gl2ps/src/gl2ps-"
776 version ".tgz"))
777 (sha256
778 (base32
779 "1qpidkz8x3bxqf69hlhyz1m0jmfi9kq24fxsp7rq6wfqzinmxjq3"))))
780 (build-system cmake-build-system)
781 (inputs
782 `(("libpng" ,libpng)
783 ("mesa" ,mesa)
784 ("zlib" ,zlib)))
785 (arguments
786 `(#:tests? #f)) ;; no tests
787 (home-page "http://www.geuz.org/gl2ps/")
788 (synopsis "OpenGL to PostScript printing library")
789 (description "GL2PS is a C library providing high quality vector
790 output for any OpenGL application. GL2PS uses sorting algorithms
791 capable of handling intersecting and stretched polygons, as well as
792 non-manifold objects. GL2PS provides many features including advanced
793 smooth shading and text rendering, culling of invisible primitives and
794 mixed vector/bitmap output.")
795 ;; GL2PS is dual-licenced and can be used under the terms of either.
796 (license (list license:lgpl2.0+
797 (license:fsf-free "http://www.geuz.org/gl2ps/COPYING.GL2PS"
798 "GPL-incompatible copyleft license")))))
799
800 (define-public virtualgl
801 (package
802 (name "virtualgl")
803 (version "2.6.2")
804 (source
805 (origin
806 (method git-fetch)
807 (uri (git-reference
808 (url "https://github.com/VirtualGL/virtualgl.git")
809 (commit version)))
810 (file-name (git-file-name name version))
811 (sha256
812 (base32 "0yyc553xsb5n0rx7jp9p4wdbd7md07b3qrkf3ssyjavqqg908qg9"))))
813 (arguments
814 `(#:tests? #f ; no tests are available
815 #:configure-flags (list
816 (string-append "-DCMAKE_INSTALL_LIBDIR="
817 (assoc-ref %outputs "out") "/lib")
818 "-DVGL_USESSL=1"))) ; use OpenSSL
819 (build-system cmake-build-system)
820 (inputs `(("glu" ,glu)
821 ("libjpeg-turbo" ,libjpeg-turbo)
822 ("libxtst" ,libxtst)
823 ("mesa" ,mesa)
824 ("openssl" ,openssl)))
825 (native-inputs `(("pkg-config" ,pkg-config)))
826 (home-page "https://www.virtualgl.org")
827 (synopsis "Redirects 3D commands from an OpenGL application onto a 3D
828 graphics card")
829 (description "VirtualGL redirects the 3D rendering commands from OpenGL
830 applications to 3D accelerator hardware in a dedicated server and displays the
831 rendered output interactively to a thin client located elsewhere on the
832 network.")
833 (license license:wxwindows3.1+)))
834
835 (define-public mojoshader
836 (let ((changeset "5887634ea695"))
837 (package
838 (name "mojoshader")
839 (version (string-append "20190825" "-" changeset))
840 (source
841 (origin
842 (method hg-fetch)
843 (uri (hg-reference
844 (url "https://hg.icculus.org/icculus/mojoshader/")
845 (changeset changeset)))
846 (file-name (git-file-name name version))
847 (sha256
848 (base32 "0ibl4z1696jiifv9j5drir7jm0b5px0vwkwckbi7cfd46p7p6wcy"))))
849 (arguments
850 ;; Tests only for COMPILER_SUPPORT=ON.
851 `(#:tests? #f
852 #:configure-flags '("-DBUILD_SHARED=ON"
853 "-DFLIP_VIEWPORT=ON"
854 "-DDEPTH_CLIPPING=ON")
855 #:phases
856 (modify-phases %standard-phases
857 (replace 'install
858 (lambda* (#:key outputs #:allow-other-keys)
859 (let* ((out (assoc-ref outputs "out"))
860 (lib (string-append out "/lib"))
861 (header (string-append out "/include")))
862 (install-file "libmojoshader.so" lib)
863 (for-each (lambda (f)
864 (install-file f header))
865 (find-files "../source" "mojoshader.*\\.h$"))
866 (let ((profiles-header (string-append header "/profiles")))
867 (mkdir-p profiles-header)
868 (rename-file (string-append header "/mojoshader_profile.h")
869 (string-append profiles-header "/mojoshader_profile.h"))))
870 #t)))))
871 (build-system cmake-build-system)
872 (home-page "https://www.icculus.org/mojoshader/")
873 (synopsis "Work with Direct3D shaders on alternate 3D APIs")
874 (description "MojoShader is a library to work with Direct3D shaders on
875 alternate 3D APIs and non-Windows platforms. The primary motivation is moving
876 shaders to OpenGL languages on the fly. The developer deals with \"profiles\"
877 that represent various target languages, such as GLSL or ARB_*_program.
878
879 This allows a developer to manage one set of shaders, presumably written in
880 Direct3D HLSL, and use them across multiple rendering backends. This also
881 means that the developer only has to worry about one (offline) compiler to
882 manage program complexity, while MojoShader itself deals with the reduced
883 complexity of the bytecode at runtime.
884
885 MojoShader provides both a simple API to convert bytecode to various profiles,
886 and (optionally) basic glue to rendering APIs to abstract the management of
887 the shaders at runtime.")
888 (license license:zlib))))
889
890 (define-public mojoshader-with-viewport-flip
891 ;; Changeset c586d4590241 replaced glProgramViewportFlip with
892 ;; glProgramViewportInfo.
893 ;; https://hg.icculus.org/icculus/mojoshader/rev/c586d4590241
894 (let ((changeset "2e37299b13d8"))
895 (package
896 (inherit mojoshader)
897 (name "mojoshader-with-viewport-flip")
898 (version (string-append "20190725" "-" changeset))
899 (source
900 (origin
901 (method hg-fetch)
902 (uri (hg-reference
903 (url "https://hg.icculus.org/icculus/mojoshader/")
904 (changeset changeset)))
905 (file-name (git-file-name name version))
906 (sha256
907 (base32 "0ffws7cqbskxwc3hjsnnzq4r2bbf008kdr3b11pa3kr7dsi50y6i"))))
908 (synopsis "Work with Direct3D shaders on alternate 3D APIs (with viewport flip)")
909 (description "This is the last version of the mojoshader library with
910 the glProgramViewportFlip before it was replaced with glProgramViewportInfo.")
911 (license license:zlib))))
912
913 (define-public mojoshader-cs
914 (let ((commit "10d0dba21ff1cfe332eb7de328a2adce01286bd7"))
915 (package
916 (name "mojoshader-cs")
917 (version (git-version "20191205" "1" commit))
918 (source (origin
919 (method git-fetch)
920 (uri (git-reference
921 (url "https://github.com/FNA-XNA/MojoShader")
922 (commit commit)))
923 (file-name (git-file-name name version))
924 (sha256
925 (base32
926 "11mdhf3fmb9rsn2iv753gmb596j4dh5j2iipgw078vg0lj23rml7"))))
927 (build-system gnu-build-system)
928 (arguments
929 '(#:tests? #f ; No tests.
930 #:phases
931 (modify-phases %standard-phases
932 (delete 'configure)
933 (replace 'build
934 (lambda _
935 (invoke "make" "-C" "csharp")))
936 (replace 'install
937 (lambda* (#:key outputs #:allow-other-keys)
938 (let ((out (assoc-ref outputs "out")))
939 (install-file "csharp/bin/MojoShader-CS.dll" (string-append out "/lib"))
940 #t))))))
941 (native-inputs
942 `(("mono" ,mono)))
943 (home-page "https://github.com/FNA-XNA/MojoShader")
944 (synopsis "C# wrapper for MojoShader")
945 (description
946 "Mojoshader-CS provides C# bindings for the Mojoshader library.
947 The C# wrapper was written to be used for FNA's platform support. However, this
948 is written in a way that can be used for any general C# application.")
949 (license license:zlib))))