gnu: exfat-utils: Update to 1.2.5.
[jackhill/guix/guix.git] / gnu / packages / mtools.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages mtools)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages python))
26
27 (define-public mtools
28 (package
29 (name "mtools")
30 (version "4.0.18")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/mtools/mtools-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1hxciksv7av5ilnkvwbidyxxr1gzn24lr0mz9z8drkml7780im1h"))))
39 (build-system gnu-build-system)
40 (home-page "https://www.gnu.org/software/mtools/")
41 (synopsis "Access MS-DOS disks without mounting")
42 (description
43 "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
44 or Unix system. It supports long file names and multiple disk formats. It
45 also supports some FAT-specific features such as volume labels and
46 FAT-specific file attributes.")
47 (license gpl3+)))
48
49 (define-public exfat-utils
50 (package
51 (name "exfat-utils")
52 (version "1.2.5")
53 (source (origin
54 (method url-fetch)
55 (uri (string-append
56 "https://github.com/relan/exfat/releases/download/v"
57 version "/" name "-" version ".tar.gz"))
58 (sha256
59 (base32
60 "1qhvjd6dmzhxjdnm4cklajbr03wsjjvkxrsjij517a33napcl93s"))))
61 (build-system gnu-build-system)
62 (home-page "https://github.com/relan/exfat")
63 (synopsis "Utilities to manipulate exFAT file systems")
64 (description
65 "This package provides an implementation of the exFAT file system,
66 including command-line tools to validate exFAT file systems and to create new
67 ones.")
68 (license gpl2+)))