gnu: gdb: Update to 7.8.
[jackhill/guix/guix.git] / gnu / packages / gdb.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gdb)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages ncurses)
22 #:use-module (gnu packages readline)
23 #:use-module (gnu packages dejagnu)
24 #:use-module (gnu packages texinfo)
25 #:use-module (gnu packages multiprecision)
26 #:use-module (gnu packages xml)
27 #:use-module (gnu packages guile)
28 #:use-module (gnu packages python)
29 #:use-module (gnu packages pkg-config)
30 #:use-module ((guix licenses) #:select (gpl3+))
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix build-system gnu))
34
35 (define-public gdb
36 (package
37 (name "gdb")
38 (version "7.8")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append "mirror://gnu/gdb/gdb-"
42 version ".tar.xz"))
43 (sha256
44 (base32
45 "0xdqxjj77q60k19hn85msnbv9nchnpzi0lp7z7hm97zpfkhspi29"))))
46 (build-system gnu-build-system)
47 (arguments
48 '(#:tests? #f ; FIXME "make check" fails on single-processor systems.
49 #:phases (alist-cons-after
50 'configure 'post-configure
51 (lambda _
52 (for-each patch-makefile-SHELL
53 (find-files "." "Makefile\\.in")))
54 %standard-phases)))
55 (inputs
56 `(("expat" ,expat)
57 ("mpfr" ,mpfr)
58 ("gmp" ,gmp)
59 ("readline" ,readline)
60 ("ncurses" ,ncurses)
61 ("guile" ,guile-2.0)
62 ("python" ,python)
63 ("python-wrapper" ,python-wrapper)
64 ("dejagnu" ,dejagnu)
65
66 ;; Allow use of XML-formatted syscall information. This enables 'catch
67 ;; syscall' and similar commands.
68 ("libxml2" ,libxml2)))
69 (native-inputs
70 `(("texinfo" ,texinfo)
71 ("pkg-config" ,pkg-config)))
72 (home-page "http://www.gnu.org/software/gdb/")
73 (synopsis "The GNU debugger")
74 (description
75 "GDB is the GNU debugger. With it, you can monitor what a program is
76 doing while it runs or what it was doing just before a crash. It allows you
77 to specify the runtime conditions, to define breakpoints, and to change how
78 the program is running to try to fix bugs. It can be used to debug programs
79 written in C, C++, Ada, Objective-C, Pascal and more.")
80 (license gpl3+)))