Make Guile-JSON a required dependency.
[jackhill/guix/guix.git] / gnu / packages / package-management.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
5 ;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
9 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
10 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
11 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages package-management)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages acl)
31 #:use-module (gnu packages attr)
32 #:use-module (gnu packages avahi)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages backup)
35 #:use-module (gnu packages bdw-gc)
36 #:use-module (gnu packages bison)
37 #:use-module (gnu packages bootstrap) ;for 'bootstrap-guile-origin'
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages cpio)
41 #:use-module (gnu packages crypto)
42 #:use-module (gnu packages curl)
43 #:use-module (gnu packages databases)
44 #:use-module (gnu packages docbook)
45 #:use-module (gnu packages emacs)
46 #:use-module (gnu packages file)
47 #:use-module (gnu packages gettext)
48 #:use-module (gnu packages glib)
49 #:use-module (gnu packages gnome)
50 #:use-module (gnu packages gnupg)
51 #:use-module (gnu packages gnuzilla)
52 #:use-module (gnu packages graphviz)
53 #:use-module (gnu packages guile)
54 #:use-module (gnu packages linux)
55 #:use-module (gnu packages lisp)
56 #:use-module (gnu packages man)
57 #:use-module (gnu packages nettle)
58 #:use-module (gnu packages patchutils)
59 #:use-module (gnu packages perl)
60 #:use-module (gnu packages perl-check)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages popt)
63 #:use-module (gnu packages python)
64 #:use-module (gnu packages python-web)
65 #:use-module (gnu packages serialization)
66 #:use-module (gnu packages ssh)
67 #:use-module (gnu packages texinfo)
68 #:use-module (gnu packages time)
69 #:use-module (gnu packages tls)
70 #:use-module (gnu packages vim)
71 #:use-module (gnu packages web)
72 #:use-module (gnu packages xml)
73 #:use-module (guix build-system emacs)
74 #:use-module (guix build-system gnu)
75 #:use-module (guix build-system meson)
76 #:use-module (guix build-system python)
77 #:use-module (guix download)
78 #:use-module (guix gexp)
79 #:use-module (guix git-download)
80 #:use-module ((guix licenses) #:prefix license:)
81 #:use-module (guix packages)
82 #:use-module (guix utils)
83 #:use-module (ice-9 match)
84 #:use-module (srfi srfi-1))
85
86 (define (boot-guile-uri arch)
87 "Return the URI for the bootstrap Guile tarball for ARCH."
88 (cond ((string=? "armhf" arch)
89 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
90 arch "-linux"
91 "/20150101/guile-2.0.11.tar.xz"))
92 ((string=? "aarch64" arch)
93 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
94 arch "-linux/20170217/guile-2.0.14.tar.xz"))
95 (else
96 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
97 arch "-linux"
98 "/20131110/guile-2.0.9.tar.xz"))))
99
100 (define-public guix
101 ;; Latest version of Guix, which may or may not correspond to a release.
102 ;; Note: the 'update-guix-package.scm' script expects this definition to
103 ;; start precisely like this.
104 (let ((version "0.15.0")
105 (commit "71a78ba65b00ad1f27086a3dcdded7dc4326ade1")
106 (revision 8))
107 (package
108 (name "guix")
109
110 (version (if (zero? revision)
111 version
112 (string-append version "-"
113 (number->string revision)
114 "." (string-take commit 7))))
115 (source (origin
116 (method git-fetch)
117 (uri (git-reference
118 (url "https://git.savannah.gnu.org/r/guix.git")
119 (commit commit)))
120 (sha256
121 (base32
122 "0isagzccfxjqrc38wamknvh0jzv1pjh0wq5baj9jzwl07xkrc0hc"))
123 (file-name (string-append "guix-" version "-checkout"))))
124 (build-system gnu-build-system)
125 (arguments
126 `(#:configure-flags (list
127 "--localstatedir=/var"
128 "--sysconfdir=/etc"
129 (string-append "--with-bash-completion-dir="
130 (assoc-ref %outputs "out")
131 "/etc/bash_completion.d")
132 (string-append "--with-libgcrypt-prefix="
133 (assoc-ref %build-inputs
134 "libgcrypt"))
135
136 ;; Set 'DOT_USER_PROGRAM' to the empty string so
137 ;; we don't keep a reference to Graphviz, whose
138 ;; closure is pretty big (too big for the GuixSD
139 ;; installation image.)
140 "ac_cv_path_DOT_USER_PROGRAM=dot"
141
142 ;; To avoid problems with the length of shebangs,
143 ;; choose a fixed-width and short directory name
144 ;; for tests.
145 "ac_cv_guix_test_root=/tmp/guix-tests")
146 #:parallel-tests? #f ;work around <http://bugs.gnu.org/21097>
147
148 #:modules ((guix build gnu-build-system)
149 (guix build utils)
150 (srfi srfi-26)
151 (ice-9 popen)
152 (ice-9 rdelim))
153
154 #:phases (modify-phases %standard-phases
155 (replace 'bootstrap
156 (lambda _
157 ;; Make sure 'msgmerge' can modify the PO files.
158 (for-each (lambda (po)
159 (chmod po #o666))
160 (find-files "." "\\.po$"))
161
162 (patch-shebang "build-aux/git-version-gen")
163
164 (call-with-output-file ".tarball-version"
165 (lambda (port)
166 (display ,version port)))
167
168 (invoke "sh" "bootstrap")))
169 (add-before 'check 'copy-bootstrap-guile
170 (lambda* (#:key system inputs #:allow-other-keys)
171 ;; Copy the bootstrap guile tarball in the store used
172 ;; by the test suite.
173 (define (intern tarball)
174 (let ((base (strip-store-file-name tarball)))
175 (copy-file tarball base)
176 (invoke "./test-env" "guix" "download"
177 (string-append "file://" (getcwd)
178 "/" base))
179 (delete-file base)))
180
181
182 (intern (assoc-ref inputs "boot-guile"))
183
184 ;; On x86_64 some tests need the i686 Guile.
185 ,@(if (and (not (%current-target-system))
186 (string=? (%current-system)
187 "x86_64-linux"))
188 '((intern (assoc-ref inputs "boot-guile/i686")))
189 '())
190 #t))
191 (add-after 'unpack 'disable-failing-tests
192 ;; XXX FIXME: These tests fail within the build container.
193 (lambda _
194 (substitute* "tests/syscalls.scm"
195 (("^\\(test-(assert|equal) \"(clone|setns|pivot-root)\"" all)
196 (string-append "(test-skip 1)\n" all)))
197 (substitute* "tests/containers.scm"
198 (("^\\(test-(assert|equal)" all)
199 (string-append "(test-skip 1)\n" all)))
200 (when (file-exists? "tests/guix-environment-container.sh")
201 (substitute* "tests/guix-environment-container.sh"
202 (("guix environment --version")
203 "exit 77\n")))
204 #t))
205 (add-before 'check 'set-SHELL
206 (lambda _
207 ;; 'guix environment' tests rely on 'SHELL' having a
208 ;; correct value, so set it.
209 (setenv "SHELL" (which "sh"))
210 #t))
211 (add-after 'install 'wrap-program
212 (lambda* (#:key inputs outputs #:allow-other-keys)
213 ;; Make sure the 'guix' command finds GnuTLS,
214 ;; Guile-JSON, and Guile-Git automatically.
215 (let* ((out (assoc-ref outputs "out"))
216 (guile (assoc-ref inputs "guile"))
217 (gcrypt (assoc-ref inputs "guile-gcrypt"))
218 (json (assoc-ref inputs "guile-json"))
219 (sqlite (assoc-ref inputs "guile-sqlite3"))
220 (git (assoc-ref inputs "guile-git"))
221 (bs (assoc-ref inputs
222 "guile-bytestructures"))
223 (ssh (assoc-ref inputs "guile-ssh"))
224 (gnutls (assoc-ref inputs "gnutls"))
225 (deps (list gcrypt json sqlite gnutls
226 git bs ssh))
227 (effective
228 (read-line
229 (open-pipe* OPEN_READ
230 (string-append guile "/bin/guile")
231 "-c" "(display (effective-version))")))
232 (path (string-join
233 (map (cut string-append <>
234 "/share/guile/site/"
235 effective)
236 (delete #f deps))
237 ":"))
238 (gopath (string-join
239 (map (cut string-append <>
240 "/lib/guile/" effective
241 "/site-ccache")
242 (delete #f deps))
243 ":")))
244
245 (wrap-program (string-append out "/bin/guix")
246 `("GUILE_LOAD_PATH" ":" prefix (,path))
247 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,gopath)))
248
249 #t))))))
250 (native-inputs `(("pkg-config" ,pkg-config)
251
252 ;; XXX: Keep the development inputs here even though
253 ;; they're unnecessary, just so that 'guix environment
254 ;; guix' always contains them.
255 ("autoconf" ,autoconf-wrapper)
256 ("automake" ,automake)
257 ("gettext" ,gettext-minimal)
258 ("texinfo" ,texinfo)
259 ("graphviz" ,graphviz)
260 ("help2man" ,help2man)
261 ("po4a" ,po4a)))
262 (inputs
263 `(("bzip2" ,bzip2)
264 ("gzip" ,gzip)
265 ("zlib" ,zlib) ;for 'guix publish'
266
267 ("sqlite" ,sqlite)
268 ("libgcrypt" ,libgcrypt)
269
270 ;; Use 2.2.4 to avoid various thread-safety issues while building
271 ;; code in parallel.
272 ("guile" ,guile-2.2.4)
273
274 ;; Many tests rely on the 'guile-bootstrap' package, which is why we
275 ;; have it here.
276 ("boot-guile" ,(bootstrap-guile-origin (%current-system)))
277 ;; Some of the tests use "unshare" when it is available.
278 ("util-linux" ,util-linux)
279 ,@(if (and (not (%current-target-system))
280 (string=? (%current-system) "x86_64-linux"))
281 `(("boot-guile/i686" ,(bootstrap-guile-origin "i686-linux")))
282 '())))
283 (propagated-inputs
284 `(("gnutls" ,gnutls)
285 ("guile-gcrypt" ,guile-gcrypt)
286 ("guile-json" ,guile-json)
287 ("guile-sqlite3" ,guile-sqlite3)
288 ("guile-ssh" ,guile-ssh)
289 ("guile-git" ,guile-git)))
290
291 (home-page "https://www.gnu.org/software/guix/")
292 (synopsis "Functional package manager for installed software packages and versions")
293 (description
294 "GNU Guix is a functional package manager for the GNU system, and is
295 also a distribution thereof. It includes a virtual machine image. Besides
296 the usual package management features, it also supports transactional
297 upgrades and roll-backs, per-user profiles, and much more. It is based on
298 the Nix package manager.")
299 (license license:gpl3+)
300 (properties '((ftp-server . "alpha.gnu.org"))))))
301
302 ;; Alias for backward compatibility.
303 (define-public guix-devel guix)
304
305 (define-public guix-daemon
306 ;; This package is for internal consumption: it allows us to quickly build
307 ;; the 'guix-daemon' program and use that in (guix self), used by 'guix
308 ;; pull'.
309 (package
310 (inherit guix)
311 (properties `((hidden? . #t)))
312 (name "guix-daemon")
313
314 ;; Use a minimum set of dependencies.
315 (native-inputs
316 (fold alist-delete (package-native-inputs guix)
317 '("po4a" "graphviz" "help2man")))
318 (inputs
319 `(("gnutls" ,gnutls)
320 ("guile-git" ,guile-git)
321 ("guile-gcrypt" ,guile-gcrypt)
322 ,@(fold alist-delete (package-inputs guix)
323 '("boot-guile" "boot-guile/i686" "util-linux"))))
324
325 (propagated-inputs '())
326
327 (arguments
328 (substitute-keyword-arguments (package-arguments guix)
329 ((#:configure-flags flags '())
330 ;; Pretend we have those libraries; we don't actually need them.
331 `(append ,flags
332 '("guix_cv_have_recent_guile_sqlite3=yes"
333 "guix_cv_have_recent_guile_ssh=yes")))
334 ((#:tests? #f #f)
335 #f)
336 ((#:phases phases '%standard-phases)
337 `(modify-phases ,phases
338 (replace 'build
339 (lambda _
340 (invoke "make" "nix/libstore/schema.sql.hh")
341 (invoke "make" "-j" (number->string
342 (parallel-job-count))
343 "guix-daemon")))
344 (delete 'copy-bootstrap-guile)
345 (replace 'install
346 (lambda* (#:key outputs #:allow-other-keys)
347 (invoke "make" "install-binPROGRAMS"
348 "install-nodist_pkglibexecSCRIPTS")
349
350 ;; We need to tell 'guix-daemon' which 'guix' command to use.
351 ;; Here we use a questionable hack where we hard-code root's
352 ;; current guix, which could be wrong (XXX). Note that scripts
353 ;; like 'guix perform-download' do not run as root so we assume
354 ;; that they have access to /var/guix/profiles/per-user/root.
355 (let ((out (assoc-ref outputs "out")))
356 (substitute* (find-files (string-append out "/libexec"))
357 (("exec \".*/bin/guix\"")
358 "exec /var/guix/profiles/per-user/root/current-guix/bin/guix"))
359 #t)))
360 (delete 'wrap-program)))))))
361
362 (define-public guile2.0-guix
363 (package
364 (inherit guix)
365 (name "guile2.0-guix")
366 (inputs
367 `(("guile" ,guile-2.0)
368 ,@(alist-delete "guile" (package-inputs guix))))
369 (propagated-inputs
370 `(("gnutls" ,gnutls/guile-2.0)
371 ("guile-gcrypt" ,guile2.0-gcrypt)
372 ("guile-json" ,guile2.0-json)
373 ("guile-sqlite3" ,guile2.0-sqlite3)
374 ("guile-ssh" ,guile2.0-ssh)
375 ("guile-git" ,guile2.0-git)))))
376
377 (define-public guix-minimal
378 ;; A version of Guix which is built with the minimal set of dependencies, as
379 ;; outlined in the README "Requirements" section. Intended as a CI job, so
380 ;; marked as hidden.
381 (let ((guix guile2.0-guix))
382 (hidden-package
383 (package
384 (inherit guix)
385 (name "guix-minimal")
386 (inputs
387 `(("guile" ,guile-2.0.13)
388 ,@(alist-delete "guile" (package-inputs guix))))
389 (propagated-inputs
390 (fold alist-delete
391 (package-propagated-inputs guix)
392 '("guile-ssh")))))))
393
394 (define (source-file? file stat)
395 "Return true if FILE is likely a source file, false if it is a typical
396 generated file."
397 (define (wrong-extension? file)
398 (or (string-suffix? "~" file)
399 (member (file-extension file)
400 '("o" "a" "lo" "so" "go"))))
401
402 (match (basename file)
403 ((or ".git" "autom4te.cache" "configure" "Makefile" "Makefile.in" ".libs")
404 #f)
405 ((? wrong-extension?)
406 #f)
407 (_
408 #t)))
409
410 (define-public current-guix
411 (let* ((repository-root (canonicalize-path
412 (string-append (current-source-directory)
413 "/../..")))
414 (select? (delay (or (git-predicate repository-root)
415 source-file?))))
416 (lambda ()
417 "Return a package representing Guix built from the current source tree.
418 This works by adding the current source tree to the store (after filtering it
419 out) and returning a package that uses that as its 'source'."
420 (package
421 (inherit guix)
422 (version (string-append (package-version guix) "+"))
423 (source (local-file repository-root "guix-current"
424 #:recursive? #t
425 #:select? (force select?)))))))
426
427 \f
428 ;;;
429 ;;; Other tools.
430 ;;;
431
432 (define-public nix
433 (package
434 (name "nix")
435 (version "2.0.4")
436 (source (origin
437 (method url-fetch)
438 (uri (string-append "http://nixos.org/releases/nix/nix-"
439 version "/nix-" version ".tar.xz"))
440 (sha256
441 (base32
442 "0ss9svxlh1pvrdmnqjvjyqjmbqmrdbyfarvbb14i9d4bggzl0r8n"))))
443 (build-system gnu-build-system)
444 (native-inputs `(("pkg-config" ,pkg-config)))
445 (inputs `(("curl" ,curl)
446 ("bzip2" ,bzip2)
447 ("libgc" ,libgc)
448 ("libseccomp" ,libseccomp)
449 ("libsodium" ,libsodium)
450 ("openssl" ,openssl)
451 ("sqlite" ,sqlite)
452 ("xz" ,xz)))
453 (home-page "https://nixos.org/nix/")
454 (synopsis "The Nix package manager")
455 (description
456 "Nix is a purely functional package manager. This means that it treats
457 packages like values in purely functional programming languages such as
458 Haskell—they are built by functions that don't have side-effects, and they
459 never change after they have been built. Nix stores packages in the Nix
460 store, usually the directory /nix/store, where each package has its own unique
461 sub-directory.")
462 (license license:lgpl2.1+)))
463
464 (define-public emacs-nix-mode
465 (package
466 (name "emacs-nix-mode")
467 (version "1.2.2")
468 (source
469 (origin
470 (method url-fetch)
471 (uri (string-append "https://github.com/NixOS/nix-mode/archive/v"
472 version ".tar.gz"))
473 (file-name (string-append name "-" version ".tar.gz"))
474 (sha256
475 (base32
476 "06aqz0czznsj8835jqnk794sy2p6pa8kxfqwh0nl5d5vxivria6z"))))
477 (build-system emacs-build-system)
478 (inputs
479 `(("emacs-company" ,emacs-company)
480 ("emacs-mmm-mode" ,emacs-mmm-mode)))
481 (home-page "https://github.com/NixOS/nix-mode")
482 (synopsis "Emacs major mode for editing Nix expressions")
483 (description "@code{nixos-mode} provides an Emacs major mode for editing
484 Nix expressions. It supports syntax highlighting, indenting and refilling of
485 comments.")
486 (license license:lgpl2.1+)))
487
488 (define-public stow
489 (package
490 (name "stow")
491 (version "2.2.2")
492 (source (origin
493 (method url-fetch)
494 (uri (string-append "mirror://gnu/stow/stow-"
495 version ".tar.gz"))
496 (sha256
497 (base32
498 "1pvky9fayms4r6fhns8jd0vavszd7d979w62vfd5n88v614pdxz2"))))
499 (build-system gnu-build-system)
500 (inputs
501 `(("perl" ,perl)))
502 (native-inputs
503 `(("perl-test-simple" ,perl-test-simple)
504 ("perl-test-output" ,perl-test-output)
505 ("perl-capture-tiny" ,perl-capture-tiny)
506 ("perl-io-stringy" ,perl-io-stringy)))
507 (home-page "https://www.gnu.org/software/stow/")
508 (synopsis "Managing installed software packages")
509 (description
510 "GNU Stow is a symlink manager. It generates symlinks to directories
511 of data and makes them appear to be merged into the same directory. It is
512 typically used for managing software packages installed from source, by
513 letting you install them apart in distinct directories and then create
514 symlinks to the files in a common directory such as /usr/local.")
515 (license license:gpl2+)))
516
517 (define-public rpm
518 (package
519 (name "rpm")
520 (version "4.14.2")
521 (source (origin
522 (method url-fetch)
523 (uri (string-append "http://ftp.rpm.org/releases/rpm-"
524 (version-major+minor version) ".x/rpm-"
525 version ".tar.bz2"))
526 (sha256
527 (base32
528 "0armd7dqr8bl0isx8l4xlylm7dikasmxhhcbz336fkp2x30w5jw0"))))
529 (build-system gnu-build-system)
530 (arguments
531 '(#:configure-flags '("--with-external-db" ;use the system's bdb
532 "--enable-python"
533 "--without-lua")
534 #:phases (modify-phases %standard-phases
535 (add-before 'configure 'set-nss-library-path
536 (lambda* (#:key inputs #:allow-other-keys)
537 (let ((nss (assoc-ref inputs "nss")))
538 (setenv "LIBRARY_PATH"
539 (string-append (getenv "LIBRARY_PATH") ":"
540 nss "/lib/nss"))
541 #t))))))
542 (native-inputs
543 `(("pkg-config" ,pkg-config)))
544 (inputs
545 `(("python" ,python-2)
546 ("xz" ,xz)
547 ("bdb" ,bdb)
548 ("popt" ,popt)
549 ("nss" ,nss)
550 ("nspr" ,nspr)
551 ("libarchive" ,libarchive)
552 ("nettle" ,nettle) ;XXX: actually a dependency of libarchive
553 ("file" ,file)
554 ("bzip2" ,bzip2)
555 ("zlib" ,zlib)
556 ("cpio" ,cpio)))
557 (home-page "http://rpm.org/")
558 (synopsis "The RPM Package Manager")
559 (description
560 "The RPM Package Manager (RPM) is a command-line driven package
561 management system capable of installing, uninstalling, verifying, querying,
562 and updating computer software packages. Each software package consists of an
563 archive of files along with information about the package like its version, a
564 description. There is also a library permitting developers to manage such
565 transactions from C or Python.")
566
567 ;; The whole is GPLv2+; librpm itself is dual-licensed LGPLv2+ | GPLv2+.
568 (license license:gpl2+)))
569
570 (define-public diffoscope
571 (package
572 (name "diffoscope")
573 (version "105")
574 (source (origin
575 (method url-fetch)
576 (uri (pypi-uri name version))
577 (sha256
578 (base32
579 "0bqkwvrvlvybqfi73qv1k5xic2qzw5lv20imqadf1wc4l8vc0vq3"))))
580 (build-system python-build-system)
581 (arguments
582 `(#:phases (modify-phases %standard-phases
583 ;; setup.py mistakenly requires python-magic from PyPi, even
584 ;; though the Python bindings of `file` are sufficient.
585 ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
586 (add-after 'unpack 'dependency-on-python-magic
587 (lambda _
588 (substitute* "setup.py"
589 (("'python-magic',") ""))))
590 (add-after 'unpack 'embed-tool-references
591 (lambda* (#:key inputs #:allow-other-keys)
592 (substitute* "diffoscope/comparators/utils/compare.py"
593 (("\\['xxd',")
594 (string-append "['" (which "xxd") "',")))
595 (substitute* "diffoscope/comparators/elf.py"
596 (("@tool_required\\('readelf'\\)") "")
597 (("get_tool_name\\('readelf'\\)")
598 (string-append "'" (which "readelf") "'")))
599 (substitute* "diffoscope/comparators/directory.py"
600 (("@tool_required\\('stat'\\)") "")
601 (("@tool_required\\('getfacl'\\)") "")
602 (("\\['stat',")
603 (string-append "['" (which "stat") "',"))
604 (("\\['getfacl',")
605 (string-append "['" (which "getfacl") "',")))
606 #t))
607 (add-before 'check 'delete-failing-test
608 (lambda _
609 (delete-file "tests/test_tools.py") ;this requires /sbin to be on the path
610 #t)))))
611 (inputs `(("rpm" ,rpm) ;for rpm-python
612 ("python-file" ,python-file)
613 ("python-debian" ,python-debian)
614 ("python-libarchive-c" ,python-libarchive-c)
615 ("python-tlsh" ,python-tlsh)
616 ("acl" ,acl) ;for getfacl
617 ("colordiff" ,colordiff)
618 ("xxd" ,xxd)
619
620 ;; Below are modules used for tests.
621 ("python-pytest" ,python-pytest)
622 ("python-chardet" ,python-chardet)))
623 (home-page "https://diffoscope.org/")
624 (synopsis "Compare files, archives, and directories in depth")
625 (description
626 "Diffoscope tries to get to the bottom of what makes files or directories
627 different. It recursively unpacks archives of many kinds and transforms
628 various binary formats into more human readable forms to compare them. It can
629 compare two tarballs, ISO images, or PDFs just as easily.")
630 (license license:gpl3+)))
631
632 (define-public python-anaconda-client
633 (package
634 (name "python-anaconda-client")
635 (version "1.6.3")
636 (source
637 (origin
638 (method url-fetch)
639 (uri (string-append "https://github.com/Anaconda-Platform/"
640 "anaconda-client/archive/" version ".tar.gz"))
641 (file-name (string-append name "-" version ".tar.gz"))
642 (sha256
643 (base32
644 "1wv4wi6k5jz7rlwfgvgfdizv77x3cr1wa2aj0k1595g7fbhkjhz2"))))
645 (build-system python-build-system)
646 (propagated-inputs
647 `(("python-pyyaml" ,python-pyyaml)
648 ("python-requests" ,python-requests)
649 ("python-clyent" ,python-clyent)))
650 (native-inputs
651 `(("python-pytz" ,python-pytz)
652 ("python-dateutil" ,python-dateutil)
653 ("python-mock" ,python-mock)
654 ("python-coverage" ,python-coverage)
655 ("python-pillow" ,python-pillow)))
656 (arguments
657 `(#:phases
658 (modify-phases %standard-phases
659 ;; This is needed for some tests.
660 (add-before 'check 'set-up-home
661 (lambda* _ (setenv "HOME" "/tmp") #t))
662 (add-before 'check 'remove-network-tests
663 (lambda* _
664 ;; Remove tests requiring a network connection
665 (let ((network-tests '("tests/test_upload.py"
666 "tests/test_authorizations.py"
667 "tests/test_login.py"
668 "tests/test_whoami.py"
669 "utils/notebook/tests/test_data_uri.py"
670 "utils/notebook/tests/test_base.py"
671 "utils/notebook/tests/test_downloader.py"
672 "inspect_package/tests/test_conda.py")))
673 (with-directory-excursion "binstar_client"
674 (for-each delete-file network-tests)))
675 #t)))))
676 (home-page "https://github.com/Anaconda-Platform/anaconda-client")
677 (synopsis "Anaconda Cloud command line client library")
678 (description
679 "Anaconda Cloud command line client library provides an interface to
680 Anaconda Cloud. Anaconda Cloud is useful for sharing packages, notebooks and
681 environments.")
682 (license license:bsd-3)))
683
684 (define-public python2-anaconda-client
685 (package-with-python2 python-anaconda-client))
686
687 (define-public python-conda
688 (package
689 (name "python-conda")
690 (version "4.3.16")
691 (source
692 (origin
693 (method url-fetch)
694 (uri (string-append "https://github.com/conda/conda/archive/"
695 version ".tar.gz"))
696 (file-name (string-append name "-" version ".tar.gz"))
697 (sha256
698 (base32
699 "1jq8hyrc5npb5sf4vw6s6by4602yj8f79vzpbwdfgpkn02nfk1dv"))))
700 (build-system python-build-system)
701 (arguments
702 `(#:phases
703 (modify-phases %standard-phases
704 (add-before 'build 'create-version-file
705 (lambda _
706 (with-output-to-file "conda/.version"
707 (lambda () (display ,version)))
708 #t))
709 (add-before 'check 'remove-failing-tests
710 (lambda _
711 ;; These tests require internet/network access
712 (let ((network-tests '("test_cli.py"
713 "test_create.py"
714 "test_export.py"
715 "test_fetch.py"
716 "test_history.py"
717 "test_info.py"
718 "test_install.py"
719 "test_priority.py"
720 "conda_env/test_cli.py"
721 "conda_env/test_create.py"
722 "conda_env/specs/test_notebook.py"
723 "conda_env/utils/test_notebooks.py"
724 "core/test_index.py"
725 "core/test_repodata.py")))
726 (with-directory-excursion "tests"
727 (for-each delete-file network-tests)
728
729 ;; FIXME: This test creates a file, then deletes it and tests
730 ;; that the file was deleted. For some reason it fails when
731 ;; building with guix, but does not when you run it in the
732 ;; directory left when you build with the --keep-failed
733 ;; option
734 (delete-file "gateways/disk/test_delete.py")
735 #t))))
736 (replace 'check
737 (lambda _
738 (setenv "HOME" "/tmp")
739 (zero? (system* "py.test")))))))
740 (native-inputs
741 `(("python-ruamel.yaml" ,python-ruamel.yaml)
742 ("python-requests" ,python-requests)
743 ("python-pycosat" ,python-pycosat)
744 ("python-pytest" ,python-pytest)
745 ("python-responses" ,python-responses)
746 ("python-pyyaml" ,python-pyyaml)
747 ("python-anaconda-client" ,python-anaconda-client)))
748 (home-page "https://github.com/conda/conda")
749 (synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
750 (description
751 "Conda is a cross-platform, Python-agnostic binary package manager. It
752 is the package manager used by Anaconda installations, but it may be used for
753 other systems as well. Conda makes environments first-class citizens, making
754 it easy to create independent environments even for C libraries. Conda is
755 written entirely in Python.
756
757 This package provides Conda as a library.")
758 (license license:bsd-3)))
759
760 (define-public python2-conda
761 (let ((base (package-with-python2
762 (strip-python2-variant python-conda))))
763 (package (inherit base)
764 (native-inputs
765 `(("python2-enum34" ,python2-enum34)
766 ,@(package-native-inputs base))))))
767
768 (define-public conda
769 (package (inherit python-conda)
770 (name "conda")
771 (arguments
772 (substitute-keyword-arguments (package-arguments python-conda)
773 ((#:phases phases)
774 `(modify-phases ,phases
775 (replace 'build
776 (lambda* (#:key outputs #:allow-other-keys)
777 ;; This test fails when run before installation.
778 (delete-file "tests/test_activate.py")
779
780 ;; Fix broken defaults
781 (substitute* "conda/base/context.py"
782 (("return sys.prefix")
783 (string-append "return \"" (assoc-ref outputs "out") "\""))
784 (("return (prefix_is_writable\\(self.root_prefix\\))" _ match)
785 (string-append "return False if self.root_prefix == self.conda_prefix else "
786 match)))
787
788 ;; The util/setup-testing.py is used to build conda in
789 ;; application form, rather than the default, library form.
790 ;; With this, we are able to run commands like `conda --help`
791 ;; directly on the command line
792 (zero? (system* "python" "utils/setup-testing.py" "build_py"))))
793 (replace 'install
794 (lambda* (#:key inputs outputs #:allow-other-keys)
795 (let* ((out (assoc-ref outputs "out"))
796 (target (string-append out "/lib/python"
797 ((@@ (guix build python-build-system)
798 get-python-version)
799 (assoc-ref inputs "python"))
800 "/site-packages/")))
801 ;; The installer aborts if the target directory is not on
802 ;; PYTHONPATH.
803 (setenv "PYTHONPATH"
804 (string-append target ":" (getenv "PYTHONPATH")))
805
806 ;; And it aborts if the directory doesn't exist.
807 (mkdir-p target)
808 (zero? (system* "python" "utils/setup-testing.py" "install"
809 (string-append "--prefix=" out))))))
810 ;; The "activate" and "deactivate" scripts don't need wrapping.
811 ;; They also break when they are renamed.
812 (add-after 'wrap 'undo-wrap
813 (lambda* (#:key outputs #:allow-other-keys)
814 (with-directory-excursion (string-append (assoc-ref outputs "out") "/bin/")
815 (delete-file "deactivate")
816 (rename-file ".deactivate-real" "deactivate")
817 (delete-file "activate")
818 (rename-file ".activate-real" "activate")
819 #t)))))))
820 (description
821 "Conda is a cross-platform, Python-agnostic binary package manager. It
822 is the package manager used by Anaconda installations, but it may be used for
823 other systems as well. Conda makes environments first-class citizens, making
824 it easy to create independent environments even for C libraries. Conda is
825 written entirely in Python.")))
826
827 (define-public gwl
828 (package
829 (name "gwl")
830 (version "0.1.1")
831 (source (origin
832 (method url-fetch)
833 (uri (string-append "https://www.guixwl.org/releases/gwl-"
834 version ".tar.gz"))
835 (sha256
836 (base32
837 "06pm967mq1wyggx7l0nfapw5s0k5qc5r9lawk2v3db868br779a7"))))
838 (build-system gnu-build-system)
839 (native-inputs
840 `(("autoconf" ,autoconf)
841 ("automake" ,automake)
842 ("pkg-config" ,pkg-config)))
843 (inputs
844 `(("guile" ,guile-2.2)))
845 (propagated-inputs
846 `(("guix" ,guix)
847 ("guile-commonmark" ,guile-commonmark)))
848 (home-page "https://www.guixwl.org")
849 (synopsis "Workflow management extension for GNU Guix")
850 (description "This project provides two subcommands to GNU Guix and
851 introduces two record types that provide a workflow management extension built
852 on top of GNU Guix.")
853 ;; The Scheme modules in guix/ and gnu/ are licensed GPL3+,
854 ;; the web interface modules in gwl/ are licensed AGPL3+,
855 ;; and the fonts included in this package are licensed OFL1.1.
856 (license (list license:gpl3+ license:agpl3+ license:silofl1.1))))
857
858 (define-public gcab
859 (package
860 (name "gcab")
861 (version "1.1")
862 (source (origin
863 (method url-fetch)
864 (uri (string-append "mirror://gnome/sources/" name "/"
865 version "/" name "-" version ".tar.xz"))
866 (sha256
867 (base32
868 "0l19sr6pg0cfcddmi5n79d08mjjbhn427ip5jlsy9zddq9r24aqr"))
869 ;; gcab 1.1 has a hard dependency on git — even when building
870 ;; from a tarball. Remove it early so ‘guix environment gcab’
871 ;; can actually build what ‘guix build --source gcab’ returns.
872 (modules '((guix build utils)))
873 (snippet
874 '(begin
875 (substitute* "meson.build"
876 (("git_version = .*$") "git_version = []\n"))
877 #t))))
878 (build-system meson-build-system)
879 (native-inputs
880 `(("glib:bin" ,glib "bin") ; for glib-mkenums
881 ("intltool" ,intltool)
882 ("pkg-config" ,pkg-config)
883 ("vala" ,vala)))
884 (inputs
885 `(("glib" ,glib)
886 ("zlib" ,zlib)))
887 (arguments
888 `(#:configure-flags
889 ;; XXX This ‘documentation’ is for developers, and fails informatively:
890 ;; Error in gtkdoc helper script: 'gtkdoc-mkhtml' failed with status 5
891 (list "-Ddocs=false"
892 "-Dintrospection=false")))
893 (home-page "https://wiki.gnome.org/msitools") ; no dedicated home page
894 (synopsis "Microsoft Cabinet file manipulation library")
895 (description
896 "The libgcab library provides GObject functions to read, write, and modify
897 Microsoft cabinet (.@dfn{CAB}) files.")
898 (license (list license:gpl2+ ; tests/testsuite.at
899 license:lgpl2.1+)))) ; the rest
900
901 (define-public msitools
902 (package
903 (name "msitools")
904 (version "0.98")
905 (source (origin
906 (method url-fetch)
907 (uri (string-append "mirror://gnome/sources/" name "/"
908 version "/" name "-" version ".tar.xz"))
909 (sha256
910 (base32
911 "19wb3n3nwkpc6bjr0q3f1znaxsfaqgjbdxxnbx8ic8bb5b49hwac"))))
912 (build-system gnu-build-system)
913 (native-inputs
914 `(("pkg-config" ,pkg-config)))
915 (inputs
916 `(("gcab" ,gcab)
917 ("glib" ,glib)
918 ("libgsf" ,libgsf)
919 ("libxml2" ,libxml2)
920 ("uuid" ,util-linux)))
921 (home-page "https://wiki.gnome.org/msitools")
922 (synopsis "Windows Installer file manipulation tool")
923 (description
924 "msitools is a collection of command-line tools to inspect, extract, build,
925 and sign Windows@tie{}Installer (.@dfn{MSI}) files. It aims to be a solution
926 for packaging and deployment of cross-compiled Windows applications.")
927 (license license:lgpl2.1+)))
928
929 (define-public libostree
930 (package
931 (name "libostree")
932 (version "2018.7")
933 (source (origin
934 (method url-fetch)
935 (uri (string-append
936 "https://github.com/ostreedev/ostree/releases/download/v"
937 version "/libostree-" version ".tar.xz"))
938 (sha256
939 (base32
940 "1nc310lv36psxn5yslkxlgi9gjxwqpwqzkg2pldgpwrlv6gkagj8"))))
941 (build-system gnu-build-system)
942 (arguments
943 '(#:phases
944 (modify-phases %standard-phases
945 (add-before 'check 'pre-check
946 (lambda _
947 ;; Don't try to use the non-existing '/var/tmp' as test
948 ;; directory.
949 (setenv "TEST_TMPDIR" (getenv "TMPDIR"))
950 #t)))
951 ;; XXX: fails with:
952 ;; tap-driver.sh: internal error getting exit status
953 ;; tap-driver.sh: fatal: I/O or internal error
954 #:tests? #f))
955 (native-inputs
956 `(("attr" ,attr) ; for tests
957 ("bison" ,bison)
958 ("glib:bin" ,glib "bin") ; for 'glib-mkenums'
959 ("gobject-introspection" ,gobject-introspection)
960 ("pkg-config" ,pkg-config)
961 ("xsltproc" ,libxslt)))
962 (inputs
963 `(("avahi" ,avahi)
964 ("docbook-xml" ,docbook-xml-4.2)
965 ("docbook-xsl" ,docbook-xsl)
966 ("e2fsprogs" ,e2fsprogs)
967 ("fuse" ,fuse)
968 ("glib" ,glib)
969 ("gpgme" ,gpgme)
970 ("libarchive" ,libarchive)
971 ("libsoup" ,libsoup)
972 ("nettle" ,nettle) ; required by 'libarchive.la'
973 ("util-linux" ,util-linux)))
974 (home-page "https://ostree.readthedocs.io/en/latest/")
975 (synopsis "Operating system and container binary deployment and upgrades")
976 (description
977 "@code{libostree} is both a shared library and suite of command line
978 tools that combines a \"git-like\" model for committing and downloading
979 bootable filesystem trees, along with a layer for deploying them and managing
980 the bootloader configuration.")
981 (license license:lgpl2.0+)))