gnu: http-parser: Update to 2.9.4-1.ec8b5ee [fixes CVE-2020-8287].
[jackhill/guix/guix.git] / gnu / packages / patches / rust-ndarray-remove-blas-src-dep.patch
1 From ed09f3c91e915c3b436854a7936566edceb3e8de Mon Sep 17 00:00:00 2001
2 From: Efraim Flashner <efraim@flashner.co.il>
3 Date: Tue, 15 Dec 2020 10:09:45 +0200
4 Subject: [PATCH] remove blas-src dependency
5
6 ---
7 Cargo.toml | 6 +-----
8 1 file changed, 1 insertion(+), 5 deletions(-)
9
10 diff --git a/Cargo.toml b/Cargo.toml
11 index 1f3e1b6..36bc816 100644
12 --- a/Cargo.toml
13 +++ b/Cargo.toml
14 @@ -37,10 +37,6 @@ debug = true
15 name = "ndarray"
16 test = true
17 bench = false
18 -[dependencies.blas-src]
19 -version = "0.2.0"
20 -optional = true
21 -default-features = false
22
23 [dependencies.cblas-sys]
24 version = "0.1.4"
25 @@ -78,7 +74,7 @@ default-features = false
26 version = "0.1"
27
28 [features]
29 -blas = ["cblas-sys", "blas-src"]
30 +blas = ["cblas-sys"]
31 docs = ["rustc-serialize", "serde-1"]
32 serde-1 = ["serde"]
33 test = ["test-blas-openblas-sys"]
34 --
35 2.29.2
36