gnu: http-parser: Update to 2.9.4-1.ec8b5ee [fixes CVE-2020-8287].
[jackhill/guix/guix.git] / gnu / packages / patches / ripperx-missing-file.patch
1 This patch adds a header file that is present in the ripperx git and needed
2 for inclusion, but missing in the distribution tarball.
3
4 diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h
5 --- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h 1970-01-01 01:00:00.000000000 +0100
6 +++ ripperx-2.8.0/src/gtk_cpp_workaround.h 2015-07-24 21:09:16.548476337 +0200
7 @@ -0,0 +1,39 @@
8 +#ifndef gtk_cpp_workaround_h
9 +#define gtk_cpp_workaround_h
10 +#ifdef __cplusplus
11 +//proto is wrong, override here for C++
12 +namespace
13 +{
14 +
15 +inline void gtk_table_attach (GtkTable *table,
16 + GtkWidget *child,
17 + guint left_attach,
18 + guint right_attach,
19 + guint top_attach,
20 + guint bottom_attach,
21 + //GtkAttachOptions xoptions,
22 + //GtkAttachOptions yoptions,
23 + guint xoptions, guint yoptions,
24 + guint xpadding,
25 + guint ypadding
26 + )
27 +{
28 + gtk_table_attach(table,
29 + child,
30 + left_attach,
31 + right_attach,
32 + top_attach,
33 + bottom_attach,
34 + (GtkAttachOptions)xoptions,
35 + (GtkAttachOptions)yoptions,
36 + xpadding,
37 + ypadding
38 + );
39 +
40 + };
41 +
42 +
43 +}
44 +
45 +#endif
46 +#endif