gnu: http-parser: Update to 2.9.4-1.ec8b5ee [fixes CVE-2020-8287].
[jackhill/guix/guix.git] / gnu / packages / patches / gnash-fix-giflib-version.patch
1 Description: Change GIFLIB_MINOR to allow matching with v5.2+
2 Source: https://savannah.gnu.org/patch/index.php?9873
3 Author: marius851000
4
5 diff --git a/libbase/GnashImageGif.cpp b/libbase/GnashImageGif.cpp
6 index 2ae5ddb..b87b1e7 100644
7 --- a/libbase/GnashImageGif.cpp
8 +++ b/libbase/GnashImageGif.cpp
9 @@ -120,7 +120,7 @@ GifInput::GifInput(std::shared_ptr<IOChannel> in)
10 GifInput::~GifInput()
11 {
12 // Clean up allocated data.
13 -#if GIFLIB_MAJOR==5 && GIFLIB_MINOR==1
14 +#if GIFLIB_MAJOR==5 && GIFLIB_MINOR!=0
15 DGifCloseFile(_gif, 0);
16 #else
17 DGifCloseFile(_gif);