gnu: http-parser: Update to 2.9.4-1.ec8b5ee [fixes CVE-2020-8287].
[jackhill/guix/guix.git] / gnu / packages / patches / calibre-no-updates-dialog.patch
1 Taken from debian.
2
3 # Description: Disable update check by default.
4 Index: calibre/src/calibre/gui2/main.py
5 ===================================================================
6 --- calibre.orig/src/calibre/gui2/main.py 2014-02-02 10:41:28.470954623 +0100
7 +++ calibre/src/calibre/gui2/main.py 2014-02-02 10:41:56.546954247 +0100
8 @@ -37,8 +37,8 @@
9 help=_('Start minimized to system tray.'))
10 parser.add_option('-v', '--verbose', default=0, action='count',
11 help=_('Ignored, do not use. Present only for legacy reasons'))
12 - parser.add_option('--no-update-check', default=False, action='store_true',
13 - help=_('Do not check for updates'))
14 + parser.add_option('--update-check', dest='no_update_check', default=True, action='store_false',
15 + help=_('Check for updates'))
16 parser.add_option('--ignore-plugins', default=False, action='store_true',
17 help=_('Ignore custom plugins, useful if you installed a plugin'
18 ' that is preventing calibre from starting'))