Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / texinfo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages texinfo)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages ncurses))
29
30 (define-public texinfo
31 (package
32 (name "texinfo")
33 (version "5.2")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/texinfo/texinfo-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "1njfwh2z34r2c4r0iqa7v24wmjzvsfyz4vplzry8ln3479lfywal"))))
41 (build-system gnu-build-system)
42 (inputs `(("ncurses" ,ncurses)
43 ("xz" ,xz)
44 ("perl" ,perl)))
45 (home-page "http://www.gnu.org/software/texinfo/")
46 (synopsis "The GNU documentation format")
47 (description
48 "Texinfo is the official documentation format of the GNU project. It
49 uses a single source file using explicit commands to produce a final document
50 in any of several supported output formats, such as HTML or PDF. This
51 package includes both the tools necessary to produce Info documents from
52 their source and the command-line Info reader. The emphasis of the language
53 is on expressing the content semantically, avoiding physical markup commands.")
54 (license gpl3+)))
55
56 (define-public texinfo-4
57 (package (inherit texinfo)
58 (version "4.13a")
59 (source (origin
60 (method url-fetch)
61 (uri (string-append
62 "mirror://gnu/texinfo/texinfo-"
63 version
64 ".tar.lzma"))
65 (sha256
66 (base32
67 "1rf9ckpqwixj65bw469i634897xwlgkm5i9g2hv3avl6mv7b0a3d"))))
68 (inputs `(("ncurses" ,ncurses) ("xz" ,xz)))))
69
70 (define-public texi2html
71 (package
72 (name "texi2html")
73 (version "5.0")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "mirror://savannah/" name "/" name "-"
77 version ".tar.bz2"))
78 (sha256
79 (base32
80 "1yprv64vrlcbksqv25asplnjg07mbq38lfclp1m5lj8cw878pag8"))
81 (patches
82 (list (search-patch "texi2html-document-encoding.patch")
83 (search-patch "texi2html-i18n.patch")))
84 (snippet
85 ;; This file is modified by the patch above, but reset its
86 ;; timestamp so we don't trigger the rule to update PO files,
87 ;; which would require Gettext.
88 ;; See <http://bugs.gnu.org/18247>.
89 '(utime "texi2html.pl" 0 0 0 0))))
90 (build-system gnu-build-system)
91 (inputs `(("perl" ,perl)))
92 (home-page "http://www.nongnu.org/texi2html/")
93 (synopsis "Convert Texinfo to HTML")
94 (description
95 "Texi2HTML is a Perl script which converts Texinfo source files to HTML
96 output. It now supports many advanced features, such as internationalization
97 and extremely configurable output formats.
98
99 Development of Texi2HTML moved to the GNU Texinfo repository in 2010, since it
100 was meant to replace the makeinfo implementation in GNU Texinfo. The route
101 forward for authors is, in most cases, to alter manuals and build processes as
102 necessary to use the new features of the makeinfo/texi2any implementation of
103 GNU Texinfo. The Texi2HTML maintainers (one of whom is the principal author
104 of the GNU Texinfo implementation) do not intend to make further releases of
105 Texi2HTML.")
106 ;; Files in /lib under lgpl2.1+ and x11
107 (license gpl2+)))