Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / protobuf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages protobuf)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses)
24 #:select (bsd-3))
25 #:use-module (gnu packages compression))
26
27 (define-public protobuf
28 (package
29 (name "protobuf")
30 (version "2.5.0")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "http://protobuf.googlecode.com/files/protobuf-"
34 version ".tar.bz2"))
35 (sha256
36 (base32
37 "0xxn9gxhvsgzz2sgmihzf6pf75clr05mqj6218camwrwajpcbgqk"))))
38 (build-system gnu-build-system)
39 (inputs `(("zlib" ,zlib)))
40 (home-page "http://code.google.com/p/protobuf/")
41 (synopsis "Data encoding for remote procedure calls (RPCs)")
42 (description
43 "Protocol Buffers are a way of encoding structured data in an efficient
44 yet extensible format. Google uses Protocol Buffers for almost all of its
45 internal RPC protocols and file formats.")
46 (license bsd-3)))