Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / cflow.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cflow)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages emacs))
25
26 (define-public cflow
27 (package
28 (name "cflow")
29 (version "1.4")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/cflow/cflow-"
33 version ".tar.bz2"))
34 (sha256
35 (base32
36 "1jkbq97ajcf834z68hbn3xfhiz921zhn39gklml1racf0kb3jzh3"))))
37 (build-system gnu-build-system)
38
39 ;; Needed to have cflow-mode.el installed.
40 (native-inputs `(("emacs" ,emacs)))
41
42 (home-page "http://www.gnu.org/software/cflow/")
43 (synopsis "Create a graph of control flow within a program")
44 (description
45 "GNU cflow analyzes C source files and produces a graph charting the
46 control flow of the program. It can output the graph in several styles and
47 in either the POSIX format or in an extended GNU format. cflow also includes
48 a major mode for Emacs for examining the flowcharts that it produces.")
49 (license gpl3+)))