build: 'sync-descriptions' now compares GNU package descriptions.
[jackhill/guix/guix.git] / gnu / packages / time.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages time)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public time
27 (package
28 (name "time")
29 (version "1.7")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/time/time-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "0va9063fcn7xykv658v2s9gilj2fq4rcdxx2mn2mmy1v4ndafzp3"))))
38 (build-system gnu-build-system)
39 (arguments
40 '(#:phases
41 (alist-replace 'configure
42 (lambda* (#:key outputs #:allow-other-keys)
43 ;; This old `configure' script doesn't support
44 ;; variables passed as arguments.
45 (let ((out (assoc-ref outputs "out")))
46 (setenv "CONFIG_SHELL" (which "bash"))
47 (zero?
48 (system* "./configure"
49 (string-append "--prefix=" out)))))
50 %standard-phases)))
51 (home-page "http://www.gnu.org/software/time/")
52 (synopsis "Run a command, then display its resource usage")
53 (description
54 "The 'time' command runs another program, then displays information
55 about the resources used by that program, collected by the system while
56 the program was running. You can select which information is reported
57 and the format in which it is shown, or have 'time' save the information
58 in a file instead of displaying it on the screen.
59
60 The resources that 'time' can report on fall into the general categories
61 of time, memory, and I/O and IPC calls. Some systems do not provide
62 much information about program resource use; 'time' reports unavailable
63 information as zero values.")
64 (license gpl2+)))