gnu: coq-mathcomp: Update home page URI.
[jackhill/guix/guix.git] / gnu / packages / coq.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
3 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
5 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
6 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages coq)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages bison)
28 #:use-module (gnu packages boost)
29 #:use-module (gnu packages emacs)
30 #:use-module (gnu packages flex)
31 #:use-module (gnu packages gawk)
32 #:use-module (gnu packages multiprecision)
33 #:use-module (gnu packages ocaml)
34 #:use-module (gnu packages perl)
35 #:use-module (gnu packages python)
36 #:use-module (gnu packages texinfo)
37 #:use-module (guix build-system gnu)
38 #:use-module (guix build-system ocaml)
39 #:use-module (guix download)
40 #:use-module (guix git-download)
41 #:use-module ((guix licenses) #:prefix license:)
42 #:use-module (guix packages)
43 #:use-module (guix utils)
44 #:use-module ((srfi srfi-1) #:hide (zip)))
45
46 (define-public coq
47 (package
48 (name "coq")
49 (version "8.10.2")
50 (source
51 (origin
52 (method git-fetch)
53 (uri (git-reference
54 (url "https://github.com/coq/coq.git")
55 (commit (string-append "V" version))))
56 (file-name (git-file-name name version))
57 (sha256
58 (base32
59 "0ji2rzd70b3hcwfw97qk7rv3m2977ylqnq82l1555dp3njr8nm3q"))))
60 (native-search-paths
61 (list (search-path-specification
62 (variable "COQPATH")
63 (files (list "lib/coq/user-contrib")))))
64 (build-system ocaml-build-system)
65 (outputs '("out" "ide"))
66 (inputs
67 `(("lablgtk" ,lablgtk3)
68 ("python" ,python-2)
69 ("camlp5" ,camlp5)
70 ("ocaml-num" ,ocaml-num)))
71 (native-inputs
72 `(("ocaml-ounit" ,ocaml-ounit)))
73 (arguments
74 `(#:phases
75 (modify-phases %standard-phases
76 (add-after 'unpack 'make-git-checkout-writable
77 (lambda _
78 (for-each make-file-writable (find-files "."))
79 #t))
80 (replace 'configure
81 (lambda* (#:key outputs #:allow-other-keys)
82 (let* ((out (assoc-ref outputs "out"))
83 (mandir (string-append out "/share/man"))
84 (browser "icecat -remote \"OpenURL(%s,new-tab)\""))
85 (invoke "./configure"
86 "-prefix" out
87 "-mandir" mandir
88 "-browser" browser
89 "-coqide" "opt"))))
90 (replace 'build
91 (lambda _
92 (invoke "make"
93 "-j" (number->string (parallel-job-count))
94 "world")))
95 (delete 'check)
96 (add-after 'install 'remove-duplicate
97 (lambda* (#:key outputs #:allow-other-keys)
98 (let* ((out (assoc-ref outputs "out"))
99 (bin (string-append out "/bin")))
100 ;; These files are exact copies without `.opt` extension.
101 ;; Removing these saves 35 MiB in the resulting package.
102 (delete-file (string-append bin "/coqtop.opt"))
103 (delete-file (string-append bin "/coqidetop.opt")))
104 #t))
105 (add-after 'install 'install-ide
106 (lambda* (#:key outputs #:allow-other-keys)
107 (let ((out (assoc-ref outputs "out"))
108 (ide (assoc-ref outputs "ide")))
109 (mkdir-p (string-append ide "/bin"))
110 (rename-file (string-append out "/bin/coqide")
111 (string-append ide "/bin/coqide")))
112 #t))
113 (add-after 'install 'check
114 (lambda _
115 (with-directory-excursion "test-suite"
116 ;; These two tests fail.
117 ;; Fails because the output is not formatted as expected.
118 (delete-file-recursively "coq-makefile/timing")
119 ;; Fails because we didn't build coqtop.byte.
120 (delete-file-recursively "coq-makefile/findlib-package")
121 (invoke "make")))))))
122 (home-page "https://coq.inria.fr")
123 (synopsis "Proof assistant for higher-order logic")
124 (description
125 "Coq is a proof assistant for higher-order logic, which allows the
126 development of computer programs consistent with their formal specification.
127 It is developed using Objective Caml and Camlp5.")
128 ;; The source code is distributed under lgpl2.1.
129 ;; Some of the documentation is distributed under opl1.0+.
130 (license (list license:lgpl2.1 license:opl1.0+))))
131
132 (define-public proof-general
133 (package
134 (name "proof-general")
135 (version "4.2")
136 (source (origin
137 (method url-fetch)
138 (uri (string-append
139 "http://proofgeneral.inf.ed.ac.uk/releases/"
140 "ProofGeneral-" version ".tgz"))
141 (sha256
142 (base32
143 "09qb0myq66fw17v4ziz401ilsb5xlxz1nl2wsp69d0vrfy0bcrrm"))))
144 (build-system gnu-build-system)
145 (native-inputs
146 `(("which" ,which)
147 ("emacs" ,emacs-minimal)
148 ("texinfo" ,texinfo)))
149 (inputs
150 `(("host-emacs" ,emacs)
151 ("perl" ,perl)
152 ("coq" ,coq)))
153 (arguments
154 `(#:tests? #f ; no check target
155 #:make-flags (list (string-append "PREFIX=" %output)
156 (string-append "DEST_PREFIX=" %output))
157 #:modules ((guix build gnu-build-system)
158 (guix build utils)
159 (guix build emacs-utils))
160 #:imported-modules (,@%gnu-build-system-modules
161 (guix build emacs-utils))
162 #:phases
163 (modify-phases %standard-phases
164 (delete 'configure)
165 (add-after 'unpack 'disable-byte-compile-error-on-warn
166 (lambda _
167 (substitute* "Makefile"
168 (("\\(setq byte-compile-error-on-warn t\\)")
169 "(setq byte-compile-error-on-warn nil)"))
170 #t))
171 (add-after 'unpack 'patch-hardcoded-paths
172 (lambda* (#:key inputs outputs #:allow-other-keys)
173 (let ((out (assoc-ref outputs "out"))
174 (coq (assoc-ref inputs "coq"))
175 (emacs (assoc-ref inputs "host-emacs")))
176 (define (coq-prog name)
177 (string-append coq "/bin/" name))
178 (emacs-substitute-variables "coq/coq.el"
179 ("coq-prog-name" (coq-prog "coqtop"))
180 ("coq-compiler" (coq-prog "coqc"))
181 ("coq-dependency-analyzer" (coq-prog "coqdep")))
182 (substitute* "Makefile"
183 (("/sbin/install-info") "install-info"))
184 (substitute* "bin/proofgeneral"
185 (("^PGHOMEDEFAULT=.*" all)
186 (string-append all
187 "PGHOME=$PGHOMEDEFAULT\n"
188 "EMACS=" emacs "/bin/emacs")))
189 #t)))
190 (add-after 'unpack 'clean
191 (lambda _
192 ;; Delete the pre-compiled elc files for Emacs 23.
193 (invoke "make" "clean")))
194 (add-after 'install 'install-doc
195 (lambda* (#:key make-flags #:allow-other-keys)
196 ;; XXX FIXME avoid building/installing pdf files,
197 ;; due to unresolved errors building them.
198 (substitute* "Makefile"
199 ((" [^ ]*\\.pdf") ""))
200 (apply invoke "make" "install-doc" make-flags))))))
201 (home-page "http://proofgeneral.inf.ed.ac.uk/")
202 (synopsis "Generic front-end for proof assistants based on Emacs")
203 (description
204 "Proof General is a major mode to turn Emacs into an interactive proof
205 assistant to write formal mathematical proofs using a variety of theorem
206 provers.")
207 (license license:gpl2+)))
208
209 (define-public coq-flocq
210 (package
211 (name "coq-flocq")
212 (version "3.2.0")
213 (source
214 (origin
215 (method git-fetch)
216 (uri (git-reference
217 (url "https://gitlab.inria.fr/flocq/flocq.git")
218 (commit (string-append "flocq-" version))))
219 (file-name (git-file-name name version))
220 (sha256
221 (base32
222 "15bi36x7zj0glsb3s2gwqd4wswhfzh36rbp7imbyff53a7nna95l"))))
223 (build-system gnu-build-system)
224 (native-inputs
225 `(("autoconf" ,autoconf)
226 ("automake" ,automake)
227 ("ocaml" ,ocaml)
228 ("which" ,which)
229 ("coq" ,coq)))
230 (arguments
231 `(#:configure-flags
232 (list (string-append "--libdir=" (assoc-ref %outputs "out")
233 "/lib/coq/user-contrib/Flocq"))
234 #:phases
235 (modify-phases %standard-phases
236 (add-after 'unpack 'remove-failing-examples
237 (lambda _
238 (substitute* "Remakefile.in"
239 ;; Fails on a union error.
240 (("Double_rounding_odd_radix.v") ""))
241 #t))
242 (add-before 'configure 'fix-remake
243 (lambda _
244 (substitute* "remake.cpp"
245 (("/bin/sh") (which "sh")))
246 #t))
247 (replace 'build
248 (lambda _
249 (invoke "./remake")))
250 (replace 'check
251 (lambda _
252 (invoke "./remake" "check")))
253 ;; TODO: requires coq-gappa and coq-interval.
254 ;(invoke "./remake" "check-more")
255 (replace 'install
256 (lambda _
257 (invoke "./remake" "install"))))))
258 (home-page "https://flocq.gforge.inria.fr/")
259 (synopsis "Floating-point formalization for the Coq system")
260 (description "Flocq (Floats for Coq) is a floating-point formalization for
261 the Coq system. It provides a comprehensive library of theorems on a multi-radix
262 multi-precision arithmetic. It also supports efficient numerical computations
263 inside Coq.")
264 (license license:lgpl3+)))
265
266 (define-public coq-gappa
267 (package
268 (name "coq-gappa")
269 (version "1.4.2")
270 (source
271 (origin
272 (method git-fetch)
273 (uri (git-reference
274 (url "https://gitlab.inria.fr/gappa/coq.git")
275 (commit (string-append "gappalib-coq-" version))))
276 (file-name (git-file-name name version))
277 (sha256
278 (base32
279 "0r7jwp5xssdfzivs2flp7mzrscqhgl63mryhhf1cvndpgzqwfk2f"))))
280 (build-system gnu-build-system)
281 (native-inputs
282 `(("autoconf" ,autoconf)
283 ("automake" ,automake)
284 ("ocaml" ,ocaml)
285 ("which" ,which)
286 ("coq" ,coq)
287 ("camlp5" ,camlp5)
288 ("bison" ,bison)
289 ("flex" ,flex)))
290 (inputs
291 `(("gmp" ,gmp)
292 ("mpfr" ,mpfr)
293 ("boost" ,boost)))
294 (propagated-inputs
295 `(("coq-flocq" ,coq-flocq)))
296 (arguments
297 `(#:configure-flags
298 (list (string-append "--libdir=" (assoc-ref %outputs "out")
299 "/lib/coq/user-contrib/Gappa"))
300 #:phases
301 (modify-phases %standard-phases
302 (add-before 'configure 'fix-remake
303 (lambda _
304 (substitute* "remake.cpp"
305 (("/bin/sh") (which "sh")))
306 #t))
307 (replace 'build
308 (lambda _ (invoke "./remake")))
309 ;; FIXME: Figure out why failures occur, and re-enable check phase.
310 (delete 'check)
311 ;; (replace 'check
312 ;; (lambda _ (invoke "./remake" "check")))
313 (replace 'install
314 (lambda _ (invoke "./remake" "install"))))))
315 (home-page "https://gappa.gforge.inria.fr/")
316 (synopsis "Verify and formally prove properties on numerical programs")
317 (description "Gappa is a tool intended to help verifying and formally proving
318 properties on numerical programs dealing with floating-point or fixed-point
319 arithmetic. It has been used to write robust floating-point filters for CGAL
320 and it is used to certify elementary functions in CRlibm. While Gappa is
321 intended to be used directly, it can also act as a backend prover for the Why3
322 software verification plateform or as an automatic tactic for the Coq proof
323 assistant.")
324 (license (list license:gpl2+ license:cecill))));either gpl2+ or cecill
325
326 (define-public coq-mathcomp
327 (package
328 (name "coq-mathcomp")
329 (version "1.10.0")
330 (source
331 (origin
332 (method git-fetch)
333 (uri (git-reference
334 (url "https://github.com/math-comp/math-comp.git")
335 (commit (string-append "mathcomp-" version))))
336 (file-name (git-file-name name version))
337 (sha256
338 (base32 "1h5h1c2025r1ms5qryvwy6pikxmpmmjav6yl127xpzmqdi6w732d"))))
339 (build-system gnu-build-system)
340 (native-inputs
341 `(("ocaml" ,ocaml)
342 ("which" ,which)
343 ("coq" ,coq)))
344 (arguments
345 `(#:tests? #f ; No tests.
346 #:phases
347 (modify-phases %standard-phases
348 (delete 'configure)
349 (add-before 'build 'chdir
350 (lambda _ (chdir "mathcomp") #t))
351 (replace 'install
352 (lambda* (#:key outputs #:allow-other-keys)
353 (invoke "make" "-f" "Makefile.coq"
354 (string-append "COQLIB=" (assoc-ref outputs "out")
355 "/lib/coq/")
356 "install"))))))
357 (home-page "https://math-comp.github.io/")
358 (synopsis "Mathematical Components for Coq")
359 (description "Mathematical Components for Coq has its origins in the formal
360 proof of the Four Colour Theorem. Since then it has grown to cover many areas
361 of mathematics and has been used for large scale projects like the formal proof
362 of the Odd Order Theorem.
363
364 The library is written using the Ssreflect proof language that is an integral
365 part of the distribution.")
366 (license license:cecill-b)))
367
368 (define-public coq-coquelicot
369 (package
370 (name "coq-coquelicot")
371 (version "3.0.3")
372 (source
373 (origin
374 (method git-fetch)
375 (uri (git-reference
376 (url "https://gitlab.inria.fr/coquelicot/coquelicot.git")
377 (commit (string-append "coquelicot-" version))))
378 (file-name (git-file-name name version))
379 (sha256
380 (base32
381 "0m5wbr2s8lnf8b7cfwv15hyzsmbcaz6hgdn7aazcrkxnwr87vgkp"))))
382 (build-system gnu-build-system)
383 (native-inputs
384 `(("autoconf" ,autoconf)
385 ("automake" ,automake)
386 ("ocaml" ,ocaml)
387 ("which" ,which)
388 ("coq" ,coq)))
389 (propagated-inputs
390 `(("mathcomp" ,coq-mathcomp)))
391 (arguments
392 `(#:configure-flags
393 (list (string-append "--libdir=" (assoc-ref %outputs "out")
394 "/lib/coq/user-contrib/Coquelicot"))
395 #:phases
396 (modify-phases %standard-phases
397 (add-before 'configure 'fix-remake
398 (lambda _
399 (substitute* "remake.cpp"
400 (("/bin/sh") (which "sh")))
401 #t))
402 (replace 'build
403 (lambda _ (invoke "./remake")))
404 (replace 'check
405 (lambda _ (invoke "./remake" "check")))
406 (replace 'install
407 (lambda _ (invoke "./remake" "install"))))))
408 (home-page "http://coquelicot.saclay.inria.fr")
409 (synopsis "Coq library for Reals")
410 (description "Coquelicot is an easier way of writing formulas and theorem
411 statements, achieved by relying on total functions in place of dependent types
412 for limits, derivatives, integrals, power series, and so on. To help with the
413 proof process, the library comes with a comprehensive set of theorems that cover
414 not only these notions, but also some extensions such as parametric integrals,
415 two-dimensional differentiability, asymptotic behaviors. It also offers some
416 automations for performing differentiability proofs. Moreover, Coquelicot is a
417 conservative extension of Coq's standard library and provides correspondence
418 theorems between the two libraries.")
419 (license license:lgpl3+)))
420
421 (define-public coq-bignums
422 (package
423 (name "coq-bignums")
424 (version "8.10.0")
425 (source (origin
426 (method git-fetch)
427 (uri (git-reference
428 (url "https://github.com/coq/bignums.git")
429 (commit (string-append "V" version))))
430 (file-name (git-file-name name version))
431 (sha256
432 (base32
433 "0bpb4flckn4nqxbs3wjiznyx1k7r8k93qdigp3qwmikp2lxvcbw5"))))
434 (build-system gnu-build-system)
435 (native-inputs
436 `(("ocaml" ,ocaml)
437 ("coq" ,coq)))
438 (inputs
439 `(("camlp5" ,camlp5)))
440 (arguments
441 `(#:tests? #f ; No test target.
442 #:make-flags
443 (list (string-append "COQLIBINSTALL=" (assoc-ref %outputs "out")
444 "/lib/coq/user-contrib"))
445 #:phases
446 (modify-phases %standard-phases
447 (delete 'configure))))
448 (home-page "https://github.com/coq/bignums")
449 (synopsis "Coq library for arbitrary large numbers")
450 (description "Bignums is a coq library of arbitrary large numbers. It
451 provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
452 (license license:lgpl2.1+)))
453
454 (define-public coq-interval
455 (package
456 (name "coq-interval")
457 (version "3.4.1")
458 (source
459 (origin
460 (method git-fetch)
461 (uri (git-reference
462 (url "https://gitlab.inria.fr/coqinterval/interval.git")
463 (commit (string-append "interval-" version))))
464 (file-name (git-file-name name version))
465 (sha256
466 (base32
467 "03q3dfqi3r3f7aji5s06ig4aav9ajcwswwdzi5lrgr69z0m487k4"))))
468 (build-system gnu-build-system)
469 (native-inputs
470 `(("autoconf" ,autoconf)
471 ("automake" ,automake)
472 ("ocaml" ,ocaml)
473 ("which" ,which)
474 ("coq" ,coq)))
475 (propagated-inputs
476 `(("flocq" ,coq-flocq)
477 ("bignums" ,coq-bignums)
478 ("coquelicot" ,coq-coquelicot)
479 ("mathcomp" ,coq-mathcomp)))
480 (arguments
481 `(#:configure-flags
482 (list (string-append "--libdir=" (assoc-ref %outputs "out")
483 "/lib/coq/user-contrib/Gappa"))
484 #:phases
485 (modify-phases %standard-phases
486 (add-before 'configure 'fix-remake
487 (lambda _
488 (substitute* "remake.cpp"
489 (("/bin/sh") (which "sh")))
490 #t))
491 (replace 'build
492 (lambda _ (invoke "./remake")))
493 (replace 'check
494 (lambda _ (invoke "./remake" "check")))
495 (replace 'install
496 (lambda _ (invoke "./remake" "install"))))))
497 (home-page "http://coq-interval.gforge.inria.fr/")
498 (synopsis "Coq tactics to simplify inequality proofs")
499 (description "Interval provides vernacular files containing tactics for
500 simplifying the proofs of inequalities on expressions of real numbers for the
501 Coq proof assistant.")
502 (license license:cecill-c)))
503
504 (define-public coq-autosubst
505 ;; Latest commit on that branch, where work on supporting coq 8.6 and
506 ;; more recent versions of coq happen.
507 (let ((branch "coq86-devel")
508 (commit "fa6ef30664511ffa659cbcf3c962715cbee03572"))
509 (package
510 (name "coq-autosubst")
511 (version (git-version "1" branch commit))
512 (source (origin
513 (method git-fetch)
514 (uri (git-reference
515 (url "git://github.com/uds-psl/autosubst.git")
516 (commit commit)))
517 (file-name (git-file-name name version))
518 (sha256
519 (base32 "1cl0bp96bk6lplbl7n5c703vd3gvbs5mvf2qrf8q333kkqd7jqq4"))))
520 (build-system gnu-build-system)
521 (arguments
522 `(#:tests? #f
523 #:phases
524 (modify-phases %standard-phases
525 (delete 'configure)
526 (replace 'install
527 (lambda* (#:key outputs #:allow-other-keys)
528 (setenv "COQLIB" (string-append (assoc-ref outputs "out") "/lib/coq/"))
529 (invoke "make"
530 (string-append "COQLIB=" (assoc-ref outputs "out")
531 "/lib/coq/")
532 "install"))))))
533 (native-inputs
534 `(("coq" ,coq)))
535 (home-page "https://www.ps.uni-saarland.de/autosubst/")
536 (synopsis "Coq library for parallel de Bruijn substitutions")
537 (description "Formalizing syntactic theories with variable binders is
538 not easy. Autosubst is a library for the Coq proof assistant to
539 automate this process. Given an inductive definition of syntactic objects in
540 de Bruijn representation augmented with binding annotations, Autosubst
541 synthesizes the parallel substitution operation and automatically proves the
542 basic lemmas about substitutions. This library contains an automation
543 tactic that solves equations involving terms and substitutions. This makes the
544 usage of substitution lemmas unnecessary. The tactic is based on our current
545 work on a decision procedure for the equational theory of an extension of the
546 sigma-calculus by Abadi et al. The library is completely written in Coq and
547 uses Ltac to synthesize the substitution operation.")
548 (license license:bsd-3))))
549
550 (define-public coq-equations
551 (package
552 (name "coq-equations")
553 (version "1.2.1")
554 (source (origin
555 (method git-fetch)
556 (uri (git-reference
557 (url "https://github.com/mattam82/Coq-Equations.git")
558 (commit (string-append "v" version "-8.10"))))
559 (file-name (git-file-name name version))
560 (sha256
561 (base32
562 "023q5dww3drw35dm9bi9p9d0wrj9k7vax7hfdsprf8l340pb4s0k"))))
563 (build-system gnu-build-system)
564 (native-inputs
565 `(("ocaml" ,ocaml)
566 ("coq" ,coq)
567 ("camlp5" ,camlp5)))
568 (arguments
569 `(#:test-target "test-suite"
570 #:phases
571 (modify-phases %standard-phases
572 (replace 'configure
573 (lambda* (#:key outputs #:allow-other-keys)
574 (invoke "sh" "./configure.sh")))
575 (replace 'install
576 (lambda* (#:key outputs #:allow-other-keys)
577 (invoke "make"
578 (string-append "COQLIB=" (assoc-ref outputs "out")
579 "/lib/coq/")
580 "install"))))))
581 (home-page "https://mattam82.github.io/Coq-Equations/")
582 (synopsis "Function definition plugin for Coq")
583 (description "Equations provides a notation for writing programs
584 by dependent pattern-matching and (well-founded) recursion in Coq. It
585 compiles everything down to eliminators for inductive types, equality
586 and accessibility, providing a definitional extension to the Coq
587 kernel.")
588 (license license:lgpl2.1)))
589
590 (define-public coq-stdpp
591 (package
592 (name "coq-stdpp")
593 (version "1.2.1")
594 (synopsis "Alternative Coq standard library std++")
595 (source (origin
596 (method git-fetch)
597 (uri (git-reference
598 (url "https://gitlab.mpi-sws.org/iris/stdpp.git")
599 (commit (string-append "coq-stdpp-" version))))
600 (file-name (git-file-name name version))
601 (sha256
602 (base32
603 "1lczybg1jq9drbi8nzrlb0k199x4n07aawjwfzrl3qqc0w8kmvdz"))))
604 (build-system gnu-build-system)
605 (inputs
606 `(("coq" ,coq)))
607 (arguments
608 `(#:tests? #f ; Tests are executed during build phase.
609 #:phases
610 (modify-phases %standard-phases
611 (delete 'configure)
612 (replace 'install
613 (lambda* (#:key outputs #:allow-other-keys)
614 (invoke "make"
615 (string-append "COQLIB=" (assoc-ref outputs "out")
616 "/lib/coq/")
617 "install"))))))
618 (description "This project contains an extended \"Standard Library\" for
619 Coq called coq-std++. The key features are:
620 @itemize
621 @item Great number of definitions and lemmas for common data structures such
622 as lists, finite maps, finite sets, and finite multisets.
623
624 @item Type classes for common notations (like ∅, ∪, and Haskell-style monad
625 notations) so that these can be overloaded for different data structures.
626
627 @item It uses type classes to keep track of common properties of types, like
628 it having decidable equality or being countable or finite.
629
630 @item Most data structures are represented in canonical ways so that Leibniz
631 equality can be used as much as possible (for example, for maps we have m1 =
632 m2 iff ∀ i, m1 !! i = m2 !! i). On top of that, the library provides setoid
633 instances for most types and operations.
634
635 @item Various tactics for common tasks, like an ssreflect inspired done tactic
636 for finishing trivial goals, a simple breadth-first solver naive_solver, an
637 equality simplifier simplify_eq, a solver solve_proper for proving
638 compatibility of functions with respect to relations, and a solver set_solver
639 for goals involving set operations.
640
641 @item The library is dependency- and axiom-free.
642 @end itemize")
643 (home-page "https://gitlab.mpi-sws.org/iris/stdpp")
644 (license license:bsd-3)))