gnu: hdf-java: Fix build.
[jackhill/guix/guix.git] / gnu / packages / profiling.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Dave Love <fx@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages profiling)
21 #:use-module (guix packages)
22 #:use-module ((guix licenses) #:prefix license:) ; avoid zlib, expat clashes
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages autotools)
28 #:use-module (gnu packages base) ;for "which"
29 #:use-module (gnu packages bison)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages documentation)
32 #:use-module (gnu packages fabric-management)
33 #:use-module (gnu packages flex)
34 #:use-module (gnu packages gawk)
35 #:use-module (gnu packages gcc)
36 #:use-module (gnu packages glib)
37 #:use-module (gnu packages libunwind)
38 #:use-module (gnu packages linux)
39 #:use-module (gnu packages mpi)
40 #:use-module (gnu packages ncurses)
41 #:use-module (gnu packages perl)
42 #:use-module (gnu packages perl)
43 #:use-module (gnu packages python)
44 #:use-module (gnu packages qt))
45
46 ;; Fixme: Separate out lib and fix resulting cycle errors; separate libpfm
47 ;; output(?); build libmsr and add that component.
48 (define-public papi
49 (package
50 (name "papi")
51 (version "5.5.1")
52 (source
53 (origin
54 (method url-fetch)
55 (uri (string-append "http://icl.utk.edu/projects/papi/downloads/papi-"
56 version ".tar.gz"))
57 (sha256 (base32 "1m62s8fkjjgq04ayf18jcxc33rqfd7nrkdw1gr54q5pn4cijrp29"))))
58 (build-system gnu-build-system)
59 (inputs
60 `(("ncurses" ,ncurses)
61 ("lm-sensors" ,lm-sensors "lib")
62 ("rdma-core" ,rdma-core)
63 ("infiniband-diags" ,infiniband-diags "lib")
64 ("net-tools" ,net-tools)))
65 (native-inputs
66 `(("autoconf" ,autoconf)
67 ("gfortran" ,gfortran)))
68 (arguments
69 `(#:tests? #f ; no check target
70 #:configure-flags
71 ;; These are roughly per Fedora, but elide mx (assumed to be dead, even
72 ;; Open-MX) and add and powercap -- I don't know the pros/cons of
73 ;; infiniband and infiniband_mad, but you can't use them together, and
74 ;; the umad version needs at least one patch.
75 ;; Implicit enabled components: perf_event perf_event_uncore
76 `("--with-perf-events" "--with-shared-lib=yes" "--with-shlib"
77 "--with-static-lib=no"
78 "--with-components=appio coretemp example lustre micpower net rapl \
79 stealtime lmsensors infiniband powercap"
80 ;; So utils get rpath set correctly:
81 ,(string-append "LDFLAGS=-Xlinker -rpath -Xlinker "
82 (assoc-ref %outputs "out") "/lib"))
83 #:phases
84 (modify-phases %standard-phases
85 (add-before 'configure 'autoconf
86 (lambda _
87 (chdir "src")
88 (invoke "autoconf")
89 #t))
90 ;; Amalgamating with the following clause gives double substitution.
91 (add-before 'patch-source-shebangs 'patch-components
92 (lambda _
93 (with-directory-excursion "src/components"
94 (substitute* '("lmsensors/configure" "infiniband_umad/configure")
95 (("/bin/sh") (which "sh"))))
96 #t))
97 (add-after 'configure 'components
98 (lambda* (#:key inputs #:allow-other-keys)
99 (with-directory-excursion "components"
100 (with-directory-excursion "infiniband_umad"
101 (invoke "./configure"))
102 (with-directory-excursion "lmsensors"
103 (let ((base (assoc-ref inputs "lm-sensors")))
104 (invoke "./configure"
105 (string-append "--with-sensors_incdir="
106 base "/include/sensors")
107 (string-append "--with-sensors_libdir="
108 base "/lib")))))
109 #t))
110 (add-after 'install 'extra-doc
111 (lambda* (#:key outputs #:allow-other-keys)
112 (let ((doc (string-append (assoc-ref outputs "out")
113 "/share/doc/" ,name "-" ,version)))
114 (chdir "..") ; we went into src above
115 (for-each (lambda (file)
116 (install-file file doc))
117 '("README" "RELEASENOTES.txt"))
118 #t))))))
119 (home-page "https://icl.utk.edu/papi/")
120 (synopsis "Performance Application Programming Interface")
121 (description
122 "PAPI provides the tool designer and application engineer with a consistent
123 interface and methodology for use of the performance counter hardware found in
124 most major microprocessors. PAPI enables software engineers to see, in near
125 real time, the relation between software performance and processor events.
126
127 In addition, PAPI provides access to a collection of components that expose
128 performance measurement opportunites across the hardware and software stack.")
129 ;; See Debian papi copyright file.
130 (license (list license:bsd-3
131 license:lgpl2.1+ ;src/components/infiniband/pscanf.h
132 ;; not used in output
133 license:gpl2+ ;src/components/appio/tests/iozone/gengnuplot.sh
134 ;src/libpfm-3.y/*/multiplex*
135 ;; "BSD-like": src/libpfm-3.y/*, src/libpfm4/*
136 ;; lgpl2.1+: src/perfctr-2.*/*
137 ))))
138
139 ;; NB. there's a potential name clash with libotf.
140 (define-public otf2
141 (package
142 (name "otf2")
143 (version "2.1.1")
144 (source
145 (origin
146 (method url-fetch)
147 (uri (string-append "http://www.vi-hps.org/upload/packages/otf2/otf2-"
148 version ".tar.gz"))
149 (sha256 (base32 "1ls7rz6qwnqbkifpafc95bnfh3m9xbs74in8zxlnhfbgwx11nn81"))))
150 (native-inputs `(("python" ,python)))
151 (outputs '("doc" ; 18MB
152 "lib"
153 "out"))
154 (build-system gnu-build-system)
155 (arguments
156 `(#:configure-flags '("--enable-shared" "--disable-static")
157 #:phases
158 (modify-phases %standard-phases
159 (add-after 'install 'licence
160 (lambda* (#:key outputs #:allow-other-keys)
161 (for-each (lambda (output)
162 (let ((doc (string-append (assoc-ref outputs output)
163 "/share/doc/otf2")))
164 (install-file "COPYING" doc)))
165 '("lib" "doc"))
166 #t)))))
167 (home-page "http://www.vi-hps.org/projects/score-p/")
168 (synopsis "Open Trace Format 2 library")
169 (description "The Open Trace Format 2 (@dfn{OTF2}) is a scalable,
170 memory-efficient event trace data format plus support library.")
171 (license license:bsd-3)))
172
173 (define-public opari2
174 (package
175 (name "opari2")
176 (version "2.0.3")
177 (source
178 (origin
179 (method url-fetch)
180 (uri (let* ((parts (string-split version #\.) )
181 (major (car parts))
182 (minor (cadr parts)))
183 (string-append "http://www.vi-hps.org/upload/packages/opari2/opari2-"
184 version ".tar.gz")))
185 (sha256 (base32 "0v785mhw9azj3ln5v7akj5b1cxvzfkxz8kj565pfwllir7xzqbky"))))
186 (build-system gnu-build-system)
187 (inputs `(("gfortran" ,gfortran)))
188 (native-inputs `(("gawk" ,gawk) ;for tests
189 ("which" ,which)))
190 (home-page "http://www.vi-hps.org/projects/score-p")
191 (synopsis "OpenMP runtime performance measurement instrumenter")
192 (description "OPARI2 is a source-to-source instrumentation tool for OpenMP
193 and hybrid codes. It surrounds OpenMP directives and runtime library calls
194 with calls to the POMP2 measurement interface.")
195 (license license:bsd-3)))
196
197 (define-public cube
198 (package
199 (name "cube")
200 (version "4.3.5")
201 (source
202 (origin
203 (method url-fetch)
204 (uri (string-append
205 "http://apps.fz-juelich.de/scalasca/releases/cube/4.3/dist/cube-"
206 version ".tar.gz"))
207 (sha256 (base32 "04irflia4rfw02093w9nx7rr98r640y4q8hisjywvd4b7r3nzhhx"))
208 (patches (search-patches "cube-nocheck.patch"))))
209 (inputs `(("dbus" ,dbus)
210 ("zlib" ,zlib)))
211 (native-inputs `(("perl" ,perl)
212 ("qtbase" ,qtbase) ; native because of qmake
213 ("which" ,which)))
214
215 ;; FIXME: The doc is 14MB, but adding a doc output results in a cycle.
216 (outputs '("out" ;"doc"
217 "lib"))
218
219 (build-system gnu-build-system)
220 (arguments
221 `(#:configure-flags
222 `("--enable-shared" "--disable-static" "--disable-silent-rules"
223 ,(string-append "LDFLAGS=-L" (assoc-ref %outputs "lib") "/lib"))
224 #:parallel-tests? #f
225 #:phases
226 (modify-phases %standard-phases
227 (add-after 'configure 'rpath
228 ;; Account for moving GUI stuff
229 (lambda* (#:key outputs #:allow-other-keys)
230 (let ((wl (string-append "-Wl,-rpath=" (assoc-ref outputs "out")
231 "/lib")))
232 (substitute* "build-backend/Makefile"
233 (("^cube_LDFLAGS =") (string-append "cube_LDFLAGS = " wl))
234 (("^libheatmap_plugin_la_LDFLAGS =")
235 (string-append "libheatmap_plugin_la_LDFLAGS = " wl))
236 (("^libbarplot_plugin_la_LDFLAGS =")
237 (string-append "libbarplot_plugin_la_LDFLAGS = " wl)))
238 #t)))
239 (add-before 'install 'includes-cube
240 ;; It tries to install here before include exists.
241 (lambda* (#:key outputs #:allow-other-keys)
242 (let ((inc (string-append (assoc-ref outputs "lib") "/include")))
243 (mkdir-p (string-append inc "/cube"))
244 (mkdir-p (string-append inc "/cubew"))
245 #t)))
246 (add-after 'install 'licence
247 (lambda* (#:key outputs #:allow-other-keys)
248 (let ((doc (string-append (assoc-ref outputs "lib")
249 "/share/doc/cube")))
250 (install-file "COPYING" doc)
251 #t)))
252 ;; XXX: Commented due to cycle (see comment above.)
253 ;; (add-after 'install 'doc
254 ;; (lambda _
255 ;; (let ((share (string-append (assoc-ref %outputs "doc")
256 ;; "/share")))
257 ;; (mkdir-p share)
258 ;; (rename-file (string-append %output "/share/doc")
259 ;; (string-append share "/doc")))))
260 (add-after 'install 'gui-stuff
261 ;; Get the Qt horror dependencies out of the lib closure
262 (lambda _
263 (let ((outlib (string-append (assoc-ref %outputs "out") "/lib"))
264 (lib (string-append (assoc-ref %outputs "lib") "/lib")))
265 (mkdir-p outlib)
266 (rename-file (string-append lib "/cube-plugins")
267 (string-append outlib "/cube-plugins"))
268 (for-each (lambda (file)
269 (rename-file
270 file (string-append outlib "/" (basename file))))
271 (append (find-files lib "libgraphwidgetcommon-plugin\\..*")
272 (find-files lib "libcube4gui\\.so.*")))
273 #t)))
274 (add-after 'install 'move-include
275 ;; Most of the headers end up under %output for some reason,
276 ;; despite --includedir in configure.
277 (lambda* (#:key outputs #:allow-other-keys)
278 (let ((outinc (string-append (assoc-ref outputs "out")
279 "/include"))
280 (libinc (string-append (assoc-ref outputs "lib")
281 "/include")))
282 (for-each (lambda (file)
283 (let ((from (string-append outinc "/" file)))
284 (copy-recursively from libinc)
285 (delete-file-recursively from)))
286 '("cube" "cubew"))
287 #t)))
288
289 ;; XXX: This doesn't work because cube-config, which is needed for
290 ;; building stuff, sources cube-config-frontend. We don't want that
291 ;; in the lib output because it pulls in >1GB via QT.
292 ;;
293 ;; (add-after 'install 'cube-config
294 ;; (lambda _
295 ;; (let* ((lib (assoc-ref %outputs "lib"))
296 ;; (libbin (string-append lib "/bin")))
297 ;; (mkdir-p libbin)
298 ;; (system (string-append "mv " (assoc-ref %outputs "out")
299 ;; "/bin/cube-config* " libbin))
300 ;; (substitute* (list (string-append libbin "/cube-config"))
301 ;; (("^prefix=.*") (string-append "prefix=" lib))
302 ;; (("^exec_prefix=\"\\$\\{prefix\\}\"")
303 ;; (string-append "exec_prefix=" lib))))))
304 (add-after 'install 'cube-config
305 (lambda* (#:key outputs #:allow-other-keys)
306 (let* ((lib (assoc-ref outputs "lib"))
307 (libbin (string-append lib "/bin")))
308 (mkdir-p libbin)
309 (install-file (string-append %output "/bin/cube-config") libbin)
310 (install-file (string-append %output "/bin/cube-config-backend")
311 libbin)
312 (substitute* (list (string-append libbin "/cube-config"))
313 (("^source .*frontend.*$") "")
314 (((assoc-ref outputs "out")) lib))
315 #t))))))
316 (home-page "http://www.scalasca.org/software/cube-4.x/download.html")
317 (synopsis "Performance report explorer for parallel programs")
318 (description
319 "CUBE (CUBE Uniform Behavioral Encoding) is a tool to display a variety
320 of performance metrics for parallel programs including MPI and OpenMP
321 applications. CUBE allows interactive exploration of a multidimensional
322 performance space in a scalable fashion. Scalability is achieved in two ways:
323 hierarchical decomposition of individual dimensions and aggregation across
324 different dimensions. All performance metrics are uniformly accommodated in
325 the same display and thus provide the ability to easily compare the effects of
326 different kinds of performance behavior.")
327 (license license:bsd-3)))
328
329 (define (make-scorep mpi)
330 (package
331 (name (string-append "scorep-" (package-name mpi)))
332 (version "3.1")
333 (source (origin
334 (method url-fetch)
335 (uri (string-append
336 "http://www.vi-hps.org/upload/packages/scorep/scorep-"
337 version ".tar.gz"))
338 (sha256
339 (base32
340 "0h45357djna4dn9jyxx0n36fhhms3jrf22988m9agz1aw2jfivs9"))
341 (modules '((guix build utils)))
342 (snippet
343 ;; Remove bundled software.
344 '(begin
345 (for-each delete-file-recursively
346 '("vendor/opari2" "vendor/cube"))
347 #t))))
348 (build-system gnu-build-system)
349 (inputs
350 `(("mpi" ,mpi)
351 ("papi" ,papi)
352 ("opari2" ,opari2)
353 ("libunwind" ,libunwind)
354 ("otf2" ,otf2)
355 ("cubelib" ,cube "lib") ;for lib, include
356 ("openmpi" ,openmpi)
357 ("zlib" ,zlib)))
358 (native-inputs
359 `(("gfortran" ,gfortran)
360 ("flex" ,flex)
361 ("cube" ,cube) ;for cube-config
362 ("bison" ,bison)
363 ("python" ,python)
364 ("doxygen" ,doxygen)
365 ("which" ,which)))
366 (arguments
367 `(#:configure-flags
368 (list "--enable-shared" "--disable-static"
369 (string-append "--with-opari2="
370 (assoc-ref %build-inputs "opari2"))
371 (string-append "--with-cube="
372 (assoc-ref %build-inputs "cube")))
373 #:parallel-tests? #f
374 #:make-flags '("V=1")
375 #:phases
376 (modify-phases %standard-phases
377 (add-after 'install 'licence
378 (lambda* (#:key outputs #:allow-other-keys)
379 (let ((doc (string-append (assoc-ref outputs "out")
380 "/share/doc/scorep")))
381 (install-file "COPYING" doc)
382 #t))))))
383 (home-page "http://www.vi-hps.org/projects/score-p/")
384 (synopsis "Performance measurement infrastructure for parallel code")
385 (description
386 "The Score-P (Scalable Performance Measurement Infrastructure for
387 Parallel Codes) measurement infrastructure is a scalable and easy-to-use tool
388 suite for profiling, event trace recording, and online analysis of
389 high-performance computing (HPC) applications.")
390 (license license:cpl1.0)))
391
392 (define-public scorep-openmpi (make-scorep openmpi))