gnu: nftables: Update to 0.8.
[jackhill/guix/guix.git] / gnu / packages / medical.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017 Quiliro <quiliro@fsfla.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages medical)
21 #:use-module (guix build-system python)
22 #:use-module (guix download)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (gnu packages python)
26 #:use-module (gnu packages qt))
27
28 (define-public openmolar-1
29 (package
30 (name "openmolar")
31 (version "1.0.15-gd81f9e5")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append
35 "https://static.openmolar.com/om1/releases/openmolar-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "1cfdzfbi6wslw7k0dc6ad6xrgs75iwsl91cg73w4myswaqqkfk3z"))))
40 (build-system python-build-system)
41 (arguments
42 `(#:use-setuptools? #f
43 #:phases
44 (modify-phases %standard-phases
45 (add-after 'unpack 'patch-/usr
46 (lambda* (#:key outputs #:allow-other-keys)
47 (substitute* "setup.py"
48 (("/usr") (assoc-ref outputs "out")))
49 #t)))))
50 (inputs
51 `(("python-pyqt+qscintilla" ,python-pyqt+qscintilla)
52 ("python-mysqlclient" ,python-mysqlclient)
53 ("qscintilla" ,qscintilla)))
54 (home-page "https://openmolar.com/om1")
55 (synopsis "Dental practice management software")
56 (description "Openmolar is a dental practice management suite. Its
57 functionality includes appointments, patient records, treatment planning,
58 billing etc. It is a full featured, reliable and thoroughly tested
59 application and has been translated into many languages.")
60 (license gpl3+)))