gnu: nftables: Update to 0.8.
[jackhill/guix/guix.git] / gnu / packages / dunst.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages dunst)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (gnu packages base)
25 #:use-module (gnu packages freedesktop)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages xorg))
31
32 (define-public dunst
33 (package
34 (name "dunst")
35 (version "1.2.0")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "https://github.com/dunst-project/dunst/archive/v"
40 version ".tar.gz"))
41 (file-name (string-append name "-" version ".tar.gz"))
42 (sha256
43 (base32
44 "1bf5fmmj79wlwi8wzir3rd8czyrxfx16w8q7c957123yz1g5ph53"))))
45 (build-system gnu-build-system)
46 (arguments
47 '(#:tests? #f ; no check target
48 #:make-flags (list "CC=gcc"
49 (string-append "PREFIX=" %output))
50 #:phases (modify-phases %standard-phases
51 (delete 'configure))))
52 (native-inputs
53 `(("pkg-config" ,pkg-config)
54 ("perl" ,perl) ; for pod2man
55 ("which" ,which)))
56 (inputs
57 `(("dbus" ,dbus)
58 ("glib" ,glib)
59 ("gtk" ,gtk+-2)
60 ("cairo" ,cairo)
61 ("pango" ,pango)
62 ("libx11" ,libx11)
63 ("libxscrnsaver" ,libxscrnsaver)
64 ("libxinerama" ,libxinerama)
65 ("libxrandr" ,libxrandr)
66 ("libxdg-basedir" ,libxdg-basedir)))
67 (home-page "https://dunst-project.org/")
68 (synopsis "Customizable and lightweight notification daemon")
69 (description
70 "Dunst is a highly configurable and minimalistic notification daemon.
71 It provides 'org.freedesktop.Notifications' D-Bus service, so it is
72 started automatically on the first call via D-Bus.")
73 (license license:bsd-3)))