gnu: nftables: Update to 0.8.
[jackhill/guix/guix.git] / gnu / packages / augeas.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages augeas)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages readline)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages xml))
30
31 (define-public augeas
32 (package
33 (name "augeas")
34 (version "1.8.1")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "http://download.augeas.net/augeas-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "1yf93fqwav1zsl8dpyfkf0g11w05mmfckqy6qsjy5zkklnspbkv5"))))
42 (build-system gnu-build-system)
43 ;; Marked as "required" in augeas.pc
44 (propagated-inputs
45 `(("libxml2" ,libxml2)))
46 (inputs
47 `(("readline" ,readline)))
48 (native-inputs
49 `(("pkg-config" ,pkg-config)))
50 (home-page "http://augeas.net/")
51 (synopsis "Edit configuration files programmatically")
52 (description
53 "Augeas is a library and command line tool for programmatically editing
54 configuration files in a controlled manner. Augeas exposes a tree of all
55 configuration settings and a simple local API for manipulating the tree.
56 Augeas then modifies underlying configuration files according to the changes
57 that have been made to the tree; it does as little modeling of configurations
58 as possible, and focuses exclusivley on transforming the tree-oriented syntax
59 of its public API to the myriad syntaxes of individual configuration files.")
60 (license license:lgpl2.1+)))