gnu: sdl2-mixer: Fix configure flags.
[jackhill/guix/guix.git] / gnu / packages / sdl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015, 2017 David Thompson <dthompson2@worcester.edu>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015, 2017 Sou Bunnbu <iyzsong@member.fsf.org>
5 ;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
6 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
8 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
11 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
12 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
13 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
14 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages sdl)
32 #:use-module (ice-9 match)
33 #:use-module (srfi srfi-1)
34 #:use-module (srfi srfi-26)
35 #:use-module (gnu packages)
36 #:use-module ((guix licenses) #:hide (freetype))
37 #:use-module (guix packages)
38 #:use-module (guix download)
39 #:use-module (guix git-download)
40 #:use-module (guix utils)
41 #:use-module (guix build-system gnu)
42 #:use-module (guix build-system trivial)
43 #:use-module (gnu packages audio)
44 #:use-module (gnu packages fcitx)
45 #:use-module (gnu packages fontutils)
46 #:use-module (gnu packages freedesktop)
47 #:use-module (gnu packages glib)
48 #:use-module (gnu packages guile)
49 #:use-module (gnu packages ibus)
50 #:use-module (gnu packages image)
51 #:use-module (gnu packages linux)
52 #:use-module (gnu packages mono)
53 #:use-module (gnu packages mp3)
54 #:use-module (gnu packages pkg-config)
55 #:use-module (gnu packages pulseaudio)
56 #:use-module (gnu packages gl)
57 #:use-module (gnu packages xdisorg)
58 #:use-module (gnu packages xiph)
59 #:use-module (gnu packages xorg)
60 #:export (sdl-union))
61
62 (define-public sdl
63 (package
64 (name "sdl")
65 (version "1.2.15")
66 (source (origin
67 (method url-fetch)
68 (uri
69 (string-append "https://libsdl.org/release/SDL-"
70 version ".tar.gz"))
71 (sha256
72 (base32
73 "005d993xcac8236fpvd1iawkz4wqjybkpn8dbwaliqz5jfkidlyn"))
74 (patches (search-patches "sdl-libx11-1.6.patch"))))
75 (build-system gnu-build-system)
76 (arguments
77 '(;; Explicitly link against shared libraries instead of dlopening them.
78 ;; For X11, ALSA, and PulseAudio.
79 ;; OpenGL library is still dlopened at runtime.
80 #:configure-flags '("--disable-alsa-shared"
81 "--disable-pulseaudio-shared"
82 "--disable-x11-shared"
83 ;; Explicitly link with mesa.
84 ;; This add mesa to libsdl's RUNPATH, to make dlopen
85 ;; finding the libGL from mesa at runtime.
86 "LDFLAGS=-lGL")
87
88 #:make-flags '("V=1") ;build verbosely
89
90 #:tests? #f)) ; no check target
91 (propagated-inputs
92 ;; SDL headers include X11 headers.
93 `(("libx11" ,libx11)
94 ("libcap" ,libcap) ; 'libSDL.la' contain `-lcap'.
95 ;; TODO: Since building Mesa with Meson it is now necessary that Mesa is
96 ;; a propogated input. We still need to figure out why, possibly due to a
97 ;; change in pkg-config.
98 ("mesa" ,mesa)))
99 (native-inputs `(("pkg-config" ,pkg-config)))
100 (inputs `(("libxrandr" ,libxrandr)
101 ("glu" ,glu)
102 ("alsa-lib" ,alsa-lib)
103 ("pulseaudio" ,pulseaudio)))
104 (outputs '("out" "debug"))
105 (synopsis "Cross platform game development library")
106 (description "Simple DirectMedia Layer is a cross-platform development
107 library designed to provide low level access to audio, keyboard, mouse,
108 joystick, and graphics hardware.")
109 (home-page "https://libsdl.org/")
110 (license lgpl2.1)))
111
112 (define-public sdl2
113 (package (inherit sdl)
114 (name "sdl2")
115 (version "2.0.10")
116 (source (origin
117 (method url-fetch)
118 (uri
119 (string-append "https://libsdl.org/release/SDL2-"
120 version ".tar.gz"))
121 (patches (search-patches "sdl2-mesa-compat.patch"))
122 (sha256
123 (base32
124 "0mqxp6w5jhbq6y1j690g9r3gpzwjxh4czaglw8x05l7hl49nqrdl"))))
125 (arguments
126 (substitute-keyword-arguments (package-arguments sdl)
127 ((#:configure-flags flags)
128 `(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
129 "--disable-kmsdrm-shared")
130 ,flags))
131 ((#:make-flags flags ''())
132 ;; Add the Fcitx header files to GCCs "system header" search path
133 ;; in order to suppress compiler warnings induced by those:
134 ;; .../include/fcitx-utils/utarray.h:178:9: error: ISO C90 forbids
135 ;; mixed declarations and code [-Werror=declaration-after-statement]
136 `(append (list (string-append "C_INCLUDE_PATH="
137 (assoc-ref %build-inputs "fcitx")
138 "/include"))
139 ,flags))))
140 (inputs
141 ;; SDL2 needs to be built with ibus support otherwise some systems
142 ;; experience a bug where input events are doubled.
143 ;;
144 ;; For more information, see: https://dev.solus-project.com/T1721
145 (append `(("dbus" ,dbus)
146 ("fcitx" ,fcitx) ; helps with CJK input
147 ("glib" ,glib)
148 ("ibus" ,ibus)
149 ("libxkbcommon" ,libxkbcommon)
150 ("libxcursor" ,libxcursor) ; enables X11 cursor support
151 ("wayland" ,wayland)
152 ("wayland-protocols" ,wayland-protocols))
153 (package-inputs sdl)))
154 (license bsd-3)))
155
156 (define-public libmikmod
157 (package
158 (name "libmikmod")
159 (version "3.3.11.1")
160 (source (origin
161 (method url-fetch)
162 (uri (list
163 (string-append "mirror://sourceforge/mikmod/libmikmod/"
164 version "/libmikmod-" version ".tar.gz")
165 ;; Older versions are sometimes moved to:
166 (string-append "mirror://sourceforge/mikmod/"
167 "outdated_versions/libmikmod/"
168 version "/libmikmod-" version ".tar.gz")))
169 (sha256
170 (base32
171 "06bdnhb0l81srdzg6gn2v2ydhhaazza7rshrcj3q8dpqr3gn97dd"))))
172 (build-system gnu-build-system)
173 (arguments
174 ;; By default, libmikmod tries to dlopen libasound etc., which won't work
175 ;; unless the right libalsa happens to be in $LD_LIBRARY_PATH. Pass
176 ;; '--disable-dl' to avoid that.
177 '(#:configure-flags '("--disable-dl")))
178 (synopsis "Library for module sound formats")
179 (description
180 "MikMod is able to play a wide range of module formats, as well as
181 digital sound files. It can take advantage of particular features of your
182 system, such as sound redirection over the network.")
183 (license lgpl2.1)
184 (home-page "http://mikmod.sourceforge.net/")))
185
186 (define-public sdl-gfx
187 (package
188 (name "sdl-gfx")
189 (version "2.0.26")
190 (source (origin
191 (method url-fetch)
192 (uri
193 (string-append "http://www.ferzkopp.net/Software/SDL_gfx-2.0/SDL_gfx-"
194 version ".tar.gz"))
195 (sha256
196 (base32
197 "0ijljhs0v99dj6y27hc10z6qchyp8gdp4199y6jzngy6dzxlzsvw"))))
198 (build-system gnu-build-system)
199 (outputs '("out" "debug"))
200 (arguments
201 `(,@(if (any (cute string-prefix? <> (or (%current-system)
202 (%current-target-system)))
203 '("x86_64" "i686"))
204 ;; mmx is supported only on Intel processors.
205 '()
206 '(#:configure-flags '("--disable-mmx")))))
207 (propagated-inputs `(("sdl" ,sdl)))
208 (synopsis "SDL graphics primitives library")
209 (description "SDL_gfx provides graphics drawing primitives, rotozoom and
210 other supporting functions for SDL.")
211 (home-page "http://www.ferzkopp.net/joomla/software-mainmenu-14/4-ferzkopps-linux-software/19-sdlgfx")
212 (license zlib)))
213
214 (define-public sdl-image
215 (package
216 (name "sdl-image")
217 (version "1.2.12")
218 (source (origin
219 (method url-fetch)
220 (uri
221 (string-append "https://www.libsdl.org/projects/SDL_image/release/SDL_image-"
222 version ".tar.gz"))
223 (sha256
224 (base32
225 "16an9slbb8ci7d89wakkmyfvp7c0cval8xw4hkg0842nhhlp540b"))))
226 (build-system gnu-build-system)
227 (outputs '("out" "debug"))
228 (arguments
229 ;; Explicitly link against shared libraries instead of dlopening them.
230 '(#:configure-flags '("--disable-jpg-shared"
231 "--disable-png-shared"
232 "--disable-tif-shared"
233 "--disable-webp-shared")))
234 (native-inputs `(("pkg-config" ,pkg-config)))
235 ;; libjpeg, libpng, and libtiff are propagated inputs because the
236 ;; SDL_image headers include the headers of these libraries. SDL is a
237 ;; propagated input because the pkg-config file refers to SDL's pkg-config
238 ;; file.
239 (propagated-inputs `(("sdl" ,sdl)
240 ("libjpeg" ,libjpeg)
241 ("libpng" ,libpng)
242 ("libtiff" ,libtiff)
243 ("libwebp" ,libwebp)))
244 (synopsis "SDL image loading library")
245 (description "SDL_image is an image file loading library for SDL that
246 supports the following formats: BMP, GIF, JPEG, LBM, PCX, PNG, PNM, TGA, TIFF,
247 WEBP, XCF, XPM, and XV.")
248 (home-page "https://www.libsdl.org/projects/SDL_image/")
249 (license zlib)))
250
251 (define-public sdl-mixer
252 (package
253 (name "sdl-mixer")
254 (version "1.2.12")
255 (source (origin
256 (method url-fetch)
257 (uri
258 (string-append "https://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-"
259 version ".tar.gz"))
260 (sha256
261 (base32
262 "0alrhqgm40p4c92s26mimg9cm1y7rzr6m0p49687jxd9g6130i0n"))))
263 (build-system gnu-build-system)
264 (outputs '("out" "debug"))
265 ;; no check target
266 ;; use libmad instead of smpeg
267 ;; explicitly link against shared libraries instead of dlopening them
268 (arguments `(#:tests? #f
269 #:configure-flags '("--enable-music-mp3-mad-gpl"
270 "--disable-music-mod-shared"
271 "--disable-music-fluidsynth-shared"
272 "--disable-music-ogg-shared"
273 "--disable-music-flac-shared")))
274 (inputs `(("libvorbis" ,libvorbis)
275 ("libflac" ,flac)
276 ("libmad" ,libmad)
277 ("libmikmod" ,libmikmod)))
278 ;; FIXME: Add libfluidsynth
279 (propagated-inputs `(("sdl" ,sdl)))
280 (synopsis "SDL multi-channel audio mixer library")
281 (description "SDL_mixer is a multi-channel audio mixer library for SDL.
282 It supports any number of simultaneously playing channels of 16 bit stereo
283 audio, plus a single channel of music. Supported format include FLAC, MOD,
284 MIDI, Ogg Vorbis, and MP3.")
285 (home-page "https://www.libsdl.org/projects/SDL_mixer/")
286 (license zlib)))
287
288 (define-public sdl-net
289 (package
290 (name "sdl-net")
291 (version "1.2.8")
292 (source (origin
293 (method url-fetch)
294 (uri
295 (string-append "https://www.libsdl.org/projects/SDL_net/release/SDL_net-"
296 version ".tar.gz"))
297 (sha256
298 (base32
299 "1d5c9xqlf4s1c01gzv6cxmg0r621pq9kfgxcg3197xw4p25pljjz"))))
300 (build-system gnu-build-system)
301 (propagated-inputs `(("sdl" ,sdl)))
302 (native-inputs `(("pkg-config" ,pkg-config)))
303 (outputs '("out" "debug"))
304 (synopsis "SDL networking library")
305 (description "SDL_net is a small, cross-platform networking library for
306 SDL.")
307 (home-page "https://www.libsdl.org/projects/SDL_net/")
308 (license zlib)))
309
310 (define-public sdl-ttf
311 (package
312 (name "sdl-ttf")
313 (version "2.0.11")
314 (source (origin
315 (method url-fetch)
316 (uri
317 (string-append "https://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-"
318 version ".tar.gz"))
319 (sha256
320 (base32
321 "1dydxd4f5kb1288i5n5568kdk2q7f8mqjr7i7sd33nplxjaxhk3j"))))
322 (build-system gnu-build-system)
323 (propagated-inputs `(("sdl" ,sdl)))
324 (inputs `(("freetype" ,freetype)
325 ("mesa" ,mesa)))
326 (native-inputs `(("pkg-config" ,pkg-config)))
327 (outputs '("out" "debug"))
328 (synopsis "SDL TrueType font library")
329 (description "SDL_ttf is a TrueType font rendering library for SDL.")
330 (home-page "https://www.libsdl.org/projects/SDL_ttf/")
331 (license zlib)))
332
333 (define* (sdl-union #:optional (packages (list sdl sdl-gfx sdl-net sdl-ttf
334 sdl-image sdl-mixer)))
335 "Return 'sdl-union' package which is a union of PACKAGES.
336 If PACKAGES are not specified, all SDL packages are used."
337 (package
338 (name "sdl-union")
339 (version (package-version sdl))
340 (source #f)
341 (build-system trivial-build-system)
342 (arguments
343 '(#:modules ((guix build union))
344 #:builder (begin
345 (use-modules (ice-9 match)
346 (guix build union))
347 (match %build-inputs
348 (((names . directories) ...)
349 (union-build (assoc-ref %outputs "out")
350 directories)
351 #t)))))
352 (inputs (map (lambda (package)
353 (list (package-name package) package))
354 packages))
355 (synopsis "Union of SDL libraries")
356 (description
357 "A union of SDL and its extension libraries. A union is required because
358 sdl-config assumes that all of the headers and libraries are in the same
359 directory.")
360 (home-page (package-home-page sdl))
361 (license (package-license sdl))))
362
363 (define (propagated-inputs-with-sdl2 package)
364 "Replace the \"sdl\" propagated input of PACKAGE with SDL2."
365 (map (match-lambda
366 (("sdl" _)
367 `("sdl2" ,sdl2))
368 (other other))
369 (package-propagated-inputs package)))
370
371 (define-public sdl2-gfx
372 (package (inherit sdl-gfx)
373 (name "sdl2-gfx")
374 (version "1.0.4")
375 (source (origin
376 (method url-fetch)
377 (uri
378 (string-append "https://www.ferzkopp.net/Software/SDL2_gfx/SDL2_gfx-"
379 version ".tar.gz"))
380 (sha256
381 (base32
382 "0qk2ax7f7grlxb13ba0ll3zlm8780s7j8fmrhlpxzjgdvldf1q33"))))
383 (propagated-inputs
384 (propagated-inputs-with-sdl2 sdl-gfx))))
385
386 (define-public sdl2-image
387 (package (inherit sdl-image)
388 (name "sdl2-image")
389 (version "2.0.4")
390 (source
391 (origin
392 (method url-fetch)
393 (uri
394 (string-append "https://www.libsdl.org/projects/SDL_image/release/"
395 "SDL2_image-" version ".tar.gz"))
396 (sha256
397 (base32 "1b6f7002bm007y3zpyxb5r6ag0lml51jyvx1pwpj9sq24jfc8kp7"))))
398 (propagated-inputs
399 (propagated-inputs-with-sdl2 sdl-image))))
400
401 (define-public sdl2-mixer
402 (package (inherit sdl-mixer)
403 (name "sdl2-mixer")
404 (version "2.0.4")
405 (source
406 (origin
407 (method url-fetch)
408 (uri
409 (string-append "http://www.libsdl.org/projects/SDL_mixer/release/"
410 "SDL2_mixer-" version ".tar.gz"))
411 (modules '((guix build utils)))
412 (snippet '(begin
413 ;; Remove bundled libraries.
414 (delete-file-recursively "external")
415 #t))
416 (sha256
417 (base32 "0694vsz5bjkcdgfdra6x9fq8vpzrl8m6q96gh58df7065hw5mkxl"))))
418 (arguments
419 (substitute-keyword-arguments (package-arguments sdl-mixer)
420 ((#:configure-flags flags)
421 `(cons*
422 ;; These options were renamed in SDL2 mixer. Keeping the inherited
423 ;; variants produces a harmless warning.
424 "--disable-music-mod-modplug-shared"
425 "--disable-music-midi-fluidsynth-shared"
426 ,flags))))
427 (inputs
428 ;; The default MOD library changed in SDL2 mixer.
429 `(("libmodplug" ,libmodplug)
430 ,@(alist-delete "libmikmod" (package-inputs sdl-mixer))))
431 (propagated-inputs
432 (propagated-inputs-with-sdl2 sdl-mixer))))
433
434 (define-public sdl2-net
435 (package (inherit sdl-net)
436 (name "sdl2-net")
437 (version "2.0.1")
438 (source
439 (origin
440 (method url-fetch)
441 (uri
442 (string-append "http://www.libsdl.org/projects/SDL_net/release/"
443 "SDL2_net-" version ".tar.gz"))
444 (sha256
445 (base32
446 "08cxc1bicmyk89kiks7izw1rlx5ng5n6xpy8fy0zxni3b9z8mkhm"))))
447 (propagated-inputs
448 (propagated-inputs-with-sdl2 sdl-net))))
449
450 (define-public sdl2-ttf
451 (package (inherit sdl-ttf)
452 (name "sdl2-ttf")
453 (version "2.0.15")
454 (source (origin
455 (method url-fetch)
456 (uri
457 (string-append "https://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-"
458 version ".tar.gz"))
459 (modules '((guix build utils)))
460 (snippet (begin
461 ;; Remove bundled libraries.
462 '(delete-file-recursively "external")
463 #t))
464 (sha256
465 (base32
466 "0cyd48dipc0m399qy8s03lci8b0bpiy8xlkvrm2ia7wcv0dfpv59"))))
467 (propagated-inputs
468 (propagated-inputs-with-sdl2 sdl-ttf))))
469
470 (define-public guile-sdl
471 (package
472 (name "guile-sdl")
473 (version "0.5.2")
474 (source (origin
475 (method url-fetch)
476 (uri
477 (string-append "mirror://gnu/guile-sdl/guile-sdl-"
478 version ".tar.xz"))
479 (sha256
480 (base32
481 "0cjgs012a9922hn6xqwj66w6qmfs3nycnm56hyykx5n3g5p7ag01"))))
482 (build-system gnu-build-system)
483 (native-inputs
484 `(("pkg-config" ,pkg-config)
485 ;; Required by test suite.
486 ("xorg-server" ,xorg-server)
487 ("libjpeg" ,libjpeg)))
488 (inputs
489 `(("guile" ,guile-2.2)
490 ("sdl-union" ,(sdl-union))))
491 (arguments
492 '(#:configure-flags
493 (list (string-append "--with-sdl-prefix="
494 (assoc-ref %build-inputs "sdl-union")))
495 #:modules ((ice-9 popen)
496 (guix build utils)
497 (guix build gnu-build-system))
498
499 #:parallel-build? #f ; parallel build fails
500
501 #:phases
502 (modify-phases %standard-phases
503 (add-before 'configure 'fix-env-and-patch
504 (lambda* (#:key inputs #:allow-other-keys)
505 (setenv "GUILE_AUTO_COMPILE" "0")
506 ;; SDL_image needs to dlopen libjpeg in the test suite.
507 (setenv "LD_LIBRARY_PATH"
508 (string-append (assoc-ref inputs "libjpeg") "/lib"))
509
510 ;; Change the site directory /site/X.Y like Guile expects.
511 (substitute* "build-aux/guile-baux/re-prefixed-site-dirs"
512 (("\"/site\"")
513 (let ((effective
514 (read
515 (open-pipe* OPEN_READ
516 "guile" "-c"
517 "(write (effective-version))"))))
518 (string-append "\"/site/" effective "\""))))
519
520 ;; Skip tests that rely on sound support, which is unavailable in
521 ;; the build environment.
522 (substitute* "test/Makefile.in"
523 (("HAVE_MIXER = .*$")
524 "HAVE_MIXER = 0\n"))
525 #t))
526 (add-before 'check 'start-xorg-server
527 (lambda* (#:key inputs #:allow-other-keys)
528 ;; The test suite requires a running X server.
529 (system (format #f "~a/bin/Xvfb :1 &"
530 (assoc-ref inputs "xorg-server")))
531 (setenv "DISPLAY" ":1")
532 #t))
533 (add-before 'check 'skip-cursor-test
534 (lambda _
535 ;; XXX: This test sometimes enters an endless loop, and sometimes
536 ;; crashes with:
537 ;; guile: xcb_io.c:147: append_pending_request: Assertion `!xcb_xlib_unknown_seq_number' failed.
538 ;; Skip it.
539 (substitute* "test/cursor.scm"
540 (("\\(SDL:init .*" all)
541 (string-append "(exit 77) ;" all "\n")))
542 #t)))))
543 (synopsis "Guile interface for SDL (Simple DirectMedia Layer)")
544 (description "Guile-SDL is a set of bindings to the Simple DirectMedia
545 Layer (SDL). With them, Guile programmers can have easy access to graphics,
546 sound and device input (keyboards, joysticks, mice, etc.).")
547 (home-page "https://www.gnu.org/software/guile-sdl/")
548 (license gpl3+)))
549
550 (define-public guile-sdl2
551 (package
552 (name "guile-sdl2")
553 (version "0.4.0")
554 (source (origin
555 (method url-fetch)
556 (uri (string-append "https://files.dthompson.us/guile-sdl2/"
557 "guile-sdl2-" version ".tar.gz"))
558 (sha256
559 (base32
560 "0zcxwgyadwpbhq6h5mv2569c3kalgra26zc186y9fqiyyzmh1v9s"))))
561 (build-system gnu-build-system)
562 (arguments
563 '(#:make-flags '("GUILE_AUTO_COMPILE=0")
564 #:configure-flags
565 (list (string-append "--with-libsdl2-prefix="
566 (assoc-ref %build-inputs "sdl2"))
567 (string-append "--with-libsdl2-image-prefix="
568 (assoc-ref %build-inputs "sdl2-image"))
569 (string-append "--with-libsdl2-ttf-prefix="
570 (assoc-ref %build-inputs "sdl2-ttf"))
571 (string-append "--with-libsdl2-mixer-prefix="
572 (assoc-ref %build-inputs "sdl2-mixer")))))
573 (native-inputs
574 `(("guile" ,guile-2.2)
575 ("pkg-config" ,pkg-config)))
576 (inputs
577 `(("sdl2" ,sdl2)
578 ("sdl2-image" ,sdl2-image)
579 ("sdl2-mixer" ,sdl2-mixer)
580 ("sdl2-ttf" ,sdl2-ttf)))
581 (synopsis "Guile bindings for SDL2")
582 (home-page "https://dthompson.us/projects/guile-sdl2.html")
583 (description
584 "Guile-SDL2 provides Guile Scheme bindings for the SDL2 C shared library.
585 The bindings are written in pure Scheme using Guile's foreign function
586 interface.")
587 (license lgpl3+)))
588
589 (define-public sdl2-cs
590 (let ((commit "1a3556441e1394eb0b5d46aeb514b8d1090b93f8"))
591 (package
592 (name "sdl2-cs")
593 (version (git-version "B1" "1" commit))
594 (source (origin
595 (method git-fetch)
596 (uri (git-reference
597 (url "https://github.com/flibitijibibo/SDL2-CS")
598 (commit commit)))
599 (file-name (git-file-name name version))
600 (sha256
601 (base32
602 "007mzkqr9nmvfrvvhs2r6cm36lzgsww24kwshsz9c4fd97f9qk58"))))
603 (build-system gnu-build-system)
604 (arguments
605 '(#:tests? #f ; No tests.
606 #:phases
607 (modify-phases %standard-phases
608 (delete 'configure)
609 (replace 'build
610 (lambda _
611 (invoke "make" "release")))
612 (replace 'install
613 (lambda* (#:key outputs #:allow-other-keys)
614 (let ((out (assoc-ref outputs "out")))
615 (install-file "bin/Release/SDL2-CS.dll" (string-append out "/lib"))
616 #t))))))
617 (native-inputs
618 `(("mono" ,mono)))
619 (inputs
620 `(("sdl2" ,sdl2)
621 ("sdl2-image" ,sdl2-image)
622 ("sdl2-mixer" ,sdl2-mixer)
623 ("sdl2-ttf" ,sdl2-ttf)))
624 (home-page "https://dthompson.us/projects/guile-sdl2.html")
625 (synopsis "C# wrapper for SDL2")
626 (description
627 "SDL2-CS provides C# bindings for the SDL2 C shared library.
628 The C# wrapper was written to be used for FNA's platform support. However, this
629 is written in a way that can be used for any general C# application.")
630 (license zlib))))