Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / onc-rpc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
4 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages onc-rpc)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages autotools)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages kerberos)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (guix build-system gnu))
32
33 (define-public libtirpc
34 (package
35 (name "libtirpc")
36 (version "1.0.3")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
40 version "/libtirpc-"
41 version ".tar.bz2"))
42 (sha256
43 (base32
44 "0ppxl3k3nsz0qdakq844i2kj4fvh9h937lhx26bgmpmxq67sghw6"))))
45 (build-system gnu-build-system)
46 (arguments
47 `(#:phases
48 (modify-phases %standard-phases
49 (add-after 'unpack 'remote-dangling-symlink
50 (lambda _
51 (substitute* '("man/netconfig.5"
52 "man/getnetconfig.3t"
53 "man/getnetpath.3t"
54 "man/rpc.3t"
55 "src/getnetconfig.c"
56 "tirpc/netconfig.h")
57 (("/etc/netconfig") (string-append %output "/etc/netconfig")))
58
59 ;; Remove the dangling symlinks since it breaks the
60 ;; 'patch-source-shebangs' file tree traversal.
61 (delete-file "INSTALL")
62 #t)))))
63 (inputs `(("mit-krb5" ,mit-krb5)))
64 (home-page "https://sourceforge.net/projects/libtirpc/")
65 (synopsis "Transport-independent Sun/ONC RPC implementation")
66 (description
67 "This package provides a library that implements the Sun/ONC RPC (remote
68 procedure calls) protocol in a transport-independent manner. It supports both
69 IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
70 (license bsd-3)))
71
72 (define-public rpcbind
73 (package
74 (name "rpcbind")
75 (version "0.2.4")
76 (source
77 (origin
78 (method url-fetch)
79 (uri (string-append "mirror://sourceforge/" name "/" name "/"
80 version "/"
81 name "-" version ".tar.bz2"))
82 (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
83 (sha256
84 (base32
85 "0rjc867mdacag4yqvs827wqhkh27135rp9asj06ixhf71m9rljh7"))))
86 (build-system gnu-build-system)
87 (arguments
88 `(#:configure-flags
89 `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
90 (inputs
91 `(("libnsl" ,libnsl)
92 ("libtirpc" ,libtirpc)))
93 (native-inputs
94 `(("pkg-config" ,pkg-config)))
95 (home-page "http://rpcbind.sourceforge.net/")
96 (synopsis "Server to convert RPC program numbers into universal addresses")
97 (description
98 "@command{Rpcbind} is a server that converts RPC program numbers into
99 universal addresses.")
100 (license bsd-3)))
101
102
103 (define-public libnsl
104 (package
105 (name "libnsl")
106 (version "1.2.0")
107 (source (origin
108 (method url-fetch)
109 (uri (string-append "https://github.com/thkukuk/libnsl/archive/v"
110 version ".tar.gz"))
111 (file-name (string-append name "-" version ".tar.gz"))
112 (sha256
113 (base32
114 "1y6kmxmv1difzvdhx7grqzw0j2v2b74mg4kjb803m8jcgkqqx8m5"))))
115 (build-system gnu-build-system)
116 (native-inputs
117 `(("autoconf" ,autoconf)
118 ("automake" ,automake)
119 ("gettext" ,gettext-minimal)
120 ("libtool" ,libtool)
121 ("pkg-config" ,pkg-config)))
122 (inputs
123 `(("libtirpc" ,libtirpc)))
124 (synopsis "Public client interface for NIS(YP) and NIS+")
125 (description "Libnsl is the public client interface for the Network
126 Information Service / Yellow Pages (NIS/YP) and NIS+. It includes IPv6 support.
127 This library was part of glibc < 2.26, but is now distributed separately.")
128 (home-page "https://github.com/thkukuk/libnsl")
129 ;; The package is distributed under the LGPL 2.1. Some files in
130 ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
131 (license lgpl2.1)))