Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / avahi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages avahi)
22 #:use-module ((guix licenses) #:select (lgpl2.1+))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages databases)
28 #:use-module (gnu packages libdaemon)
29 #:use-module (gnu packages linux)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages xml))
33
34 (define-public avahi
35 (package
36 (name "avahi")
37 (version "0.7")
38 (home-page "http://avahi.org")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append home-page "/download/avahi-"
42 version ".tar.gz"))
43 (sha256
44 (base32
45 "0128n7jlshw4bpx0vg8lwj8qwdisjxi7mvniwfafgnkzzrfrpaap"))
46 (patches (search-patches "avahi-localstatedir.patch"))))
47 (build-system gnu-build-system)
48 (arguments
49 '(#:configure-flags '("--with-distro=none"
50 "--localstatedir=/var" ; for the DBus socket
51 "--disable-python"
52 "--disable-mono"
53 "--disable-doxygen-doc"
54 "--disable-xmltoman"
55 "--enable-tests"
56 "--disable-qt3" "--disable-qt4"
57 "--disable-gtk" "--disable-gtk3"
58 "--enable-compat-libdns_sd")))
59 (inputs
60 `(("expat" ,expat)
61 ("glib" ,glib)
62 ("dbus" ,dbus)
63 ("gdbm" ,gdbm)
64 ("libcap" ,libcap) ;to enable chroot support in avahi-daemon
65 ("libdaemon" ,libdaemon)))
66 (native-inputs
67 `(("intltool" ,intltool)
68 ("glib" ,glib "bin")
69 ("pkg-config" ,pkg-config)))
70 (synopsis "Implementation of mDNS/DNS-SD protocols")
71 (description
72 "Avahi is a system which facilitates service discovery on a local
73 network. It is an implementation of the mDNS (for \"Multicast DNS\") and
74 DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
75 (license lgpl2.1+)))
76
77 (define-public nss-mdns
78 (package
79 (name "nss-mdns")
80 (version "0.12")
81 (home-page "https://github.com/lathiat/nss-mdns")
82 (source (origin
83 (method url-fetch)
84 (uri (string-append home-page "/releases/download/v" version "/"
85 name "-" version ".tar.gz"))
86 (sha256
87 (base32
88 "1p2vj9fz4kzrjrj81ipf4qwgnr2n7a8cbzw4bpk18xyqhdx8h775"))
89 (patches
90 (list (origin
91 ;; See
92 ;; <https://github.com/lathiat/nss-mdns/issues/26#issuecomment-364781799>.
93 (uri (string-append
94 home-page
95 "/commit/31ccbec3b4f054e590c7c880d8a8a50cfc97127d.patch"))
96 (sha256
97 (base32
98 "0b1jmhnkpsczbph4ala7x3rafwxdg93277s30iaxh37jnvgjnhsd"))
99 (method url-fetch))))))
100 (build-system gnu-build-system)
101 (arguments
102 '(#:phases (modify-phases %standard-phases
103 (add-after 'unpack 'set-avahi-socket-name
104 (lambda _
105 ;; The Avahi daemon socket is expected by
106 ;; src/Makefile.am to be at
107 ;; "$(localstatedir)/run/avahi-daemon/socket", but
108 ;; nowadays it lives in /run/avahi-daemon/socket.
109 ;; Remove the "$(localstatedir)" bit.
110 (substitute* "src/Makefile.in"
111 (("\\$\\(localstatedir)/run/avahi-daemon/socket")
112 "/run/avahi-daemon/socket"))
113 #t)))))
114 (synopsis "Multicast DNS Name Service Switch (@dfn{NSS}) plug-in")
115 (description
116 "Nss-mdns is a plug-in for the GNU C Library's Name Service Switch
117 (@dfn{NSS}) that resolves host names via multicast DNS (@dfn{mDNS}). It is
118 most often used in home and other small networks without a local name server,
119 to resolve host names in the @samp{.local} top-level domain.")
120 (license lgpl2.1+)))