gnu: abseil-cpp: Patch sterror_test.
[jackhill/guix/guix.git] / gnu / packages / patches / icecat-makeicecat.patch
1 Make some of the changes needed to the 'makeicecat' script, to allow it to run
2 in a snippet without network access. After this patch is applied, some
3 additional changes will be made using 'substitute*'.
4
5 diff --git a/makeicecat b/makeicecat
6 index 8be2362..48716f2 100755
7 --- a/makeicecat
8 +++ b/makeicecat
9 @@ -31,55 +31,55 @@ SOURCEDIR=icecat-$FFVERSION
10
11 DATA="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"/data
12
13 -mkdir -p output
14 -cd output
15 +# mkdir -p output
16 +# cd output
17
18 ###############################################################################
19 # Retrieve FF source code
20 ###############################################################################
21
22 -rm mozilla-esr${FFMAJOR} $SOURCEDIR -rf
23 -
24 -wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz
25 -wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
26 -gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
27 -gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
28 -echo -n 1aa041db28cd742e93d663a9da8defd33040b38d8b9470350538473251621643 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
29 -
30 -echo Extracting Firefox tarball
31 -tar -xf firefox-${FFVERSION}esr.source.tar.xz
32 -
33 -mv firefox-${FFVERSION} $SOURCEDIR
34 +# rm mozilla-esr${FFMAJOR} $SOURCEDIR -rf
35 +#
36 +# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz
37 +# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
38 +# gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
39 +# gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
40 +# echo -n 1aa041db28cd742e93d663a9da8defd33040b38d8b9470350538473251621643 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
41 +#
42 +# echo Extracting Firefox tarball
43 +# tar -xf firefox-${FFVERSION}esr.source.tar.xz
44 +#
45 +# mv firefox-${FFVERSION} $SOURCEDIR
46
47 ###############################################################################
48 # Retrieve l10n
49 ###############################################################################
50
51 -mkdir l10n
52 -cd l10n
53 -while read line;do
54 - line=$(echo $line |cut -d' ' -f1)
55 - #[ $line = "es-ES" ] || continue # To speed up testing
56 - [ $line = "en-US" ] && continue
57 - hg clone https://hg.mozilla.org/l10n-central/$line
58 - mkdir -p $line/browser/chrome/browser/preferences
59 - touch $line/browser/chrome/browser/preferences/advanced-scripts.dtd
60 - rm -rf $line/.hg*
61 -done < ../$SOURCEDIR/browser/locales/shipped-locales
62 -cd ..
63 -
64 -mv l10n $SOURCEDIR
65 -
66 -hg clone https://hg.mozilla.org/l10n/compare-locales/
67 -cd compare-locales/
68 -hg checkout RELEASE_8_0_0
69 -cd ..
70 -rm compare-locales/.hg* compare-locales/.git* -rf
71 -mv compare-locales $SOURCEDIR/l10n
72 +# mkdir l10n
73 +# cd l10n
74 +# while read line;do
75 +# line=$(echo $line |cut -d' ' -f1)
76 +# #[ $line = "es-ES" ] || continue # To speed up testing
77 +# [ $line = "en-US" ] && continue
78 +# hg clone https://hg.mozilla.org/l10n-central/$line
79 +# mkdir -p $line/browser/chrome/browser/preferences
80 +# touch $line/browser/chrome/browser/preferences/advanced-scripts.dtd
81 +# rm -rf $line/.hg*
82 +# done < ../$SOURCEDIR/browser/locales/shipped-locales
83 +# cd ..
84 +#
85 +# mv l10n $SOURCEDIR
86 +#
87 +# hg clone https://hg.mozilla.org/l10n/compare-locales/
88 +# cd compare-locales/
89 +# hg checkout RELEASE_8_0_0
90 +# cd ..
91 +# rm compare-locales/.hg* compare-locales/.git* -rf
92 +# mv compare-locales $SOURCEDIR/l10n
93
94 #######################################################
95
96 -cd $SOURCEDIR
97 +# cd $SOURCEDIR
98
99 shopt -s nullglob
100 for patch in $DATA/patches/*.patch; do
101 @@ -598,6 +598,6 @@ sed 's/777/755/;' -i toolkit/crashreporter/google-breakpad/Makefile.in
102 # Fix CVE-2012-3386
103 /bin/sed 's/chmod a+w/chmod u+w/' -i ./js/src/ctypes/libffi/Makefile.in ./toolkit/crashreporter/google-breakpad/Makefile.in ./toolkit/crashreporter/google-breakpad/src/third_party/glog/Makefile.in || true
104
105 -cd ..
106 -echo Packaging tarball
107 -tar cfj icecat-$ICECATVERSION.tar.bz2 $SOURCEDIR
108 +# cd ..
109 +# echo Packaging tarball
110 +# tar cfj icecat-$ICECATVERSION.tar.bz2 $SOURCEDIR