gnu: freeipmi: Update to 1.4.10.
[jackhill/guix/guix.git] / gnu / packages / xiph.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
4 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
5 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
6 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages xiph)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages curl)
28 #:use-module (gnu packages doxygen)
29 #:use-module (gnu packages image)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages python)
32 #:use-module (gnu packages linux)
33 #:use-module (gnu packages pulseaudio)
34 #:use-module (gnu packages tls)
35 #:use-module (gnu packages xml)
36 #:use-module ((guix licenses) #:prefix license:)
37 #:use-module (guix packages)
38 #:use-module (guix download)
39 #:use-module (guix build-system gnu)
40 #:export (libogg
41 libvorbis
42 libtheora
43 speex
44 ao
45 flac
46 libkate
47 vorbis-tools
48 opus
49 opus-tools))
50
51 (define libogg
52 (package
53 (name "libogg")
54 (version "1.3.2")
55 (source (origin
56 (method url-fetch)
57 (uri (string-append "http://downloads.xiph.org/releases/ogg/libogg-"
58 version ".tar.xz"))
59 (sha256
60 (base32
61 "16z74q422jmprhyvy7c9x909li8cqzmvzyr8cgbm52xcsp6pqs1z"))))
62 (build-system gnu-build-system)
63 (synopsis "Library for manipulating the ogg multimedia format")
64 (description
65 "The libogg library allows to manipulate the ogg multimedia container
66 format, which encapsulates raw compressed data and allows the interleaving of
67 audio and video data. In addition to encapsulation and interleaving of
68 multiple data streams, ogg provides packet framing, error detection, and
69 periodic timestamps for seeking.")
70 (license (license:non-copyleft "file://COPYING"
71 "See COPYING in the distribution."))
72 (home-page "http://xiph.org/ogg/")))
73
74 (define libvorbis
75 (package
76 (name "libvorbis")
77 (version "1.3.5")
78 (source (origin
79 (method url-fetch)
80 (uri (string-append "http://downloads.xiph.org/releases/vorbis/"
81 "libvorbis-" version ".tar.xz"))
82 (sha256
83 (base32
84 "1lg1n3a6r41492r7in0fpvzc7909mc5ir9z0gd3qh2pz4yalmyal"))))
85 (build-system gnu-build-system)
86 (propagated-inputs `(("libogg" ,libogg)))
87 (arguments `(#:configure-flags '("LDFLAGS=-lm")
88 #:parallel-tests? #f))
89 (synopsis "Library implementing the vorbis audio format")
90 (description
91 "The libvorbis library implements the ogg vorbis audio format,
92 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
93 compressed audio format for mid to high quality (8kHz-48.0kHz, 16+ bit,
94 polyphonic) audio and music at fixed and variable bitrates from 16 to
95 128 kbps/channel.")
96 (license (license:non-copyleft "file://COPYING"
97 "See COPYING in the distribution."))
98 (home-page "http://xiph.org/vorbis/")))
99
100 (define libtheora
101 (package
102 (name "libtheora")
103 (version "1.1.1")
104 (source (origin
105 (method url-fetch)
106 (uri (string-append "http://downloads.xiph.org/releases/theora/"
107 "libtheora-" version ".tar.xz"))
108 (sha256
109 (base32
110 "0q8wark9ribij57dciym5vdikg2464p8q2mgqvfb78ksjh4s8vgk"))
111 (patches (list (search-patch "libtheora-config-guess.patch")))))
112 (build-system gnu-build-system)
113 (inputs `(("libvorbis" ,libvorbis)))
114 ;; The .pc files refer to libogg.
115 (propagated-inputs `(("libogg" ,libogg)))
116 (synopsis "Library implementing the Theora video format")
117 (description
118 "The libtheora library implements the ogg theora video format,
119 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
120 compressed video format.")
121 (license license:bsd-3)
122 (home-page "http://xiph.org/theora/")))
123
124 (define speex
125 (package
126 (name "speex")
127 (version "1.2rc1")
128 (source
129 (origin
130 (method url-fetch)
131 (uri (string-append "http://downloads.xiph.org/releases/speex/speex-"
132 version ".tar.gz"))
133 (sha256
134 (base32
135 "19mpkhbz3s08snvndn0h1dk2j139max6b0rr86nnsjmxazf30brl"))))
136 (build-system gnu-build-system)
137 (inputs `(("libogg" ,libogg)))
138 (home-page "https://gnu.org/software/speex")
139 (synopsis "Library for patent-free audio compression format")
140 (description
141 "GNU Speex is a patent-free audio compression codec specially designed
142 for speech. It is well-adapted to internet applications, such as VoIP. It
143 features compression of different bands in the same bitstream, intensity
144 stereo encoding, and voice activity detection.")
145 ;; 'src/getopt.c' is under LGPLv2+
146 (license (license:non-copyleft "file://COPYING"
147 "See COPYING in the distribution."))))
148
149 (define ao
150 (package
151 (name "ao")
152 (version "1.1.0")
153 (source
154 (origin
155 (method url-fetch)
156 (uri (string-append "http://downloads.xiph.org/releases/ao/libao-"
157 version ".tar.gz"))
158 (sha256
159 (base32
160 "1m0v2y6bhr4iwsgdkc7b3y0qgpvpv1ifbxsy8n8ahsvjn6wmppi9"))))
161 (build-system gnu-build-system)
162 ;; FIXME: Add further backends, see the summary printed after configure.
163 ;; XXX: Should back-ends be pushed to different outputs? For instance,
164 ;; "out" would include only the ALSA back-end, while "pulse" would
165 ;; contain 'lib/ao/plugins-4/libpulse.*'.
166 (inputs `(("pkg-config" ,pkg-config)
167 ("alsa-lib" ,alsa-lib)
168 ("pulseaudio" ,pulseaudio)))
169 (synopsis "Cross platform audio library")
170 (description
171 "Libao is a cross-platform audio library that allows programs to
172 output audio using a simple API on a wide variety of platforms.
173 It currently supports:
174 Null output (handy for testing without a sound device),
175 WAV files,
176 AU files,
177 RAW files,
178 OSS (Open Sound System, used on Linux and FreeBSD),
179 ALSA (Advanced Linux Sound Architecture),
180 aRts (Analog RealTime Synth, used by KDE),
181 PulseAudio (next generation GNOME sound server),
182 esd (EsounD or Enlightened Sound Daemon),
183 Mac OS X,
184 Windows (98 and later),
185 AIX,
186 Sun/NetBSD/OpenBSD,
187 IRIX,
188 NAS (Network Audio Server),
189 RoarAudio (Modern, multi-OS, networked Sound System),
190 OpenBSD's sndio.")
191 (license license:gpl2+)
192 (home-page "http://www.xiph.org/ao/")))
193
194 (define flac
195 (package
196 (name "flac")
197 (version "1.3.1")
198 (source (origin
199 (method url-fetch)
200 (uri (string-append "http://downloads.xiph.org/releases/flac/flac-"
201 version ".tar.xz"))
202 (sha256
203 (base32
204 "0v65w7ph6ldwp5a8fbhp0a3w8f737ck468fr7yb7sxmskl4w0ws7"))))
205 (build-system gnu-build-system)
206 (arguments
207 `(#:parallel-tests? #f))
208 ;; FIXME: configure also looks for xmms, input could be added once it exists
209 (propagated-inputs `(("libogg" ,libogg))) ; required by flac.pc
210 (synopsis "Free lossless audio codec")
211 (description
212 "FLAC stands for Free Lossless Audio Codec, an audio format that is lossless,
213 meaning that audio is compressed in FLAC without any loss in quality.")
214 (license (license:non-copyleft "file://COPYING"
215 "See COPYING in the distribution.")) ; and LGPL and GPL
216 (home-page "http://xiph.org/flac/")))
217
218 (define libkate
219 (package
220 (name "libkate")
221 (version "0.4.1")
222 (source (origin
223 (method url-fetch)
224 (uri (string-append "http://libkate.googlecode.com/files/libkate-"
225 version ".tar.gz"))
226 (sha256
227 (base32
228 "0s3vr2nxfxlf1k75iqpp4l78yf4gil3f0v778kvlngbchvaq23n4"))))
229 (build-system gnu-build-system)
230 (native-inputs `(("doxygen" ,doxygen)
231 ("pkg-config" ,pkg-config)))
232 ;; FIXME: Add optional input liboggz
233 (inputs `(("bison" ,bison)
234 ("libogg" ,libogg)
235 ("libpng" ,libpng)
236 ("python" ,python-wrapper)
237 ("zlib" ,zlib)))
238 (synopsis "Karaoke and text codec for embedding in ogg")
239 (description
240 "Kate is an overlay codec, originally designed for karaoke and text,
241 that can be multiplixed in Ogg. Text and images can be carried by a Kate
242 stream, and animated. Most of the time, this would be multiplexed with
243 audio/video to carry subtitles, song lyrics (with or without karaoke data),
244 etc., but doesn't have to be.
245
246 Series of curves (splines, segments, etc.) may be attached to various
247 properties (text position, font size, etc.) to create animated overlays.
248 This allows scrolling or fading text to be defined. This can even be used
249 to draw arbitrary shapes, so hand drawing can also be represented by a
250 Kate stream.")
251 (license license:bsd-3)
252 (home-page "http://code.google.com/p/libkate/")))
253
254 (define vorbis-tools
255 (package
256 (name "vorbis-tools")
257 (version "1.4.0")
258 (source (origin
259 (method url-fetch)
260 (uri (string-append "http://downloads.xiph.org/releases/vorbis/"
261 "vorbis-tools-" version ".tar.gz"))
262 (sha256
263 (base32
264 "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))))
265 (build-system gnu-build-system)
266 (inputs `(("ao" ,ao)
267 ("curl" ,curl)
268 ("flac" ,flac)
269 ("libkate" ,libkate)
270 ("libogg" ,libogg)
271 ("libvorbis" ,libvorbis)
272 ("speex" ,speex)))
273 (native-inputs `(("pkg-config" ,pkg-config)))
274 (synopsis "Ogg vorbis tools")
275 (description
276 "Ogg vorbis is a non-proprietary, patent-and-royalty-free,
277 general-purpose compressed audio format.
278
279 The package vorbis-tools contains
280 ogg123, an ogg vorbis command line audio player;
281 oggenc, the ogg vorbis encoder;
282 oggdec, a simple, portable command line decoder (to wav and raw);
283 ogginfo, to obtain information (tags, bitrate, length, etc.) about
284 an ogg vorbis file.")
285 (license license:gpl2)
286 (home-page "http://xiph.org/vorbis/")))
287
288 (define opus
289 (package
290 (name "opus")
291 (version "1.1")
292 (source (origin
293 (method url-fetch)
294 (uri (string-append
295 "http://downloads.xiph.org/releases/opus/opus-" version
296 ".tar.gz"))
297 (sha256
298 (base32
299 "158xprn2086arvdib3vbbygz7z6jqkw2nci7nlywzzwallap0wmr"))))
300 (build-system gnu-build-system)
301 (synopsis "Versatile audio codec")
302 (description
303 "Opus is a totally open, royalty-free, highly versatile audio codec. Opus
304 is unmatched for interactive speech and music transmission over the Internet,
305 but is also intended for storage and streaming applications. It is
306 standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
307 incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
308 (license license:bsd-3)
309 (home-page "http://www.opus-codec.org")))
310
311 (define opus-tools
312 (package
313 (name "opus-tools")
314 (version "0.1.9")
315 (source (origin
316 (method url-fetch)
317 (uri (string-append
318 "ftp://ftp.mozilla.org/pub/mozilla.org/opus/opus-tools-"
319 version ".tar.gz"))
320 (sha256
321 (base32
322 "0fk4nknvl111k89j5yckmyrh6b2wvgyhrqfncp7rig3zikbkv1xi"))))
323 (build-system gnu-build-system)
324 (arguments
325 ;; The package developers misuse pkg-config such that it doesn't work
326 ;; when cross compiling. Therefore we avoid it completly and set the
327 ;; necessary flags ourselves.
328 `(#:configure-flags (list (string-append "CFLAGS=-I"
329 (assoc-ref %build-inputs "libogg")
330 "/include -I"
331 (assoc-ref %build-inputs "opus")
332 "/include/opus"))))
333 (inputs `(("libogg" ,libogg)
334 ("opus" ,opus)
335 ("flac" ,flac)))
336 (synopsis
337 "Command line utilities to encode, inspect, and decode .opus files")
338 (description "Opus is a royalty-free, highly versatile audio codec.
339 Opus-tools provide command line utilities for creating, inspecting and
340 decoding .opus files.")
341 (license license:bsd-3)
342 (home-page "http://www.opus-codec.org")))
343
344 (define-public icecast
345 (package
346 (name "icecast")
347 (version "2.4.1")
348 (source (origin
349 (method url-fetch)
350 (uri (string-append
351 "http://downloads.xiph.org/releases/icecast/icecast-"
352 version ".tar.gz"))
353 (sha256
354 (base32
355 "0js5lylrgklhvvaksx46zc8lc975qb1bns8h1ms545nv071rxy23"))))
356 (build-system gnu-build-system)
357 (native-inputs
358 `(("pkg-config" ,pkg-config)))
359 (inputs
360 `(("libxslt" ,libxslt)
361 ("libxml2" ,libxml2)
362 ("openssl" ,openssl)
363 ("curl" ,curl)
364 ("libogg" ,libogg)
365 ("libvorbis" ,libvorbis)
366 ("libtheora" ,libtheora)
367 ("speex" ,speex)))
368 (synopsis "Streaming media server")
369 (description "Icecast is a streaming media server which currently supports
370 Ogg (Vorbis and Theora), Opus, WebM and MP3 audio streams. It can be used to
371 create an Internet radio station or a privately running jukebox and many
372 things in between.")
373 (home-page "http://icecast.org/")
374 (license license:gpl2)))
375
376 (define-public libshout
377 (package
378 (name "libshout")
379 (version "2.3.1")
380 (source (origin
381 (method url-fetch)
382 (uri (string-append
383 "http://downloads.xiph.org/releases/libshout/"
384 name "-" version ".tar.gz"))
385 (sha256
386 (base32
387 "0vlj4dxfxg06xhvv0z2zjjlrjh5di2m28w7v16zcygsy99mmyg6g"))))
388 (build-system gnu-build-system)
389 (native-inputs
390 `(("pkg-config" ,pkg-config)))
391 (propagated-inputs
392 ;; shout.pc refers to all these.
393 `(("libtheora" ,libtheora)
394 ("libvorbis" ,libvorbis)
395 ("speex" ,speex)))
396 (home-page "http://www.icecast.org/")
397 (synopsis "Audio streaming library for icecast encoders")
398 (description
399 "Libshout is a library for communicating with and sending data to an
400 icecast server. It handles the socket connection, the timing of the data,
401 and prevents bad data from getting to the icecast server.")
402 (license license:gpl2+)))