gnu: freeipmi: Update to 1.4.10.
[jackhill/guix/guix.git] / gnu / packages / language.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages language)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages perl)
22 #:use-module (gnu packages web)
23 #:use-module (guix packages)
24 #:use-module (guix build-system perl)
25 #:use-module ((guix licenses) #:select (gpl2 gpl3))
26 #:use-module (guix download))
27
28 (define-public perl-lingua-en-findnumber
29 (package
30 (name "perl-lingua-en-findnumber")
31 (version "1.30")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
36 "Lingua-EN-FindNumber-" version ".tar.gz"))
37 (sha256
38 (base32
39 "0g5h6bwwggizwh3dd3xyx92537s4qy8nspshp1lrm9qlxh3prc28"))))
40 (build-system perl-build-system)
41 (propagated-inputs
42 `(("perl-lingua-en-words2nums" ,perl-lingua-en-words2nums)))
43 (home-page "http://search.cpan.org/dist/Lingua-EN-FindNumber")
44 (synopsis "Locate (written) numbers in English text ")
45 (description "This module provides a regular expression for finding
46 numbers in English text. It also provides functions for extracting and
47 manipulating such numbers.")
48 (license (package-license perl))))
49
50 (define-public perl-lingua-en-inflect
51 (package
52 (name "perl-lingua-en-inflect")
53 (version "1.895")
54 (source
55 (origin
56 (method url-fetch)
57 (uri (string-append "mirror://cpan/authors/id/D/DC/DCONWAY/"
58 "Lingua-EN-Inflect-" version ".tar.gz"))
59 (sha256
60 (base32
61 "0drzg9a2dkjxgf00n6jg0jzhd8972bh3j4wdnmdxpqi3zmfqhwcy"))))
62 (build-system perl-build-system)
63 (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect")
64 (synopsis "Convert singular to plural")
65 (description "Lingua::EN::Inflect provides plural inflections,
66 \"a\"/\"an\" selection for English words, and manipulation of numbers as
67 words. Plural forms of all nouns, most verbs, and some adjectives are
68 provided. Where appropriate, \"classical\" variants (for example: \"brother\"
69 -> \"brethren\", \"dogma\" -> \"dogmata\", etc.) are also provided.")
70 (license (package-license perl))))
71
72 (define-public perl-lingua-en-inflect-number
73 (package
74 (name "perl-lingua-en-inflect-number")
75 (version "1.11")
76 (source
77 (origin
78 (method url-fetch)
79 (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
80 "Lingua-EN-Inflect-Number-" version ".tar.gz"))
81 (sha256
82 (base32
83 "0rvgrff96ja7fqr79dszmiyv2wz4izw82znah0mx9szkir657gfz"))))
84 (build-system perl-build-system)
85 (propagated-inputs
86 `(("perl-lingua-en-inflect" ,perl-lingua-en-inflect)))
87 (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect-Number")
88 (synopsis "Force number of words to singular or plural")
89 (description "This module extends the functionality of Lingua::EN::Inflect
90 with three new functions for determining plurality of a word and forcefully
91 converting a word to singular or plural.")
92 (license (package-license perl))))
93
94 (define-public perl-lingua-en-inflect-phrase
95 (package
96 (name "perl-lingua-en-inflect-phrase")
97 (version "0.18")
98 (source
99 (origin
100 (method url-fetch)
101 (uri (string-append "mirror://cpan/authors/id/R/RK/RKITOVER/"
102 "Lingua-EN-Inflect-Phrase-" version ".tar.gz"))
103 (sha256
104 (base32
105 "19prg6pkgnznrc82ymdkdi3l9schg815axjig7adca5yqa7mn2i9"))))
106 (build-system perl-build-system)
107 (native-inputs
108 `(("perl-test-nowarnings" ,perl-test-nowarnings)))
109 (propagated-inputs
110 `(("perl-lingua-en-findnumber" ,perl-lingua-en-findnumber)
111 ("perl-lingua-en-inflect" ,perl-lingua-en-inflect)
112 ("perl-lingua-en-inflect-number" ,perl-lingua-en-inflect-number)
113 ("perl-lingua-en-number-isordinal" ,perl-lingua-en-number-isordinal)
114 ("perl-lingua-en-tagger" ,perl-lingua-en-tagger)))
115 (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect-Phrase")
116 (synopsis "Inflect short English phrases")
117 (description "This module attempts to pluralize or singularize short
118 English phrases.")
119 (license (package-license perl))))
120
121 (define-public perl-lingua-en-number-isordinal
122 (package
123 (name "perl-lingua-en-number-isordinal")
124 (version "0.04")
125 (source
126 (origin
127 (method url-fetch)
128 (uri (string-append "mirror://cpan/authors/id/R/RK/RKITOVER/"
129 "Lingua-EN-Number-IsOrdinal-" version ".tar.gz"))
130 (sha256
131 (base32
132 "1321fm4pyqcamffd0qsjm1gb07ijqndlb29qkcqf22kaibngfm4i"))))
133 (build-system perl-build-system)
134 (native-inputs
135 `(("perl-try-tiny" ,perl-try-tiny)
136 ("perl-test-fatal" ,perl-test-fatal)))
137 (propagated-inputs
138 `(("perl-lingua-en-findnumber" ,perl-lingua-en-findnumber)))
139 (home-page "http://search.cpan.org/dist/Lingua-EN-Number-IsOrdinal")
140 (synopsis "Detect if English number is ordinal or cardinal")
141 (description "This module will tell you if a number, either in words or as
142 digits, is a cardinal or ordinal number.")
143 (license (package-license perl))))
144
145 (define-public perl-lingua-en-tagger
146 (package
147 (name "perl-lingua-en-tagger")
148 (version "0.24")
149 (source
150 (origin
151 (method url-fetch)
152 (uri (string-append "mirror://cpan/authors/id/A/AC/ACOBURN/"
153 "Lingua-EN-Tagger-" version ".tar.gz"))
154 (sha256
155 (base32
156 "0qksqh1zi8fz76a29s2ll4g6yr8y6agmzgq7ngccvgj3gza5q241"))))
157 (build-system perl-build-system)
158 (propagated-inputs
159 `(("perl-memoize-expirelru" ,perl-memoize-expirelru)
160 ("perl-lingua-stem" ,perl-lingua-stem)
161 ("perl-html-parser" ,perl-html-parser)
162 ("perl-html-tagset" ,perl-html-tagset)))
163 (home-page "http://search.cpan.org/dist/Lingua-EN-Tagger")
164 (synopsis "Part-of-speech tagger for English natural language processing")
165 (description "This module is a probability based, corpus-trained tagger
166 that assigns part-of-speech tags to English text based on a lookup dictionary
167 and a set of probability values. The tagger assigns appropriate tags based on
168 conditional probabilities - it examines the preceding tag to determine the
169 appropriate tag for the current word. Unknown words are classified according
170 to word morphology or can be set to be treated as nouns or other parts of
171 speech. The tagger also extracts as many nouns and noun phrases as it can,
172 using a set of regular expressions.")
173 (license gpl3)))
174
175 (define-public perl-lingua-en-words2nums
176 (package
177 (name "perl-lingua-en-words2nums")
178 (version "0.18")
179 (source
180 (origin
181 (method url-fetch)
182 (uri (string-append "mirror://cpan/authors/id/J/JO/JOEY/"
183 "Lingua-EN-Words2Nums-" version ".tar.gz"))
184 (sha256
185 (base32
186 "118xx8qr1zbx30psv7ic55w65h15mc1vz6zicshfm96jgiwmcrb8"))))
187 (build-system perl-build-system)
188 (home-page "http://search.cpan.org/dist/Lingua-EN-Words2Nums")
189 (synopsis "Convert English text to numbers")
190 (description "This module converts English text into numbers. It supports
191 both ordinal and cardinal numbers, negative numbers, and very large numbers.")
192 (license (package-license perl))))
193
194 (define-public perl-lingua-pt-stemmer
195 (package
196 (name "perl-lingua-pt-stemmer")
197 (version "0.01")
198 (source
199 (origin
200 (method url-fetch)
201 (uri (string-append "mirror://cpan/authors/id/X/XE/XERN/"
202 "Lingua-PT-Stemmer-" version ".tar.gz"))
203 (sha256
204 (base32
205 "11rqc5pqnkl9c13vy7sihiyas14ci0pj3k6chrgrgjv5sjv2m4a5"))))
206 (build-system perl-build-system)
207 (home-page "http://search.cpan.org/dist/Lingua-PT-Stemmer")
208 (synopsis "Portuguese language stemming")
209 (description "This module implements a Portuguese stemming algorithm
210 proposed in the paper A Stemming Algorithm for the Portuguese Language by
211 Moreira, V. and Huyck, C.")
212 (license (package-license perl))))
213
214 (define-public perl-lingua-stem
215 (package
216 (name "perl-lingua-stem")
217 (version "0.84")
218 (source
219 (origin
220 (method url-fetch)
221 (uri (string-append "mirror://cpan/authors/id/S/SN/SNOWHARE/"
222 "Lingua-Stem-" version ".tar.gz"))
223 (sha256
224 (base32
225 "12avh2mnnc7llmmshrr5bgb473fvydxnlqrqbl2815mf2dp4pxcg"))))
226 (build-system perl-build-system)
227 (propagated-inputs
228 `(("perl-lingua-pt-stemmer" ,perl-lingua-pt-stemmer)
229 ("perl-lingua-stem-fr" ,perl-lingua-stem-fr)
230 ("perl-lingua-stem-it" ,perl-lingua-stem-it)
231 ("perl-lingua-stem-ru" ,perl-lingua-stem-ru)
232 ("perl-lingua-stem-snowball-da" ,perl-lingua-stem-snowball-da)
233 ("perl-snowball-norwegian" ,perl-snowball-norwegian)
234 ("perl-snowball-swedish" ,perl-snowball-swedish)
235 ("perl-text-german" ,perl-text-german)))
236 (home-page "http://search.cpan.org/dist/Lingua-Stem")
237 (synopsis "Stemming of words in various languages")
238 (description "This routine applies stemming algorithms to its parameters,
239 returning the stemmed words as appropriate to the selected locale.")
240 (license (package-license perl))))
241
242 (define-public perl-lingua-stem-fr
243 (package
244 (name "perl-lingua-stem-fr")
245 (version "0.02")
246 (source
247 (origin
248 (method url-fetch)
249 (uri (string-append "mirror://cpan/authors/id/S/SD/SDP/"
250 "Lingua-Stem-Fr-" version ".tar.gz"))
251 (sha256
252 (base32
253 "0vyrspwzaqjxm5mqshf4wvwa3938mkajd1918d9ii2l9m2rn8kwx"))))
254 (build-system perl-build-system)
255 (home-page "http://search.cpan.org/dist/Lingua-Stem-Fr")
256 (synopsis "Porter's stemming algorithm for French")
257 (description "This module uses a modified version of the Porter Stemming
258 Algorithm to return a stemmed French word.")
259 (license (package-license perl))))
260
261 (define-public perl-lingua-stem-it
262 (package
263 (name "perl-lingua-stem-it")
264 (version "0.02")
265 (source
266 (origin
267 (method url-fetch)
268 (uri (string-append "mirror://cpan/authors/id/A/AC/ACALPINI/"
269 "Lingua-Stem-It-" version ".tar.gz"))
270 (sha256
271 (base32
272 "1207r183s5hlh4mfwa6p46vzm0dhvrs2dnss5s41a0gyfkxp7riq"))))
273 (build-system perl-build-system)
274 (home-page "http://search.cpan.org/dist/Lingua-Stem-It")
275 (synopsis "Porter's stemming algorithm for Italian")
276 (description "This module applies the Porter Stemming Algorithm to its
277 parameters, returning the stemmed Italian word.")
278 (license (package-license perl))))
279
280 (define-public perl-lingua-stem-ru
281 (package
282 (name "perl-lingua-stem-ru")
283 (version "0.01")
284 (source
285 (origin
286 (method url-fetch)
287 (uri (string-append "mirror://cpan/authors/id/A/AL/ALGDR/"
288 "Lingua-Stem-Ru-" version ".tar.gz"))
289 (sha256
290 (base32
291 "0pqgg442fkf12ayh9fgmpa8q9x0iqx6s96181r52yn7s7pcs61h6"))))
292 (build-system perl-build-system)
293 (home-page "http://search.cpan.org/dist/Lingua-Stem-Ru")
294 (synopsis "Porter's stemming algorithm for Russian")
295 (description "This module applies the Porter Stemming Algorithm to its
296 parameters, returning the stemmed Russian (KOI8-R only) word.")
297 (license (package-license perl))))
298
299 (define-public perl-lingua-stem-snowball-da
300 (package
301 (name "perl-lingua-stem-snowball-da")
302 (version "1.01")
303 (source
304 (origin
305 (method url-fetch)
306 (uri (string-append "mirror://cpan/authors/id/C/CI/CINE/"
307 "Lingua-Stem-Snowball-Da-" version ".tar.gz"))
308 (sha256
309 (base32
310 "0mm0m7glm1s6i9f6a78jslw6wh573208arxhq93yriqmw17bwf9f"))))
311 (build-system perl-build-system)
312 (home-page "http://search.cpan.org/dist/Lingua-Stem-Snowball-Da")
313 (synopsis "Porters stemming algorithm for Danish")
314 (description "Lingua::Stem::Snowball::Da is a perl port of the danish
315 stemmer at http://snowball.sourceforge.net, it was originally altered from the
316 Lingua::Stem::Snowball::Se.")
317 (license gpl2)))
318
319 (define-public perl-snowball-norwegian
320 (package
321 (name "perl-snowball-norwegian")
322 (version "1.2")
323 (source
324 (origin
325 (method url-fetch)
326 (uri (string-append "mirror://cpan/authors/id/A/AS/ASKSH/"
327 "Snowball-Norwegian-" version ".tar.gz"))
328 (sha256
329 (base32
330 "0675v45bbsh7vr7kpf36xs2q79g02iq1kmfw22h20xdk4rzqvkqx"))))
331 (build-system perl-build-system)
332 (home-page "http://search.cpan.org/dist/Snowball-Norwegian")
333 (synopsis "Porters stemming algorithm for Norwegian")
334 (description "Lingua::Stem::Snowball::No is a perl port of the norwegian
335 stemmer at http://snowball.tartarus.org.")
336 (license (package-license perl))))
337
338 (define-public perl-snowball-swedish
339 (package
340 (name "perl-snowball-swedish")
341 (version "1.2")
342 (source
343 (origin
344 (method url-fetch)
345 (uri (string-append "mirror://cpan/authors/id/A/AS/ASKSH/"
346 "Snowball-Swedish-" version ".tar.gz"))
347 (sha256
348 (base32
349 "0agwc12jk5kmabnpsplw3wf4ii5w1zb159cpin44x3srb0sr5apg"))))
350 (build-system perl-build-system)
351 (home-page "http://search.cpan.org/dist/Snowball-Swedish")
352 (synopsis "Porters stemming algorithm for Swedish")
353 (description "Lingua::Stem::Snowball::Se is a perl port of the swedish
354 stemmer at http://snowball.sourceforge.net.")
355 (license (package-license perl))))
356
357 (define-public perl-string-toidentifier-en
358 (package
359 (name "perl-string-toidentifier-en")
360 (version "0.11")
361 (source
362 (origin
363 (method url-fetch)
364 (uri (string-append "mirror://cpan/authors/id/R/RK/RKITOVER/"
365 "String-ToIdentifier-EN-" version ".tar.gz"))
366 (sha256
367 (base32
368 "1bawghkgkkx7j3avnrj5sg3vix1z5564ks6wf9az3jc2knh8s5nh"))))
369 (build-system perl-build-system)
370 (propagated-inputs
371 `(("perl-lingua-en-inflect-phrase" ,perl-lingua-en-inflect-phrase)
372 ("perl-text-unidecode" ,perl-text-unidecode)
373 ("perl-namespace-clean" ,perl-namespace-clean)))
374 (home-page "http://search.cpan.org/dist/String-ToIdentifier-EN")
375 (synopsis "Convert strings to English program identifiers")
376 (description "This module provides a utility method, \"to_identifier\" for
377 converting an arbitrary string into a readable representation using the ASCII
378 subset of \"\\w\" for use as an identifier in a computer program. The intent
379 is to make unique identifier names from which the content of the original
380 string can be easily inferred by a human just by reading the identifier.")
381 (license (package-license perl))))
382
383 (define-public perl-text-german
384 (package
385 (name "perl-text-german")
386 (version "0.06")
387 (source
388 (origin
389 (method url-fetch)
390 (uri (string-append "mirror://cpan/authors/id/U/UL/ULPFR/"
391 "Text-German-" version ".tar.gz"))
392 (sha256
393 (base32
394 "1p87pgap99lw0nv62i3ghvsi7yg90lhn8vsa3yqp75rd04clybcj"))))
395 (build-system perl-build-system)
396 (home-page "http://search.cpan.org/dist/Text-German")
397 (synopsis "German grundform reduction")
398 (description "This module is a rather incomplete implementation of work
399 done by Gudrun Putze-Meier.")
400 (license (package-license perl))))