gnu: freeipmi: Update to 1.4.10.
[jackhill/guix/guix.git] / gnu / packages / inkscape.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages inkscape)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages aspell)
28 #:use-module (gnu packages bdw-gc)
29 #:use-module (gnu packages boost)
30 #:use-module (gnu packages glib)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages maths)
33 #:use-module (gnu packages perl)
34 #:use-module (gnu packages pdf)
35 #:use-module (gnu packages popt)
36 #:use-module (gnu packages python)
37 #:use-module (gnu packages xml)
38 #:use-module (gnu packages ghostscript)
39 #:use-module (gnu packages fontutils)
40 #:use-module (gnu packages image)
41 #:use-module (gnu packages pkg-config))
42
43 (define-public inkscape
44 (package
45 (name "inkscape")
46 (version "0.91")
47 (source (origin
48 (method url-fetch)
49 (uri (string-append "https://launchpad.net/inkscape/"
50 (version-major+minor version) ".x/"
51 version "/+download/inkscape-"
52 version ".tar.gz"))
53 (sha256
54 (base32
55 "086v01jy896dj86bq7plrf6si4p6gh6ga2v5417llgmminycz8rc"))))
56 (build-system gnu-build-system)
57 (inputs
58 `(("aspell" ,aspell)
59 ("gtkmm" ,gtkmm-2)
60 ("gtk" ,gtk+-2)
61 ("gsl" ,gsl)
62 ("poppler" ,poppler)
63 ("libpng" ,libpng)
64 ("libxml2" ,libxml2)
65 ("libxslt" ,libxslt)
66 ("libgc" ,libgc)
67 ("freetype" ,freetype)
68 ("popt" ,popt)
69 ("python" ,python-2)
70 ("lcms" ,lcms)
71 ("boost" ,boost)))
72 (native-inputs
73 `(("intltool" ,intltool)
74 ("perl" ,perl)
75 ("pkg-config" ,pkg-config)))
76 (arguments
77 `(#:phases (alist-cons-after
78 'unpack 'fix-test-includes
79 (lambda _
80 (substitute* "src/cxxtests.cpp"
81 (("\\.\\./\\.\\./src") "../src")))
82 %standard-phases)))
83 (home-page "http://inkscape.org/")
84 (synopsis "Vector graphics editor")
85 (description "Inkscape is a vector graphics editor. What sets Inkscape
86 apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
87 as the native format.")
88 (license license:gpl2+)))