gnu: liferea: Update to 1.12.8.
[jackhill/guix/guix.git] / gnu / packages / syndication.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages syndication)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix download)
24 #:use-module (guix packages)
25 #:use-module (guix build-system glib-or-gtk)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix build-system python)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages check)
30 #:use-module (gnu packages curl)
31 #:use-module (gnu packages documentation)
32 #:use-module (gnu packages gettext)
33 #:use-module (gnu packages glib)
34 #:use-module (gnu packages gnome)
35 #:use-module (gnu packages gstreamer)
36 #:use-module (gnu packages gtk)
37 #:use-module (gnu packages ncurses)
38 #:use-module (gnu packages pkg-config)
39 #:use-module (gnu packages python)
40 #:use-module (gnu packages python-check)
41 #:use-module (gnu packages python-xyz)
42 #:use-module (gnu packages python-web)
43 #:use-module (gnu packages sqlite)
44 #:use-module (gnu packages web)
45 #:use-module (gnu packages webkit)
46 #:use-module (gnu packages xml))
47
48 (define-public newsboat
49 (package
50 (name "newsboat")
51 (version "2.13")
52 (source
53 (origin
54 (method url-fetch)
55 (uri (string-append "https://newsboat.org/releases/" version
56 "/newsboat-" version ".tar.xz"))
57 (sha256
58 (base32
59 "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
60 (build-system gnu-build-system)
61 (native-inputs
62 `(("gettext" ,gettext-minimal)
63 ("pkg-config" ,pkg-config)
64 ;; For building documentation.
65 ("asciidoc" ,asciidoc)))
66 (inputs
67 `(("curl" ,curl)
68 ("json-c" ,json-c-0.13)
69 ("libxml2" ,libxml2)
70 ("ncurses" ,ncurses)
71 ("stfl" ,stfl)
72 ("sqlite" ,sqlite)))
73 (arguments
74 '(#:phases
75 (modify-phases %standard-phases
76 (delete 'configure) ; no configure script
77 (add-after 'build 'build-documentation
78 (lambda _
79 (invoke "make" "doc"))))
80 #:make-flags
81 (list (string-append "prefix=" (assoc-ref %outputs "out")))
82 #:test-target "test"))
83 (native-search-paths
84 ;; Newsboat respects CURL_CA_BUNDLE.
85 (package-native-search-paths curl))
86 (home-page "https://newsboat.org/")
87 (synopsis "Text-mode RSS and Atom feed reader with podcast support")
88 (description "Newsboat is a feed reader for @dfn{RSS} and @dfn{Atom}, XML
89 formats widely used to transmit, publish, and syndicate news or blog articles.
90 It's designed for use on text terminals, and to have a coherent and easy-to-use
91 interface that might look familiar to @command{mutt} or @command{slrn} users.
92
93 Newsboat supports OPML import/exports, HTML rendering, podcasts (with
94 @command{podboat}), off-line reading, searching and storing articles to your
95 file system, and many more features.")
96 (license (list license:gpl2+ ; filter/*
97 license:expat)))) ; everything else
98
99 (define-public liferea
100 (package
101 (name "liferea")
102 (version "1.12.8")
103 (source
104 (origin
105 (method url-fetch)
106 (uri (string-append "https://github.com/lwindolf/liferea/"
107 "releases/download/v" version "/liferea-"
108 version ".tar.bz2"))
109 (sha256
110 (base32 "1xm5if831llkjcmbq4w9ssgqjgy3zlb5n9y7kh54xpy6afafbsh7"))))
111 (build-system glib-or-gtk-build-system)
112 (arguments
113 `(#:phases
114 (modify-phases %standard-phases
115 (add-before 'configure 'prepare-build-environment
116 (lambda* (#:key inputs #:allow-other-keys)
117 ;; Workaround for https://github.com/lwindolf/liferea/issues/767.
118 (setenv "WEBKIT_DISABLE_COMPOSITING_MODE" "1")))
119 (add-after 'install 'wrap-gi-python
120 (lambda* (#:key inputs outputs #:allow-other-keys)
121 (let ((out (assoc-ref outputs "out"))
122 (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
123 (python-path (getenv "PYTHONPATH")))
124 (wrap-program (string-append out "/bin/liferea")
125 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
126 `("PYTHONPATH" ":" prefix (,python-path))))
127 #t)))))
128 (native-inputs
129 `(("gettext" ,gettext-minimal)
130 ("glib:bin" ,glib "bin")
131 ("gobject-introspection" ,gobject-introspection)
132 ("intltool" ,intltool)
133 ("pkg-config" ,pkg-config)))
134 (inputs
135 `(("glib-networking" ,glib-networking)
136 ("gnome-keyring" ,gnome-keyring)
137 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
138 ("gstreamer" ,gstreamer)
139 ("json-glib" ,json-glib)
140 ("libnotify" ,libnotify)
141 ("libpeas" ,libpeas)
142 ("libsecret" ,libsecret)
143 ("libxml2" ,libxml2)
144 ("libxslt" ,libxslt)
145 ("python" ,python)
146 ("python-pycairo" ,python-pycairo)
147 ("python-pygobject" ,python-pygobject)
148 ("webkitgtk" ,webkitgtk)))
149 (home-page "https://lzone.de/liferea/")
150 (synopsis "News reader for GTK/GNOME")
151 (description "Liferea is a desktop feed reader/news aggregator that
152 brings together all of the content from your favorite subscriptions into
153 a simple interface that makes it easy to organize and browse feeds.")
154 (license license:gpl2+)))
155
156 (define-public rtv
157 (package
158 (name "rtv")
159 (version "1.27.0")
160 (source
161 (origin
162 (method url-fetch)
163 (uri (pypi-uri "rtv" version))
164 (sha256
165 (base32 "0hvw426y09l3yzwv2zkb9hifpfbg9wd1gg0y3z3pxcli6n3ii2wl"))))
166 (build-system python-build-system)
167 (arguments
168 '(#:phases
169 (modify-phases %standard-phases
170 (add-before 'check 'set-environment-variables
171 (lambda* (#:key inputs #:allow-other-keys)
172 (setenv "HOME" (getcwd))
173 (setenv "TERM" "linux")
174 (setenv "TERMINFO" (string-append (assoc-ref inputs "ncurses")
175 "/share/terminfo"))
176 #t)))
177 #:tests? #f)) ; tests fail: _curses.error: nocbreak() returned ERR
178 (propagated-inputs
179 `(("python-beautifulsoup4" ,python-beautifulsoup4)
180 ("python-decorator" ,python-decorator)
181 ("python-kitchen" ,python-kitchen)
182 ("python-requests" ,python-requests)
183 ("python-six" ,python-six)))
184 (native-inputs
185 `(("ncurses" ,ncurses)
186 ("python-coveralls" ,python-coveralls)
187 ("python-coverage" ,python-coverage)
188 ("python-mock" ,python-mock)
189 ("python-pylint" ,python-pylint)
190 ("python-pytest" ,python-pytest)
191 ("python-vcrpy" ,python-vcrpy)))
192 (home-page "https://github.com/michael-lazar/rtv")
193 (synopsis "Terminal viewer for Reddit (Reddit Terminal Viewer)")
194 (description
195 "RTV provides a text-based interface to view and interact with Reddit.")
196 (license (list license:expat
197 license:gpl3+)))) ; rtv/packages/praw
198
199 (define-public tuir
200 (package
201 (name "tuir")
202 (version "1.29.0")
203 (source
204 (origin
205 (method url-fetch)
206 (uri (pypi-uri "tuir" version))
207 (sha256
208 (base32
209 "06xb030ibphbrz4nsxm8mh3g60ld8xfp6kc3j6vi1k4ls5s4h79i"))))
210 (build-system python-build-system)
211 (arguments
212 `(#:phases
213 (modify-phases %standard-phases
214 (replace 'check
215 (lambda* (#:key inputs outputs #:allow-other-keys)
216 (add-installed-pythonpath inputs outputs)
217 (invoke "pytest"))))))
218 (inputs
219 `(("python-beautifulsoup4" ,python-beautifulsoup4)
220 ("python-decorator" ,python-decorator)
221 ("python-kitchen" ,python-kitchen)
222 ("python-requests" ,python-requests)
223 ("python-six" ,python-six)))
224 (native-inputs
225 `(("python-coverage" ,python-coverage)
226 ("python-coveralls" ,python-coveralls)
227 ("python-mock" ,python-mock)
228 ("python-pylint" ,python-pylint)
229 ("python-pytest" ,python-pytest)
230 ("python-vcrpy" ,python-vcrpy)))
231 (home-page "https://gitlab.com/ajak/tuir")
232 (synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
233 (description
234 "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
235 (license (list license:expat
236 license:gpl3+)))) ; tuir/packages/praw
237
238 (define-public rawdog
239 (package
240 (name "rawdog")
241 (version "2.23")
242 (source
243 (origin
244 (method url-fetch)
245 (uri (string-append "https://offog.org/files/rawdog-"
246 version ".tar.gz"))
247 (sha256
248 (base32
249 "18nyg19mwxyqdnykplkqmzb4n27vvrhvp639zai8f81gg9vdbsjp"))))
250 (build-system python-build-system)
251 (arguments
252 `(#:python ,python-2.7))
253 (inputs
254 `(("python2-feedparser" ,python2-feedparser)
255 ("python2-pytidylib" ,python2-pytidylib)))
256 (home-page "https://offog.org/code/rawdog/")
257 (synopsis "RSS Aggregator Without Delusions Of Grandeur")
258 (description
259 "@command{rawdog} is a feed aggregator, capable of producing a personal
260 \"river of news\" or a public \"planet\" page. It supports all common feed
261 formats, including all versions of RSS and Atom.")
262 (license license:gpl2+)))