Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / accessibility.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 ng0 <ng0@infotropique.org>
3 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages accessibility)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix build-system glib-or-gtk)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages xml)
30 #:use-module (gnu packages gnome)
31 #:use-module (gnu packages gstreamer)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages xorg)
34 #:use-module (gnu packages gettext)
35 #:use-module (gnu packages glib)
36 #:use-module (gnu packages pkg-config)
37 #:use-module (gnu packages libusb))
38
39 (define-public florence
40 (package
41 (name "florence")
42 (version "0.6.3")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append "mirror://sourceforge/florence/florence/" version
47 "/" name "-" version ".tar.bz2"))
48 (sha256
49 (base32
50 "07h9qm22krlwayhzvc391lr23vicw81s48g7rirvx1fj0zyr4aa2"))))
51 (build-system glib-or-gtk-build-system)
52 (arguments
53 `(#:configure-flags (list "--with-xtst"
54 "--without-docs"
55 "--with-notification")))
56 (inputs
57 `(("libxml2" ,libxml2)
58 ("libglade" ,libglade)
59 ("librsvg" ,librsvg)
60 ("gstreamer" ,gstreamer)
61 ("cairo" ,cairo)
62 ("gtk+" ,gtk+)
63 ("libxtst" ,libxtst)
64 ("libxcomposite" ,libxcomposite)
65 ("libnotify" ,libnotify)))
66 (native-inputs
67 `(("gettext-minimal" ,gettext-minimal)
68 ("intltool" ,intltool)
69 ("pkg-config" ,pkg-config)))
70 (home-page "http://florence.sourceforge.net/")
71 (synopsis "Extensible, scalable virtual keyboard for X11")
72 (description
73 "Florence is an extensible scalable virtual keyboard for X11.
74 It is useful for people who can't use a real hardware keyboard (for
75 example for people with disabilities), but you must be able to use
76 a pointing device (as a mouse, a trackball, a touchscreen or opengazer).
77
78 Florence stays out of your way when you don't need it: it appears on the
79 screen only when you need it. A timer-based auto-click input method is
80 available to help to click.")
81 ;; The documentation is under FDL1.2, but we do not install the
82 ;; documentation.
83 (license license:gpl2+)))
84
85 (define-public footswitch
86 (let ((commit "deedd87fd90fad90ce342aeabafd4a3198d7d3d4")
87 (revision "2"))
88 (package
89 (name "footswitch")
90 (version (git-version "0.1" revision commit))
91 (source (origin
92 (method git-fetch)
93 (uri (git-reference
94 (url "https://github.com/rgerganov/footswitch")
95 (commit commit)))
96 (file-name (git-file-name name version))
97 (sha256
98 (base32 "1ys90wqyz62kffa8m3hgaq1dl7f29x3mrc3zqfjrkbn2ps0k6ps0"))))
99 (build-system gnu-build-system)
100 (native-inputs
101 `(("pkg-config" ,pkg-config)))
102 (inputs
103 `(("hidapi" ,hidapi)))
104 (arguments
105 `(#:tests? #f ; no tests
106 #:make-flags (list "CC=gcc")
107 #:phases (modify-phases %standard-phases
108 (delete 'configure)
109 ;; Install target in the Makefile does not work for Guix
110 (replace 'install
111 (lambda* (#:key outputs #:allow-other-keys)
112 (let ((bin (string-append (assoc-ref outputs "out")
113 "/bin")))
114 (install-file "footswitch" bin)
115 #t))))))
116 (home-page "https://github.com/rgerganov/footswitch")
117 (synopsis "Command line utility for PCsensor foot switch")
118 (description
119 "Command line utility for programming foot switches sold by PCsensor.
120 It works for both single pedal devices and three pedal devices. All supported
121 devices have vendorId:productId = 0c45:7403 or 0c45:7404.")
122 (license license:expat))))