gnu: Add java-jboss-jms-api-spec.
[jackhill/guix/guix.git] / gnu / packages / wm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
3 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
4 ;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
6 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
7 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
8 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
9 ;;; Copyright © 2016 Al McElrath <hello@yrns.org>
10 ;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
11 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
12 ;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
13 ;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
14 ;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
15 ;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
16 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
17 ;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages wm)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix packages)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages linux)
39 #:use-module (guix build-system cmake)
40 #:use-module (guix build-system gnu)
41 #:use-module (guix build-system haskell)
42 #:use-module (guix build-system perl)
43 #:use-module (guix build-system python)
44 #:use-module (gnu packages haskell)
45 #:use-module (gnu packages haskell-check)
46 #:use-module (gnu packages haskell-web)
47 #:use-module (gnu packages base)
48 #:use-module (gnu packages pkg-config)
49 #:use-module (gnu packages perl)
50 #:use-module (gnu packages pulseaudio)
51 #:use-module (gnu packages xorg)
52 #:use-module (gnu packages xdisorg)
53 #:use-module (gnu packages documentation)
54 #:use-module (gnu packages xml)
55 #:use-module (gnu packages m4)
56 #:use-module (gnu packages docbook)
57 #:use-module (gnu packages image)
58 #:use-module (gnu packages pcre)
59 #:use-module (gnu packages python)
60 #:use-module (gnu packages gtk)
61 #:use-module (gnu packages libevent)
62 #:use-module (gnu packages fribidi)
63 #:use-module (gnu packages maths)
64 #:use-module (gnu packages web)
65 #:use-module (gnu packages fontutils)
66 #:use-module (gnu packages freedesktop)
67 #:use-module (gnu packages glib)
68 #:use-module (gnu packages gperf)
69 #:use-module (gnu packages imagemagick)
70 #:use-module (gnu packages lua)
71 #:use-module (gnu packages suckless)
72 #:use-module (guix download)
73 #:use-module (guix git-download))
74
75 (define-public libconfuse
76 (package
77 (name "libconfuse")
78 (version "3.2.1")
79 (source (origin
80 (method url-fetch)
81 (uri (string-append "https://github.com/martinh/libconfuse/"
82 "releases/download/v" version
83 "/confuse-" version ".tar.xz"))
84 (sha256
85 (base32
86 "0pnjmlj9i0alp407qd7c0vq83sz7gpsjrbdgpcn4xvzjp9r35ii3"))))
87 (build-system gnu-build-system)
88 (home-page "https://github.com/martinh/libconfuse")
89 (synopsis "Configuration file parser library")
90 (description "libconfuse is a configuration file parser library. It
91 supports sections and (lists of) values (strings, integers, floats, booleans
92 or other sections), as well as some other features (such as
93 single/double-quoted strings, environment variable expansion, functions and
94 nested include statements).")
95 (license license:isc)))
96
97 (define-public bspwm
98 (package
99 (name "bspwm")
100 (version "0.9.3")
101 (source
102 (origin
103 (file-name (string-append name "-" version ".tar.gz"))
104 (method url-fetch)
105 (uri (string-append
106 "https://github.com/baskerville/bspwm/archive/"
107 version ".tar.gz"))
108 (sha256
109 (base32
110 "17dwj7w16cdj7g4s2y2f96lgj5msq1s4543dnfa3rijlazzy6mmk"))))
111 (build-system gnu-build-system)
112 (inputs
113 `(("libxcb" ,libxcb)
114 ("libxinerama" ,libxinerama)
115 ("sxhkd" ,sxhkd)
116 ("xcb-util" ,xcb-util)
117 ("xcb-util-keysyms" ,xcb-util-keysyms)
118 ("xcb-util-wm" ,xcb-util-wm)))
119 (arguments
120 '(#:phases (modify-phases %standard-phases (delete 'configure))
121 #:tests? #f ; no check target
122 #:make-flags (list "CC=gcc"
123 (string-append "PREFIX=" %output))))
124 (home-page "https://github.com/baskerville/bspwm")
125 (synopsis "Tiling window manager based on binary space partitioning")
126 (description "bspwm is a tiling window manager that represents windows as
127 the leaves of a full binary tree.")
128 (license license:bsd-2)))
129
130 (define-public i3status
131 (package
132 (name "i3status")
133 (version "2.11")
134 (source (origin
135 (method url-fetch)
136 (uri (string-append "https://i3wm.org/i3status/i3status-"
137 version ".tar.bz2"))
138 (sha256
139 (base32
140 "0pwcy599fw8by1a1sf91crkqba7679qhvhbacpmhis8c1xrpxnwq"))))
141 (build-system gnu-build-system)
142 (arguments
143 `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
144 #:phases
145 (modify-phases %standard-phases
146 (delete 'configure))
147 #:tests? #f)) ; no test suite
148 (inputs
149 `(("openlibm" ,openlibm)
150 ("libconfuse" ,libconfuse)
151 ("libyajl" ,libyajl)
152 ("alsa-lib" ,alsa-lib)
153 ("pulseaudio" ,pulseaudio)
154 ("libnl" ,libnl)
155 ("libcap" ,libcap)
156 ("asciidoc" ,asciidoc)))
157 (native-inputs
158 `(("pkg-config" ,pkg-config)))
159 (home-page "https://i3wm.org/i3status/")
160 (synopsis "Status bar for i3bar, dzen2, xmobar or similar programs")
161 (description "i3status is a small program for generating a status bar for
162 i3bar, dzen2, xmobar or similar programs. It is designed to be very efficient
163 by issuing a very small number of system calls, as one generally wants to
164 update such a status line every second. This ensures that even under high
165 load, your status bar is updated correctly. Also, it saves a bit of energy by
166 not hogging your CPU as much as spawning the corresponding amount of shell
167 commands would.")
168 (license license:bsd-3)))
169
170 (define-public i3-wm
171 (package
172 (name "i3-wm")
173 (version "4.14.1")
174 (source (origin
175 (method url-fetch)
176 (uri (string-append "https://i3wm.org/downloads/i3-"
177 version ".tar.bz2"))
178 (sha256
179 (base32
180 "1cazmfbbx6n8c81h6x6pdayq3mxs2ml3adz165z8vapkc72kl1nh"))))
181 (build-system gnu-build-system)
182 (arguments
183 `(#:make-flags
184 (list "CC=gcc"
185 (string-append "PREFIX=" %output)
186 ;; This works around the following error:
187 ;; 'error: ‘for’ loop initial declarations are only allowed in C99
188 ;; or C11 mode'
189 "CFLAGS=-std=c11")
190 ;; The build system tries to build in a separate directory, but that
191 ;; seems to be unnecessary.
192 #:configure-flags '("--disable-builddir")
193 ;; The test suite appears to require the unpackaged Perl module AnyEvent.
194 #:tests? #f))
195 (inputs
196 `(("libxcb" ,libxcb)
197 ("xcb-util" ,xcb-util)
198 ("xcb-util-cursor" ,xcb-util-cursor)
199 ("xcb-util-keysyms" ,xcb-util-keysyms)
200 ("xcb-util-wm" ,xcb-util-wm)
201 ("xcb-util-xrm" ,xcb-util-xrm)
202 ("libxkbcommon" ,libxkbcommon)
203 ("libev" ,libev)
204 ("libyajl" ,libyajl)
205 ("asciidoc" ,asciidoc)
206 ("xmlto" ,xmlto)
207 ("perl-pod-simple" ,perl-pod-simple)
208 ("libx11" ,libx11)
209 ("pcre" ,pcre)
210 ("startup-notification" ,startup-notification)
211 ("pango" ,pango)
212 ("cairo" ,cairo)))
213 (native-inputs
214 `(("which" ,which)
215 ("perl" ,perl)
216 ("pkg-config" ,pkg-config)
217 ;; For building the documentation.
218 ("libxml2" ,libxml2)
219 ("docbook-xsl" ,docbook-xsl)))
220 (home-page "https://i3wm.org/")
221 (synopsis "Improved tiling window manager")
222 (description "A tiling window manager, completely written
223 from scratch. i3 is primarily targeted at advanced users and
224 developers.")
225 (license license:bsd-3)))
226
227 (define-public perl-anyevent-i3
228 (package
229 (name "perl-anyevent-i3")
230 (version "0.17")
231 (source (origin
232 (method url-fetch)
233 (uri (string-append "mirror://cpan/authors/id/M/MS/MSTPLBG/"
234 "AnyEvent-I3-" version ".tar.gz"))
235 (sha256
236 (base32
237 "0qvd9bq16jyy7v3ma82qcnvz9j503bw0mh7h55gkjf7ir62ck0jk"))))
238 (build-system perl-build-system)
239 (propagated-inputs
240 `(("perl-anyevent" ,perl-anyevent)
241 ("perl-json-xs" ,perl-json-xs)))
242 (home-page "http://search.cpan.org/dist/AnyEvent-I3")
243 (synopsis
244 "Communicate with the i3 window manager through perl")
245 (description
246 "This module connects to the i3 window manager using the UNIX socket
247 based IPC interface it provides (if enabled in the configuration file).
248 You can then subscribe to events or send messages and receive their replies.")
249 ;; Can be used with either license.
250 (license (list license:gpl3+ license:perl-license))))
251
252 (define-public python-i3-py
253 (package
254 (name "python-i3-py")
255 (version "0.6.5")
256 (source
257 (origin
258 ;; The latest release is not tagged in Git nor has an entry in PyPi,
259 ;; but there is still a clear commit for it, and it's been the last one
260 ;; for years.
261 (method git-fetch)
262 (uri (git-reference
263 (url "https://github.com/ziberna/i3-py.git")
264 (commit "27f88a616e9ecc340e7d041d3d00782f8a1964c1")))
265 (sha256
266 (base32
267 "1nm719dc2xqlll7vj4c4m7mpjb27lpn3bg3c66gajvnrz2x1nmxs"))
268 (file-name (string-append name "-" version "-checkout"))))
269 (build-system python-build-system)
270 (arguments
271 `(#:tests? #f ; no tests yet
272 #:phases (modify-phases %standard-phases
273 (add-after 'install 'install-doc
274 ;; Copy readme file to documentation directory.
275 (lambda* (#:key outputs #:allow-other-keys)
276 (let ((doc (string-append (assoc-ref outputs "out")
277 "/share/doc/" ,name)))
278 (install-file "README.md" doc)
279 ;; Avoid unspecified return value.
280 #t))))))
281 (propagated-inputs
282 `(("i3-wm" ,i3-wm)))
283 (home-page "https://github.com/ziberna/i3-py")
284 (synopsis "Python interface to the i3 window manager")
285 (description "This package allows you to interact from a Python program
286 with the i3 window manager via its IPC socket. It can send commands and other
287 kinds of messages to i3, select the affected containers, filter results and
288 subscribe to events.")
289 (license license:gpl3+)))
290
291 (define-public python2-i3-py
292 (package-with-python2 python-i3-py))
293
294 (define-public quickswitch-i3
295 (let ((commit "ed692b1e8f43b95bd907ced26238ce8ccb2ed28f")
296 (revision "1")) ; Guix package revision
297 (package
298 (name "quickswitch-i3")
299 (version (string-append "2.2-" revision "."
300 (string-take commit 7)))
301 (source
302 (origin
303 ;; The latest commit is a few years old and just a couple commits
304 ;; after the last tagged release, so we use that latest commit
305 ;; instead of the release.
306 (method git-fetch)
307 (uri (git-reference
308 (url "https://github.com/proxypoke/quickswitch-for-i3.git")
309 (commit commit)))
310 (sha256
311 (base32
312 "0447077sama80jcdg5p64zjsvafmz5rbdrirhm1adcdjhkh6iqc5"))
313 (patches (search-patches "quickswitch-fix-dmenu-check.patch"))
314 (file-name (string-append name "-" version "-checkout"))))
315 (build-system python-build-system)
316 (arguments
317 `(#:tests? #f ; no tests yet
318 #:phases (modify-phases %standard-phases
319 (add-after 'install 'install-doc
320 ;; Copy readme file to documentation directory.
321 (lambda* (#:key outputs #:allow-other-keys)
322 (let ((doc (string-append (assoc-ref outputs "out")
323 "/share/doc/" ,name)))
324 (install-file "README.rst" doc)
325 ;; Avoid unspecified return value.
326 #t))))))
327 (inputs
328 `(("python-i3-py" ,python-i3-py)
329 ("dmenu" ,dmenu)))
330 (home-page "https://github.com/proxypoke/quickswitch-for-i3")
331 (synopsis "Quickly change to and locate windows in the i3 window manager")
332 (description
333 "This utility for the i3 window manager allows you to quickly switch to
334 and locate windows on all your workspaces, using an interactive dmenu
335 prompt.")
336 (license (license:non-copyleft "http://www.wtfpl.net/txt/copying/")))))
337
338 (define-public xmonad
339 (package
340 (name "xmonad")
341 (version "0.13")
342 (synopsis "Tiling window manager")
343 (source (origin
344 (method url-fetch)
345 (uri (string-append "mirror://hackage/package/xmonad/"
346 name "-" version ".tar.gz"))
347 (sha256
348 (base32
349 "1jh3lcs20qpna36fa5a0r174xqrsxhj10x1rm5vwf64zariipy7r"))))
350 (build-system haskell-build-system)
351 (inputs
352 `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
353 ("ghc-mtl" ,ghc-mtl)
354 ("ghc-quickcheck" ,ghc-quickcheck)
355 ("ghc-setlocale" ,ghc-setlocale)
356 ("ghc-utf8-string" ,ghc-utf8-string)
357 ("ghc-directory" ,ghc-directory)
358 ("ghc-x11" ,ghc-x11)))
359 (arguments
360 `(#:phases
361 (modify-phases %standard-phases
362 (add-after
363 'install 'install-xsession
364 (lambda _
365 (let* ((xsessions (string-append %output "/share/xsessions")))
366 (mkdir-p xsessions)
367 (call-with-output-file
368 (string-append xsessions "/xmonad.desktop")
369 (lambda (port)
370 (format port "~
371 [Desktop Entry]~@
372 Name=~a~@
373 Comment=~a~@
374 Exec=~a/bin/xmonad~@
375 Type=Application~%" ,name ,synopsis %output)))))))))
376 (home-page "http://xmonad.org")
377 (description
378 "Xmonad is a tiling window manager for X. Windows are arranged
379 automatically to tile the screen without gaps or overlap, maximising screen
380 use. All features of the window manager are accessible from the keyboard: a
381 mouse is strictly optional. Xmonad is written and extensible in Haskell.
382 Custom layout algorithms, and other extensions, may be written by the user in
383 config files. Layouts are applied dynamically, and different layouts may be
384 used on each workspace. Xinerama is fully supported, allowing windows to be
385 tiled on several screens.")
386 (license license:bsd-3)))
387
388 (define-public xmobar
389 (package
390 (name "xmobar")
391 (version "0.24.5")
392 (source (origin
393 (method url-fetch)
394 (uri (string-append "mirror://hackage/package/xmobar/"
395 name "-" version ".tar.gz"))
396 (sha256
397 (base32
398 "0sdzfj2wa4wpig1i2i5n9qpwm90jp88qifsmaa7j37yhhs6snfir"))))
399 (build-system haskell-build-system)
400 (inputs
401 `(("ghc-http" ,ghc-http)
402 ("ghc-parsec" ,ghc-parsec)
403 ("ghc-regex-compat" ,ghc-regex-compat)
404 ("ghc-stm" ,ghc-stm)
405 ("ghc-x11-xft" ,ghc-x11-xft)
406 ("ghc-hinotify" ,ghc-hinotify)
407 ("libxpm" ,libxpm)
408 ("wireless-tools" ,wireless-tools)))
409 (arguments
410 `(#:configure-flags
411 '("--flags=with_utf8 with_xft with_xpm with_inotify with_iwlib")))
412 (home-page "http://xmobar.org")
413 (synopsis "Minimalistic text based status bar")
414 (description
415 "@code{xmobar} is a lightweight, text-based, status bar written in
416 Haskell. It was originally designed to be used together with Xmonad, but it
417 is also usable with any other window manager. While xmobar is written in
418 Haskell, no knowledge of the language is required to install and use it.")
419 (license license:bsd-3)))
420
421 (define-public ghc-xmonad-contrib
422 (package
423 (name "ghc-xmonad-contrib")
424 (version "0.13")
425 (source
426 (origin
427 (method url-fetch)
428 (uri (string-append "mirror://hackage/package/xmonad-contrib/"
429 "xmonad-contrib-" version ".tar.gz"))
430 (sha256
431 (base32
432 "0vj72jhfng6y7hv5frx2v99jvl3jn9rbpk2j7xw9vydiwmzq4q57"))))
433 (build-system haskell-build-system)
434 (propagated-inputs
435 `(("ghc-mtl" ,ghc-mtl)
436 ("ghc-old-time" ,ghc-old-time)
437 ("ghc-random" ,ghc-random)
438 ("ghc-utf8-string" ,ghc-utf8-string)
439 ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
440 ("ghc-x11" ,ghc-x11)
441 ("ghc-x11-xft" ,ghc-x11-xft)
442 ("xmonad" ,xmonad)))
443 (home-page "http://xmonad.org")
444 (synopsis "Third party extensions for xmonad")
445 (description
446 "Third party tiling algorithms, configurations, and scripts to Xmonad, a
447 tiling window manager for X.")
448 (license license:bsd-3)))
449
450 (define-public evilwm
451 (package
452 (name "evilwm")
453 (version "1.1.1")
454 (source
455 (origin
456 (method url-fetch)
457 (uri (string-append "http://www.6809.org.uk/evilwm/evilwm-"
458 version ".tar.gz"))
459 (sha256
460 (base32
461 "0ak0yajzk3v4dg5wmaghv6acf7v02a4iw8qxmq5yw5ard8lrqn3r"))
462 (patches (search-patches "evilwm-lost-focus-bug.patch"))))
463 (build-system gnu-build-system)
464 (inputs
465 `(("libx11" ,libx11)
466 ("libxext" ,libxext)
467 ("libxrandr" ,libxrandr)))
468 (arguments
469 `(#:modules ((srfi srfi-26)
470 (guix build utils)
471 (guix build gnu-build-system))
472 #:make-flags (let ((inputs (map (cut assoc-ref %build-inputs <>)
473 '("libx11" "libxext" "libxrandr")))
474 (join (lambda (proc strs)
475 (string-join (map proc strs) " ")))
476 (dash-I (cut string-append "-I" <> "/include"))
477 (dash-L (cut string-append "-L" <> "/lib")))
478 `("desktopfilesdir=$(prefix)/share/xsessions"
479 ,(string-append "prefix=" (assoc-ref %outputs "out"))
480 ,(string-append "CPPFLAGS=" (join dash-I inputs))
481 ,(string-append "LDFLAGS=" (join dash-L inputs))))
482 #:tests? #f ;no tests
483 #:phases (modify-phases %standard-phases
484 (delete 'configure)))) ;no configure script
485 (home-page "http://www.6809.org.uk/evilwm/")
486 (synopsis "Minimalist window manager for the X Window System")
487 (description
488 "evilwm is a minimalist window manager based on aewm, extended to feature
489 many keyboard controls with repositioning and maximize toggles, solid window
490 drags, snap-to-border support, and virtual desktops.")
491 (license (license:x11-style "file:///README"))))
492
493 (define-public fluxbox
494 (package
495 (name "fluxbox")
496 (version "1.3.7")
497 (synopsis "Small and fast window manager")
498 (source (origin
499 (method url-fetch)
500 (uri (string-append "mirror://sourceforge/fluxbox/fluxbox/"
501 version "/fluxbox-" version ".tar.xz"))
502 (sha256
503 (base32
504 "1h1f70y40qd225dqx937vzb4k2cz219agm1zvnjxakn5jkz7b37w"))))
505 (build-system gnu-build-system)
506 (arguments
507 `(#:make-flags '("CPPFLAGS=-U__TIME__") ;ugly, but for reproducibility
508 #:phases
509 (modify-phases %standard-phases
510 (add-after
511 'install 'install-xsession
512 (lambda _
513 (let ((xsessions (string-append %output "/share/xsessions")))
514 (mkdir-p xsessions)
515 (call-with-output-file
516 (string-append xsessions "/fluxbox.desktop")
517 (lambda (port)
518 (format port "~
519 [Desktop Entry]~@
520 Name=~a~@
521 Comment=~a~@
522 Exec=~a/bin/startfluxbox~@
523 Type=Application~%" ,name ,synopsis %output)))))))))
524 (native-inputs
525 `(("pkg-config" ,pkg-config)))
526 (inputs
527 `(("freetype" ,freetype)
528 ("fribidi" ,fribidi)
529 ("imlib2" ,imlib2)
530 ("libx11" ,libx11)
531 ("libxext" ,libxext)
532 ("libxft" ,libxft)
533 ("libxinerama" ,libxinerama)
534 ("libxpm" ,libxpm)
535 ("libxrandr" ,libxrandr)
536 ("libxrender" ,libxrender)))
537 (description "Fluxbox is a window manager. It is light on resources
538 and easy to handle yet full of features to make an easy and fast desktop
539 experience.")
540 (home-page "http://fluxbox.org/")
541 (license license:expat)))
542
543 (define-public awesome
544 (package
545 (name "awesome")
546 (version "4.2")
547 (source
548 (origin (method url-fetch)
549 (uri (string-append
550 "https://github.com/awesomeWM/awesome-releases/raw/"
551 "master/awesome-" version ".tar.xz"))
552 (sha256
553 (base32
554 "0kwpbls9h1alxcmvxh5g9qb995fds5b2ngcr44w0ibazkyls2pdc"))
555 (modules '((guix build utils)
556 (srfi srfi-19)))
557 (snippet
558 ;; Remove non-reproducible timestamp and use the date of the
559 ;; source file instead.
560 '(substitute* "common/version.c"
561 (("__DATE__ \" \" __TIME__")
562 (date->string
563 (time-utc->date
564 (make-time time-utc 0
565 (stat:mtime (stat "awesome.c"))))
566 "\"~c\""))))
567 (patches (search-patches "awesome-reproducible-png.patch"))))
568 (build-system cmake-build-system)
569 (native-inputs `(("asciidoc" ,asciidoc)
570 ("docbook-xsl" ,docbook-xsl)
571 ("doxygen" ,doxygen)
572 ("gperf" ,gperf)
573 ("imagemagick" ,imagemagick)
574 ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
575 ("pkg-config" ,pkg-config)
576 ("xmlto" ,xmlto)))
577 (inputs `(("cairo" ,cairo)
578 ("dbus" ,dbus)
579 ("gdk-pixbuf" ,gdk-pixbuf)
580 ("glib" ,glib)
581 ("gobject-introspection" ,gobject-introspection)
582 ("imlib2" ,imlib2)
583 ("libev" ,libev)
584 ("libxcb" ,libxcb)
585 ("libxcursor" ,libxcursor)
586 ("libxdg-basedir" ,libxdg-basedir)
587 ("libxkbcommon" ,libxkbcommon)
588 ("lua" ,lua)
589 ("lua-lgi",lua-lgi)
590 ("pango" ,pango)
591 ("startup-notification" ,startup-notification)
592 ("xcb-util" ,xcb-util)
593 ("xcb-util-cursor" ,xcb-util-cursor)
594 ("xcb-util-image" ,xcb-util-image)
595 ("xcb-util-keysyms" ,xcb-util-keysyms)
596 ("xcb-util-renderutil" ,xcb-util-renderutil)
597 ("xcb-util-xrm" ,xcb-util-xrm)
598 ("xcb-util-wm" ,xcb-util-wm)))
599 (arguments
600 `(;; Let compression happen in our 'compress-documentation' phase so that
601 ;; '--no-name' is used, which removes timestamps from gzip output.
602 #:configure-flags '("-DCOMPRESS_MANPAGES=off")
603
604 ;; Building awesome in its source dir is no longer supported.
605 #:out-of-source? #t
606
607 #:phases
608 (modify-phases %standard-phases
609 (add-before 'build 'xmlto-skip-validation
610 (lambda _
611 ;; We can't download the necessary schema, so so skip
612 ;; validation and assume they're valid.
613 (substitute* "../build/CMakeFiles/man.dir/build.make"
614 (("/xmlto")
615 (string-append "/xmlto --skip-validation")))
616 #t))
617 (add-before 'configure 'set-lua-paths
618 (lambda* (#:key inputs #:allow-other-keys)
619 ;; The build process needs to load cairo dynamically.
620 (let* ((cairo (string-append
621 (assoc-ref inputs "cairo") "/lib" ))
622 (lua-lgi (assoc-ref inputs "lua-lgi") ))
623 (setenv "LD_LIBRARY_PATH" cairo )
624 (setenv "LUA_PATH" (string-append lua-lgi
625 "/share/lua/5.2/?.lua"))
626 (setenv "LUA_CPATH" (string-append lua-lgi
627 "/lib/lua/5.2/?.so"))
628 #t)))
629 (replace 'check
630 (lambda _
631 ;; There aren't any tests, so just make sure the binary
632 ;; gets built and can be run successfully.
633 (zero? (system* "../build/awesome" "-v"))))
634 (add-after 'install 'wrap
635 (lambda* (#:key inputs outputs #:allow-other-keys)
636 (let* ((awesome (assoc-ref outputs "out"))
637 (cairo (string-append
638 (assoc-ref inputs "cairo") "/lib" ))
639 (lua-lgi (assoc-ref inputs "lua-lgi") ))
640 (wrap-program (string-append awesome "/bin/awesome")
641 `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
642 `("LD_LIBRARY_PATH" suffix (, cairo))
643 `("LUA_PATH" suffix (,(string-append lua-lgi
644 "/share/lua/5.2/?.lua")))
645 `("LUA_CPATH" suffix (,(string-append
646 lua-lgi "/lib/lua/5.2/?.so"))))))))))
647 (synopsis "Highly configurable window manager")
648 (description
649 "Awesome has been designed as a framework window manager. It is fast, small,
650 dynamic and extensible using the Lua programming language.")
651 (license license:gpl2+)
652 (home-page "https://awesome.naquadah.org/")))
653
654 (define-public menumaker
655 (package
656 (name "menumaker")
657 (version "0.99.10")
658 (source
659 (origin
660 (method url-fetch)
661 (uri (string-append "mirror://sourceforge/menumaker/"
662 "menumaker-" version ".tar.gz"))
663 (sha256
664 (base32
665 "1mm4cvg3kphkkd8nwrhcg6d9nm5ar7mgc0wf6fxk6zck1l7xn8ky"))))
666 (build-system gnu-build-system)
667 (inputs
668 `(("python" ,python)))
669 (synopsis "Heuristics-driven menu generator")
670 (description
671 "MenuMaker is a menu generation utility for a number of X window
672 managers and desktop environments. It is capable of finding lots of
673 installed programs and generating a root menu consistent across all
674 supported window managers, so one will get (almost) the same menu in
675 all of them. Currently supported window managers include:
676
677 @enumerate
678 @item BlackBox
679 @item Deskmenu
680 @item FluxBox
681 @item IceWM
682 @item OpenBox
683 @item PekWM
684 @item WindowMaker
685 @item XFCE
686 @end enumerate\n")
687 (home-page "http://menumaker.sourceforge.net/")
688 (license license:bsd-2)))
689
690 (define-public keybinder
691 (package
692 (name "keybinder")
693 (version "0.3.1")
694 (source
695 (origin
696 (method url-fetch)
697 (uri (string-append "https://github.com/engla/keybinder/releases/"
698 "download/v" version "/keybinder-"
699 version ".tar.gz"))
700 (file-name (string-append name "-" version ".tar.gz"))
701 (sha256
702 (base32
703 "0h52hj3ay8mfhwvmfxbxlfyq74hifdk8wxgxp7fr4iy6189hg7w7"))))
704 (build-system gnu-build-system)
705 (inputs
706 `(("python-2" ,python-2)
707 ("gtk+-2" ,gtk+-2)))
708 (native-inputs
709 `(("python2-pygtk" ,python2-pygtk)
710 ("gtk-doc" ,gtk-doc)
711 ("pkg-config" ,pkg-config)))
712 (synopsis "Library for registering global keyboard shortcuts")
713 (description
714 "Keybinder is a library for registering global keyboard shortcuts.
715 Keybinder works with GTK-based applications using the X Window System.")
716 (home-page "https://github.com/engla/keybinder")
717 (license license:gpl2+)))
718
719 (define-public spectrwm
720 (package
721 (name "spectrwm")
722 (version "3.1.0")
723 (source
724 (origin
725 (method url-fetch)
726 (uri (let ((version-with-underscores
727 (string-join (string-split version #\.) "_")))
728 (string-append "https://github.com/conformal/spectrwm/archive/"
729 "SPECTRWM_" version-with-underscores ".tar.gz")))
730 (file-name (string-append name "-" version ".tar.gz"))
731 (sha256
732 (base32
733 "16lxcharxslf9rc39wxa3mr2nx5d8kzm9ls7p7dal8yrwr7y59dp"))))
734 (build-system gnu-build-system)
735 (arguments
736 `(#:make-flags (let ((pkg-config (lambda (flag)
737 (string-append
738 "$(shell pkg-config " flag " "
739 "xft fontconfig x11 libpng)"))))
740 (list
741 "CC=gcc"
742 (string-append "PREFIX=" %output)
743 (string-append "INCS=-I. " (pkg-config "--cflags"))
744 (string-append "LIBS=" (pkg-config "--libs") " -lm")))
745 #:tests? #f ;No test suite
746 #:phases
747 (modify-phases %standard-phases
748 (add-before 'build 'change-dir
749 (lambda _
750 (chdir "linux") #t))
751 (add-after 'change-dir 'patch-makefile
752 (lambda _
753 (substitute* "Makefile"
754 (("-g") ""))))
755 (add-after 'change-dir 'fix-freetype-include
756 (lambda _
757 (substitute* "Makefile"
758 (("/usr/include/freetype2")
759 (string-append (assoc-ref %build-inputs "freetype")
760 "/include/freetype2")))))
761 (delete 'configure)))) ;no 'configure' exists
762 (inputs
763 `(("freetype" ,freetype)
764 ("fontconfig" ,fontconfig)
765 ("libx11" ,libx11)
766 ("libxcursor" ,libxcursor)
767 ("libxrandr" ,libxrandr)
768 ("libxtst" ,libxtst)
769 ("libxft" ,libxft)
770 ("xcb-util" ,xcb-util)
771 ("xcb-util-wm" ,xcb-util-wm)
772 ("xcb-util-keysyms" ,xcb-util-keysyms)))
773 (native-inputs
774 `(("libxt" ,libxt)
775 ("pkg-config" ,pkg-config)))
776 (synopsis "Minimalistic automatic tiling window manager")
777 (description
778 "Spectrwm is a small dynamic tiling and reparenting window manager for X11.
779 It is inspired by Xmonad and dwm. Its major features include:
780
781 @itemize
782 @item Navigation anywhere on all screens with either the keyboard or mouse
783 @item Customizable status bar
784 @item Restartable without losing state
785 @item Quick launch menu
786 @item Many screen layouts possible with a few simple key strokes
787 @item Move/resize floating windows
788 @item Extended Window Manager Hints (EWMH) support
789 @item Configureable tiling
790 @item Adjustable tile gap allows for a true one pixel border
791 @item Customizable colors and border width
792 @end itemize\n")
793 (home-page "https://github.com/conformal/spectrwm")
794 (license license:isc)))