gnu: Add java-jboss-jms-api-spec.
[jackhill/guix/guix.git] / gnu / packages / web-browsers.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
6 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages web-browsers)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages documentation)
29 #:use-module (gnu packages fltk)
30 #:use-module (gnu packages fontutils)
31 #:use-module (gnu packages gnupg)
32 #:use-module (gnu packages libevent)
33 #:use-module (gnu packages libidn)
34 #:use-module (gnu packages ncurses)
35 #:use-module (gnu packages perl)
36 #:use-module (gnu packages pkg-config)
37 #:use-module (gnu packages python)
38 #:use-module (gnu packages python-web)
39 #:use-module (gnu packages qt)
40 #:use-module (gnu packages image)
41 #:use-module (gnu packages tls)
42 #:use-module (gnu packages xorg)
43 #:use-module (guix download)
44 #:use-module (guix build-system gnu)
45 #:use-module (guix build-system python))
46
47 (define-public dillo
48 (package
49 (name "dillo")
50 (version "3.0.5")
51 (source (origin
52 (method url-fetch)
53 (uri (string-append "http://www.dillo.org/download/"
54 name "-" version ".tar.bz2"))
55 (sha256
56 (base32
57 "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
58 (build-system gnu-build-system)
59 (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
60 (native-inputs `(("pkg-config" ,pkg-config)))
61 (inputs `(("fltk" ,fltk)
62 ("fontconfig" ,fontconfig)
63 ("libjpeg" ,libjpeg)
64 ("libpng" ,libpng)
65 ("libxcursor" ,libxcursor)
66 ("libxft" ,libxft)
67 ("libxi" ,libxi)
68 ("libxinerama" ,libxinerama)
69 ("openssl" ,openssl)
70 ("perl" ,perl)
71 ("zlib" ,zlib)))
72 (synopsis "Very small and fast graphical web browser")
73 (description "Dillo is a minimalistic web browser particularly intended for
74 older or slower computers and embedded systems.")
75 (home-page "http://www.dillo.org")
76 (license license:gpl3+)))
77
78 (define-public links
79 (package
80 (name "links")
81 (version "2.14")
82 (source (origin
83 (method url-fetch)
84 (uri (string-append "http://links.twibright.com/download/"
85 name "-" version ".tar.bz2"))
86 (sha256
87 (base32
88 "1f24y83wa1vzzjq5kp857gjqdpnmf8pb29yw7fam0m8wxxw0c3gp"))))
89 (build-system gnu-build-system)
90 (arguments
91 `(#:phases
92 (modify-phases %standard-phases
93 (replace 'configure
94 (lambda* (#:key outputs #:allow-other-keys)
95 ;; The tarball uses a very old version of autconf. It doesn't
96 ;; understand extra flags like `--enable-fast-install', so
97 ;; we need to invoke it with just what it understands.
98 (let ((out (assoc-ref outputs "out")))
99 ;; 'configure' doesn't understand '--host'.
100 ,@(if (%current-target-system)
101 `((setenv "CHOST" ,(%current-target-system)))
102 '())
103 (setenv "CONFIG_SHELL" (which "bash"))
104 (zero?
105 (system* "./configure"
106 (string-append "--prefix=" out)
107 "--enable-graphics"))))))))
108 (native-inputs `(("pkg-config" ,pkg-config)))
109 (inputs `(("zlib" ,zlib)
110 ("openssl" ,openssl)
111 ("libjpeg" ,libjpeg)
112 ("libtiff" ,libtiff)
113 ("libevent" ,libevent)
114 ("libpng" ,libpng)
115 ("libxt" ,libxt)))
116 (synopsis "Text and graphics mode web browser")
117 (description "Links is a graphics and text mode web browser, with many
118 features including, tables, builtin image display, bookmarks, SSL and more.")
119 (home-page "http://links.twibright.com")
120 ;; The distribution contains a copy of GPLv2
121 ;; However, the copyright notices simply say:
122 ;; "This file is a part of the Links program, released under GPL."
123 ;; Therefore, under the provisions of Section 9, we can choose
124 ;; any version ever published by the FSF.
125 ;; One file (https.c) contains an exception permitting
126 ;; linking of the program with openssl.
127 (license license:gpl1+)))
128
129 (define-public lynx
130 (package
131 (name "lynx")
132 (version "2.8.9dev.15")
133 (source (origin
134 (method url-fetch)
135 (uri (string-append
136 "http://invisible-mirror.net/archives/lynx/tarballs"
137 "/lynx" version ".tar.bz2"))
138 (sha256
139 (base32
140 "16bdr7ai130ps67px8ssxnjxp5j6m4rin3in7jm22fxk0a8p2428"))))
141 (build-system gnu-build-system)
142 (native-inputs `(("pkg-config" ,pkg-config)
143 ("perl" ,perl)))
144 (inputs `(("ncurses" ,ncurses)
145 ("libidn" ,libidn)
146 ("gnutls" ,gnutls)
147 ("libgcrypt" ,libgcrypt)
148 ("unzip" ,unzip)
149 ("zlib" ,zlib)
150 ("gzip" ,gzip)
151 ("bzip2" ,bzip2)))
152 (arguments
153 `(#:configure-flags
154 (let ((gnutls (assoc-ref %build-inputs "gnutls")))
155 `("--with-pkg-config"
156 "--with-screen=ncurses"
157 "--with-zlib"
158 "--with-bzlib"
159 ,(string-append "--with-gnutls=" gnutls)
160 ;; "--with-socks5" ; XXX TODO
161 "--enable-widec"
162 "--enable-ascii-ctypes"
163 "--enable-local-docs"
164 "--enable-htmlized-cfg"
165 "--enable-gzip-help"
166 "--enable-nls"
167 "--enable-ipv6"))
168 #:tests? #f ; no check target
169 #:phases
170 (modify-phases %standard-phases
171 (replace 'install
172 (lambda* (#:key (make-flags '()) #:allow-other-keys)
173 (zero? (apply system* "make" "install-full" make-flags)))))))
174 (synopsis "Text Web Browser")
175 (description
176 "Lynx is a fully-featured World Wide Web (WWW) client for users running
177 cursor-addressable, character-cell display devices. It will display Hypertext
178 Markup Language (HTML) documents containing links to files on the local
179 system, as well as files on remote systems running http, gopher, ftp, wais,
180 nntp, finger, or cso/ph/qi servers. Lynx can be used to access information on
181 the WWW, or to build information systems intended primarily for local
182 access.")
183 (home-page "https://lynx.invisible-island.net/")
184 (license license:gpl2)))
185
186 (define-public qutebrowser
187 (package
188 (name "qutebrowser")
189 (version "0.11.0")
190 (source
191 (origin
192 (method url-fetch)
193 (uri (string-append "https://github.com/The-Compiler/"
194 "qutebrowser/releases/download/v" version "/"
195 "qutebrowser-" version ".tar.gz"))
196 (sha256
197 (base32
198 "13ihx66jm1dd6vx8px7pm0kbzf2sf9x43hhivc1rp17kahnxxdyv"))))
199 (build-system python-build-system)
200 (native-inputs
201 `(("asciidoc" ,asciidoc)))
202 (inputs
203 `(("python-colorama" ,python-colorama)
204 ("python-cssutils" ,python-cssutils)
205 ("python-jinja2" ,python-jinja2)
206 ("python-markupsafe" ,python-markupsafe)
207 ("python-pygments" ,python-pygments)
208 ("python-pypeg2" ,python-pypeg2)
209 ("python-pyyaml" ,python-pyyaml)
210 ("python-pyqt" ,python-pyqt)
211 ("qtwebkit" ,qtwebkit)))
212 (arguments
213 `(#:tests? #f ;no tests
214 #:phases
215 (modify-phases %standard-phases
216 (add-after 'install 'install-more
217 (lambda* (#:key outputs #:allow-other-keys)
218 (let* ((out (assoc-ref outputs "out"))
219 (app (string-append out "/share/applications"))
220 (hicolor (string-append out "/share/icons/hicolor")))
221 (system* "a2x" "-f" "manpage" "doc/qutebrowser.1.asciidoc")
222 (install-file "doc/qutebrowser.1"
223 (string-append out "/share/man/man1"))
224
225 (for-each
226 (lambda (i)
227 (let ((src (format #f "icons/qutebrowser-~dx~d.png" i i))
228 (dest (format #f "~a/~dx~d/apps/qutebrowser.png"
229 hicolor i i)))
230 (mkdir-p (dirname dest))
231 (copy-file src dest)))
232 '(16 24 32 48 64 128 256 512))
233 (install-file "icons/qutebrowser.svg"
234 (string-append hicolor "/scalable/apps"))
235
236 (substitute* "qutebrowser.desktop"
237 (("Exec=qutebrowser")
238 (string-append "Exec=" out "/bin/qutebrowser")))
239 (install-file "qutebrowser.desktop" app)
240 #t))))))
241 (home-page "https://qutebrowser.org/")
242 (synopsis "Minimal, keyboard-focused, vim-like web browser")
243 (description "qutebrowser is a keyboard-focused browser with a minimal
244 GUI. It is based on PyQt5 and QtWebKit.")
245 (license license:gpl3+)))