gnu: Add java-jboss-jms-api-spec.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde)
21 #:use-module (guix build-system cmake)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages apr)
27 #:use-module (gnu packages boost)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages documentation)
30 #:use-module (gnu packages gl)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages kde-frameworks)
33 #:use-module (gnu packages llvm)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages tls)
36 #:use-module (gnu packages qt)
37 #:use-module (gnu packages version-control))
38
39 (define-public kdevelop
40 (package
41 (name "kdevelop")
42 (version "5.1.2")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append "mirror://kde/stable/kdevelop"
47 "/" version "/src/kdevelop-"
48 version ".tar.xz"))
49 (sha256
50 (base32
51 "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
52 (build-system cmake-build-system)
53 (native-inputs
54 `(("extra-cmake-modules" ,extra-cmake-modules)
55 ("pkg-config" ,pkg-config)
56 ("qttools" ,qttools)))
57 (inputs
58 `(("kdevplatform" ,kdevplatform)
59 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
60 ("qtbase" ,qtbase)
61 ("qtdeclarative" ,qtdeclarative)
62 ("qtquickcontrols" ,qtquickcontrols)
63 ("qtwebkit" ,qtwebkit)
64 ("karchive" ,karchive)
65 ("kcmutils" ,kcmutils)
66 ("kconfig" ,kconfig)
67 ("kdeclarative" ,kdeclarative)
68 ("kdoctools" ,kdoctools)
69 ("kguiaddons" ,kguiaddons)
70 ("ki18n" ,ki18n)
71 ("kio" ,kio)
72 ("kiconthemes" ,kiconthemes)
73 ("kitemmodels" ,kitemmodels)
74 ("kitemviews" ,kitemviews)
75 ("kjobwidgets" ,kjobwidgets)
76 ("knotifyconfig" ,knotifyconfig)
77 ("knotifications" ,knotifications)
78 ("kparts" ,kparts)
79 ("kcrash" ,kcrash)
80 ("knewstuff" ,knewstuff)
81 ("krunner" ,krunner)
82 ("kxmlgui" ,kxmlgui)
83 ("libksysguard" ,libksysguard)
84 ("threadweaver" ,threadweaver)
85 ("ktexteditor" ,ktexteditor)
86 ("kwindowsystem" ,kwindowsystem)
87 ("plasma" ,plasma-framework)
88 ("grantlee" ,grantlee)
89 ("libepoxy" ,libepoxy)
90 ("clang" ,clang)
91 ("shared-mime-info" ,shared-mime-info)))
92 (arguments
93 `(#:phases
94 (modify-phases %standard-phases
95 (delete 'check) ;; there are some issues with the test suite
96 (add-after 'install 'wrap-executable
97 (lambda* (#:key inputs outputs #:allow-other-keys)
98 (let* ((out (assoc-ref outputs "out"))
99 (kdevplatform (assoc-ref inputs "kdevplatform"))
100 (kio (assoc-ref inputs "kio"))
101 (kcmutils (assoc-ref inputs "kcmutils"))
102 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
103 (qtbase (assoc-ref inputs "qtbase"))
104 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
105 (qml "/qml"))
106 (wrap-program (string-append out "/bin/kdevelop")
107 `("XDG_DATA_DIRS" ":" prefix
108 ,(map (lambda (s) (string-append s "/share"))
109 (list out kdevplatform kcmutils)))
110 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
111 (,(string-append qtbase "/plugins/platforms")))
112 `("QT_PLUGIN_PATH" ":" prefix
113 ,(map (lambda (s) (string-append s "/lib/plugins"))
114 (list out kdevplatform kio)))
115 `("QML2_IMPORT_PATH" ":" prefix
116 (,(string-append qtquickcontrols qml)
117 ,(string-append qtdeclarative qml))))))))))
118 (home-page "https://kdevelop.org")
119 (synopsis "IDE for C, C++, Python, Javascript and PHP")
120 (description "The KDevelop IDE provides semantic syntax highlighting, as
121 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
122 JavaScript, Python and PHP. It also integrates with a debugger, different
123 build systems (CMake, QMake, custom Makefiles) and version control
124 software (Git, Subversion, Mercurial, CVS and Bazaar).")
125 (license license:lgpl2.1+)))
126
127 (define-public kdevelop-pg-qt
128 (package
129 (name "kdevelop-pg-qt")
130 (version "2.0.0")
131 (source
132 (origin
133 (method url-fetch)
134 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
135 version ".tar.gz"))
136 (file-name (string-append name "-" version ".tar.gz"))
137 (sha256
138 (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
139 (native-inputs
140 `(("extra-cmake-modules" ,extra-cmake-modules)))
141 (inputs
142 `(("qtbase" ,qtbase)))
143 (build-system cmake-build-system)
144 (home-page "https://kde.org")
145 (synopsis "Parser generator library for KDevplatform")
146 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
147 for some KDevelop language plugins (Ruby, PHP, CSS...).")
148 (license license:lgpl2.0+)))
149
150 (define-public kdevplatform
151 (package
152 (name "kdevplatform")
153 (version "5.1.2")
154 (source (origin
155 (method url-fetch)
156 (uri (string-append "mirror://kde/stable/kdevelop"
157 "/" version "/src/kdevplatform-"
158 version ".tar.xz"))
159 (sha256
160 (base32
161 "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
162 (build-system cmake-build-system)
163 (native-inputs
164 `(("extra-cmake-modules" ,extra-cmake-modules)
165 ("pkg-config" ,pkg-config)))
166 (inputs
167 `(("apr" ,apr)
168 ("apr-util" ,apr-util)
169 ("boost" ,boost)
170 ("karchive" ,karchive)
171 ("kconfigwidgets" ,kconfigwidgets)
172 ("kcmutils" ,kcmutils)
173 ("kiconthemes" ,kiconthemes)
174 ("kdeclarative" ,kdeclarative)
175 ("kdoctools" ,kdoctools)
176 ("kguiaddons" ,kguiaddons)
177 ("kinit" ,kinit)
178 ("kitemmodels" ,kitemmodels)
179 ("knewstuff" ,knewstuff)
180 ("knotifications" ,knotifications)
181 ("knotifyconfig" ,knotifyconfig)
182 ("kwindowsystem" ,kwindowsystem)
183 ("kio" ,kio)
184 ("ki18n" ,ki18n)
185 ("kparts" ,kparts)
186 ("kservice" ,kservice)
187 ("grantlee" ,grantlee)
188 ("libkomparediff2" ,libkomparediff2)
189 ("sonnet" ,sonnet)
190 ("threadweaver" ,threadweaver)
191 ("ktexteditor" ,ktexteditor)
192 ("qtbase" ,qtbase)
193 ("qtdeclarative" ,qtdeclarative)
194 ("qtscript" ,qtscript)
195 ("qtwebkit" ,qtwebkit)
196 ("qtx11extras" ,qtx11extras)
197 ("plasma" ,plasma-framework)
198 ("subversion" ,subversion)
199 ("zlib" ,zlib)))
200 (arguments
201 `(#:phases
202 (modify-phases %standard-phases
203 (delete 'check)
204 (add-after 'install 'check ;; add-after 'install
205 (lambda* (#:key outputs #:allow-other-keys)
206 (let ((out (assoc-ref outputs "out")))
207 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
208 (setenv "QT_PLUGIN_PATH"
209 (string-append out "/lib/plugins:"
210 (getenv "QT_PLUGIN_PATH")))
211 (setenv "XDG_DATA_DIRS"
212 (string-append out "/share:"
213 (getenv "XDG_DATA_DIRS")))
214 (zero?
215 (system* "ctest" "-R" ;; almost all tests require a display
216 "filteringstrategy|kdevvarlengtharray|kdevhash"))))))))
217 (home-page "https://github.com/KDE/kdevplatform")
218 (synopsis "Framework to build integrated development environments (IDEs)")
219 (description "KDevPlatform is the basis of KDevelop and contains some
220 plugins, as well as code to create plugins, or complete applications.")
221 (license license:gpl3+)))
222
223 (define-public libkomparediff2
224 (package
225 (name "libkomparediff2")
226 (version "16.08.2")
227 (source
228 (origin
229 (method url-fetch)
230 (uri (string-append "https://github.com/KDE/libkomparediff2/archive/v"
231 version ".tar.gz"))
232 (file-name (string-append name "-" version ".tar.gz"))
233 (sha256
234 (base32
235 "1lafifrwfxvn0jwhz67kwv7m38lm4syips3fq77rwcvfhmkiijmh"))))
236 (native-inputs
237 `(("extra-cmake-modules" ,extra-cmake-modules)
238 ("pkg-config" ,pkg-config)))
239 (inputs
240 `(("kcodecs" ,kcodecs)
241 ("kconfig" ,kconfig)
242 ("kcoreaddons" ,kcoreaddons)
243 ("ki18n" ,ki18n)
244 ("kio" ,kio)
245 ("kxmlgui" ,kxmlgui)
246 ("qtbase" ,qtbase)))
247 (build-system cmake-build-system)
248 (home-page "https://kde.org")
249 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
250 (description "Libkomparediff2 is a library to work with diffs and patches,
251 used in KDE development tools Kompare and KDevelop.")
252
253 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
254 ;; source archive
255 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
256
257 (define-public libksysguard
258 (package
259 (name "libksysguard")
260 (version "5.11.2")
261 (source
262 (origin
263 (method url-fetch)
264 (uri (string-append "mirror://kde//stable/plasma/" version
265 "/libksysguard-" version ".tar.xz"))
266 (sha256
267 (base32
268 "12d0r4rilydbqdgkm256khvkb9m0hya3p27xqvv3hg77wgxzdl3f"))))
269 (native-inputs
270 `(("extra-cmake-modules" ,extra-cmake-modules)
271 ("pkg-config" ,pkg-config)))
272 (inputs
273 `(("kconfigwidgets" ,kconfigwidgets)
274 ("kiconthemes" ,kiconthemes)
275 ("kwindowsystem" ,kwindowsystem)
276 ("ki18n" ,ki18n)
277 ("kauth" ,kauth)
278 ("kcompletion" ,kcompletion)
279 ("kconfig" ,kconfig)
280 ("kcoreaddons" ,kcoreaddons)
281 ("kwidgetsaddons" ,kwidgetsaddons)
282 ("kservice" ,kservice)
283 ("qtbase" ,qtbase)
284 ("qtscript" ,qtscript)
285 ("qtwebkit" ,qtwebkit)
286 ("qtx11extras" ,qtx11extras)
287 ("plasma" ,plasma-framework)
288 ("zlib" ,zlib)))
289 (build-system cmake-build-system)
290 (arguments
291 `(#:configure-flags
292 `(,(string-append "-DKDE_INSTALL_DATADIR="
293 (assoc-ref %outputs "out") "/share"))
294 #:phases
295 (modify-phases %standard-phases
296 (add-before 'configure 'patch-cmakelists
297 (lambda _
298 ;; TODO: Verify: This should no longer be necessary, since
299 ;; KF5AuthConfig.cmake.in contains this already.
300 (substitute* "processcore/CMakeLists.txt"
301 (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
302 (add-before 'check 'check-setup
303 (lambda _
304 ;; make Qt render "offscreen", required for tests
305 (setenv "QT_QPA_PLATFORM" "offscreen")))
306 (replace 'check
307 (lambda _
308 ;; TODO: Fix this failing test-case
309 (zero? (system* "ctest" "-E" "processtest")))))))
310 (home-page "https://www.kde.org/info/plasma-5.11.2.php")
311 (synopsis "Network enabled task and system monitoring")
312 (description "KSysGuard can obtain information on system load and
313 manage running processes. It obtains this information by interacting
314 with a ksysguardd daemon, which may also run on a remote system.")
315 (license license:gpl3+)))
316
317 (define-public qca
318 (package
319 (name "qca")
320 (version "2.1.3")
321 (source
322 (origin
323 (method url-fetch)
324 (uri (string-append "http://download.kde.org/stable/qca/" version
325 "/src/qca-" version ".tar.xz"))
326 (sha256
327 (base32
328 "0lz3n652z208daxypdcxiybl0a9fnn6ida0q7fh5f42269mdhgq0"))))
329 (build-system cmake-build-system)
330 (native-inputs
331 `(("pkg-config" ,pkg-config)))
332 (inputs
333 `(("openssl" ,openssl)
334 ("qtbase" ,qtbase)))
335 (home-page "https://userbase.kde.org/QCA")
336 (synopsis "Libraries for the Qt Cryptographic Architecture")
337 (description "The Qt Cryptographic Architecture (QCA) provides a
338 straightforward and cross-platform API for a range of cryptographic features,
339 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
340 cards.")
341 (license license:lgpl2.1)))
342
343 (define-public snorenotify
344 (package
345 (name "snorenotify")
346 (version "0.7.0")
347 (source
348 (origin
349 (method url-fetch)
350 (uri (string-append "http://download.kde.org/stable/snorenotify/"
351 version "/src/snorenotify-" version ".tar.xz"))
352 (sha256
353 (base32
354 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
355 (build-system cmake-build-system)
356 (arguments
357 `(#:tests? #f)) ; both tests fail, require display
358 (inputs
359 `(("extra-cmake-modules" ,extra-cmake-modules)
360 ("qtbase" ,qtbase)
361 ("qttools" ,qttools)))
362 (home-page "https://techbase.kde.org/Projects/Snorenotify")
363 (synopsis "Qt notification framework")
364 (description "Snorenotify is a multi platform Qt notification framework.
365 Using a plugin system it is possible to create notifications with many
366 different notification systems.")
367 (license license:lgpl3)))