gnu: gegl: Fix CVE-2012-4433.
[jackhill/guix/guix.git] / gnu / packages / patches / openexr-missing-samples.patch
1 This patch comments out tests that rely on files that are missing
2 from the source tarball.
3
4 --- openexr-2.2.0/IlmImfTest/testSampleImages.cpp 2015-02-25 16:19:21.565105625 +0100
5 +++ openexr-2.2.0/IlmImfTest/testSampleImages.cpp 2015-02-25 16:21:46.394128206 +0100
6 @@ -162,16 +162,6 @@ testSampleImages (const std::string&)
7 compareImages (ILM_IMF_TEST_IMAGEDIR "comp_b44.exr",
8 ILM_IMF_TEST_IMAGEDIR "comp_b44_piz.exr");
9
10 - compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwaa_v1.exr",
11 - ILM_IMF_TEST_IMAGEDIR "comp_dwaa_piz.exr");
12 - compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwaa_v2.exr",
13 - ILM_IMF_TEST_IMAGEDIR "comp_dwaa_piz.exr");
14 -
15 - compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwab_v1.exr",
16 - ILM_IMF_TEST_IMAGEDIR "comp_dwab_piz.exr");
17 - compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwab_v2.exr",
18 - ILM_IMF_TEST_IMAGEDIR "comp_dwab_piz.exr");
19 -
20
21 cout << "ok\n" << endl;
22 }
23